Update to 20030507

PR:		52261
Submitted by:	Saito Tomokatsu <saito@a2z.co.jp>
This commit is contained in:
Tilman Keskinoz 2003-05-19 14:08:30 +00:00
parent 8634ce1593
commit 894db980cd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=81390
25 changed files with 423 additions and 209 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= asir
PORTVERSION= 20030215
PORTVERSION= 20030507
CATEGORIES= math
MASTER_SITES= ftp://ftp.jssac.org/pub/distfiles/asir/ \
ftp://ftp.asir.org/pub/asir/src/
@ -16,75 +16,22 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= saito@asir.org
COMMENT= The system Risa/Asir is a general computer algebra system
WRKSRC= ${WRKDIR}/asir2000
PREFIX?= ${LOCALBASE}
USE_IMAKE= YES
LIB_DEPENDS= pari-2.2:${PORTSDIR}/math/pari-devel
GNU_CONFIGURE= yes
USE_AUTOMAKE= yes
USE_AUTOCONF= yes
USE_AUTOMAKE_VER= 15
USE_XLIB= yes
USE_REINPLACE= yes
XFREE86_HTML_MAN= no
USE_X_PREFIX = no
HAS_CONFIGURE= YES
CONFIGURE_ENV= OLD_PARI_VERSION=${OLD_PARI_VERSION} \
PARI_VERSION=${PARI_VERSION} \
LAPACK_VERSION=${LAPACK_VERSION}
CONFIGURE_ARGS= -oxhome ${PREFIX} -plot ${PARI} -fep -interval ${LAPACK}
ASIR_DOC_VERSION= 20021020
CONFIGURE_ARGS= --enable-shared --enable-plot --enable-fep --enable-interval --with-pari=new
ASIR_DOC_VERSION= 20030507
ASIR_DOC= asirdoc-${ASIR_DOC_VERSION}.tar.gz
MAN1= asir.1
WRKSRC= ${WRKDIR}/asir2000
LIB_DATA= alpi bfct bgk const cyclic defs.h dfff dmul fctrdata fctrtest \
fff gr ifplot katsura launch mat nf num primdec \
ratint robot solve sp sturm xm
LIB_DEPENDS= # dummy
OLD_PARI_DIR= ${PORTSDIR}/math/pari
OLD_PARI_VERSION= `${GREP} PORTVERSION ${OLD_PARI_DIR}/Makefile | cut -f 2`
PARI_DIR= ${PORTSDIR}/math/pari-devel
PARI_VERSION= `${GREP} MAJOR_VERSION ${PARI_DIR}/Makefile | ${GREP} -v { | cut -f 2`.`${GREP} MINOR_VERSION ${PARI_DIR}/Makefile | ${GREP} -v { | cut -f 2`.`${GREP} REV_VERSION ${PARI_DIR}/Makefile | ${GREP} -v { | cut -f 2`.alpha
.if defined(USE_OLDPARI)
LIB_DEPENDS+= pari.1:${OLD_PARI_DIR}
PARI= -oldpari
.else
LIB_DEPENDS+= pari-2.2:${PARI_DIR}
PARI= -pari
.endif
LAPACK_DIR= ${PORTSDIR}/math/lapack
LAPACK_VERSION= `${GREP} PORTVERSION ${LAPACK_DIR}/Makefile | cut -f 2`
.if defined(USE_LAPACK)
LIB_DEPENDS+= lapack.3:${LAPACK_DIR}
LAPACK= -lapack
.else
LAPACK=
.endif
pre-extract:
.if !defined(USE_OLDPARI)
@${ECHO_MSG} "If you build the pari ${OLD_PARI_VERSION} library,"
@${ECHO_MSG} " make USE_OLDPARI=yes"
@${ECHO_MSG} "otherwise link pari ${PARI_VERSION}"
.endif
.if !defined(USE_LAPACK)
@${ECHO_MSG} "To build include \"LAPACK\" library,"
@${ECHO_MSG} " make USE_LAPACK=yes"
.endif
post-patch:
${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
${WRKSRC}/configure \
${WRKSRC}/gc/configure \
${WRKSRC}/gc/libtool.m4 \
${WRKSRC}/include/Risa.tmpl \
${WRKSRC}/include/Risa.tmpl-alpha \
${WRKSRC}/lib/xm \
${WRKSRC}/old/configure
${REINPLACE_CMD} -e 's,/usr/X11R6,${X11BASE},g' \
${WRKSRC}/Imakefile \
${WRKSRC}/gc/configure \
${WRKSRC}/gc/libtool.m4 \
${WRKSRC}/old/Imakefile
pre-install:
@${MKDIR} ${DATADIR}
@ -95,14 +42,13 @@ post-install:
cd ${WRKSRC}/lib ; \
for i in ${LIB_DATA} ; do \
${INSTALL_DATA} $$i ${DATADIR} ; \
done \
done ;\
make install-doc \
)
@(cd ${WRKSRC}; make install-doc)
@${LN} -fs ${PREFIX}/bin/asir ${DATADIR}/ox_asir
@${LN} -fs ${PREFIX}/bin/asir ${DATADIR}/ox_plot
@${LN} -fs ${PREFIX}/bin/asir ${DATADIR}/ox_launch
@${TAR} xfz ${DISTDIR}/${ASIR_DOC} -C ${DOCSDIR}
@${INSTALL_MAN} ${DOCSDIR}/${MAN1} ${PREFIX}/man/man1
@${GZIP_CMD} ${PREFIX}/man/man1/${MAN1}
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
MD5 (asir-20030215.tar.gz) = 1ce5189106564822ea1d2b6733d081c6
MD5 (asirdoc-20021020.tar.gz) = f72afe8d5360e3ea69548306185433d7
MD5 (asir-20030507.tar.gz) = 78c3264965ba9fd267f05f2058fb1136
MD5 (asirdoc-20030507.tar.gz) = 979951db28ab688b326295babf25921a

View file

@ -1,45 +0,0 @@
--- include/Risa.tmpl.orig Sat Oct 6 01:24:22 2001
+++ include/Risa.tmpl Tue Oct 23 02:44:17 2001
@@ -11,7 +11,7 @@
/* #define USE_FFT_FLOAT */
/* #define USE_LAPACK */
/* #define USE_FEP */
-/* #undef OpenXM_HOME */
+#undef OpenXM_HOME
/* #define USE_INTERVAL */
#if defined(LinuxArchitecture)
@@ -38,7 +38,7 @@
#endif
ASIR_BINDIR=$(ROOTDIR)/bin
-ASIR_LIBDIR=$(ROOTDIR)/lib/asir
+ASIR_LIBDIR=$(ROOTDIR)/share/asir
ASIR_INCDIR=$(ROOTDIR)/include/asir
GC_INCDIR=$(ROOTDIR)/include/gc
@@ -48,8 +48,6 @@
CC= cc
#endif
-CDEBUGFLAGS= -g -O
-
#if defined(SunArchitecture)
#if SystemV4
#if defined(SparcArchitecture)
@@ -114,7 +112,15 @@
#ifdef USE_LAPACK
LAPACK=1
+#if defined(OpenXM_HOME)
LAPACKLIB = -llapack -lblas -lI77 -lF77
+#else
+#ifdef FreeBSDArchitecture && OSMajorVersion >= 4
+LAPACKLIB = -L/usr/local/lib -lg2c -llapack -lblas
+#else
+LAPACKLIB = -L/usr/local/lib -lf2c -llapack -lblas
+#endif
+#endif
#else
LAPACK=0
LAPACKLIB =

View file

@ -0,0 +1,45 @@
--- include/Risa.tmpl.orig Sat Oct 6 01:24:22 2001
+++ include/Risa.tmpl Tue Oct 23 02:44:17 2001
@@ -11,7 +11,7 @@
/* #define USE_FFT_FLOAT */
/* #define USE_LAPACK */
/* #define USE_FEP */
-/* #undef OpenXM_HOME */
+#undef OpenXM_HOME
/* #define USE_INTERVAL */
#if defined(LinuxArchitecture)
@@ -38,7 +38,7 @@
#endif
ASIR_BINDIR=$(ROOTDIR)/bin
-ASIR_LIBDIR=$(ROOTDIR)/lib/asir
+ASIR_LIBDIR=$(ROOTDIR)/share/asir
ASIR_INCDIR=$(ROOTDIR)/include/asir
GC_INCDIR=$(ROOTDIR)/include/gc
@@ -48,8 +48,6 @@
CC= cc
#endif
-CDEBUGFLAGS= -g -O
-
#if defined(SunArchitecture)
#if SystemV4
#if defined(SparcArchitecture)
@@ -114,7 +112,15 @@
#ifdef USE_LAPACK
LAPACK=1
+#if defined(OpenXM_HOME)
LAPACKLIB = -llapack -lblas -lI77 -lF77
+#else
+#ifdef FreeBSDArchitecture && OSMajorVersion >= 4
+LAPACKLIB = -L/usr/local/lib -lg2c -llapack -lblas
+#else
+LAPACKLIB = -L/usr/local/lib -lf2c -llapack -lblas
+#endif
+#endif
#else
LAPACK=0
LAPACKLIB =

View file

@ -1,11 +0,0 @@
--- Imakefile.org Sun Feb 4 20:11:38 2001
+++ Imakefile Sun Feb 4 20:12:03 2001
@@ -98,7 +98,7 @@
install:: $(PROGRAMS)
MakeDir($(ASIR_LIBDIR))
- $(INSTALL) $(INSTALLFLAGS) $(PROGRAMS) $(ASIR_LIBDIR)
+ $(INSTALL) $(INSTALLFLAGS) $(PROGRAMS) $(ASIR_BINDIR)
install-bin-lib:: $(PROGRAMS)
MakeDir($(ASIR_LIBDIR))

View file

@ -0,0 +1,11 @@
--- Imakefile.org Sun Feb 4 20:11:38 2001
+++ Imakefile Sun Feb 4 20:12:03 2001
@@ -98,7 +98,7 @@
install:: $(PROGRAMS)
MakeDir($(ASIR_LIBDIR))
- $(INSTALL) $(INSTALLFLAGS) $(PROGRAMS) $(ASIR_LIBDIR)
+ $(INSTALL) $(INSTALLFLAGS) $(PROGRAMS) $(ASIR_BINDIR)
install-bin-lib:: $(PROGRAMS)
MakeDir($(ASIR_LIBDIR))

View file

@ -1,14 +1,10 @@
--- include/version.h.orig Tue Jan 28 17:38:58 2003
+++ include/version.h Thu Feb 6 16:31:53 2003
@@ -47,5 +47,9 @@
+++ include/version.h Sun Mar 2 21:15:34 2003
@@ -47,5 +47,5 @@
*
* $OpenXM: OpenXM_contrib2/asir2000/include/version.h,v 1.90 2003/01/28 08:38:58 noro Exp $
*/
-#define ASIR_VERSION 20030128
-#define ASIR_VERSION 20030507
-#define ASIR_DISTRIBUTION "Kobe"
+#define ASIR_VERSION 20030215
+#define ASIR_VERSION 20030513
+#define ASIR_DISTRIBUTION "Plotting Group"
+#define PARI_DEVEL_VERSION "PARI 2.2.4.alpha, copyright (C) 2000,
+ C. Batut, K. Belabas, D. Bernardi, H. Cohen and M. Olivier"
+#define PARI_DEVEL_VERSION "PARI 2.2.4.alpha, copyright (C) 2000,
+ C. Batut, K. Belabas, D. Bernardi, H. Cohen and M. Olivier"

View file

@ -0,0 +1,14 @@
--- include/version.h.orig Tue Jan 28 17:38:58 2003
+++ include/version.h Thu Feb 6 16:31:53 2003
@@ -47,5 +47,9 @@
*
* $OpenXM: OpenXM_contrib2/asir2000/include/version.h,v 1.90 2003/01/28 08:38:58 noro Exp $
*/
-#define ASIR_VERSION 20030128
-#define ASIR_DISTRIBUTION "Kobe"
+#define ASIR_VERSION 20030215
+#define ASIR_DISTRIBUTION "Plotting Group"
+#define PARI_DEVEL_VERSION "PARI 2.2.4.alpha, copyright (C) 2000,
+ C. Batut, K. Belabas, D. Bernardi, H. Cohen and M. Olivier"
+#define PARI_DEVEL_VERSION "PARI 2.2.4.alpha, copyright (C) 2000,
+ C. Batut, K. Belabas, D. Bernardi, H. Cohen and M. Olivier"

View file

@ -1,48 +0,0 @@
--- configure.orig Wed Jan 15 22:51:27 2003
+++ configure Thu Jan 16 01:43:33 2003
@@ -4,6 +4,7 @@
use_plot=0
use_pari=0
use_interval=0
+use_lapack=0
use_fep=0
oxhome=/usr/local
@@ -24,6 +25,8 @@
use_pari=2 ;;
-interval)
use_interval=1 ;;
+ -lapack)
+ use_lapack=1 ;;
-fep)
use_fep=1 ;;
esac
@@ -43,12 +46,16 @@
libname=$libname"_pari"
libpari=pari
echo "#define USE_PARI" >> include/config.h
+echo "#define PARI_VERSION \"PARI ${OLD_PARI_VERSION}, copyright (C) 2000,
+ C. Batut, K. Belabas, D. Bernardi, H. Cohen and M. Olivier\"" >> include/version.h
fi
if [ $use_pari = 2 ]; then
libname=$libname"_pari"
libpari=pari-2.2
echo "#define USE_PARI" >> include/config.h
+echo "#define PARI_DEVEL_VERSION \"PARI ${PARI_VERSION}, copyright (C) 2000,
+ C. Batut, K. Belabas, D. Bernardi, H. Cohen and M. Olivier\"" >> include/version.h
fi
if [ $use_plot != 0 ]; then
@@ -61,6 +68,11 @@
echo "#define USE_INTERVAL" >> include/config.h
fi
+if [ $use_lapack != 0 ]; then
+echo "#define USE_LAPACK" >> include/config.h
+echo "#define LAPACK_VERSION \"LAPACK Project Version ${LAPACK_VERSION}\"" >> include/version.h
+fi
+
if [ $use_fep != 0 ]; then
echo "#define USE_FEP" >> include/config.h
fi

View file

@ -0,0 +1,48 @@
--- configure.orig Wed Jan 15 22:51:27 2003
+++ configure Thu Jan 16 01:43:33 2003
@@ -4,6 +4,7 @@
use_plot=0
use_pari=0
use_interval=0
+use_lapack=0
use_fep=0
oxhome=/usr/local
@@ -24,6 +25,8 @@
use_pari=2 ;;
-interval)
use_interval=1 ;;
+ -lapack)
+ use_lapack=1 ;;
-fep)
use_fep=1 ;;
esac
@@ -43,12 +46,16 @@
libname=$libname"_pari"
libpari=pari
echo "#define USE_PARI" >> include/config.h
+echo "#define PARI_VERSION \"PARI ${OLD_PARI_VERSION}, copyright (C) 2000,
+ C. Batut, K. Belabas, D. Bernardi, H. Cohen and M. Olivier\"" >> include/version.h
fi
if [ $use_pari = 2 ]; then
libname=$libname"_pari"
libpari=pari-2.2
echo "#define USE_PARI" >> include/config.h
+echo "#define PARI_DEVEL_VERSION \"PARI ${PARI_VERSION}, copyright (C) 2000,
+ C. Batut, K. Belabas, D. Bernardi, H. Cohen and M. Olivier\"" >> include/version.h
fi
if [ $use_plot != 0 ]; then
@@ -61,6 +68,11 @@
echo "#define USE_INTERVAL" >> include/config.h
fi
+if [ $use_lapack != 0 ]; then
+echo "#define USE_LAPACK" >> include/config.h
+echo "#define LAPACK_VERSION \"LAPACK Project Version ${LAPACK_VERSION}\"" >> include/version.h
+fi
+
if [ $use_fep != 0 ]; then
echo "#define USE_FEP" >> include/config.h
fi

View file

@ -1,13 +0,0 @@
--- builtin/numerical.c.org Thu Aug 16 18:47:06 2001
+++ builtin/numerical.c Thu Aug 16 18:47:52 2001
@@ -51,7 +51,11 @@
#include "parse.h"
#if LAPACK
+#if (__FreeBSD__ >= 4)
+#include <g2c.h>
+#else
#include <f2c.h>
+#endif
void Pflinsolve();

View file

@ -0,0 +1,13 @@
--- builtin/numerical.c.org Thu Aug 16 18:47:06 2001
+++ builtin/numerical.c Thu Aug 16 18:47:52 2001
@@ -51,7 +51,11 @@
#include "parse.h"
#if LAPACK
+#if (__FreeBSD__ >= 4)
+#include <g2c.h>
+#else
#include <f2c.h>
+#endif
void Pflinsolve();

View file

@ -1,24 +1,24 @@
--- parse/glob.c.orig Wed Sep 11 17:57:21 2002
+++ parse/glob.c Thu Oct 17 11:19:30 2002
--- parse/glob.c.orig Wed Apr 2 18:43:33 2003
+++ parse/glob.c Fri May 2 15:54:46 2003
@@ -51,6 +51,7 @@
#include "al.h"
#include "parse.h"
#include "ox.h"
+#include "version.h"
#if PARI
#if defined(PARI)
#include "genpari.h"
#endif
@@ -669,7 +670,12 @@
printf("Copyright (C) 1994-2000, all rights reserved, FUJITSU LABORATORIES LIMITED.\n");
printf("Copyright 2000,2001, Risa/Asir committers, http://www.openxm.org/.\n");
@@ -707,11 +708,8 @@
printf("Copyright 2000-2003, Risa/Asir committers, http://www.openxm.org/.\n");
printf("GC 6.1(alpha5) copyright 2001, H-J. Boehm, A. J. Demers, Xerox, SGI, HP.\n");
#if PARI
-#if 0
- printf("PARI 2.2.4, copyright (C) 2002 The PARI Group.\n");
+#if PARI
+ printf("%s.\n",PARI_DEVEL_VERSION);
+#endif
+#if LAPACK
+ printf("%s.\n",LAPACK_VERSION);
+#endif
-#endif
- printf("PARI 2.0.17, copyright 1989-1999, C. Batut, K. Belabas, D. Bernardi,\n");
- printf(" H. Cohen and M. Olivier.\n");
+ printf("%s.\n",PARIVERSION);
+ printf("copyright (C) 2002 The PARI Group.\n");
#endif
}

View file

@ -0,0 +1,24 @@
--- parse/glob.c.orig Wed Sep 11 17:57:21 2002
+++ parse/glob.c Thu Oct 17 11:19:30 2002
@@ -51,6 +51,7 @@
#include "al.h"
#include "parse.h"
#include "ox.h"
+#include "version.h"
#if PARI
#include "genpari.h"
#endif
@@ -669,7 +670,12 @@
printf("Copyright (C) 1994-2000, all rights reserved, FUJITSU LABORATORIES LIMITED.\n");
printf("Copyright 2000,2001, Risa/Asir committers, http://www.openxm.org/.\n");
printf("GC 6.1(alpha5) copyright 2001, H-J. Boehm, A. J. Demers, Xerox, SGI, HP.\n");
- printf("PARI 2.2.4, copyright (C) 2002 The PARI Group.\n");
+#if PARI
+ printf("%s.\n",PARI_DEVEL_VERSION);
+#endif
+#if LAPACK
+ printf("%s.\n",LAPACK_VERSION);
+#endif
}

View file

@ -0,0 +1,79 @@
--- Makefile.am.orig Mon Mar 24 20:30:38 2003
+++ Makefile.am Fri May 2 15:33:10 2003
@@ -9,13 +9,15 @@
SUBDIRS = asm builtin engine fft include io lib parse ${PLOTDIR}
-asirdir = ${libdir}/asir
+bindir = ${prefix}/bin
+asirlibdir = ${datadir}/asir
+asirdir = ${bindir}
asir_PROGRAMS = asir
asir_SOURCES = parse/main.c
asir_LDADD = libasir.a libasir-gc.a
CLEANFILES = ${asir_LDADD} asir-openxm-${VERSION}.tgz
-DEFS = @DEFS@ -DASIR_LIBDIR=\"${asirdir}\"
+DEFS = @DEFS@ -DASIR_LIBDIR=\"${asirlibdir}\"
INCLUDES = -I${top_srcdir}/include -I${top_srcdir}/parse -I${top_srcdir}/io \
-I${top_srcdir}/gc/include \
@PARIINC@ @MPIINC@ @X_CFLAGS@
@@ -76,33 +78,33 @@
${INSTALL_DATA} libasir-gc.a ${DESTDIR}${libdir}/libasir-gc.a
install-openxm: asir${EXEEXT} install-libasir install-libasir-gc
- -mkdir -p ${DESTDIR}${bindir}
- ${INSTALL_PROGRAM} asir ${DESTDIR}${bindir}
- -mkdir -p ${DESTDIR}${asirdir}
- (cd ${top_srcdir}/lib; ${MAKE} install-doc install-lib)
- -rm -f ${DESTDIR}${bindir}/ox_asir${EXEEXT}
- (cd ${DESTDIR}${bindir} ; ${LN_S} asir${EXEEXT} ox_asir${EXEEXT})
- -(cd ${DESTDIR}${asirdir}; \
- rm -f asir${EXEEXT} ox_asir${EXEEXT} ox_launch${EXEEXT} ox_plot${EXEEXT})
- (cd ${DESTDIR}${asirdir} ; \
- ${LN_S} ../../bin/asir${EXEEXT} asir${EXEEXT} ; \
- ${LN_S} asir${EXEEXT} ox_asir${EXEEXT} ; \
- ${LN_S} asir${EXEEXT} ox_launch${EXEEXT} ; \
- ${LN_S} asir${EXEEXT} ox_plot${EXEEXT})
- (cd ${top_srcdir}/include; ${MAKE} install)
- (cd ${top_srcdir}/parse; ${MAKE} install)
+# -mkdir -p ${DESTDIR}${bindir}
+# ${INSTALL_PROGRAM} asir /usr/local/bin
+# -mkdir -p ${DESTDIR}${asirdir}
+# (cd ${top_srcdir}/lib; ${MAKE} install-doc install-lib)
+# -rm -f ${DESTDIR}${bindir}/ox_asir${EXEEXT}
+# (cd ${DESTDIR}${bindir} ; ${LN_S} asir${EXEEXT} ox_asir${EXEEXT})
+# -(cd ${DESTDIR}${asirdir}; \
+# rm -f asir${EXEEXT} ox_asir${EXEEXT} ox_launch${EXEEXT} ox_plot${EXEEXT})
+# (cd ${DESTDIR}${asirdir} ; \
+# ${LN_S} ../../bin/asir${EXEEXT} asir${EXEEXT} ; \
+# ${LN_S} asir${EXEEXT} ox_asir${EXEEXT} ; \
+# ${LN_S} asir${EXEEXT} ox_launch${EXEEXT} ; \
+# ${LN_S} asir${EXEEXT} ox_plot${EXEEXT})
+# (cd ${top_srcdir}/include; ${MAKE} install)
+# (cd ${top_srcdir}/parse; ${MAKE} install)
install-lib:
- (cd ${top_srcdir}/lib; ${MAKE} install-lib)
- -(cd ${DESTDIR}${asirdir}; \
- rm -f ox_asir${EXEEXT} ox_launch${EXEEXT} ox_plot${EXEEXT})
- (cd ${DESTDIR}${asirdir} ; \
- ${LN_S} asir${EXEEXT} ox_asir${EXEEXT} ; \
- ${LN_S} asir${EXEEXT} ox_launch${EXEEXT} ; \
- ${LN_S} asir${EXEEXT} ox_plot${EXEEXT})
- -mkdir -p ${DESTDIR}${bindir}
- -rm -f ${DESTDIR}${bindir}/asir${EXEEXT}
- (cd ${DESTDIR}${bindir} ; ${LN_S} ../lib/asir/asir${EXEEXT} asir${EXEEXT})
+# (cd ${top_srcdir}/lib; ${MAKE} install-lib)
+# -(cd ${DESTDIR}${asirdir}; \
+# rm -f ox_asir${EXEEXT} ox_launch${EXEEXT} ox_plot${EXEEXT})
+# (cd ${DESTDIR}${asirdir} ; \
+# ${LN_S} asir${EXEEXT} ox_asir${EXEEXT} ; \
+# ${LN_S} asir${EXEEXT} ox_launch${EXEEXT} ; \
+# ${LN_S} asir${EXEEXT} ox_plot${EXEEXT})
+# -mkdir -p ${DESTDIR}${bindir}
+# -rm -f ${DESTDIR}${bindir}/asir${EXEEXT}
+# (cd ${DESTDIR}${bindir} ; ${LN_S} ../lib/asir/asir${EXEEXT} asir${EXEEXT})
install-doc:
(cd ${top_srcdir}/lib; ${MAKE} install-doc)

View file

@ -0,0 +1,10 @@
--- asm/Makefile.am.orig Fri May 2 02:18:28 2003
+++ asm/Makefile.am Fri May 2 02:18:50 2003
@@ -1,6 +1,6 @@
## $OpenXM: OpenXM_contrib2/asir2000/asm/Makefile.am,v 1.3 2003/03/20 07:34:08 ohara Exp $
-asirdir = ${prefix}/lib/asir
+asirdir = ${prefix}/share/asir
DEFS = @DEFS@ -DASIR_LIBDIR=\"${asirdir}\"
INCLUDES = -I${top_srcdir}/include -I${top_srcdir}/parse -I${top_srcdir}/io \
-I${top_srcdir}/gc/include \

View file

@ -0,0 +1,10 @@
--- builtin/Makefile.am.orig Fri May 2 02:19:51 2003
+++ builtin/Makefile.am Fri May 2 02:20:08 2003
@@ -1,6 +1,6 @@
## $OpenXM: OpenXM_contrib2/asir2000/builtin/Makefile.am,v 1.4 2003/03/20 07:34:09 ohara Exp $
-asirdir = ${prefix}/lib/asir
+asirdir = ${prefix}/share/asir
DEFS = @DEFS@ -DASIR_LIBDIR=\"${asirdir}\"
INCLUDES = -I${top_srcdir}/include -I${top_srcdir}/parse -I${top_srcdir}/io \
-I${top_srcdir}/gc/include \

View file

@ -0,0 +1,10 @@
--- engine/Makefile.am.orig Fri May 2 02:20:57 2003
+++ engine/Makefile.am Fri May 2 02:21:10 2003
@@ -1,6 +1,6 @@
## $OpenXM: OpenXM_contrib2/asir2000/engine/Makefile.am,v 1.3 2003/03/20 07:34:09 ohara Exp $
-asirdir = ${prefix}/lib/asir
+asirdir = ${prefix}/share/asir
DEFS = @DEFS@ -DASIR_LIBDIR=\"${asirdir}\"
INCLUDES = -I${top_srcdir}/include -I${top_srcdir}/parse -I${top_srcdir}/io \
-I${top_srcdir}/gc/include \

View file

@ -0,0 +1,10 @@
--- fft/Makefile.am.orig Fri May 2 02:22:14 2003
+++ fft/Makefile.am Fri May 2 02:22:25 2003
@@ -1,6 +1,6 @@
## $OpenXM: OpenXM_contrib2/asir2000/fft/Makefile.am,v 1.3 2003/03/20 07:34:10 ohara Exp $
-asirdir = ${prefix}/lib/asir
+asirdir = ${prefix}/share/asir
DEFS = @DEFS@ -DASIR_LIBDIR=\"${asirdir}\"
INCLUDES = -I${top_srcdir}/include -I${top_srcdir}/parse -I${top_srcdir}/io \
-I${top_srcdir}/gc/include \

View file

@ -0,0 +1,10 @@
--- io/Makefile.am.orig Fri May 2 02:23:04 2003
+++ io/Makefile.am Fri May 2 02:23:28 2003
@@ -1,6 +1,6 @@
## $OpenXM: OpenXM_contrib2/asir2000/io/Makefile.am,v 1.3 2003/03/20 07:34:11 ohara Exp $
-asirdir = ${prefix}/lib/asir
+asirdir = ${prefix}/share/asir
DEFS = @DEFS@ -DASIR_LIBDIR=\"${asirdir}\"
INCLUDES = -I${top_srcdir}/include -I${top_srcdir}/parse -I${top_srcdir}/io \
-I${top_srcdir}/gc/include \

View file

@ -0,0 +1,11 @@
--- parse/Makefile.am.orig Fri May 2 02:24:05 2003
+++ parse/Makefile.am Fri May 2 02:24:23 2003
@@ -3,7 +3,7 @@
incdir = ${prefix}/include/asir
inc_HEADERS = comp.h cpp.h parse.h w_stdio.h
-asirdir = ${prefix}/lib/asir
+asirdir = ${prefix}/share/asir
DEFS = @DEFS@ -DASIR_LIBDIR=\"${asirdir}\"
INCLUDES = -I${top_srcdir}/include -I${top_srcdir}/parse -I${top_srcdir}/io \
-I${top_srcdir}/gc/include \

View file

@ -0,0 +1,10 @@
--- plot/Makefile.am.orig Fri May 2 02:24:53 2003
+++ plot/Makefile.am Fri May 2 02:25:03 2003
@@ -1,6 +1,6 @@
## $OpenXM: OpenXM_contrib2/asir2000/plot/Makefile.am,v 1.3 2003/03/20 07:34:13 ohara Exp $
-asirdir = ${prefix}/lib/asir
+asirdir = ${prefix}/share/asir
DEFS = @DEFS@ -DASIR_LIBDIR=\"${asirdir}\"
INCLUDES = -I${top_srcdir}/include -I${top_srcdir}/parse -I${top_srcdir}/io \
-I${top_srcdir}/gc/include \

View file

@ -0,0 +1,11 @@
--- configure.in.orig Fri May 2 02:12:44 2003
+++ configure.in Fri May 2 02:15:11 2003
@@ -2,7 +2,7 @@
AC_INIT([LICENSE])
AC_PREREQ(2.53)
-AM_INIT_AUTOMAKE(asir, 20030307)
+AM_INIT_AUTOMAKE(asir, 20030502)
AM_MAINTAINER_MODE
AC_CANONICAL_SYSTEM

View file

@ -0,0 +1,10 @@
--- lib/Makefile.am.orig Fri May 2 02:30:42 2003
+++ lib/Makefile.am Fri May 2 02:30:57 2003
@@ -1,6 +1,6 @@
## $OpenXM: OpenXM_contrib2/asir2000/lib/Makefile.am,v 1.7 2003/04/20 07:15:35 noro Exp $
-asirdir = ${libdir}/asir
+asirdir = ${datadir}/asir
RR = alpi bfct bgk const cyclic defs.h dfff dmul fctrdata fctrtest \
fff glib gr ifplot katsura mat nf num primdec primdec_lex \
ratint robot solve sp sturm sym xm primdec_mod

View file

@ -1,4 +1,21 @@
bin/asir
include/asir/al.h
include/asir/b.h
include/asir/base.h
include/asir/bf.h
include/asir/ca-27.h
include/asir/ca.h
include/asir/com.h
include/asir/comp.h
include/asir/cpp.h
include/asir/inline.h
include/asir/interval.h
include/asir/ox.h
include/asir/parse.h
include/asir/prime.h
include/asir/version.h
include/asir/w_stdio.h
include/asir/wsio.h
share/asir/alpi
share/asir/bfct
share/asir/bgk
@ -27,17 +44,22 @@ share/asir/xm
share/asir/ox_asir
share/asir/ox_plot
share/asir/ox_launch
share/asir/help
share/asir/help-eg/%
share/asir/help-eg/af
share/asir/help-eg/af_noalg
share/asir/help-eg/alg
share/asir/help-eg/algptorat
share/asir/help-eg/algv
share/asir/help-eg/ann
share/asir/help-eg/ann0
share/asir/help-eg/append
share/asir/help-eg/arfreg
share/asir/help-eg/args
share/asir/help-eg/asciitostr
share/asir/help-eg/asq
share/asir/help-eg/bfct
share/asir/help-eg/bfunction
share/asir/help-eg/bload
share/asir/help-eg/bload27
share/asir/help-eg/break
@ -67,6 +89,7 @@ share/asir/help-eg/deval
share/asir/help-eg/dgr
share/asir/help-eg/diff
share/asir/help-eg/dn
share/asir/help-eg/dp_gr_f_main
share/asir/help-eg/dp_dehomo
share/asir/help-eg/dp_dtop
share/asir/help-eg/dp_etov
@ -103,6 +126,11 @@ share/asir/help-eg/dp_td
share/asir/help-eg/dp_true_nf
share/asir/help-eg/dp_true_nf_mod
share/asir/help-eg/dp_vtoe
share/asir/help-eg/dp_weyl_f4_main
share/asir/help-eg/dp_weyl_f4_mod_main
share/asir/help-eg/dp_weyl_gr_f_main
share/asir/help-eg/dp_weyl_gr_main
share/asir/help-eg/dp_weyl_gr_mod_main
share/asir/help-eg/draw_obj
share/asir/help-eg/draw_string
share/asir/help-eg/ecm_add_ff
@ -125,6 +153,7 @@ share/asir/help-eg/gb_comp
share/asir/help-eg/gcd
share/asir/help-eg/gcdz
share/asir/help-eg/generate_port
share/asir/help-eg/generic_bfct
share/asir/help-eg/get_byte
share/asir/help-eg/get_line
share/asir/help-eg/get_rootdir
@ -223,6 +252,9 @@ share/asir/help-eg/primadec
share/asir/help-eg/prime
share/asir/help-eg/primedec
share/asir/help-eg/print
share/asir/help-eg/polarplot
share/asir/help-eg/primedec_mod
share/asir/help-eg/ptosfp
share/asir/help-eg/psubst
share/asir/help-eg/ptogf2n
share/asir/help-eg/ptozp
@ -250,6 +282,8 @@ share/asir/help-eg/set_uptkara
share/asir/help-eg/setmod
share/asir/help-eg/setmod_ff
share/asir/help-eg/setprec
share/asir/help-eg/sffctr
share/asir/help-eg/sfptop
share/asir/help-eg/shell
share/asir/help-eg/simp_ff
share/asir/help-eg/simpalg
@ -313,11 +347,15 @@ share/asir/help-jp/af_noalg
share/asir/help-jp/alg
share/asir/help-jp/algptorat
share/asir/help-jp/algv
share/asir/help-jp/ann
share/asir/help-jp/ann0
share/asir/help-jp/append
share/asir/help-jp/arfreg
share/asir/help-jp/args
share/asir/help-jp/asciitostr
share/asir/help-jp/asq
share/asir/help-jp/bfct
share/asir/help-jp/bfunction
share/asir/help-jp/bload
share/asir/help-jp/bload27
share/asir/help-jp/bsave
@ -351,6 +389,7 @@ share/asir/help-jp/dp_etov
share/asir/help-jp/dp_f4_main
share/asir/help-jp/dp_f4_mod_main
share/asir/help-jp/dp_gr_flags
share/asir/help-jp/dp_gr_f_main
share/asir/help-jp/dp_gr_main
share/asir/help-jp/dp_gr_mod_main
share/asir/help-jp/dp_gr_print
@ -381,6 +420,11 @@ share/asir/help-jp/dp_td
share/asir/help-jp/dp_true_nf
share/asir/help-jp/dp_true_nf_mod
share/asir/help-jp/dp_vtoe
share/asir/help-jp/dp_weyl_f4_main
share/asir/help-jp/dp_weyl_f4_mod_main
share/asir/help-jp/dp_weyl_gr_f_main
share/asir/help-jp/dp_weyl_gr_main
share/asir/help-jp/dp_weyl_gr_mod_main
share/asir/help-jp/draw_obj
share/asir/help-jp/draw_string
share/asir/help-jp/ecm_add_ff
@ -403,6 +447,7 @@ share/asir/help-jp/gb_comp
share/asir/help-jp/gcd
share/asir/help-jp/gcdz
share/asir/help-jp/generate_port
share/asir/help-jp/generic_bfct
share/asir/help-jp/get_byte
share/asir/help-jp/get_line
share/asir/help-jp/get_rootdir
@ -500,6 +545,9 @@ share/asir/help-jp/primadec
share/asir/help-jp/prime
share/asir/help-jp/primedec
share/asir/help-jp/print
share/asir/help-jp/polarplot
share/asir/help-jp/primedec_mod
share/asir/help-jp/ptosfp
share/asir/help-jp/psubst
share/asir/help-jp/ptogf2n
share/asir/help-jp/ptozp
@ -526,6 +574,8 @@ share/asir/help-jp/set_uptkara
share/asir/help-jp/setmod
share/asir/help-jp/setmod_ff
share/asir/help-jp/setprec
share/asir/help-jp/sffctr
share/asir/help-jp/sfptop
share/asir/help-jp/shell
share/asir/help-jp/simp_ff
share/asir/help-jp/simpalg
@ -583,8 +633,8 @@ share/asir/help-jp/version
share/asir/help-jp/vtol
share/asir/help-jp/vtype
share/asir/help-jp/which
share/doc/asir/man-eg.ps
share/doc/asir/man-jp.ps
share/doc/asir/man-eg.pdf
share/doc/asir/man-jp.pdf
share/doc/asir/html-eg/man_1.html
share/doc/asir/html-eg/man_10.html
share/doc/asir/html-eg/man_100.html
@ -768,6 +818,12 @@ share/doc/asir/html-eg/man_260.html
share/doc/asir/html-eg/man_261.html
share/doc/asir/html-eg/man_262.html
share/doc/asir/html-eg/man_263.html
share/doc/asir/html-eg/man_264.html
share/doc/asir/html-eg/man_265.html
share/doc/asir/html-eg/man_266.html
share/doc/asir/html-eg/man_267.html
share/doc/asir/html-eg/man_268.html
share/doc/asir/html-eg/man_269.html
share/doc/asir/html-eg/man_27.html
share/doc/asir/html-eg/man_28.html
share/doc/asir/html-eg/man_29.html
@ -1032,6 +1088,12 @@ share/doc/asir/html-jp/man_260.html
share/doc/asir/html-jp/man_261.html
share/doc/asir/html-jp/man_262.html
share/doc/asir/html-jp/man_263.html
share/doc/asir/html-jp/man_264.html
share/doc/asir/html-jp/man_265.html
share/doc/asir/html-jp/man_266.html
share/doc/asir/html-jp/man_267.html
share/doc/asir/html-jp/man_268.html
share/doc/asir/html-jp/man_269.html
share/doc/asir/html-jp/man_27.html
share/doc/asir/html-jp/man_28.html
share/doc/asir/html-jp/man_29.html
@ -1115,8 +1177,9 @@ share/doc/asir/html-jp/man_99.html
share/doc/asir/html-jp/man_toc.html
share/doc/asir/html-internal-ja/internal.html
share/doc/asir/html-internal-ja/internal_toc.html
share/doc/asir/internal.ps
share/doc/asir/internal-jp.pdf
share/doc/asir/asir.1
@dirrm include/asir
@dirrm share/asir/help-jp
@dirrm share/asir/help-eg
@dirrm share/asir