- Update to 0.9.0, Retire 0.8.5

This commit is contained in:
Dirk Meyer 2003-10-19 11:14:50 +00:00
parent a58da456de
commit 897319326d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=91667
7 changed files with 922 additions and 1559 deletions

View file

@ -6,11 +6,7 @@
#
PORTNAME= gnustep-back
.if defined(WITH_GNUSTEP_DEVEL)
PORTVERSION= 0.8.9
.else
PORTVERSION= 0.8.5
.endif
PORTVERSION= 0.9.0
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNUSTEP} \
ftp://ftp.gnustep.org/pub/gnustep/%SUBDIR%/
@ -56,9 +52,6 @@ CONFIGURE_ARGS+= --enable-graphics=art --with-name=art
PLIST_SUB+= BACK=art USE_XLIB="@comment "
PLIST_SUB+= USE_XLIB="@comment " USE_XDPS="@comment " USE_ART=""
PKGNAMESUFFIX?= -art
.if !defined(WITH_GNUSTEP_DEVEL)
EXTRA_PATCHES+= ${FILESDIR}/ftfont.m.diff
.endif
.else
CONFIGURE_ARGS+= --enable-graphics=xlib --with-name=back
PLIST_SUB+= BACK=back

View file

@ -1,2 +1 @@
MD5 (gnustep-back-0.8.5.tar.gz) = 9020f254f584ed176221321218857b55
MD5 (gnustep-back-0.8.9.tar.gz) = af2ba9a683a28f75ebdeb91dd58debec
MD5 (gnustep-back-0.9.0.tar.gz) = a2e912a376315dbd3a188e0d5a617b3c

View file

@ -1,179 +0,0 @@
--- Source/art/ftfont.m.orig Sun May 11 19:23:43 2003
+++ Source/art/ftfont.m Tue Jun 3 05:25:16 2003
@@ -79,9 +79,9 @@
@interface FTFontInfo : GSFontInfo <FTFontInfo>
{
@public
- FTC_ImageDesc imgd;
+ FTC_Image_Desc imgd;
- FTC_ImageDesc fallback;
+ FTC_Image_Desc fallback;
FTFaceInfo *face_info;
@@ -748,7 +748,7 @@
int use_sbit;
FTC_SBit sbit;
- FTC_ImageDesc cur;
+ FTC_Image_Desc cur;
FT_Matrix ftmatrix;
FT_Vector ftdelta;
@@ -800,23 +800,23 @@
int rh = face_info->render_hints_hack;
if (rh & 0x10000)
{
- cur.type = ftc_image_grays;
+ cur.image_type = ftc_image_grays;
rh = (rh >> 8) & 0xff;
}
else
{
- cur.type = ftc_image_mono;
+ cur.image_type = ftc_image_mono;
rh = rh & 0xff;
}
if (rh & 1)
- cur.type |= ftc_image_flag_autohinted;
+ cur.image_type |= ftc_image_flag_autohinted;
if (!(rh & 2))
- cur.type |= ftc_image_flag_unhinted;
+ cur.image_type |= ftc_image_flag_unhinted;
}
else if (xx < 8)
- cur.type = ftc_image_grays | ftc_image_flag_unhinted;
+ cur.image_type = ftc_image_grays | ftc_image_flag_unhinted;
else
- cur.type = ftc_image_grays;
+ cur.image_type = ftc_image_grays;
}
else
{
@@ -1163,7 +1163,7 @@
int use_sbit;
FTC_SBit sbit;
- FTC_ImageDesc cur;
+ FTC_Image_Desc cur;
FT_Matrix ftmatrix;
FT_Vector ftdelta;
@@ -1215,23 +1215,23 @@
int rh = face_info->render_hints_hack;
if (rh & 0x10000)
{
- cur.type = ftc_image_grays;
+ cur.image_type = ftc_image_grays;
rh = (rh >> 8) & 0xff;
}
else
{
- cur.type = ftc_image_mono;
+ cur.image_type = ftc_image_mono;
rh = rh & 0xff;
}
if (rh & 1)
- cur.type |= ftc_image_flag_autohinted;
+ cur.image_type |= ftc_image_flag_autohinted;
if (!(rh & 2))
- cur.type |= ftc_image_flag_unhinted;
+ cur.image_type |= ftc_image_flag_unhinted;
}
else if (xx < 8)
- cur.type = ftc_image_grays | ftc_image_flag_unhinted;
+ cur.image_type = ftc_image_grays | ftc_image_flag_unhinted;
else
- cur.type = ftc_image_grays;
+ cur.image_type = ftc_image_grays;
}
else
{
@@ -1521,7 +1521,7 @@
/* TODO: try to more efficiently? */
/* TODO: set up all this stuff in -init... for the raw metric case */
float xx, yy;
- FTC_ImageDesc cur;
+ FTC_Image_Desc cur;
FTC_SBit sbit;
cur = imgd;
@@ -1534,23 +1534,23 @@
int rh = face_info->render_hints_hack;
if (rh & 0x10000)
{
- cur.type = ftc_image_grays;
+ cur.image_type = ftc_image_grays;
rh = (rh >> 8) & 0xff;
}
else
{
- cur.type = ftc_image_mono;
+ cur.image_type = ftc_image_mono;
rh = rh & 0xff;
}
if (rh & 1)
- cur.type |= ftc_image_flag_autohinted;
+ cur.image_type |= ftc_image_flag_autohinted;
if (!(rh & 2))
- cur.type |= ftc_image_flag_unhinted;
+ cur.image_type |= ftc_image_flag_unhinted;
}
else if (xx < 8)
- cur.type = ftc_image_grays | ftc_image_flag_unhinted;
+ cur.image_type = ftc_image_grays | ftc_image_flag_unhinted;
else
- cur.type = ftc_image_grays;
+ cur.image_type = ftc_image_grays;
if ((error=FTC_SBitCache_Lookup(ftc_sbitcache, &cur, glyph, &sbit, NULL)))
{
@@ -1605,7 +1605,7 @@
- (NSRect) boundingRectForGlyph: (NSGlyph)glyph
{
- FTC_ImageDesc *cur;
+ FTC_Image_Desc *cur;
FT_BBox bbox;
FT_Glyph g;
FT_Error error;
@@ -1682,7 +1682,7 @@
FTC_SBit sbit;
- FTC_ImageDesc *cur;
+ FTC_Image_Desc *cur;
cmap.face_id = imgd.font.face_id;
@@ -1895,7 +1895,7 @@
unichar *uch;
int ulen;
- FTC_ImageDesc cur;
+ FTC_Image_Desc cur;
FT_Matrix ftmatrix;
@@ -2065,7 +2065,7 @@
int use_sbit;
FTC_SBit sbit;
- FTC_ImageDesc cur;
+ FTC_Image_Desc cur;
FT_Matrix ftmatrix;
FT_Vector ftdelta;
@@ -2111,9 +2111,9 @@
/* if (cur.font.pix_width < 16 && cur.font.pix_height < 16 &&
cur.font.pix_width > 6 && cur.font.pix_height > 6)
- cur.type = ftc_image_mono;
+ cur.image_type = ftc_image_mono;
else*/
- cur.type = ftc_image_grays, subpixel = YES, cur.font.pix_width *= 3, x *= 3;
+ cur.image_type = ftc_image_grays, subpixel = YES, cur.font.pix_width *= 3, x *= 3;
// imgd.type|=|ftc_image_flag_unhinted; /* TODO? when? */
}
else

View file

@ -1,32 +1,12 @@
%%GNUSTEP_DEVEL%%System/Library/Bundles/libgnustep-%%BACK%%.bundle/Resources/English.lproj/nfontFaceNames.strings
System/Library/Bundles/libgnustep-%%BACK%%.bundle/Resources/English.lproj/nfontFaceNames.strings
System/Library/Bundles/libgnustep-%%BACK%%.bundle/Resources/Info-gnustep.plist
%%GNUSTEP_DEVEL%%System/Library/Bundles/libgnustep-%%BACK%%.bundle/Resources/Swedish.lproj/nfontFaceNames.strings
System/Library/Bundles/libgnustep-%%BACK%%.bundle/%%NOFLAT%%libgnustep-%%BACK%%
System/Library/Bundles/libgnustep-%%BACK%%.bundle/Resources/Swedish.lproj/nfontFaceNames.strings
System/Library/Bundles/libgnustep-%%BACK%%.bundle/libgnustep-%%BACK%%
System/Library/Bundles/libgnustep-%%BACK%%.bundle/stamp.make
%%GNUSTEP_STABLE%%%%SYSTEMLIBRARY%%/Headers/gnustep/gsc/GSContext.h
%%GNUSTEP_STABLE%%%%SYSTEMLIBRARY%%/Headers/gnustep/gsc/GSGState.h
%%GNUSTEP_STABLE%%%%SYSTEMLIBRARY%%/Headers/gnustep/gsc/GSGStateOps.h
%%GNUSTEP_STABLE%%%%SYSTEMLIBRARY%%/Headers/gnustep/gsc/gscolors.h
%%GNUSTEP_STABLE%%%%SYSTEMLIBRARY%%/Headers/gnustep/x11/XGServer.h
%%GNUSTEP_STABLE%%%%SYSTEMLIBRARY%%/Headers/gnustep/x11/XGServerWindow.h
%%GNUSTEP_STABLE%%%%USE_ART%%%%SYSTEMLIBRARY%%/Headers/gnustep/art/ARTContext.h
%%GNUSTEP_STABLE%%%%USE_XDPS%%%%SYSTEMLIBRARY%%/Headers/gnustep/xdps/NSDPSContext.h
%%GNUSTEP_STABLE%%%%USE_XLIB%%%%SYSTEMLIBRARY%%/Headers/gnustep/xlib/XGContext.h
%%GNUSTEP_STABLE%%%%USE_XLIB%%%%SYSTEMLIBRARY%%/Headers/gnustep/xlib/XGGState.h
%%GNUSTEP_STABLE%%%%USE_XLIB%%%%SYSTEMLIBRARY%%/Headers/gnustep/xlib/XGGeometry.h
%%GNUSTEP_STABLE%%%%USE_XLIB%%%%SYSTEMLIBRARY%%/Headers/gnustep/xlib/XGPrivate.h
%%GNUSTEP_DEVEL%%System/Library/Documentation/man/man1/gpbs.1.gz
%%USE_XLIB%%System/Tools/%%NOFLAT%%font_cacher
System/Tools/%%NOFLAT%%gpbs
%%GNUSTEP_STABLE%%@dirrm %%SYSTEMLIBRARY%%/Headers/gnustep/x11
%%GNUSTEP_STABLE%%%%USE_ART%%@dirrm %%SYSTEMLIBRARY%%/Headers/gnustep/art
%%GNUSTEP_STABLE%%%%USE_XDPS%%@dirrm %%SYSTEMLIBRARY%%/Headers/gnustep/xdps
%%GNUSTEP_STABLE%%%%USE_XLIB%%@dirrm %%SYSTEMLIBRARY%%/Headers/gnustep/xlib
%%GNUSTEP_STABLE%%@dirrm %%SYSTEMLIBRARY%%/Headers/gnustep/gsc
%%GNUSTEP_STABLE%%@dirrm System/Library/Bundles/libgnustep-%%BACK%%.bundle/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu
%%GNUSTEP_STABLE%%@dirrm System/Library/Bundles/libgnustep-%%BACK%%.bundle/%%GNU_ARCH%%/%%OPSYS%%
%%GNUSTEP_STABLE%%@dirrm System/Library/Bundles/libgnustep-%%BACK%%.bundle/%%GNU_ARCH%%
%%GNUSTEP_DEVEL%%@dirrm System/Library/Bundles/libgnustep-%%BACK%%.bundle/Resources/Swedish.lproj
%%GNUSTEP_DEVEL%%@dirrm System/Library/Bundles/libgnustep-%%BACK%%.bundle/Resources/English.lproj
System/Library/Documentation/man/man1/gpbs.1.gz
%%USE_XLIB%%System/Tools/font_cacher
System/Tools/gpbs
@dirrm System/Library/Bundles/libgnustep-%%BACK%%.bundle/Resources/Swedish.lproj
@dirrm System/Library/Bundles/libgnustep-%%BACK%%.bundle/Resources/English.lproj
@dirrm System/Library/Bundles/libgnustep-%%BACK%%.bundle/Resources
@dirrm System/Library/Bundles/libgnustep-%%BACK%%.bundle

View file

@ -6,11 +6,7 @@
#
PORTNAME= gnustep-gui
.if defined(WITH_GNUSTEP_DEVEL)
PORTVERSION= 0.8.9
.else
PORTVERSION= 0.8.5
.endif
PORTVERSION= 0.9.0
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNUSTEP} \
ftp://ftp.gnustep.org/pub/gnustep/%SUBDIR%/
@ -39,7 +35,7 @@ USE_GNUSTEP_BASE= yes
MAKEFILE=
MAKE_FLAGS+= OPTFLAG="${CFLAGS}"
BREAKS_IF_PEDANTIC= yes
EXTRA_FIX= ${WRKSRC}/Tools/gsnd/portaudio/pa_unix_oss/Makefile
USE_REINPLACE= yes
post-extract:
.for file in config.guess config.sub install-sh
@ -47,10 +43,12 @@ post-extract:
.endfor
pre-configure:
@ ${MV} ${EXTRA_FIX} ${EXTRA_FIX}.sed
${SED} -e "s=-lphread=${PTHREAD_LIBS}=" -e "s;CFLAGS =;CFLAGS+=;" \
-e "s;-Wall;-Wall ${PTHREAD_CFLAGS:S=""==};" \
${EXTRA_FIX}.sed > ${EXTRA_FIX}
${REINPLACE_CMD} -e "s|-lphread|${PTHREAD_LIBS}|" -e "s|CFLAGS =|CFLAGS+=|" \
-e "s|-Wall|-Wall ${PTHREAD_CFLAGS:S=""==}|" \
${WRKSRC}/Tools/gsnd/portaudio/pa_unix_oss/Makefile
.if !defined(NOPORTDOCS)
${REINPLACE_CMD} -e "s|doc=no|doc=yes|" ${WRKSRC}/GNUmakefile
.endif
test:
@(cd ${WRKSRC}/Tools/gsnd/portaudio/pa_unix_oss && \

View file

@ -1,2 +1 @@
MD5 (gnustep-gui-0.8.5.tar.gz) = ddaf662db31a4e6b382499548e9efcf4
MD5 (gnustep-gui-0.8.9.tar.gz) = 294b03e9c39e6f08c56ff66abade121e
MD5 (gnustep-gui-0.9.0.tar.gz) = d8fd5b87bc0673684c643194a4f10aa9

File diff suppressed because it is too large Load diff