Update Perl 5.20 to 5.20.2.

Poked by:	az
Sponsored by:	Absolight
This commit is contained in:
Mathieu Arnold 2015-02-17 15:58:12 +00:00
parent b23c6d4405
commit 898d0049d2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=379168
10 changed files with 28 additions and 23 deletions

View file

@ -54,7 +54,7 @@ PERL_VERSION= 5.16.3
.elif ${PERL5_DEFAULT} == 5.18
PERL_VERSION= 5.18.4
.elif ${PERL5_DEFAULT} == 5.20
PERL_VERSION= 5.20.1
PERL_VERSION= 5.20.2
.else
IGNORE= Invalid perl5 version ${PERL5_DEFAULT}
.endif

View file

@ -3,7 +3,6 @@
PORTNAME= perl
PORTVERSION= ${PERL_VERSION}
PORTREVISION= 10
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../../src
@ -56,7 +55,7 @@ PORTSCOUT= limitw:1,even
#PORTSCOUT= limit:^${PERL_VER}.
# Remember to update Mk/Uses/perl5.mk too.
PERL_VERSION= 5.20.1
PERL_VERSION= 5.20.2
PERL_VER= ${PERL_VERSION:C/\.[0-9]+$//}
PERL_ARCH= mach
SITE_PERL_REL?= lib/perl5/site_perl

View file

@ -1,2 +1,2 @@
SHA256 (perl/perl-5.20.1.tar.bz2) = ede5ded37e7fb6139b04728cfca826f17076f9888dbfd100a56834dbeb04657c
SIZE (perl/perl-5.20.1.tar.bz2) = 13676155
SHA256 (perl/perl-5.20.2.tar.bz2) = e5a4713bc65e1da98ebd833dce425c000768bfe84d17ec5183ec5ca249db71ab
SIZE (perl/perl-5.20.2.tar.bz2) = 13717128

View file

@ -1,6 +1,6 @@
--- Configure.orig 2014-09-14 11:30:59 UTC
--- Configure.orig 2015-01-10 12:06:37 UTC
+++ Configure
@@ -4948,7 +4948,7 @@
@@ -4948,7 +4948,7 @@ esac
: Now check and see which directories actually exist, avoiding duplicates
for xxx in $dlist
do
@ -9,7 +9,7 @@
case " $libpth " in
*" $xxx "*) ;;
*) libpth="$libpth $xxx";;
@@ -9345,8 +9345,7 @@
@@ -9342,8 +9342,7 @@ prefixvar=siteman3dir
: determine where add-on public executable scripts go
case "$sitescript" in

View file

@ -1,4 +1,4 @@
--- Makefile.SH.orig 2014-09-14 11:30:59 UTC
--- Makefile.SH.orig 2014-12-27 11:49:22 UTC
+++ Makefile.SH
@@ -31,7 +31,6 @@ esac
pwd="`pwd`"

View file

@ -1,6 +1,6 @@
--- cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Any.pm.orig 2014-05-14 23:51:23 UTC
--- cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Any.pm.orig 2014-12-27 11:49:22 UTC
+++ cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Any.pm
@@ -1744,13 +1744,14 @@
@@ -1744,13 +1744,14 @@ sub init_INSTALL_from_PREFIX {
('$(PREFIX)') x 3;
}
else {

View file

@ -1,6 +1,6 @@
--- cpan/ExtUtils-MakeMaker/t/INST_PREFIX.t.orig 2014-05-14 23:51:23 UTC
--- cpan/ExtUtils-MakeMaker/t/INST_PREFIX.t.orig 2014-12-27 11:48:37 UTC
+++ cpan/ExtUtils-MakeMaker/t/INST_PREFIX.t
@@ -10,7 +10,7 @@
@@ -10,7 +10,7 @@ BEGIN {
}
use strict;
@ -9,7 +9,7 @@
use MakeMaker::Test::Utils;
use MakeMaker::Test::Setup::BFD;
use ExtUtils::MakeMaker;
@@ -62,7 +62,7 @@
@@ -62,7 +62,7 @@ like( $stdout->read, qr{
(?:Writing\ MYMETA.yml\ and\ MYMETA.json\n)?
}x );

View file

@ -1,6 +1,6 @@
--- dist/Math-BigInt/lib/Math/BigInt.pm.orig 2014-09-14 11:31:01 UTC
--- dist/Math-BigInt/lib/Math/BigInt.pm.orig 2014-12-27 11:49:23 UTC
+++ dist/Math-BigInt/lib/Math/BigInt.pm
@@ -62,7 +62,7 @@
@@ -62,7 +62,7 @@ use overload
'>>=' => sub { $_[0]->brsft($_[1]); },
# not supported by Perl yet

View file

@ -1,6 +1,6 @@
--- hints/freebsd.sh.orig 2012-05-07 13:40:34 UTC
--- hints/freebsd.sh.orig 2014-12-27 11:49:23 UTC
+++ hints/freebsd.sh
@@ -88,6 +88,8 @@
@@ -88,6 +88,8 @@ case "$osvers" in
esac
libswanted=`echo $libswanted | sed 's/ malloc / /'`
libswanted=`echo $libswanted | sed 's/ bind / /'`
@ -9,7 +9,7 @@
# iconv gone in Perl 5.8.1, but if someone compiles 5.8.0 or earlier.
libswanted=`echo $libswanted | sed 's/ iconv / /'`
d_setregid='define'
@@ -102,6 +104,10 @@
@@ -102,6 +104,10 @@ case "$osvers" in
;;
esac
libswanted=`echo $libswanted | sed 's/ malloc / /'`
@ -20,7 +20,7 @@
;;
esac
@@ -126,7 +132,7 @@
@@ -126,7 +132,7 @@ case "$osvers" in
else
libpth="/usr/lib /usr/local/lib"
glibpth="/usr/lib /usr/local/lib"
@ -29,7 +29,7 @@
lddlflags="-shared "
fi
cccdlflags='-DPIC -fPIC'
@@ -134,7 +140,7 @@
@@ -134,7 +140,7 @@ case "$osvers" in
*)
libpth="/usr/lib /usr/local/lib"
glibpth="/usr/lib /usr/local/lib"
@ -38,7 +38,7 @@
lddlflags="-shared "
cccdlflags='-DPIC -fPIC'
;;
@@ -144,7 +150,7 @@
@@ -144,7 +150,7 @@ case "$osvers" in
0.*|1.*|2.*|3.*) ;;
*)
@ -47,7 +47,7 @@
if /usr/bin/file -L /usr/lib/libc.so | /usr/bin/grep -vq "not stripped" ; then
usenm=false
fi
@@ -191,7 +197,9 @@
@@ -191,7 +197,9 @@ esac
# This script UU/usethreads.cbu will get 'called-back' by Configure
# after it has prompted the user for whether to use threads.

View file

@ -1475,8 +1475,10 @@ etc/perl5_version
%%PRIV_LIB%%/pod/perl5180delta.pod
%%PRIV_LIB%%/pod/perl5181delta.pod
%%PRIV_LIB%%/pod/perl5182delta.pod
%%PRIV_LIB%%/pod/perl5184delta.pod
%%PRIV_LIB%%/pod/perl5200delta.pod
%%PRIV_LIB%%/pod/perl5201delta.pod
%%PRIV_LIB%%/pod/perl5202delta.pod
%%PRIV_LIB%%/pod/perl561delta.pod
%%PRIV_LIB%%/pod/perl56delta.pod
%%PRIV_LIB%%/pod/perl581delta.pod
@ -1617,6 +1619,7 @@ etc/perl5_version
%%PRIV_LIB%%/pod/perltru64.pod
%%PRIV_LIB%%/pod/perltw.pod
%%PRIV_LIB%%/pod/perlunicode.pod
%%PRIV_LIB%%/pod/perlunicook.pod
%%PRIV_LIB%%/pod/perlunifaq.pod
%%PRIV_LIB%%/pod/perluniintro.pod
%%PRIV_LIB%%/pod/perluniprops.pod
@ -2071,8 +2074,10 @@ man/man1/perl5163delta.1.gz
man/man1/perl5180delta.1.gz
man/man1/perl5181delta.1.gz
man/man1/perl5182delta.1.gz
man/man1/perl5184delta.1.gz
man/man1/perl5200delta.1.gz
man/man1/perl5201delta.1.gz
man/man1/perl5202delta.1.gz
man/man1/perl561delta.1.gz
man/man1/perl56delta.1.gz
man/man1/perl581delta.1.gz
@ -2216,6 +2221,7 @@ man/man1/perltrap.1.gz
man/man1/perltru64.1.gz
man/man1/perltw.1.gz
man/man1/perlunicode.1.gz
man/man1/perlunicook.1.gz
man/man1/perlunifaq.1.gz
man/man1/perluniintro.1.gz
man/man1/perluniprops.1.gz