- Use USE_GNOMENG;

- use USE_LIBTOOL;
- get rid of gettext-old dependency.
This commit is contained in:
Maxim Sobolev 2002-07-20 11:20:49 +00:00
parent 5903422ee3
commit 89a289fce8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=63267
16 changed files with 170 additions and 119 deletions

View file

@ -14,25 +14,20 @@ MASTER_SITE_SUBDIR= stable/sources/gedit
MAINTAINER= gnome@FreeBSD.org
BUILD_DEPENDS= msgfmt-old:${PORTSDIR}/devel/gettext-old
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= yes
USE_GNOMENG= yes
USE_GNOME= gnomeprefix gnomehack gnomeprint libglade gnomevfs
USE_REINPLACE= yes
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib" \
MSGFMT="${LOCALBASE}/bin/msgfmt-old" \
XGETTEXT="${LOCALBASE}/bin/xgettext-old"
LIBS="-L${LOCALBASE}/lib"
MAKE_ENV= OLD_PO_FILE_INPUT=1
MAN1= gedit.1
pre-patch:
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${REINPLACE_CMD} -e \
's|[(]datadir[)]/gnome/|(datadir)/|g ; \
s|[(]datadir[)]/locale|(prefix)/share/locale|g'
.include <bsd.port.mk>

View file

@ -1,11 +0,0 @@
--- po/Makefile.in.in.orig Tue Apr 18 14:25:43 2000
+++ po/Makefile.in.in Wed Apr 19 19:06:53 2000
@@ -19,7 +19,7 @@
prefix = @prefix@
exec_prefix = @exec_prefix@
datadir = $(prefix)/@DATADIRNAME@
-localedir = $(datadir)/locale
+localedir = $(prefix)/share/locale
gnulocaledir = $(prefix)/share/locale
gettextsrcdir = $(prefix)/share/gettext/po
subdir = po

View file

@ -1,56 +1,14 @@
--- plugins/browse/Makefile.in.orig Sun Jun 11 03:00:15 2000
+++ plugins/browse/Makefile.in Sun Jun 11 11:15:17 2000
@@ -138,3 +138,3 @@
$FreeBSD$
--- plugins/browse/Makefile.in.orig Sat Jul 20 13:59:48 2002
+++ plugins/browse/Makefile.in Sat Jul 20 14:09:48 2002
@@ -147,7 +147,7 @@
DEFS = @DEFS@ -I. -I$(srcdir) -I../..
LIBS = @LIBS@
-libbrowse_la_LDFLAGS =
+libbrowse_la_LDFLAGS = -avoid-version
+libbrowse_la_LDFLAGS = -avoid-version -module
libbrowse_la_LIBADD =
--- plugins/convert/Makefile.in.orig Sun Jun 11 03:00:17 2000
+++ plugins/convert/Makefile.in Sun Jun 11 11:15:25 2000
@@ -147,3 +147,3 @@
LIBS = @LIBS@
-libconvert_la_LDFLAGS =
+libconvert_la_LDFLAGS = -avoid-version
libconvert_la_LIBADD =
--- plugins/diff/Makefile.in.orig Sun Jul 9 17:12:13 2000
+++ plugins/diff/Makefile.in Mon Jul 10 09:32:42 2000
@@ -144,3 +144,3 @@
LIBS = @LIBS@
-libdiff_la_LDFLAGS =
+libdiff_la_LDFLAGS = -avoid-version
libdiff_la_LIBADD =
--- plugins/email/Makefile.in.orig Sun Jun 11 03:00:16 2000
+++ plugins/email/Makefile.in Sun Jun 11 11:15:33 2000
@@ -147,3 +147,3 @@
LIBS = @LIBS@
-libemail_la_LDFLAGS =
+libemail_la_LDFLAGS = -avoid-version
libemail_la_LIBADD =
--- plugins/reverse/Makefile.in.orig Sun Jun 11 03:00:18 2000
+++ plugins/reverse/Makefile.in Sun Jun 11 11:15:40 2000
@@ -140,3 +140,3 @@
LIBS = @LIBS@
-libreverse_la_LDFLAGS =
+libreverse_la_LDFLAGS = -avoid-version
libreverse_la_LIBADD =
--- plugins/sample/Makefile.in.orig Sun Jul 9 17:12:15 2000
+++ plugins/sample/Makefile.in Mon Jul 10 09:33:18 2000
@@ -140,3 +140,3 @@
LIBS = @LIBS@
-libsample_la_LDFLAGS =
+libsample_la_LDFLAGS = -avoid-version
libsample_la_LIBADD =
--- plugins/shell_output/Makefile.in.orig Sun Jul 9 17:12:19 2000
+++ plugins/shell_output/Makefile.in Mon Jul 10 09:38:40 2000
@@ -147,3 +147,3 @@
LIBS = @LIBS@
-libshell_output_la_LDFLAGS =
+libshell_output_la_LDFLAGS = -avoid-version
libshell_output_la_LIBADD =
--- plugins/time/Makefile.in.orig Sun Jul 9 17:12:16 2000
+++ plugins/time/Makefile.in Mon Jul 10 09:33:38 2000
@@ -140,3 +140,3 @@
LIBS = @LIBS@
-libtime_la_LDFLAGS =
+libtime_la_LDFLAGS = -avoid-version
libtime_la_LIBADD =
libbrowse_la_OBJECTS = browse.lo
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- configure.orig Sat Jul 20 13:58:23 2002
+++ configure Sat Jul 20 13:58:37 2002
@@ -5492,6 +5492,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'

View file

@ -1,28 +0,0 @@
$FreeBSD$
--- ltmain.sh 2001/08/27 09:51:26 1.1
+++ ltmain.sh 2001/08/27 09:51:42
@@ -2408,6 +2408,9 @@
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
# Add libc to deplibs on all other systems if necessary.
if test "$build_libtool_need_lc" = "yes"; then
@@ -4175,10 +4178,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View file

@ -0,0 +1,14 @@
$FreeBSD$
--- plugins/ASCII/Makefile.in 2002/07/20 11:08:53 1.1
+++ plugins/ASCII/Makefile.in 2002/07/20 11:09:42
@@ -150,7 +150,7 @@
DEFS = @DEFS@ -I. -I$(srcdir) -I../..
LIBS = @LIBS@
-libasciitable_la_LDFLAGS =
+libasciitable_la_LDFLAGS = -avoid-version -module
libasciitable_la_LIBADD =
libasciitable_la_OBJECTS = ascii.lo
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)

View file

@ -0,0 +1,14 @@
$FreeBSD$
--- plugins/convert/Makefile.in.orig Sat Jul 20 13:59:48 2002
+++ plugins/convert/Makefile.in Sat Jul 20 14:09:54 2002
@@ -150,7 +150,7 @@
DEFS = @DEFS@ -I. -I$(srcdir) -I../..
LIBS = @LIBS@
-libconvert_la_LDFLAGS =
+libconvert_la_LDFLAGS = -avoid-version -module
libconvert_la_LIBADD =
libconvert_la_OBJECTS = convert.lo
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)

View file

@ -0,0 +1,14 @@
$FreeBSD$
--- plugins/diff/Makefile.in.orig Sat Jul 20 13:59:48 2002
+++ plugins/diff/Makefile.in Sat Jul 20 14:10:00 2002
@@ -147,7 +147,7 @@
DEFS = @DEFS@ -I. -I$(srcdir) -I../..
LIBS = @LIBS@
-libdiff_la_LDFLAGS =
+libdiff_la_LDFLAGS = -avoid-version -module
libdiff_la_LIBADD =
libdiff_la_OBJECTS = diff.lo
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)

View file

@ -0,0 +1,14 @@
$FreeBSD$
--- plugins/docinfo/Makefile.in 2002/07/20 11:09:25 1.1
+++ plugins/docinfo/Makefile.in 2002/07/20 11:10:07
@@ -150,7 +150,7 @@
DEFS = @DEFS@ -I. -I$(srcdir) -I../..
LIBS = @LIBS@
-libdocinfo_la_LDFLAGS =
+libdocinfo_la_LDFLAGS = -avoid-version -module
libdocinfo_la_LIBADD =
libdocinfo_la_OBJECTS = docinfo.lo
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)

View file

@ -0,0 +1,14 @@
$FreeBSD$
--- plugins/email/Makefile.in.orig Sat Jul 20 13:59:48 2002
+++ plugins/email/Makefile.in Sat Jul 20 14:10:11 2002
@@ -150,7 +150,7 @@
DEFS = @DEFS@ -I. -I$(srcdir) -I../..
LIBS = @LIBS@
-libemail_la_LDFLAGS =
+libemail_la_LDFLAGS = -avoid-version -module
libemail_la_LIBADD =
libemail_la_OBJECTS = email.lo
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)

View file

@ -0,0 +1,14 @@
$FreeBSD$
--- plugins/reverse/Makefile.in.orig Sat Jul 20 13:59:48 2002
+++ plugins/reverse/Makefile.in Sat Jul 20 14:10:16 2002
@@ -143,7 +143,7 @@
DEFS = @DEFS@ -I. -I$(srcdir) -I../..
LIBS = @LIBS@
-libreverse_la_LDFLAGS =
+libreverse_la_LDFLAGS = -avoid-version -module
libreverse_la_LIBADD =
libreverse_la_OBJECTS = reverse.lo
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)

View file

@ -0,0 +1,14 @@
$FreeBSD$
--- plugins/sample/Makefile.in.orig Sat Jul 20 13:59:48 2002
+++ plugins/sample/Makefile.in Sat Jul 20 14:10:21 2002
@@ -143,7 +143,7 @@
DEFS = @DEFS@ -I. -I$(srcdir) -I../..
LIBS = @LIBS@
-libsample_la_LDFLAGS =
+libsample_la_LDFLAGS = -avoid-version -module
libsample_la_LIBADD =
libsample_la_OBJECTS = sample.lo
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)

View file

@ -0,0 +1,14 @@
$FreeBSD$
--- plugins/shell_output/Makefile.in.orig Sat Jul 20 13:59:48 2002
+++ plugins/shell_output/Makefile.in Sat Jul 20 14:10:26 2002
@@ -150,7 +150,7 @@
DEFS = @DEFS@ -I. -I$(srcdir) -I../..
LIBS = @LIBS@
-libshell_output_la_LDFLAGS =
+libshell_output_la_LDFLAGS = -avoid-version -module
libshell_output_la_LIBADD =
libshell_output_la_OBJECTS = shell_output.lo
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)

View file

@ -0,0 +1,14 @@
$FreeBSD$
--- plugins/sort/Makefile.in 2002/07/20 11:09:25 1.1
+++ plugins/sort/Makefile.in 2002/07/20 11:10:30
@@ -150,7 +150,7 @@
DEFS = @DEFS@ -I. -I$(srcdir) -I../..
LIBS = @LIBS@
-libsort_la_LDFLAGS =
+libsort_la_LDFLAGS = -avoid-version -module
libsort_la_LIBADD =
libsort_la_OBJECTS = sort.lo
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)

View file

@ -0,0 +1,14 @@
$FreeBSD$
--- plugins/time/Makefile.in.orig Sat Jul 20 13:59:48 2002
+++ plugins/time/Makefile.in Sat Jul 20 14:10:35 2002
@@ -143,7 +143,7 @@
DEFS = @DEFS@ -I. -I$(srcdir) -I../..
LIBS = @LIBS@
-libtime_la_LDFLAGS =
+libtime_la_LDFLAGS = -avoid-version -module
libtime_la_LIBADD =
libtime_la_OBJECTS = time.lo
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)

View file

@ -1,28 +1,14 @@
bin/gedit
lib/gedit/plugins/libasciitable.a
lib/gedit/plugins/libasciitable.so
lib/gedit/plugins/libasciitable.so.0
lib/gedit/plugins/libbrowse.a
lib/gedit/plugins/libbrowse.so
lib/gedit/plugins/libconvert.a
lib/gedit/plugins/libconvert.so
lib/gedit/plugins/libdiff.a
lib/gedit/plugins/libdiff.so
lib/gedit/plugins/libdocinfo.a
lib/gedit/plugins/libdocinfo.so
lib/gedit/plugins/libdocinfo.so.0
lib/gedit/plugins/libemail.a
lib/gedit/plugins/libemail.so
lib/gedit/plugins/libreverse.a
lib/gedit/plugins/libreverse.so
lib/gedit/plugins/libsample.a
lib/gedit/plugins/libsample.so
lib/gedit/plugins/libshell_output.a
lib/gedit/plugins/libshell_output.so
lib/gedit/plugins/libsort.a
lib/gedit/plugins/libsort.so
lib/gedit/plugins/libsort.so.0
lib/gedit/plugins/libtime.a
lib/gedit/plugins/libtime.so
share/gnome/apps/Applications/gedit.desktop
share/gnome/gedit/glade/about.glade
@ -122,8 +108,6 @@ share/locale/zh_TW/LC_MESSAGES/gedit.mo
@dirrm share/gnome/help/gedit/ja
@dirrm share/gnome/help/gedit/C/stylesheet-images
@dirrm share/gnome/help/gedit/C/images
@dirrm share/gnome/help/gedit/C
@dirrm share/gnome/help/gedit
@dirrm share/gnome/gedit/glade
@dirrm share/gnome/gedit
@dirrm lib/gedit/plugins