Add bfbtester 2.0, a security tool for testing binaries for overflows.
PR: 24774 Submitted by: Mike Heffner <mheffner@vt.edu>
This commit is contained in:
parent
dd537b1721
commit
8a44bfc355
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=41019
7 changed files with 49 additions and 0 deletions
|
@ -8,6 +8,7 @@
|
|||
SUBDIR += amavis-perl
|
||||
SUBDIR += apg
|
||||
SUBDIR += beecrypt
|
||||
SUBDIR += bfbtester
|
||||
SUBDIR += bjorb
|
||||
SUBDIR += bro
|
||||
SUBDIR += bugs
|
||||
|
|
19
security/bfbtester/Makefile
Normal file
19
security/bfbtester/Makefile
Normal file
|
@ -0,0 +1,19 @@
|
|||
# New ports collection makefile for: bfbtester
|
||||
# Date created: 31 January 2001
|
||||
# Whom: Mike Heffner <mheffner@vt.edu>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= bfbtester
|
||||
PORTVERSION= 2.0
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= bfbtester
|
||||
|
||||
MAINTAINER= mheffner@vt.edu
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
.include <bsd.port.mk>
|
1
security/bfbtester/distinfo
Normal file
1
security/bfbtester/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (bfbtester-2.0.tar.gz) = 73f41bfe1b8498b7bb2967fe7339e8bd
|
17
security/bfbtester/files/patch-src::bfbt::exec.c
Normal file
17
security/bfbtester/files/patch-src::bfbt::exec.c
Normal file
|
@ -0,0 +1,17 @@
|
|||
Index: src/bfbt/exec.c
|
||||
===================================================================
|
||||
RCS file: /cvsroot/bfbtester/bfbtester/src/bfbt/exec.c,v
|
||||
retrieving revision 1.5
|
||||
diff -u -r1.5 exec.c
|
||||
--- src/bfbt/exec.c 2001/01/25 06:24:49 1.5
|
||||
+++ src/bfbt/exec.c 2001/02/01 03:35:37
|
||||
@@ -144,7 +144,8 @@
|
||||
else if( WIFSIGNALED(entry->status) ){
|
||||
/* we ignore SIGKILL and SIGPIPE */
|
||||
if( WTERMSIG(entry->status) == SIGKILL
|
||||
- || WTERMSIG(entry->status) == SIGPIPE){
|
||||
+ || WTERMSIG(entry->status) == SIGPIPE
|
||||
+ || WTERMSIG(entry->status) == SIGPROF){
|
||||
return;
|
||||
}
|
||||
{
|
1
security/bfbtester/pkg-comment
Normal file
1
security/bfbtester/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A security tool for testing binaries for overflows
|
9
security/bfbtester/pkg-descr
Normal file
9
security/bfbtester/pkg-descr
Normal file
|
@ -0,0 +1,9 @@
|
|||
BFBTester will perform checks of single and multiple argument command
|
||||
line overflows and environment variable overflows. BFBTester will also
|
||||
watch for tempfile creation activity to alert the user of any programs
|
||||
using unsafe tempfile names.
|
||||
|
||||
WWW: http://bfbtester.sourceforge.net
|
||||
|
||||
- Mike Heffner
|
||||
mheffner@vt.edu
|
1
security/bfbtester/pkg-plist
Normal file
1
security/bfbtester/pkg-plist
Normal file
|
@ -0,0 +1 @@
|
|||
bin/bfbtester
|
Loading…
Reference in a new issue