- Update to 0.4.0

- Enhance description
- Adjust dependencies

Changelog: https://mail.xfce.org/pipermail/xfce/2015-April/034400.html
This commit is contained in:
Olivier Duchateau 2015-04-11 20:04:41 +00:00
parent a80332b83b
commit 8a6376763d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=383827
9 changed files with 100 additions and 33 deletions

View file

@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= dashboard
PORTVERSION= 0.2.3
PORTREVISION= 2
PORTVERSION= 0.4.0
CATEGORIES= x11 xfce
MASTER_SITES= http://xfdashboard.froevel.de/releases/
MASTER_SITES= XFCE/src/apps/xfdashboard/${PORTVERSION:R}/
PKGNAMEPREFIX= xfce4-
DISTNAME= xfdashboard-${PORTVERSION}
DIST_SUBDIR= xfce4
@ -14,22 +13,24 @@ MAINTAINER= xfce@FreeBSD.org
COMMENT= GNOME shell like dashboard for the Xfce desktop
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
libclutter-1.0.so:${PORTSDIR}/graphics/clutter
RUN_DEPENDS= gnome-icon-theme-symbolic>=3.6.2:${PORTSDIR}/x11-themes/gnome-icon-theme-symbolic
GNU_CONFIGURE= yes
USES= pkgconfig libtool gmake perl5 gettext xfce tar:bzip2
USE_GNOME= glib20 libwnck intltool intlhack
USE_GNOME= glib20 gtk30 libwnck3 intltool intlhack
USE_XFCE= garcon
USE_XORG= x11 xcomposite xdamage
USE_XORG= x11 xcomposite xdamage xinerama
USE_GL= gl
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
post-patch:
${FIND} ${WRKSRC}/data/themes -type f -name '*.css' \
| ${XARGS} ${REINPLACE_CMD} -i "" 's|gtk-home|go-home|'
# Decrease default value of desaturation factor (0.0 -> no desaturation)
# With some graphics cards, quick launch icons are totally black with
# default value
${FIND} ${WRKSRC}/data/themes -type f -name 'effects.xml' \
| ${XARGS} ${REINPLACE_CMD} -i "" 's|>1.0<|>0.45<|'
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (xfce4/xfdashboard-0.2.3.tar.bz2) = 666d470f5a769a8cc8e8374e2f79e6b7e5b6a3bc96271d1b865c57961155a32e
SIZE (xfce4/xfdashboard-0.2.3.tar.bz2) = 630584
SHA256 (xfce4/xfdashboard-0.4.0.tar.bz2) = 4016c97011bf7316c8e365f0f4ff753b8e4e74776f2b25e282efa7675965cb45
SIZE (xfce4/xfdashboard-0.4.0.tar.bz2) = 2249568

View file

@ -1,11 +0,0 @@
--- src/windows-view.c.orig 2014-08-26 15:48:01 UTC
+++ src/windows-view.c
@@ -87,7 +87,7 @@ static XfdashboardLiveWindow* _xfdashboa
static void _xfdashboard_windows_view_set_active_workspace(XfdashboardWindowsView *self, XfdashboardWindowTrackerWorkspace *inWorkspace);
/* IMPLEMENTATION: Private variables and methods */
-#define DEFAULT_VIEW_ICON GTK_STOCK_FULLSCREEN
+#define DEFAULT_VIEW_ICON "view-fullscreen"
#define DEFAULT_DRAG_HANDLE_SIZE 32.0f
/* Check if window should be shown */

View file

@ -0,0 +1,11 @@
--- xfdashboard/applications-search-provider.c.orig 2015-03-04 05:46:06 UTC
+++ xfdashboard/applications-search-provider.c
@@ -318,7 +318,7 @@ static const gchar* _xfdashboard_applica
/* Overriden virtual function: get_icon */
static const gchar* _xfdashboard_applications_search_provider_get_icon(XfdashboardSearchProvider *inProvider)
{
- return("gtk-missing-image");
+ return("applications-other");
}
/* Overriden virtual function: get_result_set */

View file

@ -1,10 +1,10 @@
--- src/applications-view.c.orig 2014-08-26 15:48:00 UTC
+++ src/applications-view.c
@@ -949,7 +949,7 @@ static void xfdashboard_applications_vie
--- xfdashboard/applications-view.c.orig 2015-03-04 05:45:24 UTC
+++ xfdashboard/applications-view.c
@@ -1374,7 +1374,7 @@ static void xfdashboard_applications_vie
/* Set up view */
xfdashboard_view_set_internal_name(XFDASHBOARD_VIEW(self), "applications");
xfdashboard_view_set_name(XFDASHBOARD_VIEW(self), _("Applications"));
- xfdashboard_view_set_icon(XFDASHBOARD_VIEW(self), GTK_STOCK_HOME);
- xfdashboard_view_set_icon(XFDASHBOARD_VIEW(self), "gtk-home");
+ xfdashboard_view_set_icon(XFDASHBOARD_VIEW(self), "go-home");
/* Set up actor */

View file

@ -1,11 +1,11 @@
--- src/search-view.c.orig 2014-08-26 15:48:00 UTC
+++ src/search-view.c
@@ -1052,7 +1052,7 @@ static void xfdashboard_search_view_init
--- xfdashboard/search-view.c.orig 2015-03-04 05:44:14 UTC
+++ xfdashboard/search-view.c
@@ -1540,7 +1540,7 @@ static void xfdashboard_search_view_init
/* Set up view (Note: Search view is disabled by default!) */
xfdashboard_view_set_internal_name(XFDASHBOARD_VIEW(self), "search");
xfdashboard_view_set_name(XFDASHBOARD_VIEW(self), _("Search"));
- xfdashboard_view_set_icon(XFDASHBOARD_VIEW(self), GTK_STOCK_FIND);
+ xfdashboard_view_set_icon(XFDASHBOARD_VIEW(self), "edit-find");
- xfdashboard_view_set_icon(XFDASHBOARD_VIEW(self), "gtk-find");
+ xfdashboard_view_set_icon(XFDASHBOARD_VIEW(self), "system-search");
xfdashboard_view_set_enabled(XFDASHBOARD_VIEW(self), FALSE);
/* Set up actor */

View file

@ -0,0 +1,11 @@
--- xfdashboard/windows-view.c.orig 2015-03-17 21:31:03 UTC
+++ xfdashboard/windows-view.c
@@ -128,7 +128,7 @@ static void _xfdashboard_windows_view_se
/* IMPLEMENTATION: Private variables and methods */
#define SCROLL_EVENT_CHANGES_WORKSPACE_XFCONF_PROP "/components/windows-view/scroll-event-changes-workspace"
-#define DEFAULT_VIEW_ICON "gtk-fullscreen"
+#define DEFAULT_VIEW_ICON "view-fullscreen"
#define DEFAULT_DRAG_HANDLE_SIZE 32.0f
/* Stage interface has changed monitor */

View file

@ -1,3 +1,6 @@
Xfdashboard is GNOME shell like for the Xfce desktop
Xfdashboard provides a GNOME shell dashboard like interface for use with
the Xfce desktop. It can be configured to run any keyboard shortcut and
when executed provides an overview of applications currently open enabling
the user to switch between different applications.
WWW: http://xfdashboard.froevel.de/
WWW: http://goodies.xfce.org/projects/applications/xfdashboard/

View file

@ -1,7 +1,9 @@
bin/xfdashboard
bin/xfdashboard-settings
etc/xdg/autostart/xfdashboard-autostart.desktop
share/appdata/xfdashboard.appdata.xml
share/applications/xfdashboard.desktop
share/applications/xfdashboard-settings.desktop
share/icons/hicolor/128x128/apps/xfdashboard.png
share/icons/hicolor/16x16/apps/xfdashboard.png
share/icons/hicolor/22x22/apps/xfdashboard.png
@ -11,7 +13,57 @@ share/icons/hicolor/32x32/apps/xfdashboard.png
share/icons/hicolor/48x48/apps/xfdashboard.png
share/icons/hicolor/64x64/apps/xfdashboard.png
share/icons/hicolor/96x96/apps/xfdashboard.png
share/locale/es/LC_MESSAGES/xfdashboard.mo
share/locale/he/LC_MESSAGES/xfdashboard.mo
share/locale/it_IT/LC_MESSAGES/xfdashboard.mo
share/locale/sr/LC_MESSAGES/xfdashboard.mo
share/themes/xfdashboard-auber/xfdashboard-1.0/effects.xml
share/themes/xfdashboard-auber/xfdashboard-1.0/screenshot-xfdashboard-auber.png
share/themes/xfdashboard-auber/xfdashboard-1.0/xfdashboard-auber.css
share/themes/xfdashboard-auber/xfdashboard-1.0/xfdashboard.css
share/themes/xfdashboard-auber/xfdashboard-1.0/xfdashboard.theme
share/themes/xfdashboard-auber/xfdashboard-1.0/xfdashboard.xml
share/themes/xfdashboard-auber/xfdashboard-1.0/xfdashboard-secondary.xml
share/themes/xfdashboard-blue/xfdashboard-1.0/effects.xml
share/themes/xfdashboard-blue/xfdashboard-1.0/xfdashboard-blue.css
share/themes/xfdashboard-blue/xfdashboard-1.0/xfdashboard.css
share/themes/xfdashboard-blue/xfdashboard-1.0/xfdashboard.theme
share/themes/xfdashboard-blue/xfdashboard-1.0/xfdashboard.xml
share/themes/xfdashboard-blue/xfdashboard-1.0/xfdashboard-secondary.xml
share/themes/xfdashboard-dark/xfdashboard-1.0/effects.xml
share/themes/xfdashboard-dark/xfdashboard-1.0/screenshot-xfdashboard-dark.png
share/themes/xfdashboard-dark/xfdashboard-1.0/xfdashboard-dark.css
share/themes/xfdashboard-dark/xfdashboard-1.0/xfdashboard.css
share/themes/xfdashboard-dark/xfdashboard-1.0/xfdashboard.theme
share/themes/xfdashboard-dark/xfdashboard-1.0/xfdashboard.xml
share/themes/xfdashboard-dark/xfdashboard-1.0/xfdashboard-secondary.xml
share/themes/xfdashboard-mint/xfdashboard-1.0/effects.xml
share/themes/xfdashboard-mint/xfdashboard-1.0/screenshot-xfdashboard-mint.png
share/themes/xfdashboard-mint/xfdashboard-1.0/xfdashboard-mint.css
share/themes/xfdashboard-mint/xfdashboard-1.0/xfdashboard.css
share/themes/xfdashboard-mint/xfdashboard-1.0/xfdashboard.theme
share/themes/xfdashboard-mint/xfdashboard-1.0/xfdashboard.xml
share/themes/xfdashboard-mint/xfdashboard-1.0/xfdashboard-secondary.xml
share/themes/xfdashboard-moranga/xfdashboard-1.0/effects.xml
share/themes/xfdashboard-moranga/xfdashboard-1.0/screenshot-xfdashboard-moranga.png
share/themes/xfdashboard-moranga/xfdashboard-1.0/xfdashboard-moranga.css
share/themes/xfdashboard-moranga/xfdashboard-1.0/xfdashboard.css
share/themes/xfdashboard-moranga/xfdashboard-1.0/xfdashboard.theme
share/themes/xfdashboard-moranga/xfdashboard-1.0/xfdashboard.xml
share/themes/xfdashboard-moranga/xfdashboard-1.0/xfdashboard-secondary.xml
share/themes/xfdashboard-wine/xfdashboard-1.0/effects.xml
share/themes/xfdashboard-wine/xfdashboard-1.0/screenshot-xfdashboard-wine.png
share/themes/xfdashboard-wine/xfdashboard-1.0/xfdashboard-wine.css
share/themes/xfdashboard-wine/xfdashboard-1.0/xfdashboard.css
share/themes/xfdashboard-wine/xfdashboard-1.0/xfdashboard.theme
share/themes/xfdashboard-wine/xfdashboard-1.0/xfdashboard.xml
share/themes/xfdashboard-wine/xfdashboard-1.0/xfdashboard-secondary.xml
share/themes/xfdashboard/xfdashboard-1.0/effects.xml
share/themes/xfdashboard/xfdashboard-1.0/screenshot-xfdashboard.png
share/themes/xfdashboard/xfdashboard-1.0/windows-view.png
share/themes/xfdashboard/xfdashboard-1.0/xfdashboard.css
share/themes/xfdashboard/xfdashboard-1.0/xfdashboard.theme
share/themes/xfdashboard/xfdashboard-1.0/xfdashboard.xml
share/themes/xfdashboard/xfdashboard-1.0/xfdashboard-secondary.xml
share/xfdashboard/bindings.xml
share/xfdashboard/preferences.ui