Update to 1.0.0, the first production version. This includes security

fixes for CVE-2015-8373 in addition to the following improvements:

- Lease expiration. A configurable mechanism which provides the
  ability to properly clean up expired leases including hook points,
  DNS clean up, and logging.

- Client classification. Initial support for client classification
  using conditional logic expressions to test inbound packet content
  is available for both DHCPv4 and DHCPv6.

- Decline support in both DHCPv4 and DHCPv6.

- New statistics. Several new statistics have been added. They can be
  used to monitor lease expiration and decline processing.

- PXE boot. Several new DHCPv4 and DHCPv6 options useful for PXE and
  iPXE boot are now supported.

- Host Reservations in MySQL. Kea is now able to store host
  reservations in both its configuration file and a MySQL
  database. While currently available only for DHCPv4, this
  functionality will be available for DHCPv6 in an upcoming release.

- Kea 1.0.0 is released under new license Mozilla Public License
  2.0. Earlier releases were licensed under the ISC license. The new
  license is slightly more restrictive than the original ISC license.

Security:	CVE-2015-8373
Security:	https://kb.isc.org/article/AA-01318/0/CVE-2015-8373-ISC-Kea%3A-unexpected-termination-while-handling-a-malformed-packet.html
This commit is contained in:
Hiroki Sato 2016-01-04 18:13:37 +00:00
parent 8d1b61feef
commit 8ac54f835f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=405259
13 changed files with 31 additions and 389 deletions

View file

@ -1,7 +1,7 @@
# $FreeBSD$ # $FreeBSD$
PORTNAME= kea PORTNAME= kea
PORTVERSION= 0.9.2 PORTVERSION= 1.0.0
CATEGORIES= net ipv6 CATEGORIES= net ipv6
MASTER_SITES= ISC MASTER_SITES= ISC
MASTER_SITE_SUBDIR= kea/${PORTVERSION} MASTER_SITE_SUBDIR= kea/${PORTVERSION}
@ -9,7 +9,7 @@ MASTER_SITE_SUBDIR= kea/${PORTVERSION}
MAINTAINER= hrs@FreeBSD.org MAINTAINER= hrs@FreeBSD.org
COMMENT= Alternative DHCP implementation by ISC COMMENT= Alternative DHCP implementation by ISC
LICENSE= BSD3CLAUSE LICENSE= MPL
LICENSE_FILE= ${WRKSRC}/COPYING LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= liblog4cplus.so:${PORTSDIR}/devel/log4cplus \ LIB_DEPENDS= liblog4cplus.so:${PORTSDIR}/devel/log4cplus \
@ -24,11 +24,12 @@ CONFIGURE_ARGS= --disable-silent-rules \
--with-openssl=${OPENSSLBASE} \ --with-openssl=${OPENSSLBASE} \
--with-log4cplus=${LOCALBASE} \ --with-log4cplus=${LOCALBASE} \
--with-boost-include=${LOCALBASE}/include \ --with-boost-include=${LOCALBASE}/include \
--with-boost-lib-dir=${LOCALBASE}/lib \
--without-werror --without-werror
INSTALL_TARGET= install-strip INSTALL_TARGET= install-strip
PORTDOCS= AUTHORS COPYING ChangeLog README \ PORTDOCS= AUTHORS COPYING ChangeLog README \
kea-guide.css kea-guide.html kea-guide.txt \ kea-guide.css kea-guide.html kea-guide.txt \
kea-messages.html \ kea-messages.html kea-logo-100x70.png \
examples examples
OPTIONS_DEFINE= DOCS MYSQL PGSQL OPTIONS_DEFINE= DOCS MYSQL PGSQL

View file

@ -1,2 +1,2 @@
SHA256 (kea-0.9.2.tar.gz) = 9845fa23e9dee576724018f2371107a5e608caa337e3e2eb008dea57a7c4e95d SHA256 (kea-1.0.0.tar.gz) = 96984fe918f9133d08d3115eac012d28814d8ccfaf25289499f028de56135afe
SIZE (kea-0.9.2.tar.gz) = 4433329 SIZE (kea-1.0.0.tar.gz) = 4559334

View file

@ -1,16 +1,16 @@
--- Makefile.am.orig 2015-07-23 16:45:11 UTC --- Makefile.am.orig 2015-12-28 12:18:05 UTC
+++ Makefile.am +++ Makefile.am
@@ -121,7 +121,7 @@ cppcheck: @@ -106,7 +106,7 @@ cppcheck:
# These steps are necessary during installation # These steps are necessary during installation
install-exec-hook: install-exec-hook:
mkdir -p $(DESTDIR)${localstatedir}/log/ mkdir -p $(DESTDIR)${localstatedir}/log/
- mkdir -p $(DESTDIR)${localstatedir}/run/${PACKAGE_NAME} - mkdir -p $(DESTDIR)${localstatedir}/run/${PACKAGE_NAME}
+ mkdir -p $(DESTDIR)${localstatedir}/run/ + mkdir -p $(DESTDIR)${localstatedir}/run/
### include tool to generate documentation from log message specifications EXTRA_DIST = tools/path_replacer.sh
### in the distributed tarball: EXTRA_DIST += tools/mk_cfgrpt.sh
@@ -439,7 +439,7 @@ EXTRA_DIST += ext/asio/asio/deadline_tim @@ -114,7 +114,7 @@ EXTRA_DIST += tools/mk_cfgrpt.sh
EXTRA_DIST += ext/asio/asio/stream_socket_service.hpp #### include external sources in the distributed tarball:
EXTRA_DIST += ext/coroutine/coroutine.h EXTRA_DIST += ext/coroutine/coroutine.h
-pkgconfigdir = $(libdir)/pkgconfig -pkgconfigdir = $(libdir)/pkgconfig

View file

@ -1,4 +1,4 @@
--- src/bin/keactrl/Makefile.am.orig 2015-07-23 16:45:11 UTC --- src/bin/keactrl/Makefile.am.orig 2015-12-28 12:18:05 UTC
+++ src/bin/keactrl/Makefile.am +++ src/bin/keactrl/Makefile.am
@@ -38,7 +38,7 @@ install-data-local: @@ -38,7 +38,7 @@ install-data-local:
$(mkinstalldirs) $(DESTDIR)/@sysconfdir@/@PACKAGE@ $(mkinstalldirs) $(DESTDIR)/@sysconfdir@/@PACKAGE@

View file

@ -1,6 +1,6 @@
--- src/bin/keactrl/keactrl.in.orig 2015-07-23 16:45:11 UTC --- src/bin/keactrl/keactrl.in.orig 2015-12-28 12:18:45 UTC
+++ src/bin/keactrl/keactrl.in +++ src/bin/keactrl/keactrl.in
@@ -77,7 +77,7 @@ get_pid_from_file() { @@ -69,7 +69,7 @@ get_pid_from_file() {
local conf_name=$(basename ${kea_config_file} | cut -f1 -d'.') local conf_name=$(basename ${kea_config_file} | cut -f1 -d'.')
# Default the directory to --localstatedir # Default the directory to --localstatedir
@ -9,7 +9,7 @@
# Use directory override if set (primarily for testing only) # Use directory override if set (primarily for testing only)
if [ ! -z $KEA_PIDFILE_DIR ]; then if [ ! -z $KEA_PIDFILE_DIR ]; then
@@ -260,7 +260,7 @@ check_kea_conf() { @@ -252,7 +252,7 @@ check_kea_conf() {
# to the default file. # to the default file.
if [ -z ${KEA_LOGGER_DESTINATION} ]; then if [ -z ${KEA_LOGGER_DESTINATION} ]; then
prefix=@prefix@ prefix=@prefix@

View file

@ -1,4 +1,4 @@
--- src/lib/dhcpsrv/Makefile.am.orig 2015-07-23 16:45:11 UTC --- src/lib/dhcpsrv/Makefile.am.orig 2015-12-28 12:18:05 UTC
+++ src/lib/dhcpsrv/Makefile.am +++ src/lib/dhcpsrv/Makefile.am
@@ -2,10 +2,10 @@ AUTOMAKE_OPTIONS = subdir-objects @@ -2,10 +2,10 @@ AUTOMAKE_OPTIONS = subdir-objects

View file

@ -1,6 +1,6 @@
--- src/lib/dhcpsrv/daemon.cc.orig 2015-07-23 16:45:11 UTC --- src/lib/dhcpsrv/daemon.cc.orig 2015-12-28 12:18:45 UTC
+++ src/lib/dhcpsrv/daemon.cc +++ src/lib/dhcpsrv/daemon.cc
@@ -36,7 +36,7 @@ namespace dhcp { @@ -28,7 +28,7 @@ namespace dhcp {
Daemon::Daemon() Daemon::Daemon()
: signal_set_(), signal_handler_(), config_file_(""), proc_name_(""), : signal_set_(), signal_handler_(), config_file_(""), proc_name_(""),

View file

@ -1,11 +1,11 @@
--- src/lib/log/interprocess/Makefile.am.orig 2015-07-23 16:45:11 UTC --- src/lib/log/interprocess/Makefile.am.orig 2015-12-28 12:18:05 UTC
+++ src/lib/log/interprocess/Makefile.am +++ src/lib/log/interprocess/Makefile.am
@@ -1,7 +1,7 @@ @@ -1,7 +1,7 @@
SUBDIRS = . tests SUBDIRS = . tests
AM_CPPFLAGS = -I$(top_srcdir)/src/lib -I$(top_builddir)/src/lib AM_CPPFLAGS = -I$(top_srcdir)/src/lib -I$(top_builddir)/src/lib
-AM_CPPFLAGS += -DLOCKFILE_DIR=\"${localstatedir}/run/${PACKAGE_NAME}\" -AM_CPPFLAGS += -DLOCKFILE_DIR=\"$(localstatedir)/run/$(PACKAGE_NAME)\"
+AM_CPPFLAGS += -DLOCKFILE_DIR=\"${localstatedir}/run\" +AM_CPPFLAGS += -DLOCKFILE_DIR=\"$(localstatedir)/run\"
AM_CPPFLAGS += $(BOOST_INCLUDES) AM_CPPFLAGS += $(BOOST_INCLUDES)
AM_CXXFLAGS = $(KEA_CXXFLAGS) AM_CXXFLAGS = $(KEA_CXXFLAGS)

View file

@ -1,14 +0,0 @@
--- src/lib/util/encode/base16_from_binary.h.orig 2015-09-12 06:07:02.929641000 +0900
+++ src/lib/util/encode/base16_from_binary.h 2015-09-12 06:07:28.903859000 +0900
@@ -85,9 +85,9 @@
public:
// make composable by using templated constructor
template<class T>
- base16_from_binary(BOOST_PFTO_WRAPPER(T) start) :
+ base16_from_binary(T start) :
super_t(
- Base(BOOST_MAKE_PFTO_WRAPPER(static_cast<T>(start))),
+ Base(static_cast<T>(start)),
detail::from_4_bit<CharType>()
)
{}

View file

@ -1,14 +0,0 @@
--- src/lib/util/encode/base32hex_from_binary.h.orig 2015-09-12 06:08:07.415328000 +0900
+++ src/lib/util/encode/base32hex_from_binary.h 2015-09-12 06:08:28.438126000 +0900
@@ -87,9 +87,9 @@
public:
// make composable by using templated constructor
template<class T>
- base32hex_from_binary(BOOST_PFTO_WRAPPER(T) start) :
+ base32hex_from_binary(T start) :
super_t(
- Base(BOOST_MAKE_PFTO_WRAPPER(static_cast<T>(start))),
+ Base(static_cast<T>(start)),
detail::from_5_bit<CharType>()
)
{}

View file

@ -1,14 +0,0 @@
--- src/lib/util/encode/binary_from_base16.h.orig 2015-09-12 06:08:57.358126000 +0900
+++ src/lib/util/encode/binary_from_base16.h 2015-09-12 06:09:12.997499000 +0900
@@ -93,9 +93,9 @@
public:
// make composable by using templated constructor
template<class T>
- binary_from_base16(BOOST_PFTO_WRAPPER(T) start) :
+ binary_from_base16(T start) :
super_t(
- Base(BOOST_MAKE_PFTO_WRAPPER(static_cast<T>(start))),
+ Base(static_cast<T>(start)),
detail::to_4_bit<CharType>()
)
{}

View file

@ -1,14 +0,0 @@
--- src/lib/util/encode/binary_from_base32hex.h.orig 2015-09-12 06:05:44.329389000 +0900
+++ src/lib/util/encode/binary_from_base32hex.h 2015-09-12 06:06:24.217165000 +0900
@@ -96,9 +96,9 @@
public:
// make composable by using templated constructor
template<class T>
- binary_from_base32hex(BOOST_PFTO_WRAPPER(T) start) :
+ binary_from_base32hex(T start) :
super_t(
- Base(BOOST_MAKE_PFTO_WRAPPER(static_cast<T>(start))),
+ Base(static_cast<T>(start)),
detail::to_5_bit<CharType>()
)
{}

View file

@ -1,312 +1,6 @@
bin/message bin/kea-msg-compiler
include/kea/asio/LICENSE_1_0.txt
include/kea/asio/README
include/kea/asio/basic_datagram_socket.hpp
include/kea/asio/basic_deadline_timer.hpp
include/kea/asio/basic_io_object.hpp
include/kea/asio/basic_raw_socket.hpp
include/kea/asio/basic_serial_port.hpp
include/kea/asio/basic_socket.hpp
include/kea/asio/basic_socket_acceptor.hpp
include/kea/asio/basic_socket_iostream.hpp
include/kea/asio/basic_socket_streambuf.hpp
include/kea/asio/basic_stream_socket.hpp
include/kea/asio/basic_streambuf.hpp
include/kea/asio/basic_streambuf_fwd.hpp
include/kea/asio/buffer.hpp
include/kea/asio/buffered_read_stream.hpp
include/kea/asio/buffered_read_stream_fwd.hpp
include/kea/asio/buffered_stream.hpp
include/kea/asio/buffered_stream_fwd.hpp
include/kea/asio/buffered_write_stream.hpp
include/kea/asio/buffered_write_stream_fwd.hpp
include/kea/asio/buffers_iterator.hpp
include/kea/asio/completion_condition.hpp
include/kea/asio/datagram_socket_service.hpp
include/kea/asio/deadline_timer.hpp
include/kea/asio/deadline_timer_service.hpp
include/kea/asio/detail/array_fwd.hpp
include/kea/asio/detail/base_from_completion_cond.hpp
include/kea/asio/detail/bind_handler.hpp
include/kea/asio/detail/buffer_resize_guard.hpp
include/kea/asio/detail/buffer_sequence_adapter.hpp
include/kea/asio/detail/buffered_stream_storage.hpp
include/kea/asio/detail/call_stack.hpp
include/kea/asio/detail/completion_handler.hpp
include/kea/asio/detail/config.hpp
include/kea/asio/detail/consuming_buffers.hpp
include/kea/asio/detail/deadline_timer_service.hpp
include/kea/asio/detail/descriptor_ops.hpp
include/kea/asio/detail/descriptor_read_op.hpp
include/kea/asio/detail/descriptor_write_op.hpp
include/kea/asio/detail/dev_poll_reactor.hpp
include/kea/asio/detail/dev_poll_reactor_fwd.hpp
include/kea/asio/detail/epoll_reactor.hpp
include/kea/asio/detail/epoll_reactor_fwd.hpp
include/kea/asio/detail/event.hpp
include/kea/asio/detail/eventfd_select_interrupter.hpp
include/kea/asio/detail/fd_set_adapter.hpp
include/kea/asio/detail/fenced_block.hpp
include/kea/asio/detail/gcc_arm_fenced_block.hpp
include/kea/asio/detail/gcc_fenced_block.hpp
include/kea/asio/detail/gcc_hppa_fenced_block.hpp
include/kea/asio/detail/gcc_sync_fenced_block.hpp
include/kea/asio/detail/gcc_x86_fenced_block.hpp
include/kea/asio/detail/handler_alloc_helpers.hpp
include/kea/asio/detail/handler_invoke_helpers.hpp
include/kea/asio/detail/hash_map.hpp
include/kea/asio/detail/impl/descriptor_ops.ipp
include/kea/asio/detail/impl/dev_poll_reactor.hpp
include/kea/asio/detail/impl/dev_poll_reactor.ipp
include/kea/asio/detail/impl/epoll_reactor.hpp
include/kea/asio/detail/impl/epoll_reactor.ipp
include/kea/asio/detail/impl/eventfd_select_interrupter.ipp
include/kea/asio/detail/impl/kqueue_reactor.hpp
include/kea/asio/detail/impl/kqueue_reactor.ipp
include/kea/asio/detail/impl/pipe_select_interrupter.ipp
include/kea/asio/detail/impl/posix_event.ipp
include/kea/asio/detail/impl/posix_mutex.ipp
include/kea/asio/detail/impl/posix_thread.ipp
include/kea/asio/detail/impl/posix_tss_ptr.ipp
include/kea/asio/detail/impl/reactive_descriptor_service.ipp
include/kea/asio/detail/impl/reactive_serial_port_service.ipp
include/kea/asio/detail/impl/reactive_socket_service_base.ipp
include/kea/asio/detail/impl/resolver_service_base.ipp
include/kea/asio/detail/impl/select_reactor.hpp
include/kea/asio/detail/impl/select_reactor.ipp
include/kea/asio/detail/impl/service_registry.hpp
include/kea/asio/detail/impl/service_registry.ipp
include/kea/asio/detail/impl/socket_ops.ipp
include/kea/asio/detail/impl/socket_select_interrupter.ipp
include/kea/asio/detail/impl/strand_service.hpp
include/kea/asio/detail/impl/strand_service.ipp
include/kea/asio/detail/impl/task_io_service.hpp
include/kea/asio/detail/impl/task_io_service.ipp
include/kea/asio/detail/impl/throw_error.ipp
include/kea/asio/detail/impl/timer_queue.ipp
include/kea/asio/detail/impl/timer_queue_set.ipp
include/kea/asio/detail/impl/win_event.ipp
include/kea/asio/detail/impl/win_iocp_handle_service.ipp
include/kea/asio/detail/impl/win_iocp_io_service.hpp
include/kea/asio/detail/impl/win_iocp_io_service.ipp
include/kea/asio/detail/impl/win_iocp_serial_port_service.ipp
include/kea/asio/detail/impl/win_iocp_socket_service_base.ipp
include/kea/asio/detail/impl/win_mutex.ipp
include/kea/asio/detail/impl/win_thread.ipp
include/kea/asio/detail/impl/win_tss_ptr.ipp
include/kea/asio/detail/impl/winsock_init.ipp
include/kea/asio/detail/io_control.hpp
include/kea/asio/detail/kqueue_reactor.hpp
include/kea/asio/detail/kqueue_reactor_fwd.hpp
include/kea/asio/detail/local_free_on_block_exit.hpp
include/kea/asio/detail/macos_fenced_block.hpp
include/kea/asio/detail/mutex.hpp
include/kea/asio/detail/noncopyable.hpp
include/kea/asio/detail/null_buffers_op.hpp
include/kea/asio/detail/null_event.hpp
include/kea/asio/detail/null_fenced_block.hpp
include/kea/asio/detail/null_mutex.hpp
include/kea/asio/detail/null_signal_blocker.hpp
include/kea/asio/detail/null_thread.hpp
include/kea/asio/detail/null_tss_ptr.hpp
include/kea/asio/detail/object_pool.hpp
include/kea/asio/detail/old_win_sdk_compat.hpp
include/kea/asio/detail/op_queue.hpp
include/kea/asio/detail/operation.hpp
include/kea/asio/detail/pipe_select_interrupter.hpp
include/kea/asio/detail/pop_options.hpp
include/kea/asio/detail/posix_event.hpp
include/kea/asio/detail/posix_fd_set_adapter.hpp
include/kea/asio/detail/posix_mutex.hpp
include/kea/asio/detail/posix_signal_blocker.hpp
include/kea/asio/detail/posix_thread.hpp
include/kea/asio/detail/posix_tss_ptr.hpp
include/kea/asio/detail/push_options.hpp
include/kea/asio/detail/reactive_descriptor_service.hpp
include/kea/asio/detail/reactive_null_buffers_op.hpp
include/kea/asio/detail/reactive_serial_port_service.hpp
include/kea/asio/detail/reactive_socket_accept_op.hpp
include/kea/asio/detail/reactive_socket_connect_op.hpp
include/kea/asio/detail/reactive_socket_recv_op.hpp
include/kea/asio/detail/reactive_socket_recvfrom_op.hpp
include/kea/asio/detail/reactive_socket_send_op.hpp
include/kea/asio/detail/reactive_socket_sendto_op.hpp
include/kea/asio/detail/reactive_socket_service.hpp
include/kea/asio/detail/reactive_socket_service_base.hpp
include/kea/asio/detail/reactor.hpp
include/kea/asio/detail/reactor_fwd.hpp
include/kea/asio/detail/reactor_op.hpp
include/kea/asio/detail/reactor_op_queue.hpp
include/kea/asio/detail/regex_fwd.hpp
include/kea/asio/detail/resolve_endpoint_op.hpp
include/kea/asio/detail/resolve_op.hpp
include/kea/asio/detail/resolver_service.hpp
include/kea/asio/detail/resolver_service_base.hpp
include/kea/asio/detail/scoped_lock.hpp
include/kea/asio/detail/select_interrupter.hpp
include/kea/asio/detail/select_reactor.hpp
include/kea/asio/detail/select_reactor_fwd.hpp
include/kea/asio/detail/service_base.hpp
include/kea/asio/detail/service_id.hpp
include/kea/asio/detail/service_registry.hpp
include/kea/asio/detail/service_registry_fwd.hpp
include/kea/asio/detail/shared_ptr.hpp
include/kea/asio/detail/signal_blocker.hpp
include/kea/asio/detail/signal_init.hpp
include/kea/asio/detail/socket_holder.hpp
include/kea/asio/detail/socket_ops.hpp
include/kea/asio/detail/socket_option.hpp
include/kea/asio/detail/socket_select_interrupter.hpp
include/kea/asio/detail/socket_types.hpp
include/kea/asio/detail/solaris_fenced_block.hpp
include/kea/asio/detail/strand_service.hpp
include/kea/asio/detail/task_io_service.hpp
include/kea/asio/detail/task_io_service_fwd.hpp
include/kea/asio/detail/task_io_service_operation.hpp
include/kea/asio/detail/thread.hpp
include/kea/asio/detail/throw_error.hpp
include/kea/asio/detail/timer_op.hpp
include/kea/asio/detail/timer_queue.hpp
include/kea/asio/detail/timer_queue_base.hpp
include/kea/asio/detail/timer_queue_fwd.hpp
include/kea/asio/detail/timer_queue_set.hpp
include/kea/asio/detail/timer_scheduler.hpp
include/kea/asio/detail/timer_scheduler_fwd.hpp
include/kea/asio/detail/tss_ptr.hpp
include/kea/asio/detail/wait_handler.hpp
include/kea/asio/detail/weak_ptr.hpp
include/kea/asio/detail/win_event.hpp
include/kea/asio/detail/win_fd_set_adapter.hpp
include/kea/asio/detail/win_fenced_block.hpp
include/kea/asio/detail/win_iocp_handle_read_op.hpp
include/kea/asio/detail/win_iocp_handle_service.hpp
include/kea/asio/detail/win_iocp_handle_write_op.hpp
include/kea/asio/detail/win_iocp_io_service.hpp
include/kea/asio/detail/win_iocp_io_service_fwd.hpp
include/kea/asio/detail/win_iocp_null_buffers_op.hpp
include/kea/asio/detail/win_iocp_operation.hpp
include/kea/asio/detail/win_iocp_overlapped_op.hpp
include/kea/asio/detail/win_iocp_overlapped_ptr.hpp
include/kea/asio/detail/win_iocp_serial_port_service.hpp
include/kea/asio/detail/win_iocp_socket_accept_op.hpp
include/kea/asio/detail/win_iocp_socket_recv_op.hpp
include/kea/asio/detail/win_iocp_socket_recvfrom_op.hpp
include/kea/asio/detail/win_iocp_socket_send_op.hpp
include/kea/asio/detail/win_iocp_socket_service.hpp
include/kea/asio/detail/win_iocp_socket_service_base.hpp
include/kea/asio/detail/win_mutex.hpp
include/kea/asio/detail/win_signal_blocker.hpp
include/kea/asio/detail/win_thread.hpp
include/kea/asio/detail/win_tss_ptr.hpp
include/kea/asio/detail/wince_thread.hpp
include/kea/asio/detail/winsock_init.hpp
include/kea/asio/detail/wrapped_handler.hpp
include/kea/asio/error.hpp
include/kea/asio/error_code.hpp
include/kea/asio/handler_alloc_hook.hpp
include/kea/asio/handler_invoke_hook.hpp
include/kea/asio/impl/error.ipp
include/kea/asio/impl/error_code.ipp
include/kea/asio/impl/io_service.hpp
include/kea/asio/impl/io_service.ipp
include/kea/asio/impl/read.hpp
include/kea/asio/impl/read.ipp
include/kea/asio/impl/read_at.hpp
include/kea/asio/impl/read_at.ipp
include/kea/asio/impl/read_until.hpp
include/kea/asio/impl/read_until.ipp
include/kea/asio/impl/serial_port_base.hpp
include/kea/asio/impl/serial_port_base.ipp
include/kea/asio/impl/src.cpp
include/kea/asio/impl/src.hpp
include/kea/asio/impl/write.hpp
include/kea/asio/impl/write.ipp
include/kea/asio/impl/write_at.hpp
include/kea/asio/impl/write_at.ipp
include/kea/asio/io_service.hpp
include/kea/asio/ip/address.hpp
include/kea/asio/ip/address_v4.hpp
include/kea/asio/ip/address_v6.hpp
include/kea/asio/ip/basic_endpoint.hpp
include/kea/asio/ip/basic_resolver.hpp
include/kea/asio/ip/basic_resolver_entry.hpp
include/kea/asio/ip/basic_resolver_iterator.hpp
include/kea/asio/ip/basic_resolver_query.hpp
include/kea/asio/ip/detail/endpoint.hpp
include/kea/asio/ip/detail/impl/endpoint.ipp
include/kea/asio/ip/detail/socket_option.hpp
include/kea/asio/ip/host_name.hpp
include/kea/asio/ip/icmp.hpp
include/kea/asio/ip/impl/address.hpp
include/kea/asio/ip/impl/address.ipp
include/kea/asio/ip/impl/address_v4.hpp
include/kea/asio/ip/impl/address_v4.ipp
include/kea/asio/ip/impl/address_v6.hpp
include/kea/asio/ip/impl/address_v6.ipp
include/kea/asio/ip/impl/basic_endpoint.hpp
include/kea/asio/ip/impl/host_name.ipp
include/kea/asio/ip/multicast.hpp
include/kea/asio/ip/resolver_query_base.hpp
include/kea/asio/ip/resolver_service.hpp
include/kea/asio/ip/tcp.hpp
include/kea/asio/ip/udp.hpp
include/kea/asio/ip/unicast.hpp
include/kea/asio/ip/v6_only.hpp
include/kea/asio/is_read_buffered.hpp
include/kea/asio/is_write_buffered.hpp
include/kea/asio/local/basic_endpoint.hpp
include/kea/asio/local/connect_pair.hpp
include/kea/asio/local/datagram_protocol.hpp
include/kea/asio/local/detail/endpoint.hpp
include/kea/asio/local/detail/impl/endpoint.ipp
include/kea/asio/local/stream_protocol.hpp
include/kea/asio/placeholders.hpp
include/kea/asio/posix/basic_descriptor.hpp
include/kea/asio/posix/basic_stream_descriptor.hpp
include/kea/asio/posix/descriptor_base.hpp
include/kea/asio/posix/stream_descriptor.hpp
include/kea/asio/posix/stream_descriptor_service.hpp
include/kea/asio/raw_socket_service.hpp
include/kea/asio/read.hpp
include/kea/asio/read_at.hpp
include/kea/asio/read_until.hpp
include/kea/asio/serial_port.hpp
include/kea/asio/serial_port_base.hpp
include/kea/asio/serial_port_service.hpp
include/kea/asio/socket_acceptor_service.hpp
include/kea/asio/socket_base.hpp
include/kea/asio/ssl.hpp
include/kea/asio/ssl/basic_context.hpp
include/kea/asio/ssl/context.hpp
include/kea/asio/ssl/context_base.hpp
include/kea/asio/ssl/context_service.hpp
include/kea/asio/ssl/detail/openssl_context_service.hpp
include/kea/asio/ssl/detail/openssl_init.hpp
include/kea/asio/ssl/detail/openssl_operation.hpp
include/kea/asio/ssl/detail/openssl_stream_service.hpp
include/kea/asio/ssl/detail/openssl_types.hpp
include/kea/asio/ssl/stream.hpp
include/kea/asio/ssl/stream_base.hpp
include/kea/asio/ssl/stream_service.hpp
include/kea/asio/strand.hpp
include/kea/asio/stream_socket_service.hpp
include/kea/asio/streambuf.hpp
include/kea/asio/system_error.hpp
include/kea/asio/thread.hpp
include/kea/asio/time_traits.hpp
include/kea/asio/version.hpp
include/kea/asio/windows/basic_handle.hpp
include/kea/asio/windows/basic_random_access_handle.hpp
include/kea/asio/windows/basic_stream_handle.hpp
include/kea/asio/windows/overlapped_ptr.hpp
include/kea/asio/windows/random_access_handle.hpp
include/kea/asio/windows/random_access_handle_service.hpp
include/kea/asio/windows/stream_handle.hpp
include/kea/asio/windows/stream_handle_service.hpp
include/kea/asio/write.hpp
include/kea/asio/write_at.hpp
include/kea/asiolink/io_address.h
include/kea/config.h include/kea/config.h
include/kea/asiolink/io_address.h
include/kea/dhcp/classify.h include/kea/dhcp/classify.h
include/kea/dhcp/dhcp4.h include/kea/dhcp/dhcp4.h
include/kea/dhcp/dhcp6.h include/kea/dhcp/dhcp6.h
@ -412,6 +106,10 @@ lib/libkea-exceptions.a
lib/libkea-exceptions.so lib/libkea-exceptions.so
lib/libkea-exceptions.so.0 lib/libkea-exceptions.so.0
lib/libkea-exceptions.so.0.0.0 lib/libkea-exceptions.so.0.0.0
lib/libkea-eval.a
lib/libkea-eval.so
lib/libkea-eval.so.3
lib/libkea-eval.so.3.0.0
lib/libkea-hooks.a lib/libkea-hooks.a
lib/libkea-hooks.so lib/libkea-hooks.so
lib/libkea-hooks.so.1 lib/libkea-hooks.so.1
@ -456,13 +154,12 @@ sbin/perfdhcp
%%DATADIR%%/dhcp6.spec %%DATADIR%%/dhcp6.spec
%%DATADIR%%/scripts/admin-utils.sh %%DATADIR%%/scripts/admin-utils.sh
%%DATADIR%%/scripts/mysql/dhcpdb_create.mysql %%DATADIR%%/scripts/mysql/dhcpdb_create.mysql
%%DATADIR%%/scripts/mysql/lease_dump_1.0.sh
%%DATADIR%%/scripts/mysql/lease_dump_2.0.sh
%%DATADIR%%/scripts/mysql/lease_dump_3.0.sh
%%DATADIR%%/scripts/mysql/upgrade_1.0_to_2.0.sh %%DATADIR%%/scripts/mysql/upgrade_1.0_to_2.0.sh
%%DATADIR%%/scripts/mysql/upgrade_2.0_to_3.0.sh %%DATADIR%%/scripts/mysql/upgrade_2.0_to_3.0.sh
%%DATADIR%%/scripts/mysql/upgrade_3.0_to_4.0.sh
%%DATADIR%%/scripts/mysql/upgrade_4.0_to_4.1.sh
%%DATADIR%%/scripts/pgsql/upgrade_1.0_to_2.0.sh
%%DATADIR%%/scripts/pgsql/dhcpdb_create.pgsql %%DATADIR%%/scripts/pgsql/dhcpdb_create.pgsql
%%DATADIR%%/scripts/pgsql/lease_dump_1.0.sh
@sample %%ETCDIR%%/kea.conf.sample @sample %%ETCDIR%%/kea.conf.sample
@sample %%ETCDIR%%/keactrl.conf.sample @sample %%ETCDIR%%/keactrl.conf.sample
@dir /var/db/kea @dir /var/db/kea