Partial revert r564845 on games/devilutionX
Reported by: mat
This commit is contained in:
parent
d3c48e1b91
commit
8b1c951e17
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=564850
3 changed files with 18 additions and 10 deletions
|
@ -2,7 +2,7 @@
|
|||
|
||||
PORTNAME= devilutionX
|
||||
PORTVERSION= 1.1.0
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= games
|
||||
|
||||
MAINTAINER= eduardo@FreeBSD.org
|
||||
|
@ -20,7 +20,6 @@ USES= cmake compiler:c++11-lang dos2unix sdl
|
|||
DOS2UNIX_GLOB= *.c *.h CMakeLists.txt
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= diasurgical
|
||||
GH_TAGNAME= 298092b
|
||||
USE_SDL= mixer2 sdl2 ttf2
|
||||
|
||||
CMAKE_ARGS= -DCMAKE_INSTALL_SHAREDIR:PATH=${PREFIX}/share \
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1612260956
|
||||
SHA256 (diasurgical-devilutionX-1.1.0-298092b_GH0.tar.gz) = d1faf7f01ffb378143ec74cade96fffd10fdffa864476968beca2234cef5779a
|
||||
SIZE (diasurgical-devilutionX-1.1.0-298092b_GH0.tar.gz) = 2870959
|
||||
TIMESTAMP = 1602752246
|
||||
SHA256 (diasurgical-devilutionX-1.1.0_GH0.tar.gz) = 395ec298df5383abe60550d45adba5e5811984589ccb1e504891b267b3c467c1
|
||||
SIZE (diasurgical-devilutionX-1.1.0_GH0.tar.gz) = 2271614
|
||||
|
|
|
@ -1,14 +1,23 @@
|
|||
--- CMakeLists.txt.orig 2021-02-02 10:18:23 UTC
|
||||
--- CMakeLists.txt.orig 2020-10-15 09:55:17 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -668,6 +668,11 @@ if(CPACK)
|
||||
@@ -513,7 +513,7 @@ if(WIN32)
|
||||
endif()
|
||||
endif()
|
||||
|
||||
-if(NOT WIN32 AND NOT APPLE)
|
||||
+if(NOT WIN32 AND NOT APPLE AND NOT ${CMAKE_SYSTEM_NAME} STREQUAL FreeBSD)
|
||||
# Enable POSIX extensions such as `readlink` and `ftruncate`.
|
||||
add_definitions(-D_POSIX_C_SOURCE=200809L)
|
||||
endif()
|
||||
@@ -651,6 +651,11 @@ if(CPACK)
|
||||
set(CPACK_STRIP_FILES TRUE)
|
||||
set(CPACK_GENERATOR "DragNDrop")
|
||||
endif()
|
||||
|
||||
+
|
||||
+install(TARGETS devilutionx DESTINATION ${CMAKE_INSTALL_BINDIR})
|
||||
+install(FILES Packaging/fedora/devilutionx.desktop DESTINATION ${CMAKE_INSTALL_SHAREDIR}/applications)
|
||||
+install(FILES Packaging/resources/icon.png DESTINATION ${CMAKE_INSTALL_SHAREDIR}/icons/hicolor/512x512/apps RENAME devilutionx.png)
|
||||
+install(FILES Packaging/resources/icon_solid.png DESTINATION ${CMAKE_INSTALL_SHAREDIR}/icons/hicolor/512x512/apps RENAME devilutionx_solid.png)
|
||||
+
|
||||
|
||||
set(CPACK_PACKAGE_VERSION_MAJOR ${PROJECT_VERSION_MAJOR})
|
||||
set(CPACK_PACKAGE_VERSION_MINOR ${PROJECT_VERSION_MINOR})
|
||||
set(CPACK_PACKAGE_VERSION_PATCH ${PROJECT_VERSION_PATCH})
|
||||
|
|
Loading…
Reference in a new issue