Upgrade to 0.46
PR: ports/15816 Submitted by: Ade Lovett
This commit is contained in:
parent
0972728260
commit
8b2abdea01
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=24351
8 changed files with 76 additions and 56 deletions
|
@ -1,12 +1,12 @@
|
|||
# New ports collection makefile for: gnumeric
|
||||
# Version required: 0.45
|
||||
# Version required: 0.46
|
||||
# Date created: 08 October 1998
|
||||
# Whom: Yukihiro Nakai <Nakai@technologist.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= gnumeric-0.45
|
||||
DISTNAME= gnumeric-0.46
|
||||
CATEGORIES= math gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME}
|
||||
MASTER_SITE_SUBDIR= stable/sources/gnumeric
|
||||
|
@ -33,4 +33,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
|||
GTK_CONFIG="${GTK_CONFIG}" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
|
||||
PLIST_SUB= GNUMERIC_REV=${DISTNAME:S/gnumeric-//g}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (gnumeric-0.45.tar.gz) = 7d7308f8d94ea6d3ca0940be78a80e18
|
||||
MD5 (gnumeric-0.46.tar.gz) = e873180c7f9cad1004ac75ea57170ed2
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- configure.orig Fri Nov 19 15:59:10 1999
|
||||
+++ configure Sat Nov 27 14:06:34 1999
|
||||
--- configure.orig Thu Dec 30 18:02:16 1999
|
||||
+++ configure Fri Dec 31 12:29:33 1999
|
||||
@@ -2790,7 +2790,7 @@
|
||||
fi
|
||||
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
|
||||
|
@ -27,7 +27,7 @@
|
|||
|
||||
else
|
||||
echo "$ac_t""no" 1>&6
|
||||
@@ -5602,15 +5602,15 @@
|
||||
@@ -5602,15 +5602,16 @@
|
||||
fi
|
||||
|
||||
|
||||
|
@ -37,7 +37,8 @@
|
|||
INSTOBJEXT=.mo
|
||||
DATADIRNAME=share
|
||||
- INTLDEPS='$(top_builddir)/intl/libintl.a'
|
||||
+ INTLDEPS='-lintl'
|
||||
+# INTLDEPS='$(top_builddir)/intl/libintl.a'
|
||||
+ INTLDEPS="-lintl"
|
||||
INTLLIBS=$INTLDEPS
|
||||
LIBS=`echo $LIBS | sed -e 's/-lintl//'`
|
||||
- nls_cv_header_intl=intl/libintl.h
|
||||
|
@ -47,30 +48,34 @@
|
|||
fi
|
||||
|
||||
if test "$XGETTEXT" != ":"; then
|
||||
@@ -6110,7 +6110,7 @@
|
||||
@@ -6110,7 +6111,7 @@
|
||||
echo "configure:6111: checking for GnomePrint libraries" >&5
|
||||
if gnome-config --libs print > /dev/null 2>&1; then
|
||||
echo "$ac_t""found" 1>&6
|
||||
- . `gnome-config --libdir`/printConf.sh
|
||||
+ . `gnome-config --sysconfdir`/printConf.sh
|
||||
+ . `$GNOME_CONFIG --sysconfdir`/printConf.sh
|
||||
echo $ac_n "checking for GnomePrint >= 0.8""... $ac_c" 1>&6
|
||||
echo "configure:6116: checking for GnomePrint >= 0.8" >&5
|
||||
case x$MODULE_VERSION in
|
||||
@@ -6125,14 +6125,14 @@
|
||||
@@ -6125,8 +6126,8 @@
|
||||
|
||||
echo $ac_n "checking for Glade libraries""... $ac_c" 1>&6
|
||||
echo "configure:6128: checking for Glade libraries" >&5
|
||||
echo $ac_n "checking for Glade libraries >= 0.11""... $ac_c" 1>&6
|
||||
echo "configure:6128: checking for Glade libraries >= 0.11" >&5
|
||||
-if gnome-config --libs libglade > /dev/null 2>&1; then
|
||||
- vers=`gnome-config --modversion libglade`
|
||||
+if libglade-config --libs > /dev/null 2>&1; then
|
||||
echo "$ac_t""found" 1>&6
|
||||
else
|
||||
+ vers=`libglade-config --version | sed -e 's/ /-/'`
|
||||
case $vers
|
||||
in
|
||||
libglade-0.1[123456789]) echo "$ac_t""found" 1>&6 ;;
|
||||
@@ -6136,8 +6137,8 @@
|
||||
{ echo "configure: error: Did not find libGlade installed" 1>&2; exit 1; }
|
||||
fi
|
||||
|
||||
-EXTRA_GNOME_LIBS=`gnome-config --libs gnomeui print libglade $bonobo $gb`
|
||||
-EXTRA_GNOME_CFLAGS=`gnome-config --cflags gnomeui print libglade $bonobo $gb`
|
||||
+EXTRA_GNOME_LIBS="`gnome-config --libs gnomeui print $bonobo $gb` `libglade-config --libs gnome`"
|
||||
+EXTRA_GNOME_CFLAGS="`gnome-config --cflags gnomeui print $bonobo $gb` `libglade-config --cflags gnome`"
|
||||
+EXTRA_GNOME_LIBS="`$GNOME_CONFIG --libs gnomeui print $bonobo $gb` `libglade-config --libs gnome`"
|
||||
+EXTRA_GNOME_CFLAGS="`$GNOME_CONFIG --cflags gnomeui print $bonobo $gb` `libglade-config --cflags gnome`"
|
||||
|
||||
|
||||
|
||||
|
|
|
@ -15,19 +15,20 @@ share/gnome/gnumeric/glade/print.glade
|
|||
share/gnome/gnumeric/glade/row-height.glade
|
||||
share/gnome/gnumeric/glade/sheet-rename.glade
|
||||
share/gnome/gnumeric/glade/summary.glade
|
||||
share/gnome/gnumeric/guile/functions.scm
|
||||
share/gnome/gnumeric/guile/gnumeric_startup.scm
|
||||
share/gnome/gnumeric/plugins/libcsv.so
|
||||
share/gnome/gnumeric/plugins/libdif.so
|
||||
share/gnome/gnumeric/plugins/libgnumguile.so
|
||||
share/gnome/gnumeric/plugins/libhtml.so
|
||||
share/gnome/gnumeric/plugins/liblotus.so
|
||||
share/gnome/gnumeric/plugins/liboleo.so
|
||||
share/gnome/gnumeric/plugins/libpython.so
|
||||
share/gnome/gnumeric/plugins/libsc.so
|
||||
share/gnome/gnumeric/plugins/libstat.so
|
||||
share/gnome/gnumeric/plugins/libsylk.so
|
||||
share/gnome/gnumeric/plugins/libtext.so
|
||||
share/gnome/gnumeric/plugins/libxbase.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_csv.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_dif.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_guile.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_html.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_lotus.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_oleo.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_python.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_sc.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_stat.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_sylk.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_text.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_xbase.so
|
||||
share/gnome/gnumeric/python/gnumeric_startup.py
|
||||
share/gnome/idl/Gnumeric.idl
|
||||
share/gnome/idl/Gnumeric-value.idl
|
||||
|
@ -183,9 +184,11 @@ share/locale/pt_BR/LC_MESSAGES/gnumeric.mo
|
|||
share/locale/ru/LC_MESSAGES/gnumeric.mo
|
||||
share/locale/sk/LC_MESSAGES/gnumeric.mo
|
||||
share/locale/sv/LC_MESSAGES/gnumeric.mo
|
||||
share/locale/uk/LC_MESSAGES/gnumeric.mo
|
||||
share/locale/zh_TW.Big5/LC_MESSAGES/gnumeric.mo
|
||||
@dirrm share/gnome/gnumeric/guile
|
||||
@dirrm share/gnome/gnumeric/glade
|
||||
@dirrm share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/
|
||||
@dirrm share/gnome/gnumeric/plugins
|
||||
@dirrm share/gnome/gnumeric/python
|
||||
@dirrm share/gnome/gnumeric
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
# New ports collection makefile for: gnumeric
|
||||
# Version required: 0.45
|
||||
# Version required: 0.46
|
||||
# Date created: 08 October 1998
|
||||
# Whom: Yukihiro Nakai <Nakai@technologist.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= gnumeric-0.45
|
||||
DISTNAME= gnumeric-0.46
|
||||
CATEGORIES= math gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME}
|
||||
MASTER_SITE_SUBDIR= stable/sources/gnumeric
|
||||
|
@ -33,4 +33,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
|||
GTK_CONFIG="${GTK_CONFIG}" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
|
||||
PLIST_SUB= GNUMERIC_REV=${DISTNAME:S/gnumeric-//g}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (gnumeric-0.45.tar.gz) = 7d7308f8d94ea6d3ca0940be78a80e18
|
||||
MD5 (gnumeric-0.46.tar.gz) = e873180c7f9cad1004ac75ea57170ed2
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- configure.orig Fri Nov 19 15:59:10 1999
|
||||
+++ configure Sat Nov 27 14:06:34 1999
|
||||
--- configure.orig Thu Dec 30 18:02:16 1999
|
||||
+++ configure Fri Dec 31 12:29:33 1999
|
||||
@@ -2790,7 +2790,7 @@
|
||||
fi
|
||||
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
|
||||
|
@ -27,7 +27,7 @@
|
|||
|
||||
else
|
||||
echo "$ac_t""no" 1>&6
|
||||
@@ -5602,15 +5602,15 @@
|
||||
@@ -5602,15 +5602,16 @@
|
||||
fi
|
||||
|
||||
|
||||
|
@ -37,7 +37,8 @@
|
|||
INSTOBJEXT=.mo
|
||||
DATADIRNAME=share
|
||||
- INTLDEPS='$(top_builddir)/intl/libintl.a'
|
||||
+ INTLDEPS='-lintl'
|
||||
+# INTLDEPS='$(top_builddir)/intl/libintl.a'
|
||||
+ INTLDEPS="-lintl"
|
||||
INTLLIBS=$INTLDEPS
|
||||
LIBS=`echo $LIBS | sed -e 's/-lintl//'`
|
||||
- nls_cv_header_intl=intl/libintl.h
|
||||
|
@ -47,30 +48,34 @@
|
|||
fi
|
||||
|
||||
if test "$XGETTEXT" != ":"; then
|
||||
@@ -6110,7 +6110,7 @@
|
||||
@@ -6110,7 +6111,7 @@
|
||||
echo "configure:6111: checking for GnomePrint libraries" >&5
|
||||
if gnome-config --libs print > /dev/null 2>&1; then
|
||||
echo "$ac_t""found" 1>&6
|
||||
- . `gnome-config --libdir`/printConf.sh
|
||||
+ . `gnome-config --sysconfdir`/printConf.sh
|
||||
+ . `$GNOME_CONFIG --sysconfdir`/printConf.sh
|
||||
echo $ac_n "checking for GnomePrint >= 0.8""... $ac_c" 1>&6
|
||||
echo "configure:6116: checking for GnomePrint >= 0.8" >&5
|
||||
case x$MODULE_VERSION in
|
||||
@@ -6125,14 +6125,14 @@
|
||||
@@ -6125,8 +6126,8 @@
|
||||
|
||||
echo $ac_n "checking for Glade libraries""... $ac_c" 1>&6
|
||||
echo "configure:6128: checking for Glade libraries" >&5
|
||||
echo $ac_n "checking for Glade libraries >= 0.11""... $ac_c" 1>&6
|
||||
echo "configure:6128: checking for Glade libraries >= 0.11" >&5
|
||||
-if gnome-config --libs libglade > /dev/null 2>&1; then
|
||||
- vers=`gnome-config --modversion libglade`
|
||||
+if libglade-config --libs > /dev/null 2>&1; then
|
||||
echo "$ac_t""found" 1>&6
|
||||
else
|
||||
+ vers=`libglade-config --version | sed -e 's/ /-/'`
|
||||
case $vers
|
||||
in
|
||||
libglade-0.1[123456789]) echo "$ac_t""found" 1>&6 ;;
|
||||
@@ -6136,8 +6137,8 @@
|
||||
{ echo "configure: error: Did not find libGlade installed" 1>&2; exit 1; }
|
||||
fi
|
||||
|
||||
-EXTRA_GNOME_LIBS=`gnome-config --libs gnomeui print libglade $bonobo $gb`
|
||||
-EXTRA_GNOME_CFLAGS=`gnome-config --cflags gnomeui print libglade $bonobo $gb`
|
||||
+EXTRA_GNOME_LIBS="`gnome-config --libs gnomeui print $bonobo $gb` `libglade-config --libs gnome`"
|
||||
+EXTRA_GNOME_CFLAGS="`gnome-config --cflags gnomeui print $bonobo $gb` `libglade-config --cflags gnome`"
|
||||
+EXTRA_GNOME_LIBS="`$GNOME_CONFIG --libs gnomeui print $bonobo $gb` `libglade-config --libs gnome`"
|
||||
+EXTRA_GNOME_CFLAGS="`$GNOME_CONFIG --cflags gnomeui print $bonobo $gb` `libglade-config --cflags gnome`"
|
||||
|
||||
|
||||
|
||||
|
|
|
@ -15,19 +15,20 @@ share/gnome/gnumeric/glade/print.glade
|
|||
share/gnome/gnumeric/glade/row-height.glade
|
||||
share/gnome/gnumeric/glade/sheet-rename.glade
|
||||
share/gnome/gnumeric/glade/summary.glade
|
||||
share/gnome/gnumeric/guile/functions.scm
|
||||
share/gnome/gnumeric/guile/gnumeric_startup.scm
|
||||
share/gnome/gnumeric/plugins/libcsv.so
|
||||
share/gnome/gnumeric/plugins/libdif.so
|
||||
share/gnome/gnumeric/plugins/libgnumguile.so
|
||||
share/gnome/gnumeric/plugins/libhtml.so
|
||||
share/gnome/gnumeric/plugins/liblotus.so
|
||||
share/gnome/gnumeric/plugins/liboleo.so
|
||||
share/gnome/gnumeric/plugins/libpython.so
|
||||
share/gnome/gnumeric/plugins/libsc.so
|
||||
share/gnome/gnumeric/plugins/libstat.so
|
||||
share/gnome/gnumeric/plugins/libsylk.so
|
||||
share/gnome/gnumeric/plugins/libtext.so
|
||||
share/gnome/gnumeric/plugins/libxbase.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_csv.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_dif.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_guile.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_html.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_lotus.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_oleo.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_python.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_sc.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_stat.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_sylk.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_text.so
|
||||
share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/libgnum_xbase.so
|
||||
share/gnome/gnumeric/python/gnumeric_startup.py
|
||||
share/gnome/idl/Gnumeric.idl
|
||||
share/gnome/idl/Gnumeric-value.idl
|
||||
|
@ -183,9 +184,11 @@ share/locale/pt_BR/LC_MESSAGES/gnumeric.mo
|
|||
share/locale/ru/LC_MESSAGES/gnumeric.mo
|
||||
share/locale/sk/LC_MESSAGES/gnumeric.mo
|
||||
share/locale/sv/LC_MESSAGES/gnumeric.mo
|
||||
share/locale/uk/LC_MESSAGES/gnumeric.mo
|
||||
share/locale/zh_TW.Big5/LC_MESSAGES/gnumeric.mo
|
||||
@dirrm share/gnome/gnumeric/guile
|
||||
@dirrm share/gnome/gnumeric/glade
|
||||
@dirrm share/gnome/gnumeric/plugins/%%GNUMERIC_REV%%/
|
||||
@dirrm share/gnome/gnumeric/plugins
|
||||
@dirrm share/gnome/gnumeric/python
|
||||
@dirrm share/gnome/gnumeric
|
||||
|
|
Loading…
Reference in a new issue