Update to version 2.94

PR: 42025
Submitted by: MAINTAINER
This commit is contained in:
Kevin Lo 2002-08-28 03:35:16 +00:00
parent 3aabe34168
commit 8b5029d684
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=65134
4 changed files with 3 additions and 52 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= CGI-Session
PORTVERSION= 2.91
PORTVERSION= 2.94
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= CGI
@ -23,7 +23,6 @@ MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= CGI::Session::DB_File.3 \
CGI::Session::MySQL.3 \
CGI::Session::MD5.3 \
CGI::Session::File.3 \
CGI::Session.3
CGI::Session::File.3
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (CGI-Session-2.91.tar.gz) = 95c9fac80fec2b13526548f81f6ec147
MD5 (CGI-Session-2.94.tar.gz) = 67e623d6e2d1e4a3699a2e8b1605cb84

View file

@ -1,47 +0,0 @@
--- Session.pm.orig Wed Jun 12 11:56:43 2002
+++ Session.pm Wed Jun 12 12:04:39 2002
@@ -915,7 +915,7 @@
=head2 STANDARD INSTALLATION
The library is installed with just like other Perl libraries, or via CPAN interactive
-shell (Perl -MCPAN -e install CGI::Session).
+shell (Perl -MCPAN C<-e> install CGI::Session).
Installation can also be done by following below instructions:
@@ -1117,7 +1117,7 @@
above example. So, how do we "mark" the user? There are several ways of
"marking".
-=head3 IDENTIFYING THE USER VIA CGI QUERY
+=item IDENTIFYING THE USER VIA CGI QUERY
One way of doing it is to append the session id to every single link in the
web site:
@@ -1167,7 +1167,7 @@
session id appended to them. Too bad, because the client has to start
everything over again.
-=head3 INDENTIFYING THE USER VIA COOKIES
+=item INDENTIFYING THE USER VIA COOKIES
We can deal with the above problem by sending the client a cookie. This cookie
will hold the session id only! Thus if the client visits some other site, or
@@ -1211,7 +1211,7 @@
the C<sid> parameter in the URL, and if that fails, then it will default to
undef, which will force C<CGI::Session> to create a new id for the client.
-=head3 IDENTIFYING THE USER VIA PATH_INFO
+=item IDENTIFYING THE USER VIA PATH_INFO
The least common, but at the same time quite convenient way of C<marking> users
with a session id is appending the session id to the url of the script
@@ -1363,7 +1363,7 @@
=back
-=head3 SPECIAL NAMES
+=item SPECIAL NAMES
When you create a fresh-blank session, it's not blank as it seems. It is
initialized with the following 4 parameters, which are serialized together

View file

@ -3,7 +3,6 @@ lib/perl5/site_perl/%%PERL_VER%%/CGI/Session/MD5.pm
lib/perl5/site_perl/%%PERL_VER%%/CGI/Session/MySQL.pm
lib/perl5/site_perl/%%PERL_VER%%/CGI/Session/File.pm
lib/perl5/site_perl/%%PERL_VER%%/CGI/Session.pm
lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/id.al
lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/remote_addr.al
lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/remote_host.al
lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/close.al