New port audio/mad, a High-quality MPEG audio decoder.
PR: 22950 Submitted by: Jason R. Mastaler <jason-freebsd@mastaler.com>
This commit is contained in:
parent
66ccdf8cbc
commit
8b5d6fc1d8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=36127
8 changed files with 112 additions and 0 deletions
|
@ -87,6 +87,7 @@
|
|||
SUBDIR += linux-realplayer
|
||||
SUBDIR += litestream
|
||||
SUBDIR += lopster
|
||||
SUBDIR += mad
|
||||
SUBDIR += maplay
|
||||
SUBDIR += mikmod
|
||||
SUBDIR += mixer.app
|
||||
|
|
29
audio/mad/Makefile
Normal file
29
audio/mad/Makefile
Normal file
|
@ -0,0 +1,29 @@
|
|||
# New ports collection makefile for: mad
|
||||
# Date created: 18 November 2000
|
||||
# Whom: Jason R. Mastaler <jason-freebsd@mastaler.com> et al.
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= mad
|
||||
PORTVERSION= 0.12.1b
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
|
||||
ftp://ftp.mars.org/pub/mpeg/
|
||||
MASTER_SITE_SUBDIR= mad
|
||||
|
||||
MAINTAINER= jason-freebsd@mastaler.com
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
# This port is not CFLAGS SAFE, something like CFLAGS="-O -Os"
|
||||
# breaks configure and configure likes to use -O2 instead of
|
||||
# trusting the system. We'll have it use -O instead of -O*
|
||||
# since this configure requires a standard and this has
|
||||
# been the system standard
|
||||
CONFIGURE_ENV= CFLAGS="-O -pipe"
|
||||
USE_GMAKE= yes
|
||||
USE_LIBTOOL= yes
|
||||
|
||||
MAN1= abxtest.1 madplay.1
|
||||
|
||||
.include <bsd.port.mk>
|
1
audio/mad/distinfo
Normal file
1
audio/mad/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (mad-0.12.1b.tar.gz) = 7562add886aee7b2dbdc3c22b32e70bd
|
37
audio/mad/files/patch-aa
Normal file
37
audio/mad/files/patch-aa
Normal file
|
@ -0,0 +1,37 @@
|
|||
This port is not CFLAGS safe. I will not try to make it on this
|
||||
particular version. However, I will make it use -O instead of -O2
|
||||
since I am told that -O2 brakes the alpha ARCH. Partially provided
|
||||
by lioux@freebsd.org
|
||||
|
||||
--- configure.orig Fri Nov 17 04:20:18 2000
|
||||
+++ configure Sun Nov 26 22:56:39 2000
|
||||
@@ -3800,7 +3800,8 @@
|
||||
then
|
||||
case "$host" in
|
||||
i386-*) ARCH="" ;;
|
||||
- i?86-*) ARCH="-m486" ;;
|
||||
+ i486-*) ARCH="-m486" ;;
|
||||
+ i586-*) ARCH="-mpentium" ;;
|
||||
arm-empeg-*) ARCH="-march=armv4 -mtune=strongarm1100" ;;
|
||||
armv4*-*) ARCH="-march=armv4 -mtune=strongarm" ;;
|
||||
mips*-*) ARCH="" ;;
|
||||
@@ -3813,7 +3814,7 @@
|
||||
esac
|
||||
|
||||
case "$CFLAGS" in
|
||||
- *-O*) OPTIMIZER="-O2" ;;
|
||||
+ *-O*) OPTIMIZER="-O" ;;
|
||||
esac
|
||||
|
||||
CFLAGS=`echo ".$CFLAGS" | \
|
||||
@@ -5439,10 +5440,6 @@
|
||||
*) # Relative path.
|
||||
ac_sub_cache_file="$ac_dots$cache_file" ;;
|
||||
esac
|
||||
- case "$ac_given_INSTALL" in
|
||||
- [/$]*) INSTALL="$ac_given_INSTALL" ;;
|
||||
- *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
|
||||
- esac
|
||||
|
||||
echo "running ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir"
|
||||
# The eval makes quoting arguments work.
|
13
audio/mad/files/patch-ab
Normal file
13
audio/mad/files/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- audio_oss.c.orig Thu Nov 16 03:51:04 2000
|
||||
+++ audio_oss.c Sat Nov 18 13:45:25 2000
|
||||
@@ -57,6 +57,10 @@
|
||||
# undef AUDIO_TRY32BITS
|
||||
# endif
|
||||
|
||||
+# if !defined(SNDCTL_DSP_CHANNELS) && defined(SOUND_PCM_WRITE_CHANNELS)
|
||||
+# define SNDCTL_DSP_CHANNELS SOUND_PCM_WRITE_CHANNELS
|
||||
+# endif
|
||||
+
|
||||
# define AUDIO_DEVICE "/dev/dsp"
|
||||
|
||||
static int sfd;
|
1
audio/mad/pkg-comment
Normal file
1
audio/mad/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
High-quality MPEG audio decoder
|
20
audio/mad/pkg-descr
Normal file
20
audio/mad/pkg-descr
Normal file
|
@ -0,0 +1,20 @@
|
|||
MAD is a high-quality MPEG audio decoder. It currently supports MPEG-1
|
||||
as well as the MPEG-2 extension to Lower Sampling Frequencies. All
|
||||
three audio layers (Layer I, Layer II, and Layer III a.k.a. MP3) are
|
||||
fully implemented.
|
||||
|
||||
MAD does not yet support MPEG-2 multichannel audio (although it should
|
||||
be backward compatible with such streams) or AAC, nor does it support
|
||||
the so-called MPEG 2.5 format.
|
||||
|
||||
MAD has the following special features:
|
||||
|
||||
- 24-bit PCM output
|
||||
- 100% fixed-point (integer) computation
|
||||
- completely new implementation based on the ISO/IEC standards
|
||||
- distributed under the terms of the GNU General Public License (GPL)
|
||||
|
||||
The software is distributed as a library (libmad) and command-line
|
||||
front-end (madplay).
|
||||
|
||||
WWW: http://mad.sourceforge.net/
|
10
audio/mad/pkg-plist
Normal file
10
audio/mad/pkg-plist
Normal file
|
@ -0,0 +1,10 @@
|
|||
bin/abxtest
|
||||
bin/madplay
|
||||
include/mad.h
|
||||
lib/libmad.a
|
||||
lib/libmad.la
|
||||
share/locale/en/LC_MESSAGES/mad.mo
|
||||
share/locale/es/LC_MESSAGES/mad.mo
|
||||
share/locale/fr/LC_MESSAGES/mad.mo
|
||||
share/locale/hr/LC_MESSAGES/mad.mo
|
||||
share/locale/no/LC_MESSAGES/mad.mo
|
Loading…
Reference in a new issue