Atmel AVR cross-development, part #3: a C and floating point math
library. This port also installs some documentation which actually describes the combo of all three ports (avr-binutils, avr-gcc, avr-libc).
This commit is contained in:
parent
639ffde3ac
commit
8b68d52148
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=35684
9 changed files with 137 additions and 0 deletions
|
@ -19,6 +19,7 @@
|
|||
SUBDIR += avltree
|
||||
SUBDIR += avr-binutils
|
||||
SUBDIR += avr-gcc
|
||||
SUBDIR += avr-libc
|
||||
SUBDIR += bcc
|
||||
SUBDIR += bin86
|
||||
SUBDIR += binutils-m68k
|
||||
|
|
44
devel/avr-libc/Makefile
Normal file
44
devel/avr-libc/Makefile
Normal file
|
@ -0,0 +1,44 @@
|
|||
# New ports collection makefile for: avr-libc
|
||||
# Date created: 04 Dec 2000
|
||||
# Whom: Joerg Wunsch <joerg@freebsd.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= avr-libc
|
||||
PORTVERSION= 20000207
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.gwdg.de/~mrickma/avr/snapshot/
|
||||
DISTNAME= ${PORTNAME}-nma-${PORTVERSION}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= joerg@freebsd.org
|
||||
|
||||
BUILD_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
|
||||
avr-ld:${PORTSDIR}/devel/avr-binutils \
|
||||
avr-gcc:${PORTSDIR}/devel/avr-gcc
|
||||
RUN_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
|
||||
avr-ld:${PORTSDIR}/devel/avr-binutils \
|
||||
avr-gcc:${PORTSDIR}/devel/avr-gcc
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/src
|
||||
|
||||
USE_GMAKE= yes
|
||||
|
||||
MAKE_FLAGS= prefix=${PREFIX}
|
||||
|
||||
post-install:
|
||||
${MKDIR} ${PREFIX}/share/doc/avr-libc
|
||||
${MKDIR} ${PREFIX}/share/doc/avr-libc/examples
|
||||
${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/README \
|
||||
${PREFIX}/share/doc/avr-libc
|
||||
${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/README.too \
|
||||
${PREFIX}/share/doc/avr-libc
|
||||
@for f in avr-recv.c io.c prg progmem.c send_byte.s signal.c;\
|
||||
do \
|
||||
${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/doc/examples/$$f \
|
||||
${PREFIX}/share/doc/avr-libc/examples; \
|
||||
done
|
||||
${INSTALL_DATA} ${FILESDIR}/avr-lib.pdf ${PREFIX}/share/doc/avr-libc
|
||||
|
||||
.include <bsd.port.mk>
|
1
devel/avr-libc/distinfo
Normal file
1
devel/avr-libc/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (avr-libc-nma-20000207.tgz) = 8256e25373ab6064cc4ccf4164cf80bb
|
3
devel/avr-libc/files/README.libdoc
Normal file
3
devel/avr-libc/files/README.libdoc
Normal file
|
@ -0,0 +1,3 @@
|
|||
The file avr-lib.pdf has been obtained from
|
||||
|
||||
http://www.enteract.com/~rneswold/avr/avr-lib.pdf
|
BIN
devel/avr-libc/files/avr-lib.pdf
Normal file
BIN
devel/avr-libc/files/avr-lib.pdf
Normal file
Binary file not shown.
11
devel/avr-libc/files/patch-aa
Normal file
11
devel/avr-libc/files/patch-aa
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.orig Mon Feb 7 11:19:03 2000
|
||||
+++ Makefile Tue Dec 5 14:23:40 2000
|
||||
@@ -17,7 +17,7 @@
|
||||
AR = ${target}-ar
|
||||
RM = rm
|
||||
MD = mkdir -p $@
|
||||
-INSTALL = install -m644 $^/
|
||||
+INSTALL = install -C -m644 $^/
|
||||
|
||||
CFLAGS = -Wall -Wstrict-prototypes -DNO_UNDERSCORES=1
|
||||
CFLAGS_DEBUG = -g
|
1
devel/avr-libc/pkg-comment
Normal file
1
devel/avr-libc/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
a C and math library for the Atmel AVR controller family
|
10
devel/avr-libc/pkg-descr
Normal file
10
devel/avr-libc/pkg-descr
Normal file
|
@ -0,0 +1,10 @@
|
|||
avr-libc -- a C and math library for the Atmel AVR controller family
|
||||
|
||||
This library implements a subset of common C library functions, some
|
||||
Atmel AVR specific additions (like handling AVR's IO facilities,
|
||||
EEPROM etc.), as well as a 32-bit floating point math library (-lm).
|
||||
|
||||
Everything is designed and implemented to cooperate with avr-gcc and
|
||||
avr-binutils.
|
||||
|
||||
WWW: http://www.gwdg.de/~mrickma/avr/snapshot/
|
66
devel/avr-libc/pkg-plist
Normal file
66
devel/avr-libc/pkg-plist
Normal file
|
@ -0,0 +1,66 @@
|
|||
avr/lib/gcrt1-2313.o
|
||||
avr/lib/gcrt1-2323.o
|
||||
avr/lib/gcrt1-2333.o
|
||||
avr/lib/gcrt1-2343.o
|
||||
avr/lib/gcrt1-4414.o
|
||||
avr/lib/gcrt1-4433.o
|
||||
avr/lib/gcrt1-4434.o
|
||||
avr/lib/gcrt1-8515.o
|
||||
avr/lib/gcrt1-8535.o
|
||||
avr/lib/gcrt1-mega103.o
|
||||
avr/lib/gcrt1-mega603.o
|
||||
avr/lib/gcrt1-tiny22.o
|
||||
avr/lib/gcrt1-mega161.o
|
||||
avr/lib/libc.a
|
||||
avr/lib/libc-mega.a
|
||||
avr/lib/libm.a
|
||||
avr/lib/libm-mega.a
|
||||
avr/include/crt1init.h
|
||||
avr/include/ctype.h
|
||||
avr/include/eeprom.h
|
||||
avr/include/errno.h
|
||||
avr/include/interrupt.h
|
||||
avr/include/inttypes.h
|
||||
avr/include/io-avr.h
|
||||
avr/include/io.h
|
||||
avr/include/io1200.h
|
||||
avr/include/io2313.h
|
||||
avr/include/io2323.h
|
||||
avr/include/io2333.h
|
||||
avr/include/io2343.h
|
||||
avr/include/io4414.h
|
||||
avr/include/io4433.h
|
||||
avr/include/io4434.h
|
||||
avr/include/io8515.h
|
||||
avr/include/io8534.h
|
||||
avr/include/io8535.h
|
||||
avr/include/iom103.h
|
||||
avr/include/iom161.h
|
||||
avr/include/iom603.h
|
||||
avr/include/iomacros.h
|
||||
avr/include/iotn11.h
|
||||
avr/include/iotn12.h
|
||||
avr/include/iotn15.h
|
||||
avr/include/iotn22.h
|
||||
avr/include/iotn28.h
|
||||
avr/include/math.h
|
||||
avr/include/progmem.h
|
||||
avr/include/setjmp.h
|
||||
avr/include/signal.h
|
||||
avr/include/stdio.h
|
||||
avr/include/stdlib.h
|
||||
avr/include/string-avr.h
|
||||
avr/include/string.h
|
||||
avr/include/timer.h
|
||||
avr/include/wdt.h
|
||||
share/doc/avr-libc/README
|
||||
share/doc/avr-libc/README.too
|
||||
share/doc/avr-libc/avr-lib.pdf
|
||||
share/doc/avr-libc/examples/avr-recv.c
|
||||
share/doc/avr-libc/examples/io.c
|
||||
share/doc/avr-libc/examples/prg
|
||||
share/doc/avr-libc/examples/progmem.c
|
||||
share/doc/avr-libc/examples/send_byte.s
|
||||
share/doc/avr-libc/examples/signal.c
|
||||
@dirrm share/doc/avr-libc/examples
|
||||
@dirrm share/doc/avr-libc
|
Loading…
Reference in a new issue