Sound plugin for Mupen64

-
Mupen64 is a highly portable Nintendo 64 emulator. It has been developed
on/for Linux originally but has already been ported successfully to other
operating systems. The program can easily be ported to all operating systems
supported by the SDL library.

In its current state, the emulator is highly compatible and uses a plugin
system. With the correct plugins ("correct" can be computer dependent), it
can achieve nearly perfect graphics and sound in many games.

WWW: http://mupen64.emulation64.com/

PR:		71895
Submitted by:	Travis Poppe
This commit is contained in:
Dirk Meyer 2004-10-12 05:07:52 +00:00
parent a0888aa7fc
commit 8b6b4b9ed1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=118797
6 changed files with 91 additions and 0 deletions

View file

@ -69,6 +69,7 @@
SUBDIR += mupen64-rsp
SUBDIR += mupen64-sdlaudio
SUBDIR += mupen64-sdlinput
SUBDIR += mupen64-sound
SUBDIR += osf1_base
SUBDIR += p-interp
SUBDIR += pcemu

View file

@ -0,0 +1,49 @@
# New ports collection makefile for: mupen64-sound
# Date created: 12.Aug 2004
# Whom: dirk.meyer@dinoex.sub.org
#
# $FreeBSD$
#
PORTNAME= mupen64
PORTVERSION= 0.4
CATEGORIES+= emulators
MASTER_SITES= http://mupen64.emulation64.com/files/${PORTVERSION}/
PKGNAMESUFFIX= -sound
DISTNAME= mupen64_sound
MAINTAINER?= tlp@LiquidX.org
COMMENT= Sound plugin for Mupen64
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gtk12
USE_GCC= 3.4
USE_REINPLACE= yes
ONLY_FOR_ARCHS= i386
PLUGIN_NAME= mupen64_audio
PLIST_FILES= share/mupen64/plugins/${PLUGIN_NAME}.so
PLIST_DIRS= share/mupen64/plugins
post-patch:
@${REINPLACE_CMD} -e 's|linux/soundcard.h|sys/soundcard.h|' ${WRKSRC}/main.c
do-install:
@${MKDIR} ${PREFIX}/share/mupen64/plugins
${INSTALL_SCRIPT} ${WRKSRC}/${PLUGIN_NAME}.so \
${PREFIX}/share/mupen64/plugins/
.include <bsd.port.pre.mk>
CFLAGS+= -DUSE_GTK `${GTK_CONFIG} --cflags` -fPIC
CFLAGS+= -O3 -fomit-frame-pointer -funroll-loops -ffast-math -Wall -pipe
CFLAGS+= -DX86 -mcpu=athlon
LDFLAGS+= -shared -Wl,-Bsymbolic
MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" LD="${CC}"
post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View file

@ -0,0 +1,2 @@
MD5 (mupen64_sound.tar.bz2) = 88dfa0045794db7f1fc100b4c7b23125
SIZE (mupen64_sound.tar.bz2) = 5932

View file

@ -0,0 +1,14 @@
--- Makefile.orig Sun Jul 4 11:43:39 2004
+++ Makefile Thu Aug 12 16:09:11 2004
@@ -1,7 +1,7 @@
-CC = gcc
-CFLAGS = -O3 -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=athlon `gtk-config --cflags` -DUSE_GTK -Wall
-LD = gcc
-LDFLAGS = -shared -Wl,-Bsymbolic `gtk-config --libs` -lpthread
+#CC = gcc
+#CFLAGS = -O3 -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=athlon `gtk-config --cflags` -DUSE_GTK -Wall
+#LD = gcc
+#LDFLAGS = -shared -Wl,-Bsymbolic `gtk-config --libs` -lpthread
OBJECTS = main.o

View file

@ -0,0 +1,16 @@
Sound plugin for Mupen64
Tip: Use mupen64-sdlaudio (JttL's SDL plugin) instead!
-
Mupen64 is a highly portable Nintendo 64 emulator. It has been developed
on/for Linux originally but has already been ported successfully to other
operating systems. The program can easily be ported to all operating systems
supported by the SDL library.
In its current state, the emulator is highly compatible and uses a plugin
system. With the correct plugins ("correct" can be computer dependent), it
can achieve nearly perfect graphics and sound in many games.
WWW: http://mupen64.emulation64.com/
- Travis Poppe
tlp@liquidx.org

View file

@ -0,0 +1,9 @@
-------------------------------------------------------------------------------
If you have installed/upgraded any new plugins or are upgrading from a previous
version of Mupen64, please note that in order for these changes to take effect,
you -must- backup and then remove ~/.mupen64 first. After you have removed the
directory, run 'mupen64' to re-create it. Then, manually copy back your save
files/other data you need from the backup if necessary.
Enjoy!
-------------------------------------------------------------------------------