Add easygtk. EasyGTK is a wrapper library for GTK+ for people who want to learn
GTK programming in 2 hours instead of 2 weeks
This commit is contained in:
parent
c2509bf1a0
commit
8bce27f85f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=36650
7 changed files with 91 additions and 0 deletions
|
@ -9,6 +9,7 @@
|
|||
SUBDIR += buffy
|
||||
SUBDIR += clean-theme-gtk
|
||||
SUBDIR += colorstep
|
||||
SUBDIR += easygtk
|
||||
SUBDIR += eazel-themes
|
||||
SUBDIR += engradient
|
||||
SUBDIR += fltk
|
||||
|
|
28
x11-toolkits/easygtk/Makefile
Normal file
28
x11-toolkits/easygtk/Makefile
Normal file
|
@ -0,0 +1,28 @@
|
|||
# New ports collection makefile for: easygtk
|
||||
# Date created: 3 January 2001
|
||||
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= easygtk
|
||||
PORTVERSION= 1.2
|
||||
CATEGORIES= x11-toolkits
|
||||
MASTER_SITES= http://www.linsupport.com/sw/ \
|
||||
http://www.linuxbox.com/~drow/EasyGTK/
|
||||
EXTRACT_SUFX= .tar
|
||||
|
||||
MAINTAINER= sobomax@FreeBSD.org
|
||||
|
||||
EXTRACT_BEFORE_ARGS= # it's intentionally left blank
|
||||
EXTRACT_CMD= ${CAT} # not quite `extract', but who cares? ;)
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GNOMELIBS= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
MAKE_ENV= MKDIR="${MKDIR}" \
|
||||
LN="${LN}"
|
||||
|
||||
.include <bsd.port.mk>
|
1
x11-toolkits/easygtk/distinfo
Normal file
1
x11-toolkits/easygtk/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (easygtk-1.2.tar) = 04bf9844bed30d34c6e6cb6416cadced
|
43
x11-toolkits/easygtk/files/patch-Makefile
Normal file
43
x11-toolkits/easygtk/files/patch-Makefile
Normal file
|
@ -0,0 +1,43 @@
|
|||
--- Makefile.orig Wed Feb 16 00:07:21 2000
|
||||
+++ Makefile Wed Jan 3 16:03:42 2001
|
||||
@@ -1,23 +1,31 @@
|
||||
-CFLAGS = -Wall -O -I. -I/usr/X11R6/include -I/usr/lib/glib/include -I/usr/X11R6/include/X11 -DUSE_IMLIB -DUSE_GNOME -I/usr/include -DNEED_GNOMESUPPORT_H -I/usr/lib/gnome-libs/include -I/usr/X11R6/include -I/usr/lib/glib/include
|
||||
-LIBS = -L. -L/usr/lib -L/usr/X11R6/lib -lgtk -lgdk -rdynamic -lgmodule -lglib -ldl -lXext -lX11 -lm -lgdk_imlib -L/usr/lib -lImlib -ljpeg -ltiff -lungif -lpng -lz -lm -lXext -L/usr/X11R6/lib -lSM -lICE -lXext -lX11 -I/usr/include/glib -rdynamic -L/usr/lib -L/usr/X11R6/lib -lgnomeui -lart_lgpl -lgdk_imlib -lSM -lICE -lgtk -lgdk -lgmodule -lXext -lX11 -lgnome -lgnomesupport -lesd -laudiofile -lm -ldb1 -lglib -ldl
|
||||
-CC = gcc
|
||||
+GNOME_CFLAGS != $(X11BASE)/bin/gnome-config --cflags gnomeui
|
||||
+GNOME_LIBS != $(X11BASE)/bin/gnome-config --libs gnomeui
|
||||
+CFLAGS += -I. -DUSE_IMLIB -DUSE_GNOME $(GNOME_CFLAGS)
|
||||
+LIBS = $(GNOME_LIBS)
|
||||
+CC ?= gcc
|
||||
|
||||
all: easygtk.c
|
||||
$(CC) $(CFLAGS) -c easygtk.c
|
||||
ar rc libeasygtk.a easygtk.o
|
||||
ranlib libeasygtk.a
|
||||
+ $(CC) $(CFLAGS) -shared -fpic easygtk.c -o libeasygtk.so.1 $(LIBS)
|
||||
+ $(LN) -sf libeasygtk.so.1 libeasygtk.so
|
||||
|
||||
install:
|
||||
- cp libeasygtk.a /usr/lib/libeasygtk.a
|
||||
- cp easygtk.h /usr/include/easygtk.h
|
||||
- mkdir -p /usr/doc/EasyGTK
|
||||
- cp manual.html /usr/doc/EasyGTK/manual.html
|
||||
+ $(BSD_INSTALL_DATA) libeasygtk.a $(PREFIX)/lib
|
||||
+ $(BSD_INSTALL_DATA) easygtk.h $(PREFIX)/include
|
||||
+ $(BSD_INSTALL_PROGRAM) libeasygtk.so.1 $(PREFIX)/lib
|
||||
+ $(LN) -sf $(PREFIX)/lib/libeasygtk.so.1 $(PREFIX)/lib/libeasygtk.so
|
||||
+ $(MKDIR) $(PREFIX)/share/doc/EasyGTK
|
||||
+ $(BSD_INSTALL_MAN) manual.html $(PREFIX)/share/doc/EasyGTK
|
||||
+ $(MKDIR) $(PREFIX)/share/examples/EasyGTK
|
||||
+ $(BSD_INSTALL_DATA) example.c $(PREFIX)/share/examples/EasyGTK
|
||||
|
||||
clean:
|
||||
rm example testtree *.o *.a .libdep* *~ core
|
||||
|
||||
example: example.c
|
||||
- $(CC) $(CFLAGS) -o example example.c $(LIBS) libeasygtk.a
|
||||
+ $(CC) $(CFLAGS) -o example example.c $(LIBS) -L./ -leasygtk
|
||||
|
||||
testtree: testtree.c
|
||||
- $(CC) $(CFLAGS) -o testtree testtree.c $(LIBS) libeasygtk.a
|
||||
+ $(CC) $(CFLAGS) -o testtree testtree.c $(LIBS) -L./ -leasygtk
|
1
x11-toolkits/easygtk/pkg-comment
Normal file
1
x11-toolkits/easygtk/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A wrapper library for GTK+ which provides simplified GUI API
|
9
x11-toolkits/easygtk/pkg-descr
Normal file
9
x11-toolkits/easygtk/pkg-descr
Normal file
|
@ -0,0 +1,9 @@
|
|||
EasyGTK is a wrapper library around the GTK+ library to provide a much
|
||||
easier and simplier Application Programming Interface to the developer.
|
||||
|
||||
Check the manual.html for a list of the available functions.
|
||||
See the file example.c for a working example of EasyGTK.
|
||||
|
||||
This library is (C) 1999-2000 Patrick Lambert <drow@post.com>
|
||||
|
||||
http://www.linsupport.com/sw/easygtk.html
|
8
x11-toolkits/easygtk/pkg-plist
Normal file
8
x11-toolkits/easygtk/pkg-plist
Normal file
|
@ -0,0 +1,8 @@
|
|||
include/easygtk.h
|
||||
lib/libeasygtk.a
|
||||
lib/libeasygtk.so
|
||||
lib/libeasygtk.so.1
|
||||
share/doc/EasyGTK/manual.html
|
||||
share/examples/EasyGTK/example.c
|
||||
@dirrm share/examples/EasyGTK
|
||||
@dirrm share/doc/EasyGTK
|
Loading…
Reference in a new issue