- Unbreak build on 10.x and -CURRENT
- Use a modern GCC toolchain to unbreak the build on 8.x - Force 32-bit mode on i386 - Enhance default OPTIONs for a better usability of the port Supported by: John Van Sickle <john.vansickle@gmail.com>
This commit is contained in:
parent
d5057f768f
commit
8be041e13a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=333283
2 changed files with 23 additions and 1 deletions
|
@ -2,6 +2,7 @@
|
|||
|
||||
PORTNAME= libav
|
||||
PORTVERSION= 9.10
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= multimedia audio ipv6 net
|
||||
MASTER_SITES= http://libav.org/releases/
|
||||
|
||||
|
@ -26,6 +27,8 @@ CONFIGURE_ARGS+= --prefix="${PREFIX}" \
|
|||
--enable-pthreads \
|
||||
--enable-shared \
|
||||
--enable-runtime-cpudetect \
|
||||
--disable-debug \
|
||||
--cc="${CC}" \
|
||||
--disable-avserver
|
||||
|
||||
OPTIONS_DEFINE= ALSA AMR_NB AMR_WB BZIP2 CDIO FAAC FDK_AAC FREETYPE FREI0R \
|
||||
|
@ -34,7 +37,7 @@ OPTIONS_DEFINE= ALSA AMR_NB AMR_WB BZIP2 CDIO FAAC FDK_AAC FREETYPE FREI0R \
|
|||
VO_AACENC VO_AMRWBENC VORBIS VPX X264 XVID ZLIB
|
||||
|
||||
OPTIONS_DEFAULT= BZIP2 FREETYPE FREI0R GNUTLS OPENCV SCHROEDINGER \
|
||||
THEORA VPX X264 XVID
|
||||
THEORA VO_AACENC VORBIS VPX X264 XVID ZLIB
|
||||
|
||||
FDK_AAC_DESC= AAC audio encoding via Fraunhofer FDK
|
||||
ILBC_DESC= iLBC en/decoding via libilbc
|
||||
|
@ -150,6 +153,14 @@ USE_OPENSSL= yes
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == "i386"
|
||||
CONFIGURE_ARGS+= --extra-cflags=-m32
|
||||
.endif
|
||||
|
||||
.if ${OSVERSION} < 900000
|
||||
USE_GCC= 4.6+
|
||||
.endif
|
||||
|
||||
.if ${HAVE_SDL:Msdl}
|
||||
USE_SDL+= sdl
|
||||
MAN1+= avplay.1
|
||||
|
|
11
multimedia/libav/files/patch-libavutil_x86_asm.h
Normal file
11
multimedia/libav/files/patch-libavutil_x86_asm.h
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- libavutil/x86/asm.h.orig 2013-11-07 22:15:35.000000000 +0100
|
||||
+++ libavutil/x86/asm.h 2013-11-07 22:15:52.000000000 +0100
|
||||
@@ -68,7 +68,7 @@
|
||||
typedef int x86_reg;
|
||||
#endif
|
||||
|
||||
-#define HAVE_7REGS (ARCH_X86_64 || (HAVE_EBX_AVAILABLE && HAVE_EBP_AVAILABLE))
|
||||
+#define HAVE_7REGS (ARCH_X86_64 || (HAVE_EBX_AVAILABLE && HAVE_EBP_AVAILABLE && !defined(__clang__)))
|
||||
#define HAVE_6REGS (ARCH_X86_64 || (HAVE_EBX_AVAILABLE || HAVE_EBP_AVAILABLE))
|
||||
|
||||
#if ARCH_X86_64 && defined(PIC)
|
Loading…
Reference in a new issue