- Update to 1.0.2
Feature safe: yes
This commit is contained in:
parent
df54dfb288
commit
8be170a9d9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=250051
3 changed files with 12 additions and 14 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= bitefusion
|
||||
PORTVERSION= 1.0.1
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 1.0.2
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://www.junoplay.com/files/ \
|
||||
http://mirror.amdmi3.ru/distfiles/
|
||||
|
@ -18,14 +17,14 @@ COMMENT= A snake game with 8 levels
|
|||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_SDL= sdl
|
||||
CONFIGURE_ENV= CPPFLAGS="`${SDL_CONFIG} --cflags`" \
|
||||
LDFLAGS="`${SDL_CONFIG} --libs`"
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
PLIST_FILES= bin/bitefusion
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-linux-gnu|-portbld-freebsd|' \
|
||||
${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e 's|-lSDL||' ${WRKSRC}/Makefile.in
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (bitefusion-1.0.1.tar.gz) = d7bc933c3363a76b4cb3eeb2a4f33b40
|
||||
SHA256 (bitefusion-1.0.1.tar.gz) = 8977ec4b04bec4b795188c68686802b7bf540b2ea0719ab95197da20b7191665
|
||||
SIZE (bitefusion-1.0.1.tar.gz) = 280347
|
||||
MD5 (bitefusion-1.0.2.tar.gz) = 0d7fc10ad0d08f8f90de07fe3bcd8f26
|
||||
SHA256 (bitefusion-1.0.2.tar.gz) = 12e4aed2aa85ed66ce31e529c165a3457b512f77447bb7375a5ed3a41ded350d
|
||||
SIZE (bitefusion-1.0.2.tar.gz) = 246280
|
||||
|
|
|
@ -1,18 +1,17 @@
|
|||
--- main.c.orig Thu Oct 5 18:49:20 2006
|
||||
+++ main.c Wed Nov 1 14:09:15 2006
|
||||
@@ -5,7 +5,7 @@
|
||||
--- main.c.orig 2010-01-31 20:07:57.000000000 +0300
|
||||
+++ main.c 2010-02-18 22:34:59.000000000 +0300
|
||||
@@ -5,7 +5,6 @@
|
||||
#define __BIT_ENDIAN 1234
|
||||
#define __BYTE_ORDER __LITTLE_ENDIAN
|
||||
#else
|
||||
-#include <endian.h>
|
||||
+//#include <endian.h>
|
||||
#endif
|
||||
|
||||
#include <SDL/SDL.h>
|
||||
@@ -17,6 +17,7 @@
|
||||
#include <math.h>
|
||||
@@ -18,6 +17,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <getopt.h>
|
||||
+#include <unistd.h>
|
||||
|
||||
#include "error.h"
|
||||
|
|
Loading…
Reference in a new issue