(1) Update to latest version.
(2) Add support for latest isl and cloog.
This commit is contained in:
parent
9ab836d4d0
commit
8be35b98d8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=393485
6 changed files with 266 additions and 56 deletions
|
@ -1,10 +1,10 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= gcc-arm-embedded
|
||||
PORTVERSION= 4.9.20150306
|
||||
PORTVERSION= 4.9.20150609
|
||||
PORTREVISION= 0
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://launchpad.net/gcc-arm-embedded/4.9/4.9-2015-q1-update/+download/
|
||||
MASTER_SITES= http://launchpad.net/gcc-arm-embedded/4.9/4.9-2015-q2-update/+download/
|
||||
DISTNAME= ${ORIGINAL_PACKAGE_NAME}-src
|
||||
|
||||
MAINTAINER= lev@FreeBSD.org
|
||||
|
@ -21,7 +21,7 @@ PDF_DESC= Install PDF documentation (requires TeX, it is huge)
|
|||
PYGDB_DESC= Build and install pyhon-enabled gdb in addition to standard one
|
||||
|
||||
|
||||
PURE_EXTRA_PATCHES_OFF= ${PATCHDIR}/extra-patch-gcc-isl-0.13-compatibility
|
||||
PURE_EXTRA_PATCHES_OFF= ${PATCHDIR}/extra-patch-gcc-isl-0.15-compatibility
|
||||
PURE_LIB_DEPENDS_OFF= \
|
||||
libexpat.so:${PORTSDIR}/textproc/expat2 \
|
||||
libgmp.so:${PORTSDIR}/math/gmp \
|
||||
|
@ -45,7 +45,7 @@ PATCH_WRKSRC= ${WRKDIR}/${ORIGINAL_PACKAGE_NAME}
|
|||
BUILD_WRKSRC= ${WRKDIR}
|
||||
|
||||
GCC_VERSION= 4.9.3
|
||||
FULL_VERSION= 4_9-2015q1-20150306
|
||||
FULL_VERSION= 4_9-2015q2-20150609
|
||||
TARGET= arm-none-eabi
|
||||
ORIGINAL_PACKAGE_NAME= gcc-${TARGET}-${FULL_VERSION}
|
||||
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (gcc-arm-none-eabi-4_9-2015q1-20150306-src.tar.bz2) = efe59b9549131ffc66730ad4eb4c519c57ab8c97da5c1cb837c93eab494e04db
|
||||
SIZE (gcc-arm-none-eabi-4_9-2015q1-20150306-src.tar.bz2) = 162012212
|
||||
SHA256 (gcc-arm-none-eabi-4_9-2015q2-20150609-src.tar.bz2) = e471cb4de1f2caaf3195689e91c5b8dafc2ab1847d52892bb480aa3bfd5a01f5
|
||||
SIZE (gcc-arm-none-eabi-4_9-2015q2-20150609-src.tar.bz2) = 165087074
|
||||
|
|
|
@ -224,6 +224,7 @@ build-binutils:
|
|||
--htmldir=${DOC_PREFIX}/html \
|
||||
--pdfdir=${DOC_PREFIX}/pdf \
|
||||
--disable-nls \
|
||||
--disable-werror \
|
||||
--enable-interwork \
|
||||
--enable-plugins \
|
||||
--with-sysroot=${INTERIM_PREFIX}/${TARGET} \
|
||||
|
|
|
@ -1,50 +0,0 @@
|
|||
diff -Naur src/gcc.orig/gcc/graphite-clast-to-gimple.c src/gcc/gcc/graphite-clast-to-gimple.c
|
||||
--- src/gcc.orig/gcc/graphite-clast-to-gimple.c 2014-03-03 21:39:22.000000000 +1000
|
||||
+++ src/gcc/gcc/graphite-clast-to-gimple.c 2014-06-25 15:07:57.958697105 +1000
|
||||
@@ -28,6 +28,8 @@
|
||||
#include <isl/constraint.h>
|
||||
#include <isl/ilp.h>
|
||||
#include <isl/aff.h>
|
||||
+#include <isl/deprecated/int.h>
|
||||
+#include <isl/deprecated/ilp_int.h>
|
||||
#include <cloog/cloog.h>
|
||||
#include <cloog/isl/domain.h>
|
||||
#endif
|
||||
diff -Naur src/gcc.orig/gcc/graphite-interchange.c src/gcc/gcc/graphite-interchange.c
|
||||
--- src/gcc.orig/gcc/graphite-interchange.c 2014-01-03 08:23:26.000000000 +1000
|
||||
+++ src/gcc/gcc/graphite-interchange.c 2014-06-25 15:10:06.882899243 +1000
|
||||
@@ -29,6 +29,9 @@
|
||||
#include <isl/map.h>
|
||||
#include <isl/union_map.h>
|
||||
#include <isl/ilp.h>
|
||||
+#include <isl/deprecated/int.h>
|
||||
+#include <isl/deprecated/ilp_int.h>
|
||||
+#include <isl/deprecated/constraint_int.h>
|
||||
#include <cloog/cloog.h>
|
||||
#include <cloog/isl/domain.h>
|
||||
#endif
|
||||
diff -Naur src/gcc.orig/gcc/graphite-poly.c src/gcc/gcc/graphite-poly.c
|
||||
--- src/gcc.orig/gcc/graphite-poly.c 2014-01-03 08:23:26.000000000 +1000
|
||||
+++ src/gcc/gcc/graphite-poly.c 2014-06-25 15:18:01.207157796 +1000
|
||||
@@ -28,6 +28,8 @@
|
||||
#include <isl/constraint.h>
|
||||
#include <isl/ilp.h>
|
||||
#include <isl/aff.h>
|
||||
+#include <isl/deprecated/int.h>
|
||||
+#include <isl/deprecated/ilp_int.h>
|
||||
#include <cloog/cloog.h>
|
||||
#include <cloog/isl/domain.h>
|
||||
#endif
|
||||
diff -Naur src/gcc.orig/gcc/graphite-sese-to-poly.c src/gcc/gcc/graphite-sese-to-poly.c
|
||||
--- src/gcc.orig/gcc/graphite-sese-to-poly.c 2014-04-08 20:59:40.000000000 +1000
|
||||
+++ src/gcc/gcc/graphite-sese-to-poly.c 2014-06-25 15:19:46.575140398 +1000
|
||||
@@ -26,6 +26,9 @@
|
||||
#include <isl/union_map.h>
|
||||
#include <isl/constraint.h>
|
||||
#include <isl/aff.h>
|
||||
+#include <isl/deprecated/int.h>
|
||||
+#include <isl/deprecated/aff_int.h>
|
||||
+#include <isl/deprecated/constraint_int.h>
|
||||
#include <cloog/cloog.h>
|
||||
#include <cloog/cloog.h>
|
||||
#include <cloog/isl/domain.h>
|
|
@ -0,0 +1,254 @@
|
|||
diff -Naur src/gcc.orig/gcc/config.in src/gcc/gcc/config.in
|
||||
--- src/gcc.orig/gcc/config.in 2015-02-26 14:16:40.000000000 -0300
|
||||
+++ src/gcc/gcc/config.in 2015-08-01 03:27:39.616665000 -0300
|
||||
@@ -1217,6 +1217,12 @@
|
||||
#endif
|
||||
|
||||
|
||||
+/* Define if isl_options_set_schedule_serialize_sccs exists. */
|
||||
+#ifndef USED_FOR_TARGET
|
||||
+#undef HAVE_ISL_OPTIONS_SET_SCHEDULE_SERIALIZE_SCCS
|
||||
+#endif
|
||||
+
|
||||
+
|
||||
/* Define if isl_schedule_constraints_compute_schedule exists. */
|
||||
#ifndef USED_FOR_TARGET
|
||||
#undef HAVE_ISL_SCHED_CONSTRAINTS_COMPUTE_SCHEDULE
|
||||
diff -Naur src/gcc.orig/gcc/configure src/gcc/gcc/configure
|
||||
--- src/gcc.orig/gcc/configure 2015-02-26 14:16:40.000000000 -0300
|
||||
+++ src/gcc/gcc/configure 2015-08-01 03:27:39.625522000 -0300
|
||||
@@ -27888,6 +27888,8 @@
|
||||
|
||||
# Check whether isl_schedule_constraints_compute_schedule is available;
|
||||
# it's new in ISL-0.13.
|
||||
+# Check whether isl_options_set_schedule_serialize_sccs is available;
|
||||
+# it's new in ISL-0.15.
|
||||
saved_CFLAGS="$CFLAGS"
|
||||
CFLAGS="$CFLAGS $ISLINC"
|
||||
saved_LIBS="$LIBS"
|
||||
@@ -27916,6 +27918,29 @@
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_has_isl_schedule_constraints_compute_schedule" >&5
|
||||
$as_echo "$ac_has_isl_schedule_constraints_compute_schedule" >&6; }
|
||||
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking Checking for isl_options_set_schedule_serialize_sccs" >&5
|
||||
+$as_echo_n "checking Checking for isl_options_set_schedule_serialize_sccs... " >&6; }
|
||||
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
+/* end confdefs.h. */
|
||||
+#include <isl/schedule.h>
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+isl_options_set_schedule_serialize_sccs (NULL, 0);
|
||||
+ ;
|
||||
+ return 0;
|
||||
+}
|
||||
+_ACEOF
|
||||
+if ac_fn_cxx_try_link "$LINENO"; then :
|
||||
+ ac_has_isl_options_set_schedule_serialize_sccs=yes
|
||||
+else
|
||||
+ ac_has_isl_options_set_schedule_serialize_sccs=no
|
||||
+fi
|
||||
+rm -f core conftest.err conftest.$ac_objext \
|
||||
+ conftest$ac_exeext conftest.$ac_ext
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_has_isl_options_set_schedule_serialize_sccs" >&5
|
||||
+$as_echo "$ac_has_isl_options_set_schedule_serialize_sccs" >&6; }
|
||||
+
|
||||
LIBS="$saved_LIBS"
|
||||
CFLAGS="$saved_CFLAGS"
|
||||
|
||||
@@ -27924,6 +27949,12 @@
|
||||
$as_echo "#define HAVE_ISL_SCHED_CONSTRAINTS_COMPUTE_SCHEDULE 1" >>confdefs.h
|
||||
|
||||
fi
|
||||
+
|
||||
+ if test x"$ac_has_isl_options_set_schedule_serialize_sccs" = x"yes"; then
|
||||
+
|
||||
+$as_echo "#define HAVE_ISL_OPTIONS_SET_SCHEDULE_SERIALIZE_SCCS 1" >>confdefs.h
|
||||
+
|
||||
+ fi
|
||||
fi
|
||||
|
||||
|
||||
diff -Naur src/gcc.orig/gcc/configure.ac src/gcc/gcc/configure.ac
|
||||
--- src/gcc.orig/gcc/configure.ac 2015-02-26 14:15:13.000000000 -0300
|
||||
+++ src/gcc/gcc/configure.ac 2015-08-01 03:27:39.618893000 -0300
|
||||
@@ -5506,6 +5506,8 @@
|
||||
|
||||
# Check whether isl_schedule_constraints_compute_schedule is available;
|
||||
# it's new in ISL-0.13.
|
||||
+ # Check whether isl_options_set_schedule_serialize_sccs is available;
|
||||
+ # it's new in ISL-0.15.
|
||||
saved_CFLAGS="$CFLAGS"
|
||||
CFLAGS="$CFLAGS $ISLINC"
|
||||
saved_LIBS="$LIBS"
|
||||
@@ -5518,6 +5520,13 @@
|
||||
[ac_has_isl_schedule_constraints_compute_schedule=no])
|
||||
AC_MSG_RESULT($ac_has_isl_schedule_constraints_compute_schedule)
|
||||
|
||||
+ AC_MSG_CHECKING([Checking for isl_options_set_schedule_serialize_sccs])
|
||||
+ AC_TRY_LINK([#include <isl/schedule.h>],
|
||||
+ [isl_options_set_schedule_serialize_sccs (NULL, 0);],
|
||||
+ [ac_has_isl_options_set_schedule_serialize_sccs=yes],
|
||||
+ [ac_has_isl_options_set_schedule_serialize_sccs=no])
|
||||
+ AC_MSG_RESULT($ac_has_isl_options_set_schedule_serialize_sccs)
|
||||
+
|
||||
LIBS="$saved_LIBS"
|
||||
CFLAGS="$saved_CFLAGS"
|
||||
|
||||
@@ -5525,6 +5534,11 @@
|
||||
AC_DEFINE(HAVE_ISL_SCHED_CONSTRAINTS_COMPUTE_SCHEDULE, 1,
|
||||
[Define if isl_schedule_constraints_compute_schedule exists.])
|
||||
fi
|
||||
+
|
||||
+ if test x"$ac_has_isl_options_set_schedule_serialize_sccs" = x"yes"; then
|
||||
+ AC_DEFINE(HAVE_ISL_OPTIONS_SET_SCHEDULE_SERIALIZE_SCCS, 1,
|
||||
+ [Define if isl_options_set_schedule_serialize_sccs exists.])
|
||||
+ fi
|
||||
fi
|
||||
|
||||
|
||||
diff -Naur src/gcc.orig/gcc/graphite-dependences.c src/gcc/gcc/graphite-dependences.c
|
||||
--- src/gcc.orig/gcc/graphite-dependences.c 2014-10-06 03:27:22.000000000 -0300
|
||||
+++ src/gcc/gcc/graphite-dependences.c 2015-08-01 03:27:39.626538000 -0300
|
||||
@@ -183,7 +183,7 @@
|
||||
/* Helper function used on each MAP of a isl_union_map. Computes the
|
||||
maximal output dimension. */
|
||||
|
||||
-static int
|
||||
+static isl_stat
|
||||
max_number_of_out_dimensions (__isl_take isl_map *map, void *user)
|
||||
{
|
||||
int global_max = *((int *) user);
|
||||
@@ -195,7 +195,7 @@
|
||||
|
||||
isl_map_free (map);
|
||||
isl_space_free (space);
|
||||
- return 0;
|
||||
+ return isl_stat_ok;
|
||||
}
|
||||
|
||||
/* Extends the output dimension of MAP to MAX dimensions. */
|
||||
@@ -219,12 +219,12 @@
|
||||
|
||||
/* Helper function for extend_schedule. */
|
||||
|
||||
-static int
|
||||
+static isl_stat
|
||||
extend_schedule_1 (__isl_take isl_map *map, void *user)
|
||||
{
|
||||
struct extend_schedule_str *str = (struct extend_schedule_str *) user;
|
||||
str->umap = isl_union_map_add_map (str->umap, extend_map (map, str->max));
|
||||
- return 0;
|
||||
+ return isl_stat_ok;
|
||||
}
|
||||
|
||||
/* Return a relation that has uniform output dimensions. */
|
||||
@@ -233,16 +233,16 @@
|
||||
extend_schedule (__isl_take isl_union_map *x)
|
||||
{
|
||||
int max = 0;
|
||||
- int res;
|
||||
+ isl_stat res;
|
||||
struct extend_schedule_str str;
|
||||
|
||||
res = isl_union_map_foreach_map (x, max_number_of_out_dimensions, (void *) &max);
|
||||
- gcc_assert (res == 0);
|
||||
+ gcc_assert (res == isl_stat_ok);
|
||||
|
||||
str.max = max;
|
||||
str.umap = isl_union_map_empty (isl_union_map_get_space (x));
|
||||
res = isl_union_map_foreach_map (x, extend_schedule_1, (void *) &str);
|
||||
- gcc_assert (res == 0);
|
||||
+ gcc_assert (res == isl_stat_ok);
|
||||
|
||||
isl_union_map_free (x);
|
||||
return str.umap;
|
||||
diff -Naur src/gcc.orig/gcc/graphite-interchange.c src/gcc/gcc/graphite-interchange.c
|
||||
--- src/gcc.orig/gcc/graphite-interchange.c 2015-01-13 15:14:51.000000000 -0200
|
||||
+++ src/gcc/gcc/graphite-interchange.c 2015-08-01 03:31:17.482630000 -0300
|
||||
@@ -24,6 +24,7 @@
|
||||
#include "config.h"
|
||||
|
||||
#ifdef HAVE_cloog
|
||||
+#include <isl/constraint.h>
|
||||
#include <isl/aff.h>
|
||||
#include <isl/set.h>
|
||||
#include <isl/map.h>
|
||||
diff -Naur src/gcc.orig/gcc/graphite-optimize-isl.c src/gcc/gcc/graphite-optimize-isl.c
|
||||
--- src/gcc.orig/gcc/graphite-optimize-isl.c 2015-01-13 15:14:51.000000000 -0200
|
||||
+++ src/gcc/gcc/graphite-optimize-isl.c 2015-08-01 03:31:43.271150000 -0300
|
||||
@@ -21,7 +21,9 @@
|
||||
#include "config.h"
|
||||
|
||||
#ifdef HAVE_cloog
|
||||
+#include <isl/constraint.h>
|
||||
#include <isl/set.h>
|
||||
+#include <isl/union_set.h>
|
||||
#include <isl/map.h>
|
||||
#include <isl/union_map.h>
|
||||
#include <isl/schedule.h>
|
||||
@@ -415,13 +417,13 @@
|
||||
return ScheduleMap;
|
||||
}
|
||||
|
||||
-static int
|
||||
+static isl_stat
|
||||
getSingleMap (__isl_take isl_map *map, void *user)
|
||||
{
|
||||
isl_map **singleMap = (isl_map **) user;
|
||||
*singleMap = map;
|
||||
|
||||
- return 0;
|
||||
+ return isl_stat_ok;
|
||||
}
|
||||
|
||||
static void
|
||||
@@ -469,7 +471,11 @@
|
||||
|
||||
isl_options_set_schedule_max_constant_term (scop->ctx, CONSTANT_BOUND);
|
||||
isl_options_set_schedule_maximize_band_depth (scop->ctx, 1);
|
||||
+#ifdef HAVE_ISL_OPTIONS_SET_SCHEDULE_SERIALIZE_SCCS
|
||||
+ isl_options_set_schedule_serialize_sccs (scop->ctx, 1);
|
||||
+#else
|
||||
isl_options_set_schedule_fuse (scop->ctx, ISL_SCHEDULE_FUSE_MIN);
|
||||
+#endif
|
||||
isl_options_set_on_error (scop->ctx, ISL_ON_ERROR_CONTINUE);
|
||||
schedule = isl_union_set_compute_schedule (domain, validity, proximity);
|
||||
isl_options_set_on_error (scop->ctx, ISL_ON_ERROR_ABORT);
|
||||
diff -Naur src/gcc.orig/gcc/graphite-poly.h src/gcc/gcc/graphite-poly.h
|
||||
--- src/gcc.orig/gcc/graphite-poly.h 2014-10-06 03:27:22.000000000 -0300
|
||||
+++ src/gcc/gcc/graphite-poly.h 2015-08-01 03:27:39.628524000 -0300
|
||||
@@ -22,6 +22,11 @@
|
||||
#ifndef GCC_GRAPHITE_POLY_H
|
||||
#define GCC_GRAPHITE_POLY_H
|
||||
|
||||
+#ifndef HAVE_ISL_OPTIONS_SET_SCHEDULE_SERIALIZE_SCCS
|
||||
+# define isl_stat int
|
||||
+# define isl_stat_ok 0
|
||||
+#endif
|
||||
+
|
||||
typedef struct poly_dr *poly_dr_p;
|
||||
|
||||
typedef struct poly_bb *poly_bb_p;
|
||||
diff -Naur src/gcc.orig/gcc/graphite-scop-detection.c src/gcc/gcc/graphite-scop-detection.c
|
||||
--- src/gcc.orig/gcc/graphite-scop-detection.c 2014-10-06 03:27:22.000000000 -0300
|
||||
+++ src/gcc/gcc/graphite-scop-detection.c 2015-08-01 03:32:21.170581000 -0300
|
||||
@@ -22,6 +22,7 @@
|
||||
#include "config.h"
|
||||
|
||||
#ifdef HAVE_cloog
|
||||
+#include <isl/constraint.h>
|
||||
#include <isl/set.h>
|
||||
#include <isl/map.h>
|
||||
#include <isl/union_map.h>
|
||||
diff -Naur src/gcc.orig/gcc/graphite.c src/gcc/gcc/graphite.c
|
||||
--- src/gcc.orig/gcc/graphite.c 2014-10-06 03:27:22.000000000 -0300
|
||||
+++ src/gcc/gcc/graphite.c 2015-08-01 03:33:02.692021000 -0300
|
||||
@@ -35,6 +35,7 @@
|
||||
#include "config.h"
|
||||
|
||||
#ifdef HAVE_cloog
|
||||
+#include <isl/constraint.h>
|
||||
#include <isl/set.h>
|
||||
#include <isl/map.h>
|
||||
#include <isl/options.h>
|
|
@ -984,6 +984,9 @@ gcc-arm-embedded-%%FULL_VERSION%%/%%TARGET%%/include/string.h
|
|||
gcc-arm-embedded-%%FULL_VERSION%%/%%TARGET%%/include/strings.h
|
||||
gcc-arm-embedded-%%FULL_VERSION%%/%%TARGET%%/include/sys/_default_fcntl.h
|
||||
gcc-arm-embedded-%%FULL_VERSION%%/%%TARGET%%/include/sys/_intsup.h
|
||||
gcc-arm-embedded-%%FULL_VERSION%%/%%TARGET%%/include/sys/_stdint.h
|
||||
gcc-arm-embedded-%%FULL_VERSION%%/%%TARGET%%/include/sys/_timespec.h
|
||||
gcc-arm-embedded-%%FULL_VERSION%%/%%TARGET%%/include/sys/_timeval.h
|
||||
gcc-arm-embedded-%%FULL_VERSION%%/%%TARGET%%/include/sys/_types.h
|
||||
gcc-arm-embedded-%%FULL_VERSION%%/%%TARGET%%/include/sys/cdefs.h
|
||||
gcc-arm-embedded-%%FULL_VERSION%%/%%TARGET%%/include/sys/config.h
|
||||
|
@ -1009,6 +1012,8 @@ gcc-arm-embedded-%%FULL_VERSION%%/%%TARGET%%/include/sys/syslimits.h
|
|||
gcc-arm-embedded-%%FULL_VERSION%%/%%TARGET%%/include/sys/time.h
|
||||
gcc-arm-embedded-%%FULL_VERSION%%/%%TARGET%%/include/sys/timeb.h
|
||||
gcc-arm-embedded-%%FULL_VERSION%%/%%TARGET%%/include/sys/times.h
|
||||
gcc-arm-embedded-%%FULL_VERSION%%/%%TARGET%%/include/sys/timespec.h
|
||||
gcc-arm-embedded-%%FULL_VERSION%%/%%TARGET%%/include/sys/tree.h
|
||||
gcc-arm-embedded-%%FULL_VERSION%%/%%TARGET%%/include/sys/types.h
|
||||
gcc-arm-embedded-%%FULL_VERSION%%/%%TARGET%%/include/sys/unistd.h
|
||||
gcc-arm-embedded-%%FULL_VERSION%%/%%TARGET%%/include/sys/utime.h
|
||||
|
|
Loading…
Reference in a new issue