mark as BROKEN on FreeBSD 10 only

This commit is contained in:
Oliver Lehmann 2014-06-15 14:08:52 +00:00
parent 6ddbb15911
commit 8bf9130c1e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=357886
2 changed files with 15 additions and 2 deletions

View file

@ -22,8 +22,6 @@ LIB_DEPENDS= libAtlas-0.6.so:${PORTSDIR}/devel/atlas-devel \
CONFIGURE_ARGS= --with-python=${LOCALBASE}
BROKEN= Does not compile with clang
GNU_CONFIGURE= yes
USE_BZIP2= yes
USES= gmake pathfix pkgconfig compiler:c++11-lib
@ -40,6 +38,10 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
BROKEN= Does not compile with clang
.endif
post-patch:
@${REINPLACE_CMD} -e 's| install-dist_docDATA | |g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's| install-confbackupDATA | |g' \

View file

@ -0,0 +1,11 @@
--- physics/BBox.cpp.orig 2014-06-15 17:53:14.000000000 +0200
+++ physics/BBox.cpp 2014-06-15 17:51:40.000000000 +0200
@@ -19,7 +19,7 @@
#include "BBox.h"
#include "common/const.h"
-
+#include <algorithm>
#include <wfmath/axisbox.h>
#include <wfmath/point.h>