add libafterbase
AfterStep basic functionality library
This commit is contained in:
parent
38ec3a704a
commit
8c2edddff8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=48568
7 changed files with 112 additions and 0 deletions
|
@ -199,6 +199,7 @@
|
|||
SUBDIR += leoarg
|
||||
SUBDIR += libPropList
|
||||
SUBDIR += libU77
|
||||
SUBDIR += libafterbase
|
||||
SUBDIR += libast
|
||||
SUBDIR += libavl
|
||||
SUBDIR += libcache
|
||||
|
|
27
devel/libafterbase/Makefile
Normal file
27
devel/libafterbase/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
# ex:ts=8
|
||||
# New ports collection makefile for: libAfterBase
|
||||
# Date created: Oct 7, 2001
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libafterbase
|
||||
PORTVERSION= 0.81
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= afterstep
|
||||
DISTNAME= libAfterBase-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --enable-sharedlibs --with-x
|
||||
WRKSRC= ${WRKDIR}/libAfterBase
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
post-install:
|
||||
@${MV} -f ${PREFIX}/lib/libAfterBase.so.0.81 ${PREFIX}/lib/libAfterBase.so.0
|
||||
|
||||
.include <bsd.port.mk>
|
1
devel/libafterbase/distinfo
Normal file
1
devel/libafterbase/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (libAfterBase-0.81.tar.gz) = a79b1769b977df94d77daa96262f7452
|
59
devel/libafterbase/files/patch-audit.c
Normal file
59
devel/libafterbase/files/patch-audit.c
Normal file
|
@ -0,0 +1,59 @@
|
|||
--- audit.c.orig Sun Oct 7 22:16:37 2001
|
||||
+++ audit.c Sun Oct 7 22:19:10 2001
|
||||
@@ -427,7 +427,7 @@
|
||||
m1->line = line;
|
||||
#else
|
||||
safefree (m->ptr);
|
||||
- mem_destroy( (ASHashableValue)NULL, m );
|
||||
+ mem_destroy( (ASHashableValue)(void*)NULL, m );
|
||||
#endif
|
||||
}
|
||||
|
||||
@@ -714,7 +714,7 @@
|
||||
*/
|
||||
|
||||
XFreePixmap (display, pmap);
|
||||
- mem_destroy( (ASHashableValue)NULL, m );
|
||||
+ mem_destroy( (ASHashableValue)(void*)NULL, m );
|
||||
return Success;
|
||||
}
|
||||
|
||||
@@ -750,7 +750,7 @@
|
||||
}
|
||||
|
||||
XFreeGC (display, gc);
|
||||
- mem_destroy( (ASHashableValue)NULL, m );
|
||||
+ mem_destroy( (ASHashableValue)(void*)NULL, m );
|
||||
return Success;
|
||||
}
|
||||
|
||||
@@ -830,17 +830,17 @@
|
||||
/* can also be of C_MEM type if we allocated it ourselvs */
|
||||
m = count_find_and_extract (fname, line, (void *)image, C_MEM);
|
||||
if (m)
|
||||
- mem_destroy( (ASHashableValue)NULL, m );
|
||||
+ mem_destroy( (ASHashableValue)(void*)NULL, m );
|
||||
|
||||
/* find and free the image->data pointer if it is in our list */
|
||||
if( image_data )
|
||||
if ((m = count_find_and_extract (fname, line, image_data, C_MEM)) != NULL)
|
||||
- mem_destroy( (ASHashableValue)NULL, m );
|
||||
+ mem_destroy( (ASHashableValue)(void*)NULL, m );
|
||||
|
||||
/* find and free the image->obdata pointer if it is in our list */
|
||||
if( image_obdata )
|
||||
if ((m = count_find_and_extract (fname, line, image_obdata, C_MEM)) != NULL)
|
||||
- mem_destroy( (ASHashableValue)NULL, m );
|
||||
+ mem_destroy( (ASHashableValue)(void*)NULL, m );
|
||||
|
||||
return Success;
|
||||
}
|
||||
@@ -1025,7 +1025,7 @@
|
||||
}
|
||||
|
||||
XFree (data);
|
||||
- mem_destroy( (ASHashableValue)NULL, m );
|
||||
+ mem_destroy( (ASHashableValue)(void*)NULL, m );
|
||||
return Success;
|
||||
}
|
||||
|
1
devel/libafterbase/pkg-comment
Normal file
1
devel/libafterbase/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
AfterStep basic functionality library
|
1
devel/libafterbase/pkg-descr
Normal file
1
devel/libafterbase/pkg-descr
Normal file
|
@ -0,0 +1 @@
|
|||
AfterStep basic functionality library
|
22
devel/libafterbase/pkg-plist
Normal file
22
devel/libafterbase/pkg-plist
Normal file
|
@ -0,0 +1,22 @@
|
|||
include/libAfterBase/ashash.h
|
||||
include/libAfterBase/astypes.h
|
||||
include/libAfterBase/asvector.h
|
||||
include/libAfterBase/audit.h
|
||||
include/libAfterBase/fs.h
|
||||
include/libAfterBase/mystring.h
|
||||
include/libAfterBase/os.h
|
||||
include/libAfterBase/output.h
|
||||
include/libAfterBase/parse.h
|
||||
include/libAfterBase/regexp.h
|
||||
include/libAfterBase/safemalloc.h
|
||||
include/libAfterBase/selfdiag.h
|
||||
include/libAfterBase/sleep.h
|
||||
include/libAfterBase/socket.h
|
||||
include/libAfterBase/timer.h
|
||||
include/libAfterBase/trace.h
|
||||
include/libAfterBase/xprop.h
|
||||
include/libAfterBase/xwrap.h
|
||||
@dirrm include/libAfterBase
|
||||
lib/libAfterBase.a
|
||||
lib/libAfterBase.so
|
||||
lib/libAfterBase.so.0
|
Loading…
Reference in a new issue