Add thebridge, an amateur radio EchoLink compatible conference bridge

reimplementation for UNIX

PR:		ports/68350
Submitted by:	Diane Bruce <db@db.net>
This commit is contained in:
Pav Lucistnik 2004-06-27 13:56:54 +00:00
parent 71d7cb8789
commit 8c3c4671f0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=112363
9 changed files with 115 additions and 0 deletions

View file

@ -70,6 +70,7 @@
SUBDIR += sms_client
SUBDIR += snooper
SUBDIR += sredird
SUBDIR += thebridge
SUBDIR += tilp
SUBDIR += tits
SUBDIR += tkhylafax

34
comms/thebridge/Makefile Normal file
View file

@ -0,0 +1,34 @@
# ports collection makefile for: thebridge
# Date created: 22 June 2004
# Whom: db
#
# $FreeBSD$
#
PORTNAME= thebridge
PORTVERSION= 0.72
CATEGORIES= comms
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= cqinet
EXTRACT_SUFX= .tgz
MAINTAINER= db@db.net
COMMENT= Amateur Radio Echolink conference bridge
GNU_CONFIGURE= yes
USE_REINPLACE= yes
PORTDOCS= README
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/FreeBSD/tbd.sh
@${MV} ${WRKSRC}/tbd.conf ${WRKSRC}/tbd.conf.sample
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
${INSTALL_SCRIPT} ${WRKSRC}/FreeBSD/tbd.sh ${PREFIX}/etc/rc.d/tbd.sh.sample
.include <bsd.port.mk>

2
comms/thebridge/distinfo Normal file
View file

@ -0,0 +1,2 @@
MD5 (thebridge-0.72.tgz) = 29b934c6f28c72de1e8fc24027cf2f3a
SIZE (thebridge-0.72.tgz) = 286396

View file

@ -0,0 +1,11 @@
--- FreeBSD/tbd.sh.orig Wed Jun 23 16:02:28 2004
+++ FreeBSD/tbd.sh Wed Jun 23 16:02:59 2004
@@ -2,7 +2,7 @@
# $Id: tbd.sh,v 1.1.1.1 2002/08/10 20:33:40 wb6ymh Exp $
pidfiledir=/var/run
-tbd=/usr/local/libexec/tbd
+tbd=%%PREFIX%%/libexec/tbd
# start
if [ "x$1" = "x" -o "x$1" = "xstart" ]; then

View file

@ -0,0 +1,16 @@
--- Makefile.in.orig Tue Sep 9 17:06:55 2003
+++ Makefile.in Wed Jun 23 17:50:24 2004
@@ -85,10 +85,10 @@
RANLIB = @RANLIB@
VERSION = @VERSION@
-SUBDIRS = common zlib src inc tbdcmd
-EXTRA_DIST = theBridge.dsp tbd.conf README.txt FreeBSD RedHat config SCRIPTING.txt
+SUBDIRS = common src inc tbdcmd
+EXTRA_DIST = theBridge.dsp tbd.conf.sample README.txt FreeBSD RedHat config SCRIPTING.txt
-sysconf_DATA = tbd.conf
+sysconf_DATA = tbd.conf.sample
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
mkinstalldirs = $(SHELL) $(top_srcdir)/config/mkinstalldirs
CONFIG_HEADER = config.h

View file

@ -0,0 +1,20 @@
--- configure.orig Thu Jun 24 14:32:44 2004
+++ configure Thu Jun 24 14:33:09 2004
@@ -1961,7 +1961,7 @@
ac_given_srcdir=$srcdir
ac_given_INSTALL="$INSTALL"
-trap 'rm -fr `echo "Makefile src/Makefile common/Makefile inc/Makefile tbdcmd/Makefile zlib/Makefile config.h" | sed "s/:[^ ]*//g"` conftest*; exit 1' 1 2 15
+trap 'rm -fr `echo "Makefile src/Makefile common/Makefile inc/Makefile tbdcmd/Makefile config.h" | sed "s/:[^ ]*//g"` conftest*; exit 1' 1 2 15
EOF
cat >> $CONFIG_STATUS <<EOF
@@ -2054,7 +2054,7 @@
cat >> $CONFIG_STATUS <<EOF
-CONFIG_FILES=\${CONFIG_FILES-"Makefile src/Makefile common/Makefile inc/Makefile tbdcmd/Makefile zlib/Makefile"}
+CONFIG_FILES=\${CONFIG_FILES-"Makefile src/Makefile common/Makefile inc/Makefile tbdcmd/Makefile "}
EOF
cat >> $CONFIG_STATUS <<\EOF
for ac_file in .. $CONFIG_FILES; do if test "x$ac_file" != x..; then

View file

@ -0,0 +1,21 @@
--- src/Makefile.in.orig Tue Sep 9 23:06:56 2003
+++ src/Makefile.in Sun Jun 27 15:46:18 2004
@@ -86,7 +86,7 @@
tbd_SOURCES = conference.c conference.h configvars.c configvars.h dirclient.c dirclient.h thebridge.c users.c users.h hostfile.c hostfile.h eventhook.c eventhook.h
-tbd_LDADD = $(top_builddir)/common/libcommon.a $(top_builddir)/zlib/libzlib.a
+tbd_LDADD = $(top_builddir)/common/libcommon.a -lz
AM_CPPFLAGS = -I$(top_srcdir)/inc
AM_CFLAGS = -Wall -DSYSCON_DIR=\"$(sysconfdir)\"
@@ -102,8 +102,7 @@
LIBS = @LIBS@
tbd_OBJECTS = conference.o configvars.o dirclient.o thebridge.o users.o \
hostfile.o eventhook.o
-tbd_DEPENDENCIES = $(top_builddir)/common/libcommon.a \
-$(top_builddir)/zlib/libzlib.a
+tbd_DEPENDENCIES = $(top_builddir)/common/libcommon.a
tbd_LDFLAGS =
CFLAGS = @CFLAGS@
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)

View file

@ -0,0 +1,6 @@
Amateur Radio EchoLink compatible conference bridge for UNIX
WWW: http://cqinet.sourceforge.net/
- Diane Bruce, VA3DB
db@db.net

View file

@ -0,0 +1,4 @@
bin/tbdcmd
etc/rc.d/tbd.sh.sample
etc/tbd.conf.sample
libexec/tbd