- Update to 3.1b2

- Pass maintainership to submitter

PR:		223561
Submitted by:	mzaki@niid.go.jp
Approved by:	bacon4000@gmail.com(previous maintainer)
This commit is contained in:
Wen Heping 2017-11-11 12:51:52 +00:00
parent 0779926ea3
commit 8c8dc2d005
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=453972
5 changed files with 69 additions and 39 deletions

View file

@ -2,47 +2,41 @@
# $FreeBSD$
PORTNAME= hmmer
PORTVERSION= 3.0
PORTREVISION= 1
PORTVERSION= 3.1b2
CATEGORIES= biology
MASTER_SITES= ftp://selab.janelia.org/pub/software/hmmer3/3.0/ \
http://selab.janelia.org/software/hmmer3/3.0/
MASTER_SITES= http://eddylab.org/software/hmmer3/${PORTVERSION}/
MAINTAINER= bacon4000@gmail.com
MAINTAINER= mzaki@niid.go.jp
COMMENT= Profile hidden Markov models for biological sequence analysis
BROKEN= No public distfiles
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= gmake
GNU_CONFIGURE= yes
USES= perl5
CONFIGURE_ARGS+=--enable-threads
MAKE_ARGS= V=1
DOCFILES= COPYRIGHT INSTALL LICENSE Userguide.pdf
EXAMPLES= 7LESS_DROME Pkinase.sto fn3.sto globins4.sto minifam.h3f minifam.h3p \
HBB_HUMAN fn3.hmm globins4.hmm globins45.fa minifam.h3i \
Pkinase.hmm fn3.out globins4.out minifam minifam.h3m
OPTIONS_DEFINE= DOCS EXAMPLES TEST
TEST_TEST_TARGET= check
TEST_USES= shebangfix perl5
TEST_VARS= shebang_glob=*.pl shebang_files=easel/devkit/* use_perl5=build
OPTIONS_DEFINE= DOCS EXAMPLES
DOCFILES= COPYRIGHT Userguide.pdf
EXAMPLES= 7LESS_DROME HBB_HUMAN MADE1.hmm MADE1.out MADE1.sto \
Pkinase.hmm Pkinase.sto dna_target.fa fn3.hmm fn3.out fn3.sto \
globins4.hmm globins4.out globins4.sto globins45.fa \
minifam minifam.h3f minifam.h3i minifam.h3m minifam.h3p
.include <bsd.port.options.mk>
# HMMER is useless without SSE and any PC in use today should support it
# Should probably also do enable-vmx on Power processors to enable
# Altivec/VMX, but I don't have a machine to test this.
.if ${ARCH} == "amd64" || ${ARCH} == "i386"
CONFIGURE_ARGS+=--enable-sse
.endif
post-build-TEST-on: do-test
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
(cd ${WRKSRC}/documentation/man; for i in *.man; do \
${INSTALL_MAN} $$i ${STAGEDIR}${PREFIX}/man/man1/`echo $$i|${SED} 's/.man/.1/'`; \
done)
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOCFILES:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${EXAMPLES:S,^,${WRKSRC}/tutorial/,} ${STAGEDIR}${EXAMPLESDIR}

View file

@ -1,2 +1,3 @@
SHA256 (hmmer-3.0.tar.gz) = 6977e6473fcb554b1d5a86dc9edffffa53918c1bd88d7fd20d7499f1ba719e83
SIZE (hmmer-3.0.tar.gz) = 3952015
TIMESTAMP = 1510218548
SHA256 (hmmer-3.1b2.tar.gz) = dd16edf4385c1df072c9e2f58c16ee1872d855a018a2ee6894205277017b5536
SIZE (hmmer-3.1b2.tar.gz) = 5965253

View file

@ -0,0 +1,10 @@
--- configure.orig 2015-02-26 12:45:55 UTC
+++ configure
@@ -3912,6 +3912,7 @@ fi
if test "$impl_choice" = "none"; then
case $host in
ia64-*-*) impl_choice=sse;;
+ amd64-*-*) impl_choice=sse;;
i?86-*-*) impl_choice=sse;;
x86*-*-*) impl_choice=sse;;
powerpc*-*-*) impl_choice=vmx;;

View file

@ -7,4 +7,4 @@ model called a "hidden Markov model" which can then be used as a query into
a sequence database to find (and/or align) additional homologues of the
sequence family.
WWW: http://hmmer.janelia.org/
WWW: http://hmmer.org/

View file

@ -1,45 +1,70 @@
bin/alimask
bin/hmmalign
bin/hmmbuild
bin/hmmc2
bin/hmmconvert
bin/hmmemit
bin/hmmerfm-exactmatch
bin/hmmfetch
bin/hmmlogo
bin/hmmpgmd
bin/hmmpress
bin/hmmscan
bin/hmmsearch
bin/hmmsim
bin/hmmstat
bin/jackhmmer
bin/makehmmerdb
bin/nhmmer
bin/nhmmscan
bin/phmmer
include/cachedb.h
include/hmmer.h
include/impl_sse.h
include/p7_config.h
include/p7_gbands.h
include/p7_gmxb.h
include/p7_gmxchk.h
include/p7_hmmcache.h
lib/libhmmer.a
man/man1/alimask.1.gz
man/man1/hmmalign.1.gz
man/man1/hmmbuild.1.gz
man/man1/hmmconvert.1.gz
man/man1/hmmemit.1.gz
man/man1/hmmer.1.gz
man/man1/hmmfetch.1.gz
man/man1/hmmlogo.1.gz
man/man1/hmmpgmd.1.gz
man/man1/hmmpress.1.gz
man/man1/hmmscan.1.gz
man/man1/hmmsearch.1.gz
man/man1/hmmsim.1.gz
man/man1/hmmstat.1.gz
man/man1/jackhmmer.1.gz
man/man1/makehmmerdb.1.gz
man/man1/nhmmer.1.gz
man/man1/nhmmscan.1.gz
man/man1/phmmer.1.gz
%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
%%PORTDOCS%%%%DOCSDIR%%/Userguide.pdf
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/7LESS_DROME
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Pkinase.sto
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fn3.sto
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/globins4.sto
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/minifam.h3f
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/minifam.h3p
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/HBB_HUMAN
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fn3.hmm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/globins4.hmm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/globins45.fa
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/minifam.h3i
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/MADE1.hmm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/MADE1.out
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/MADE1.sto
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Pkinase.hmm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Pkinase.sto
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dna_target.fa
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fn3.hmm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fn3.out
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fn3.sto
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/globins4.hmm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/globins4.out
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/globins4.sto
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/globins45.fa
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/minifam
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/minifam.h3f
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/minifam.h3i
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/minifam.h3m
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/minifam.h3p