Update danish ispell.
Tested by: phk
This commit is contained in:
parent
da9816c587
commit
8c907ce0c5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=119874
3 changed files with 30 additions and 12 deletions
|
@ -7,7 +7,7 @@
|
|||
|
||||
PORTNAME?= ispell
|
||||
PORTVERSION?= 3.2.06
|
||||
PORTREVISION?= 11
|
||||
PORTREVISION?= 12
|
||||
CATEGORIES+= textproc
|
||||
MASTER_SITES= http://fmg-www.cs.ucla.edu/geoff/tars/
|
||||
DISTNAME= ispell-3.2.06 # needed for slave ports / options
|
||||
|
@ -36,6 +36,7 @@ BUILDHASH= ${WRKSRC}/buildhash
|
|||
UNSQ?= ${WRKDIR}/${DENEUDISTFILE:S=.tar.bz2$==}/bin/unsq.pl
|
||||
MUNCHLIST= ${WRKSRC}/munchlist
|
||||
DATADIR= ${PREFIX}/share/ispell
|
||||
ISPELL= ${WRKSRC}/ispell
|
||||
|
||||
.if (!defined(ISPELL_IT) && !defined(ISPELL_FR) && !defined(ISPELL_SE) && !defined(ISPELL_BR) && !defined(ISPELL_DENEU) && !defined(ISPELL_DEALT) && !defined(ISPELL_BRITISH) && !defined(ISPELL_NO) && !defined(ISPELL_NL) && !defined(ISPELL_DA) && !defined(ISPELL_AF) && !defined(ISPELL_FI) && !defined(ISPELL_PL)) && !defined(ISPELL_BG)
|
||||
pre-everything::
|
||||
|
@ -116,7 +117,7 @@ EXTRA_DICT+= ${NLDISTFILE}
|
|||
EXTRACT_ONLY+= ${NLDISTFILE}
|
||||
.endif
|
||||
.if defined(ISPELL_DA)
|
||||
DADISTFILE= ispell-da-1.4.22.tar.gz
|
||||
DADISTFILE= ispell-da-1.4.43.tar.gz
|
||||
MASTER_SITES+= http://da.speling.org/filer/ \
|
||||
${MASTER_SITE_LOCAL}
|
||||
MASTER_SITE_SUBDIR= asmodai
|
||||
|
@ -270,7 +271,7 @@ post-build:
|
|||
.endif
|
||||
.if defined(ISPELL_DA)
|
||||
@cd ${WRKDIR}/${DADISTFILE:S=.tar.gz==} && \
|
||||
${MAKE} ${MAKEFLAGS} BUILDHASH=${BUILDHASH} all
|
||||
${MAKE} ${MAKEFLAGS} BUILDHASH=${BUILDHASH} ISPELL=${ISPELL} all
|
||||
.endif
|
||||
.if defined(ISPELL_AF)
|
||||
@cd ${WRKDIR}/${AFDISTFILE:S=.tar.gz==} && \
|
||||
|
|
|
@ -6,7 +6,7 @@ MD5 (hk-deutsch.tar.gz) = 0fb468159f7f0ba5b8a02c1fe111ac2d
|
|||
MD5 (br.ispell-2.4.tar.gz) = 241d9e2fefb92ea74f13c1e07d0b4e7b
|
||||
MD5 (ispell-norsk-2.0.tar.gz) = 7dd200f749459a42f7ded937ee72bb05
|
||||
MD5 (ispell-nl-1.0.0.tar.gz) = d9f8c68f28053e71792053e34201a28b
|
||||
MD5 (ispell-da-1.4.22.tar.gz) = fd4580d33dc61b3dc667495db1d6f098
|
||||
MD5 (ispell-da-1.4.43.tar.gz) = d20e9eab39f04cb909e5781abab90588
|
||||
MD5 (ispell-sa-1.0.0.tar.gz) = b70889894d1427e5b78c0a6ecc4f8235
|
||||
MD5 (igerman98-20001109.tar.bz2) = ec06d69a4b045b738788fd3359de37ee
|
||||
MD5 (finnish.dict.bz2) = 977a5eebe21881dca6be6cf38a244457
|
||||
|
|
|
@ -1,11 +1,28 @@
|
|||
--- ispell-da-1.4.22/Makefile.orig Tue Jan 2 10:47:45 2001
|
||||
+++ ispell-da-1.4.22/Makefile Wed Jan 10 09:10:51 2001
|
||||
@@ -7,7 +7,7 @@
|
||||
install -o root -g root -m 0644 dansk.aff $(installdir)
|
||||
--- ispell-da-1.4.43/Makefile.orig Mon Sep 20 09:30:48 2004
|
||||
+++ ispell-da-1.4.43/Makefile Wed Oct 20 22:08:19 2004
|
||||
@@ -9,13 +9,13 @@
|
||||
lang = da
|
||||
version = 1.4.43
|
||||
|
||||
dansk.hash: dansk.aff words-da.ispell
|
||||
- buildhash words-da.ispell dansk.aff dansk.hash
|
||||
+ ${BUILDHASH} words-da.ispell dansk.aff dansk.hash
|
||||
-installdir=`ispell -vv | grep LIBDIR | cut -d'"' -f2`
|
||||
+installdir=`${ISPELL} -vv | grep LIBDIR | cut -d'"' -f2`
|
||||
|
||||
all: maskbits $(sprog).hash
|
||||
|
||||
maskbits:
|
||||
- @test "`ispell -vv | grep MASKBITS`" != "" || ( echo Ispell should be compiled with MASKBITS set to at least 64. ; exit -2 )
|
||||
- @test `ispell -vv | grep MASKBITS | cut -d= -f2` -ge 64 || ( echo Ispell should be compiled with MASKBITS set to at least 64. ; exit -3 )
|
||||
+ @test "`${ISPELL} -vv | grep MASKBITS`" != "" || ( echo Ispell should be compiled with MASKBITS set to at least 64. ; exit -2 )
|
||||
+ @test `${ISPELL} -vv | grep MASKBITS | cut -d= -f2` -ge 64 || ( echo Ispell should be compiled with MASKBITS set to at least 64. ; exit -3 )
|
||||
|
||||
install: maskbits $(sprog).hash $(sprog).aff
|
||||
install -o root -g root -m 0644 $(sprog).hash $(installdir)
|
||||
@@ -26,7 +26,7 @@
|
||||
ln -fs $(installdir)/$(sprog).aff $(installdir)/$(sprog_en_lower_case).aff
|
||||
|
||||
$(sprog).hash: maskbits $(sprog).aff words-$(sprogkode).ispell
|
||||
- buildhash words-$(sprogkode).ispell $(sprog).aff $(sprog).hash
|
||||
+ ${BUILDHASH} words-$(sprogkode).ispell $(sprog).aff $(sprog).hash
|
||||
|
||||
clean:
|
||||
rm -f words-da.ispell.stat dansk.hash words-da.ispell.cnt *~
|
||||
rm -f words-$(sprogkode).ispell.stat $(sprog).hash words-$(sprogkode).ispell.cnt *~
|
||||
|
|
Loading…
Reference in a new issue