Updated to 2.1.23.

This commit is contained in:
Hajimu UMEMOTO 2003-12-17 18:26:09 +00:00
parent 1c0cabb0b9
commit 8cc8f64cb0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=96078
5 changed files with 2 additions and 64 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= gkrellm
PORTVERSION= 2.1.22
PORTVERSION= 2.1.23
#PORTREVISION= 0
CATEGORIES= sysutils ipv6
MASTER_SITES= http://web.wt.net/~billw/gkrellm/ \

View file

@ -1 +1 @@
MD5 (gkrellm-2.1.22.tar.bz2) = 036823ec64a2c496d46adc5e3f019337
MD5 (gkrellm-2.1.23.tar.bz2) = 4a284b76167c882183d517c01c2182d6

View file

@ -1,13 +0,0 @@
Index: src/configure
diff -u src/configure.orig src/configure
--- src/configure.orig Fri Dec 12 04:06:52 2003
+++ src/configure Sat Dec 13 14:15:14 2003
@@ -45,7 +45,7 @@
EOF
$CC ${PKG_INCLUDE} -c test.c -o test.o 2>& 5
-$CC test.o -o test ${PKG_LIBS} -lssl 2>& 5
+$CC test.o -o test ${PKG_LIBS} -lssl -lcrypto 2>& 5
if [ -e ./test ] && ./test
then

View file

@ -1,40 +0,0 @@
Index: src/mail.c
diff -u src/mail.c.orig src/mail.c
--- src/mail.c.orig Sat Dec 13 02:26:21 2003
+++ src/mail.c Sat Dec 13 14:35:20 2003
@@ -72,11 +72,17 @@
# endif
#endif
+#if defined(HAVE_SSL)
+#define MD5Init MD5_Init
+#define MD5Update MD5_Update
+#define MD5Final MD5_Final
+#else
#if defined(HAVE_MD5_H)
#include <md5.h>
#else
#include "md5.h"
#endif
+#endif
#define MUTE_FLAG -1
@@ -654,7 +660,7 @@
unsigned char opad[64];
unsigned char hash_passwd[16];
- MD5_CTX_ ctx;
+ MD5_CTX ctx;
if (resp_len != 16)
return;
@@ -846,7 +852,7 @@
if (account->authtype == AUTH_POP3_APOP)
{
static const gchar hex[] = "0123456789abcdef";
- MD5_CTX_ ctx;
+ MD5_CTX ctx;
gint i;
gchar *key, *p;
guchar digest[16];

View file

@ -2,15 +2,6 @@ Index: src/Makefile
diff -u src/Makefile.orig src/Makefile
--- src/Makefile.orig Fri Dec 12 03:31:04 2003
+++ src/Makefile Sat Dec 13 14:29:56 2003
@@ -32,7 +32,7 @@
HAVE_SSL = $(shell grep -c HAVE_SSL configure.h)
ifeq ($(HAVE_SSL),1)
- SSL_LIBS ?= -lssl
+ SSL_LIBS ?= -lssl -lcrypto
endif
CC ?= gcc
@@ -44,7 +44,7 @@
PKG_LIB = `$(PKG_CONFIG) --libs gtk+-2.0 gthread-2.0`