Garbage collect unmaintained expired ports:
2011-01-01 security/lxnb: Development has ceased, mastersite disappeared 2011-01-01 x11-wm/lxsession-lite: Superseded by x11-wm/lxsession
This commit is contained in:
parent
fd171f7c6f
commit
8cf66a3790
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=267295
11 changed files with 2 additions and 127 deletions
2
MOVED
2
MOVED
|
@ -4746,3 +4746,5 @@ java/tya||2010-12-31|Has expired: looks like abandonware and does not compile wt
|
|||
net-p2p/qbittorrent-22||2011-01-01|Old version no longer updated
|
||||
dns/bind95||2011-01-01|Entered EOL 2010-09 - Update to dns/bind97 or dns/bind96
|
||||
www/mozilla|www/seamonkey2|2011-01-01|Unmaintained upstream for years and has security issues
|
||||
security/lxnb||2011-01-02|Has expired: Development has ceased, mastersite disappeared
|
||||
x11-wm/lxsession-lite|x11-wm/lxsession|2011-01-02|Has expired: Superseded by x11-wm/lxsession
|
||||
|
|
|
@ -285,7 +285,6 @@
|
|||
SUBDIR += logcheck
|
||||
SUBDIR += lsh
|
||||
SUBDIR += luasec
|
||||
SUBDIR += lxnb
|
||||
SUBDIR += lynis
|
||||
SUBDIR += mac-robber
|
||||
SUBDIR += maia
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
# New ports collection makefile for: lxnb
|
||||
# Date created: 04 March 2000
|
||||
# Whom: Kris Kennaway <kris@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= lxnb
|
||||
PORTVERSION= 0.4
|
||||
CATEGORIES= security
|
||||
# mastersite disappeared in December 2001
|
||||
MASTER_SITES= # http://ns2.crw.se/~tm/projects/lxnb/
|
||||
DISTFILES= linux-netbus-client-v${PORTVERSION}.tgz
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= NetBus client
|
||||
|
||||
DEPRECATED= Development has ceased, mastersite disappeared
|
||||
EXPIRATION_DATE= 2011-01-01
|
||||
|
||||
PLIST_FILES= bin/lxnb
|
||||
|
||||
pre-build:
|
||||
rm -f ${WRKSRC}/lxnetbus
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,3 +0,0 @@
|
|||
MD5 (linux-netbus-client-v0.4.tgz) = eb93877c61df4d623d8e44e684444960
|
||||
SHA256 (linux-netbus-client-v0.4.tgz) = cddb92feaffb7e3d41c5ae9309cef8e80ea149f7ad2ee42be44fa155892ffa1d
|
||||
SIZE (linux-netbus-client-v0.4.tgz) = 19612
|
|
@ -1,22 +0,0 @@
|
|||
--- Makefile.orig Sat Aug 22 09:03:00 1998
|
||||
+++ Makefile Sun Mar 5 02:20:19 2000
|
||||
@@ -1,12 +1,17 @@
|
||||
# Makefile for the Linux Netbus Client by noupe@efnet #hack.se
|
||||
|
||||
-CC = gcc -Wall -O3
|
||||
+CC ?= gcc
|
||||
+CFLAGS ?= -O3
|
||||
+CFLAGS += -Wall
|
||||
OBJEKTFILER = lxnetbus.o lxnbfunc.o lxnbmenu.o
|
||||
|
||||
-
|
||||
all: ${OBJEKTFILER} lxnetbus
|
||||
|
||||
lxnetbus: ${OBJEKTFILER}
|
||||
+ ${CC} ${CFLAGS} -o $@ ${OBJEKTFILER}
|
||||
+
|
||||
+install:
|
||||
+ install -c -m 755 lxnetbus ${PREFIX}/bin/lxnb
|
||||
|
||||
clean:
|
||||
rm -f *.o *~ diskdump.txt screendump.jpg
|
|
@ -1,3 +0,0 @@
|
|||
A NetBus Client (Works with NetBus 1.60)
|
||||
|
||||
WWW: http://ns2.crw.se/~tm/
|
|
@ -125,7 +125,6 @@
|
|||
SUBDIR += libwraster
|
||||
SUBDIR += lwm
|
||||
SUBDIR += lxsession
|
||||
SUBDIR += lxsession-lite
|
||||
SUBDIR += matchbox
|
||||
SUBDIR += matwm2
|
||||
SUBDIR += metacity
|
||||
|
|
|
@ -1,46 +0,0 @@
|
|||
# New ports collection makefile for: lxsession-lite
|
||||
# Date created: 2008/06/20
|
||||
# Whom: chinsan
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= lxsession-lite
|
||||
PORTVERSION= 0.3.6
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= x11-wm gnome
|
||||
MASTER_SITES= SF/lxde/LXSession%20%28session%20manager%29/LXSession%20Lite%20${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= LXDE Lite Session Manager
|
||||
|
||||
LIB_DEPENDS= hal.1:${PORTSDIR}/sysutils/hal
|
||||
|
||||
DEPRECATED= Superseded by x11-wm/lxsession
|
||||
EXPIRATION_DATE= 2011-01-01
|
||||
|
||||
CONFLICTS= lxsession-[0-9]*
|
||||
|
||||
USE_GNOME= gtk20
|
||||
USE_AUTOTOOLS= automake:env
|
||||
USE_GMAKE= yes
|
||||
USE_ICONV= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --prefix=${PREFIX} \
|
||||
CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
CFLAGS+= -I${WRKSRC}
|
||||
|
||||
DATADIR= ${PREFIX}/share/lxsession
|
||||
|
||||
MAN1= lxsession.1 lxsession-logout.1
|
||||
|
||||
.if !defined(WITHOUT_NLS)
|
||||
USE_GETTEXT= yes
|
||||
PLIST_SUB+= NLS=""
|
||||
.else
|
||||
CONFIGURE_ARGS+=--disable-nls
|
||||
PLIST_SUB+= NLS="@comment "
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,3 +0,0 @@
|
|||
MD5 (lxsession-lite-0.3.6.tar.gz) = 909c3b0f4c6e4855f64dfbb47467c0b3
|
||||
SHA256 (lxsession-lite-0.3.6.tar.gz) = 3754ee460942bfde94e6a7fdf20c337a1b6a069cea6972d0c33a115db828dba4
|
||||
SIZE (lxsession-lite-0.3.6.tar.gz) = 229644
|
|
@ -1,4 +0,0 @@
|
|||
LXSession Lite is a stripped-down lightweight version without X11 session
|
||||
management support, and it's more stable than lxsession.
|
||||
|
||||
WWW: http://lxde.sourceforge.net/
|
|
@ -1,18 +0,0 @@
|
|||
bin/lxsession
|
||||
bin/lxsession-logout
|
||||
%%NLS%%share/locale/de/LC_MESSAGES/lxsession.mo
|
||||
%%NLS%%share/locale/es/LC_MESSAGES/lxsession.mo
|
||||
%%NLS%%share/locale/fi/LC_MESSAGES/lxsession.mo
|
||||
%%NLS%%share/locale/fr/LC_MESSAGES/lxsession.mo
|
||||
%%NLS%%share/locale/hu/LC_MESSAGES/lxsession.mo
|
||||
%%NLS%%share/locale/pl/LC_MESSAGES/lxsession.mo
|
||||
%%NLS%%share/locale/sk/LC_MESSAGES/lxsession.mo
|
||||
%%NLS%%share/locale/zh_TW/LC_MESSAGES/lxsession.mo
|
||||
%%DATADIR%%/images/gnome-session-halt.png
|
||||
%%DATADIR%%/images/gnome-session-hibernate.png
|
||||
%%DATADIR%%/images/gnome-session-logout.png
|
||||
%%DATADIR%%/images/gnome-session-reboot.png
|
||||
%%DATADIR%%/images/gnome-session-suspend.png
|
||||
%%DATADIR%%/images/gnome-session-switch.png
|
||||
@dirrm %%DATADIR%%/images
|
||||
@dirrm %%DATADIR%%
|
Loading…
Reference in a new issue