databases/galera26: Update to 26.4.8
PR: 254877 Submitted by: devel@galeracluster.com (maintainer)
This commit is contained in:
parent
d3a1e886a8
commit
8d57df64e6
5 changed files with 12 additions and 73 deletions
|
@ -1,7 +1,7 @@
|
|||
# Created by: Nicolas Embriz <nbari@tequila.io>
|
||||
|
||||
PORTNAME= galera
|
||||
PORTVERSION= 26.4.6
|
||||
PORTVERSION= 26.4.8
|
||||
DISTVERSIONPREFIX= release_
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= databases
|
||||
|
@ -28,41 +28,22 @@ BUILD_DEPENDS= checkmk:devel/check \
|
|||
objdump:devel/binutils
|
||||
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs
|
||||
|
||||
USES= compiler:c++11-lang python:build scons ssl
|
||||
USES= compiler:c++11-lang python:build cmake ssl
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_TUPLE?= codership:galera:${DISTVERSIONPREFIX}${PORTVERSION}${DISTVERSIONSUFFIX} \
|
||||
codership:wsrep-API:75a5f452f2ba07b0f4a3a9a94825fccc71b27398:dummy/wsrep/src
|
||||
codership:wsrep-API:76cf223c690845bbf561cb820a46e06a18ad80d1:dummy/wsrep/src
|
||||
|
||||
CMAKE_ARGS+= -DGALERA_REVISION=${GH_TAGNAME}
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
USE_RC_SUBR= garb.sh
|
||||
|
||||
MAKE_ARGS+= revno=${GH_TAGNAME} system_asio=0 tests=0
|
||||
# Abuse TEST_TARGET to append tests=1 (which is not a target, strictly
|
||||
# speaking) at the end of the "scons ..." command so that it overrides
|
||||
# tests=0 from ${MAKE_ARGS}. To rerun the tests a second time, remove
|
||||
# all *.passed files: find ./work -name *.passed -print -delete
|
||||
TEST_TARGET= deterministic_tests=1 tests=1
|
||||
|
||||
LDFLAGS+= -lboost_program_options -lboost_system
|
||||
|
||||
PLIST_FILES= bin/garbd \
|
||||
lib/libgalera.so \
|
||||
lib/libgalera_smm.so
|
||||
|
||||
OPTIONS_DEFINE= BOOSTPOOL BPOSTATIC DEBUG
|
||||
|
||||
BOOSTPOOL_DESC= Use boost pool allocator
|
||||
BPOSTATIC_DESC= Use static boost_program_options
|
||||
|
||||
BOOSTPOOL_MAKE_ARGS= boost_pool=1
|
||||
BPOSTATIC_MAKE_ARGS= bpostatic=${LOCALBASE}/lib/libboost_program_options.a
|
||||
DEBUG_MAKE_ARGS= debug=0
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/garb/garbd ${STAGEDIR}${PREFIX}/bin/
|
||||
${INSTALL_LIB} ${WRKSRC}/libgalera_smm.so ${STAGEDIR}${PREFIX}/lib/
|
||||
@(cd ${STAGEDIR}${PREFIX}/lib && ${LN} -sf libgalera_smm.so \
|
||||
libgalera.so)
|
||||
post-install:
|
||||
${RLN} ${STAGEDIR}/${PREFIX}/lib/libgalera_smm.so ${STAGEDIR}/${PREFIX}/lib/libgalera.so
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
TIMESTAMP = 1603735085
|
||||
SHA256 (codership-galera-release_26.4.6_GH0.tar.gz) = d1d0f300bcf1097191f438952e7ceea59f40e158cf2c5f83b325da5437728b99
|
||||
SIZE (codership-galera-release_26.4.6_GH0.tar.gz) = 3438009
|
||||
SHA256 (codership-wsrep-API-75a5f452f2ba07b0f4a3a9a94825fccc71b27398_GH0.tar.gz) = ac782d33d84a874d89bbe4eeb818ab56ae729aee4c491f91892694a2e134c558
|
||||
SIZE (codership-wsrep-API-75a5f452f2ba07b0f4a3a9a94825fccc71b27398_GH0.tar.gz) = 50214
|
||||
TIMESTAMP = 1617278996
|
||||
SHA256 (codership-galera-release_26.4.8_GH0.tar.gz) = c7669b3a3594c6db2f7b793d7cb455e7ccb71b15f699efe5db4af472b685b7ea
|
||||
SIZE (codership-galera-release_26.4.8_GH0.tar.gz) = 3489437
|
||||
SHA256 (codership-wsrep-API-76cf223c690845bbf561cb820a46e06a18ad80d1_GH0.tar.gz) = 214fb8701ae51bcdf8171475a93f2c28ddd56e642feb172ec5148b4d3c73d4a6
|
||||
SIZE (codership-wsrep-API-76cf223c690845bbf561cb820a46e06a18ad80d1_GH0.tar.gz) = 90155
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
--- galerautils/SConscript.orig 2020-10-27 20:24:02 UTC
|
||||
+++ galerautils/SConscript
|
||||
@@ -48,7 +48,9 @@ if not crc32c_no_hardware:
|
||||
|
||||
int main()
|
||||
{
|
||||
+ #if defined(__linux__)
|
||||
(void)getauxval(AT_HWCAP);
|
||||
+ #endif
|
||||
|
||||
(void)__crc32b(0, 0);
|
||||
(void)__crc32h(0, 0);
|
|
@ -1,14 +0,0 @@
|
|||
--- galerautils/src/gu_byteswap.h.orig 2020-10-12 06:33:51 UTC
|
||||
+++ galerautils/src/gu_byteswap.h
|
||||
@@ -53,11 +53,6 @@ static GU_FORCE_INLINE uint64_t GU_ROTL64 (uint64_t x,
|
||||
# define gu_bswap16 _OSSwapInt16
|
||||
# define gu_bswap32 _OSSwapInt32
|
||||
# define gu_bswap64 _OSSwapInt64
|
||||
-#elif defined(__FreeBSD__)
|
||||
-/* do not use bswapXX, because gcc44 gives old-style cast warnings */
|
||||
-# define gu_bswap16 __bswap16_var
|
||||
-# define gu_bswap32 __bswap32_var
|
||||
-# define gu_bswap64 __bswap64_var
|
||||
#elif defined(__sun__)
|
||||
# define gu_bswap16 BSWAP_16
|
||||
# define gu_bswap32 BSWAP_32
|
|
@ -1,16 +0,0 @@
|
|||
--- galerautils/src/gu_crc32c_arm64.c.orig 2020-10-27 20:24:41 UTC
|
||||
+++ galerautils/src/gu_crc32c_arm64.c
|
||||
@@ -74,7 +74,13 @@ gu_crc32c_arm64(gu_crc32c_t state, const void* data, s
|
||||
gu_crc32c_func_t
|
||||
gu_crc32c_hardware()
|
||||
{
|
||||
+#if defined(__linux__)
|
||||
unsigned long int const hwcaps = getauxval(AT_HWCAP);
|
||||
+#endif
|
||||
+#if defined(__FreeBSD__)
|
||||
+ unsigned long hwcaps;
|
||||
+ elf_aux_info(AT_HWCAP, &hwcaps, sizeof(hwcaps));
|
||||
+#endif
|
||||
if (hwcaps & HWCAP_CRC32)
|
||||
{
|
||||
gu_info ("CRC-32C: using hardware acceleration.");
|
Loading…
Reference in a new issue