yaunc is "yet another" client for the Uptimes project, at www.uptimes.net.
This commit is contained in:
parent
6885bd453e
commit
8d59a14f13
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=26695
8 changed files with 101 additions and 0 deletions
28
misc/yaunc/Makefile
Normal file
28
misc/yaunc/Makefile
Normal file
|
@ -0,0 +1,28 @@
|
|||
# New ports collection makefile for: yaunc
|
||||
# Version required: 0.02
|
||||
# Date created: 5 March 2000
|
||||
# Whom: nsayer@freebsd.org
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= yaunc-0.02
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://www.redterror.net/code/yaunc/
|
||||
|
||||
MAINTAINER= nsayer@freebsd.org
|
||||
|
||||
WRKSRC= ${WRKDIR}/yaunc
|
||||
|
||||
MAN1= yaunc.1
|
||||
|
||||
do-install:
|
||||
( cd ${WRKSRC} ;\
|
||||
${INSTALL_PROGRAM} yaunc ${PREFIX}/bin ;\
|
||||
${INSTALL_DATA} -m 600 yaunc.conf ${PREFIX}/etc/yaunc.conf.sample ;\
|
||||
${INSTALL_MAN} yaunc.man ${PREFIX}/man/man1/yaunc.1 ;\
|
||||
${SED} s+%%PREFIX%%+${PREFIX}+g < ${FILESDIR}/startup > \
|
||||
${PREFIX}/etc/rc.d/yaunc.sh ;\
|
||||
chmod 755 ${PREFIX}/etc/rc.d/yaunc.sh )
|
||||
|
||||
.include <bsd.port.mk>
|
1
misc/yaunc/distinfo
Normal file
1
misc/yaunc/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (yaunc-latest.tar.gz) = a5c9bf1e1e72064c80dc5c3d66292863
|
50
misc/yaunc/files/patch-aa
Normal file
50
misc/yaunc/files/patch-aa
Normal file
|
@ -0,0 +1,50 @@
|
|||
--- Makefile.orig Sun Mar 5 11:18:06 2000
|
||||
+++ Makefile Sun Mar 5 11:29:57 2000
|
||||
@@ -1,6 +1,9 @@
|
||||
# Compiler, flags, etc...
|
||||
-CC = gcc
|
||||
-CFLAGS = -ansi -pedantic -Wall -O3 #-DDEBUG2 -DDEBUG1
|
||||
+#CC = gcc
|
||||
+#CFLAGS = -ansi -pedantic -Wall -O3 #-DDEBUG2 -DDEBUG1
|
||||
+CFLAGS+= -DETCDIR=\"$(PREFIX)/etc/\"
|
||||
+
|
||||
+all: bsd
|
||||
|
||||
# platform dependant stuff has the appropriate suffix :)
|
||||
OBJ1 = read_conf.o usage.o unp_error.o encode.o unp_sock_wrappers.o \
|
||||
@@ -24,23 +27,23 @@
|
||||
linux_funcs.o get_ut_proc.o get_ut_bsd.o : yaunc.h my_hdrs.h
|
||||
|
||||
# housekeeping
|
||||
-.PHONY : clean distclean install uninstall package backup
|
||||
-clean :
|
||||
- rm -f *.o core
|
||||
-distclean : clean
|
||||
- rm -f yaunc
|
||||
+#.PHONY : clean distclean install uninstall package backup
|
||||
+#clean :
|
||||
+# rm -f *.o core
|
||||
+#distclean : clean
|
||||
+# rm -f yaunc
|
||||
|
||||
install :
|
||||
- cp yaunc /usr/local/bin ; \
|
||||
- cp yaunc.1 /usr/local/man/man1 ; \
|
||||
- cp yaunc.conf /etc/
|
||||
+ ${INSTALL_PROGRAM} yaunc $(PREFIX)/bin
|
||||
+ ${INSTALL_MAN} yaunc.1 $(PREFIX)/man/man1
|
||||
+ ${INSTALL_DATA} yaunc.conf $(PREFIX)/etc
|
||||
|
||||
uninstall :
|
||||
rm /usr/local/bin/yaunc ; \
|
||||
rm /usr/local/man/man1/yaunc.1 ; \
|
||||
rm /etc/yaunc.conf
|
||||
|
||||
-package : distclean
|
||||
- cd .. ; tar -cf - yaunc | gzip -9 > yaunc-`cat yaunc/VERSION`.tar.gz
|
||||
-backup : distclean
|
||||
- cp -a . ../src_backup
|
||||
+#package : distclean
|
||||
+# cd .. ; tar -cf - yaunc | gzip -9 > yaunc-`cat yaunc/VERSION`.tar.gz
|
||||
+#backup : distclean
|
||||
+# cp -a . ../src_backup
|
11
misc/yaunc/files/patch-ab
Normal file
11
misc/yaunc/files/patch-ab
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- main.c.orig Sun Mar 5 11:26:38 2000
|
||||
+++ main.c Sun Mar 5 11:26:57 2000
|
||||
@@ -13,7 +13,7 @@
|
||||
struct utsname sys_info;
|
||||
struct info info;
|
||||
time_t uptime;
|
||||
- char * path = "/etc/yaunc.conf";
|
||||
+ char * path = ETCDIR"yaunc.conf";
|
||||
char * data_ptr;
|
||||
|
||||
/* read data from the conf file */
|
2
misc/yaunc/files/startup
Normal file
2
misc/yaunc/files/startup
Normal file
|
@ -0,0 +1,2 @@
|
|||
#! /bin/sh
|
||||
[ -x %%PREFIX%%/bin/yaunc -a -f %%PREFIX%%/etc/yaunc.conf ] && %%PREFIX%%/bin/yaunc & && echo -n ' yaunc'
|
1
misc/yaunc/pkg-comment
Normal file
1
misc/yaunc/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Yet Another uptimes.net client
|
5
misc/yaunc/pkg-descr
Normal file
5
misc/yaunc/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
This is an uptimes.net client. See http://www.uptimes.net/ for a
|
||||
description. Note that after installing this port, you MUST edit
|
||||
the yaunc.conf file and set the hid, username and password.
|
||||
|
||||
WWW: http://www.redterror.net/code/yaunc/
|
3
misc/yaunc/pkg-plist
Normal file
3
misc/yaunc/pkg-plist
Normal file
|
@ -0,0 +1,3 @@
|
|||
bin/yaunc
|
||||
etc/rc.d/yaunc.sh
|
||||
etc/yaunc.conf.sample
|
Loading…
Reference in a new issue