* Maintenance update to 0.8.4.
* Support for the aRts plugin now must be explicitly enabled by defining WITH_ARTS. * NAS plugin available by defining WITH_NAS. Consider experimental.
This commit is contained in:
parent
39b94d499d
commit
8d7a265edd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=90645
6 changed files with 116 additions and 71 deletions
|
@ -6,20 +6,16 @@
|
|||
#
|
||||
|
||||
PORTNAME= libao
|
||||
PORTVERSION= 0.8.3
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.8.4
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://www.vorbis.com/files/1.0/unix/ \
|
||||
ftp://ftp.wiles.org/pub/mirrors/Vorbis/unix/ \
|
||||
http://www.casterclub.com/vorbis/unix/ \
|
||||
http://www.math.utoledo.edu/~chaese/Vorbis/unix/
|
||||
MASTER_SITES= http://www.xiph.org/ao/src/
|
||||
|
||||
MAINTAINER= naddy@FreeBSD.org
|
||||
COMMENT= Portable audio output library
|
||||
|
||||
WANT_GNOME= yes
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
WANT_GNOME= yes
|
||||
|
||||
.if defined(NOPORTDOCS)
|
||||
MAKE_ENV= DOC=""
|
||||
|
@ -29,6 +25,26 @@ MAKE_ENV= DOC=doc
|
|||
|
||||
MAN5= libao.conf.5
|
||||
|
||||
.if defined(WITH_ARTS)
|
||||
LIB_DEPENDS= artsc.0:${PORTSDIR}/audio/arts
|
||||
PLIST_SUB+= ARTS=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-arts
|
||||
PLIST_SUB+= ARTS="@comment "
|
||||
pre-everything::
|
||||
@${ECHO_MSG} "Define WITH_ARTS to enable the aRts module."
|
||||
.endif
|
||||
|
||||
.if defined(WITH_NAS)
|
||||
LIB_DEPENDS= audio.2:${PORTSDIR}/audio/nas
|
||||
PLIST_SUB+= NAS=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-nas
|
||||
PLIST_SUB+= NAS="@comment "
|
||||
pre-everything::
|
||||
@${ECHO_MSG} "Define WITH_NAS to enable the NAS module."
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${HAVE_GNOME:Mesound}
|
||||
|
@ -40,13 +56,4 @@ CONFIGURE_ARGS+= --disable-esd
|
|||
PLIST_SUB+= ESOUND="@comment "
|
||||
.endif
|
||||
|
||||
# XXX This needs a better check.
|
||||
.if exists(${LOCALBASE}/bin/artsc-config)
|
||||
LIB_DEPENDS= artsc.0:${PORTSDIR}/audio/arts
|
||||
PLIST_SUB+= ARTS=""
|
||||
.else
|
||||
PLIST_SUB+= ARTS="@comment "
|
||||
CONFIGURE_ARGS+= --disable-arts
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (libao-0.8.3.tar.gz) = b1422a6ff7f58131921b9f2fabe2295c
|
||||
MD5 (libao-0.8.4.tar.gz) = 0525549b0bf665f617913c916064cc87
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- configure.orig Fri Jul 19 16:16:55 2002
|
||||
+++ configure Fri Aug 23 16:47:25 2002
|
||||
@@ -5386,6 +5386,7 @@
|
||||
--- configure.orig Sun Oct 5 03:32:52 2003
|
||||
+++ configure Wed Oct 8 16:17:26 2003
|
||||
@@ -7787,6 +7787,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
|
@ -11,25 +11,61 @@ $FreeBSD$
|
|||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
||||
@@ -5412,7 +5413,7 @@
|
||||
PROFILE="-v -xpg -g -xO4 -fast -native -fsimple -xcg92 -Dsuncc" ;;
|
||||
@@ -7816,7 +7817,7 @@
|
||||
*)
|
||||
PLUGIN_LDFLAGS="-export-dynamic -avoid-version"
|
||||
DEBUG="-g"
|
||||
- CFLAGS="-O"
|
||||
+ CFLAGS=""
|
||||
PROFILE="-g -p" ;;
|
||||
esac
|
||||
else
|
||||
@@ -5432,9 +5433,9 @@
|
||||
CFLAGS="-O20 -D__NO_MATH_INLINES -fsigned-char $SILLY_CARBON_PATH"
|
||||
PROFILE="-O20 -g -pg -D__NO_MATH_INLINES -fsigned-char $SILLY_CARBON_PATH" ;;
|
||||
@@ -7839,9 +7840,9 @@
|
||||
PROFILE="-g -pg -D__NO_MATH_INLINES -fsigned-char -Ddlsym=dlsym_auto_underscore" ;;
|
||||
*)
|
||||
PLUGIN_LDFLAGS="-export-dynamic -avoid-version"
|
||||
- DEBUG="-g -Wall -D__NO_MATH_INLINES -fsigned-char"
|
||||
- CFLAGS="-O20 -D__NO_MATH_INLINES -fsigned-char"
|
||||
- PROFILE="-O20 -g -pg -D__NO_MATH_INLINES -fsigned-char" ;;
|
||||
+ DEBUG="-g -Wall"
|
||||
+ CFLAGS=""
|
||||
+ PROFILE="-g -pg" ;;
|
||||
+ DEBUG="-g -Wall -fsigned-char"
|
||||
+ CFLAGS="-fsigned-char"
|
||||
+ PROFILE="-g -pg -fsigned-char" ;;
|
||||
esac
|
||||
fi
|
||||
CFLAGS="$CFLAGS $cflags_save"
|
||||
@@ -9348,6 +9349,8 @@
|
||||
rm -f conf.esdtest
|
||||
|
||||
|
||||
+fi
|
||||
+
|
||||
|
||||
if test "x$have_esd" = xyes; then
|
||||
HAVE_ESD_TRUE=
|
||||
@@ -9357,8 +9360,6 @@
|
||||
HAVE_ESD_FALSE=
|
||||
fi
|
||||
|
||||
-fi
|
||||
-
|
||||
|
||||
|
||||
|
||||
@@ -12128,7 +12129,7 @@
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
ac_check_lib_save_LIBS=$LIBS
|
||||
-LIBS="-laudio -lXau $X_LIBS $LIBS"
|
||||
+LIBS="-laudio -lXau -lXt -lm $X_LIBS $LIBS"
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
#line $LINENO "configure"
|
||||
/* confdefs.h. */
|
||||
@@ -12337,7 +12338,7 @@
|
||||
|
||||
if test "x$have_nas" = xyes; then
|
||||
NAS_CFLAGS="$X_CFLAGS"
|
||||
- NAS_LIBS="-laudio -lXau $X_LIBS"
|
||||
+ NAS_LIBS="-laudio -lXau -lXt -lm $X_LIBS"
|
||||
else
|
||||
NAS_CFLAGS=""
|
||||
NAS_LIBS=""
|
||||
|
|
|
@ -1,14 +1,14 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- src/Makefile.in.orig Sat Jul 20 15:27:46 2002
|
||||
+++ src/Makefile.in Sat Jul 20 15:27:54 2002
|
||||
@@ -99,7 +99,7 @@
|
||||
--- src/Makefile.in.orig Wed Oct 8 03:17:06 2003
|
||||
+++ src/Makefile.in Wed Oct 8 03:17:23 2003
|
||||
@@ -171,7 +171,7 @@
|
||||
lib_LTLIBRARIES = libao.la
|
||||
|
||||
libao_la_SOURCES = audio_out.c config.c ao_null.c ao_wav.c ao_au.c ao_raw.c ao_private.h
|
||||
libao_la_SOURCES = audio_out.c config.c ao_null.c ao_wav.c ao_au.c ao_raw.c ao_aixs.c ao_private.h
|
||||
-libao_la_LDFLAGS = -version-info @LIB_CURRENT@:@LIB_REVISION@:@LIB_AGE@ -ldl
|
||||
+libao_la_LDFLAGS = -version-info @LIB_CURRENT@:@LIB_REVISION@:@LIB_AGE@
|
||||
subdir = src
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
CONFIG_CLEAN_FILES =
|
||||
LTLIBRARIES = $(lib_LTLIBRARIES)
|
||||
|
|
|
@ -9,4 +9,4 @@ On FreeBSD, it currently supports:
|
|||
* ESD (ESounD or Enlightened Sound Daemon)
|
||||
* aRts (KDE sound server)
|
||||
|
||||
WWW: http://www.vorbis.com/
|
||||
WWW: http://www.xiph.org/ao/
|
||||
|
|
|
@ -8,43 +8,45 @@ lib/libao.so.3
|
|||
%%ARTS%%lib/ao/plugins-2/libarts.so
|
||||
lib/ao/plugins-2/liboss.so
|
||||
%%ESOUND%%lib/ao/plugins-2/libesd.so
|
||||
%%NAS%%lib/ao/plugins-2/libnas.so
|
||||
lib/pkgconfig/ao.pc
|
||||
share/aclocal/ao.m4
|
||||
%%PORTDOCS%%share/doc/libao/ao_append_option.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_close.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_default_driver_id.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_device.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_driver_id.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_driver_info.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_driver_info_list.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_example.c
|
||||
%%PORTDOCS%%share/doc/libao/ao_file_extension.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_free_options.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_info.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_initialize.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_open_file.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_open_live.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_option.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_play.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_plugin_close.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_plugin_device_clear.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_plugin_device_init.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_plugin_driver_info.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_plugin_file_extension.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_plugin_open.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_plugin_play.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_plugin_set_option.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_plugin_test.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_sample_format.html
|
||||
%%PORTDOCS%%share/doc/libao/ao_shutdown.html
|
||||
%%PORTDOCS%%share/doc/libao/config.html
|
||||
%%PORTDOCS%%share/doc/libao/drivers.html
|
||||
%%PORTDOCS%%share/doc/libao/index.html
|
||||
%%PORTDOCS%%share/doc/libao/libao-api.html
|
||||
%%PORTDOCS%%share/doc/libao/overview.html
|
||||
%%PORTDOCS%%share/doc/libao/plugin-api.html
|
||||
%%PORTDOCS%%share/doc/libao/plugin-overview.html
|
||||
%%PORTDOCS%%share/doc/libao/style.css
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_append_option.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_close.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_default_driver_id.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_device.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_driver_id.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_driver_info.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_driver_info_list.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_example.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_file_extension.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_free_options.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_info.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_initialize.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_open_file.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_open_live.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_option.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_play.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_plugin_close.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_plugin_device_clear.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_plugin_device_init.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_plugin_driver_info.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_plugin_file_extension.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_plugin_open.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_plugin_play.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_plugin_set_option.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_plugin_test.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_sample_format.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ao_shutdown.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/drivers.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libao-api.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/overview.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/plugin-api.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/plugin-overview.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/style.css
|
||||
@dirrm include/ao
|
||||
@dirrm lib/ao/plugins-2
|
||||
@dirrm lib/ao
|
||||
%%PORTDOCS%%@dirrm share/doc/libao
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
|
|
Loading…
Reference in a new issue