games/xataxx: Remove expired port

2024-03-15 games/xataxx: No available WWW
This commit is contained in:
Rene Ladan 2024-03-16 22:08:29 +01:00
parent 3d93e481a6
commit 8d98869f0d
15 changed files with 1 additions and 263 deletions

1
MOVED
View File

@ -3043,3 +3043,4 @@ net-im/gtkcord4|net-im/dissent|2024-03-03|Project renamed
devel/anjuta|devel/gnome-builder|2024-03-12|Has expired: Unmaintained, upstream WWW owned by gambling site, use devel/gnome-builder
deskutils/rubrica||2024-03-12|Has expired: Upstream WWW redirects to a different site not related to the application
x11/mrxvt-devel|x11/mrxvt|2024-03-12|Merge most recent version into main port
games/xataxx||2024-03-16|Has expired: No available WWW

View File

@ -1060,7 +1060,6 @@
SUBDIR += wyrmgus
SUBDIR += wyrmsun
SUBDIR += xasteroids
SUBDIR += xataxx
SUBDIR += xbat
SUBDIR += xbill
SUBDIR += xbl

View File

@ -1,33 +0,0 @@
PORTNAME= xataxx
PORTVERSION= 1.0
PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= XCONTRIB/../R5contrib
DISTNAME= ${PORTNAME}
MAINTAINER= bofh@FreeBSD.org
COMMENT= Strategy game of position and movement for X Window System
LICENSE= NONE
DEPRECATED= No available WWW
EXPIRATION_DATE=2024-03-15
USES= imake tar:Z xorg
USE_XORG= x11 xext
OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=int-conversion
.endif
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in README TODO
(cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${STAGEDIR}${DOCSDIR})
.endfor
.include <bsd.port.post.mk>

View File

@ -1,2 +0,0 @@
SHA256 (xataxx.tar.Z) = 83885b0b682463a7e7a01ea0b7b9703111c68ddfc5f287cf9acebd28f696e907
SIZE (xataxx.tar.Z) = 50921

View File

@ -1,27 +0,0 @@
--- ./Imakefile.orig 1991-10-29 02:23:52.000000000 -0200
+++ ./Imakefile 2013-11-16 00:46:31.000000000 -0200
@@ -4,11 +4,13 @@
# in the system default BINDIR
# BINDIR =
+MANSUFFIX = 6
+
# !%^#*
DEPLIBS =
/* DATADIR is where the boards and bitmaps will be installed */
-DATADIR = /afs/andrew.cmu.edu/usr0/games/lib/xataxx
+DATADIR = $(LOCALBASE)/share/xataxx
LOCAL_LIBRARIES = $(XLIB)
SRCS = bits.c board.c colbits.c demo.c display.c main.c nubot.c parse.c zot.c
@@ -19,6 +21,8 @@
install:: install.lib
install.lib:
+ @if [ -d $(DESTDIR)$(DATADIR) ]; then set +x; \
+ else (set -x; $(MKDIRHIER) $(DESTDIR)$(DATADIR)); fi
for i in lib//**/*; do \
- (set -x; install -c $$i $(DATADIR)); \
+ (set -x; install -c $$i $(DESTDIR)$(DATADIR)); \
done

View File

@ -1,22 +0,0 @@
--- bits.c.orig
+++ bits.c
@@ -1,7 +1,10 @@
#include <stdio.h>
+#include <stdlib.h>
#include <ctype.h>
#include <X11/Xlib.h>
+#include <X11/Xutil.h>
#include <math.h>
+#include <sys/types.h>
#include <sys/socket.h>
#include <sys/time.h>
#include "struct.h"
@@ -16,7 +19,7 @@
#define NFDSHIFT 5 /* Shift based on above */
#ifndef howmany
#define howmany(x, y) (((x)+((y)-1))/(y))
-#endif howmany
+#endif
#define NBBY 8 /* number of bits in a byte */

View File

@ -1,16 +0,0 @@
--- board.c.orig
+++ board.c
@@ -1,3 +1,4 @@
+#include <stdlib.h>
#include <X11/Xlib.h>
#include "struct.h"
@@ -461,7 +462,7 @@
}
}
if (best_count==-1)
- return;
+ return(0);
move_piece(best.ox,best.oy,best.nx,best.ny,player);
}

View File

@ -1,8 +0,0 @@
--- demo.c.orig
+++ demo.c
@@ -1,4 +1,5 @@
#include <stdio.h>
+#include <stdlib.h>
#include <X11/Xlib.h>
#include "struct.h"

View File

@ -1,27 +0,0 @@
--- display.c.orig
+++ display.c
@@ -1,4 +1,6 @@
#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
#include <X11/Xlib.h>
#include <X11/Xutil.h>
#include <math.h>
@@ -145,7 +147,7 @@
int occ,x,y;
if (currdpy != dpy && !botmode)
- return;
+ return(0);
wipemap(currdpy, currbamp, currgc, currscr, currwin);
for (y=0;y!=ysize;y++)
for (x=0;x!=xsize;x++)
@@ -386,7 +388,7 @@
XFlush(currdpy);
}
XNextEvent(dpy,&event);
- return;
+ return(0);
}
}

View File

@ -1,19 +0,0 @@
--- main.c.orig
+++ main.c
@@ -1,4 +1,7 @@
#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
+#include <unistd.h>
#include <X11/Xlib.h>
#include <math.h>
#include "struct.h"
@@ -160,7 +163,7 @@
int x;
{
int z1, z2, z3, z4, z=0;
- char nn[6];
+ static char nn[6];
z1 = (int) (x)/1000;
z2 = (int) (x)/100-(10*z1);

View File

@ -1,27 +0,0 @@
--- nubot.c.orig
+++ nubot.c
@@ -1,4 +1,6 @@
#include <stdio.h>
+#include <stdlib.h>
+#include <strings.h>
#include <X11/Xlib.h>
#include "struct.h"
@@ -172,7 +174,7 @@
list_moves(player, board, movel);
- if (movel[0].ox==(-1)) return; /* there are no legal moves */
+ if (movel[0].ox==(-1)) return(0); /* there are no legal moves */
if (botlevel==0) {
for (ix=0; movel[ix].ox!=(-1); ix++);
@@ -180,7 +182,7 @@
best = &(movel[ix]);
move_piece(best->ox,best->oy,best->nx,best->ny,player);
- return;
+ return(0);
};
for (ix=0; movel[ix].ox!=(-1); ix++) {

View File

@ -1,9 +0,0 @@
--- parse.c.orig
+++ parse.c
@@ -1,4 +1,6 @@
#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
#include <strings.h>
#include "struct.h"

View File

@ -1,11 +0,0 @@
--- zot.c.orig
+++ zot.c
@@ -23,7 +23,7 @@
GC bgc;
if (!wflump)
- return;
+ return(0);
zot(dx, dy, cmaps, cdpy, cscr, cgc, cwin, cmap);
}

View File

@ -1,3 +0,0 @@
XAtaxx is a strategy game based on Ataxx, a popular arcade video game.
It is a game of position and movement. The object is to have the most
pieces of your color on the board at the end of the game.

View File

@ -1,58 +0,0 @@
bin/xataxx
share/man/man6/xataxx.6.gz
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%DATADIR%%/1.xbd
%%DATADIR%%/10.xbd
%%DATADIR%%/11.xbd
%%DATADIR%%/12.xbd
%%DATADIR%%/13.xbd
%%DATADIR%%/14.xbd
%%DATADIR%%/15.xbd
%%DATADIR%%/16.xbd
%%DATADIR%%/17.xbd
%%DATADIR%%/18.xbd
%%DATADIR%%/19.xbd
%%DATADIR%%/2.xbd
%%DATADIR%%/20.xbd
%%DATADIR%%/21.xbd
%%DATADIR%%/22.xbd
%%DATADIR%%/23.xbd
%%DATADIR%%/24.xbd
%%DATADIR%%/25.xbd
%%DATADIR%%/26.xbd
%%DATADIR%%/27.xbd
%%DATADIR%%/28.xbd
%%DATADIR%%/29.xbd
%%DATADIR%%/3.xbd
%%DATADIR%%/30.xbd
%%DATADIR%%/31.xbd
%%DATADIR%%/32.xbd
%%DATADIR%%/33.xbd
%%DATADIR%%/34.xbd
%%DATADIR%%/35.xbd
%%DATADIR%%/4.xbd
%%DATADIR%%/5.xbd
%%DATADIR%%/6.xbd
%%DATADIR%%/7.xbd
%%DATADIR%%/8.xbd
%%DATADIR%%/9.xbd
%%DATADIR%%/boards.num
%%DATADIR%%/clearstone.xbm
%%DATADIR%%/dkblock.xbm
%%DATADIR%%/dksmiley.xbm
%%DATADIR%%/dkstone.xbm
%%DATADIR%%/downcursor.xbm
%%DATADIR%%/downmask.xbm
%%DATADIR%%/ltblock.xbm
%%DATADIR%%/ltsmiley.xbm
%%DATADIR%%/ltstone.xbm
%%DATADIR%%/scowlcurs.xbm
%%DATADIR%%/scowlcursmask.xbm
%%DATADIR%%/smilecurs.xbm
%%DATADIR%%/smilecursmask.xbm
%%DATADIR%%/stone.xbm
%%DATADIR%%/stonemask.xbm
%%DATADIR%%/title.xbm
%%DATADIR%%/upcursor.xbm
%%DATADIR%%/upmask.xbm