Unbreak: add a patch to let this build on -current with gcc 3.1.
While I'm here, make the port respect CC/CXX/CFLAGS/CXXFLAGS.
This commit is contained in:
parent
d14636d6c8
commit
8dd6d82525
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=60936
3 changed files with 32 additions and 5 deletions
|
@ -12,12 +12,16 @@ MASTER_SITES= ftp://ftp.sourceforge.net/pub/sourceforge/larbin/
|
|||
|
||||
MAINTAINER= hiten@uk.FreeBSD.org
|
||||
|
||||
BROKEN= "Does not build"
|
||||
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
PATCH_WRKSRC= ${WRKSRC}/src
|
||||
MAKE_ARGS= CXX=${CXX}
|
||||
|
||||
post-patch:
|
||||
@${SED} -e 's,CC=,CC?=,' -e 's,CFLAGS=-O3,CFLAGS+=,' < \
|
||||
${WRKSRC}/adns/Makefile > ${WRKSRC}/adns/Makefile.new
|
||||
@${MV} ${WRKSRC}/adns/Makefile.new ${WRKSRC}/adns/Makefile
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/larbin ${PREFIX}/bin/
|
||||
|
|
|
@ -1,6 +1,16 @@
|
|||
--- larbin.make~ Mon Mar 4 11:47:28 2002
|
||||
+++ larbin.make Tue Mar 26 21:17:01 2002
|
||||
@@ -37,5 +37,3 @@
|
||||
--- larbin.make.orig Mon Mar 4 06:47:28 2002
|
||||
+++ larbin.make Sat Jun 8 21:27:26 2002
|
||||
@@ -13,8 +13,7 @@
|
||||
ABS-MAIN-OBJ:=$(MAIN-OBJ)
|
||||
|
||||
MAKE:=gmake
|
||||
-CXX:=g++
|
||||
-CPPFLAGS:=-Wall -O3 -D_REENTRANT -I- -I$(BASEDIR) -I$(ADNSDIR)
|
||||
+CPPFLAGS= ${CXXFLAGS} -Wall -D_REENTRANT -I- -I$(BASEDIR) -I$(ADNSDIR)
|
||||
RM:=rm -f
|
||||
|
||||
first: all
|
||||
@@ -37,5 +36,3 @@
|
||||
|
||||
prof-in: CPPFLAGS += -pg -DPROF
|
||||
prof-in: redo-in
|
||||
|
|
13
www/larbin/files/patch-utils::SyncFifo.h
Normal file
13
www/larbin/files/patch-utils::SyncFifo.h
Normal file
|
@ -0,0 +1,13 @@
|
|||
$FreeBSD$
|
||||
|
||||
--- utils/SyncFifo.h.orig Sat Jun 8 21:29:43 2002
|
||||
+++ utils/SyncFifo.h Sat Jun 8 21:31:09 2002
|
||||
@@ -45,7 +45,7 @@
|
||||
};
|
||||
|
||||
template <class T>
|
||||
-SyncFifo<T>::SyncFifo (uint size = std_size) {
|
||||
+SyncFifo<T>::SyncFifo (uint size) {
|
||||
tab = new T*[size];
|
||||
this->size = size;
|
||||
in = 0;
|
Loading…
Reference in a new issue