editors/py-vim-bridge: New port
vim_bridge is a Python-to-Vim bridge decorator that allows transparent calls to Python functions in native Vim scripts. WWW: https://github.com/nvie/vim_bridge
This commit is contained in:
parent
de618556e1
commit
8e0a4fc28c
5 changed files with 47 additions and 0 deletions
|
@ -223,6 +223,7 @@
|
|||
SUBDIR += py-babi
|
||||
SUBDIR += py-editorconfig
|
||||
SUBDIR += py-pynvim
|
||||
SUBDIR += py-vim-bridge
|
||||
SUBDIR += quilter
|
||||
SUBDIR += rehex
|
||||
SUBDIR += rubygem-neovim
|
||||
|
|
28
editors/py-vim-bridge/Makefile
Normal file
28
editors/py-vim-bridge/Makefile
Normal file
|
@ -0,0 +1,28 @@
|
|||
PORTNAME= vim-bridge
|
||||
DISTVERSION= 0.6
|
||||
CATEGORIES= editors python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= 0mp@FreeBSD.org
|
||||
COMMENT= Decorator enabing transparent calls to Python functions in Vim scripts
|
||||
|
||||
LICENSE= BSD4CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/setup.py
|
||||
|
||||
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose@${PY_FLAVOR}
|
||||
|
||||
USES= python
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= nvie
|
||||
GH_PROJECT= vim_bridge
|
||||
USE_PYTHON= autoplist concurrent distutils flavors
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
do-test:
|
||||
@(cd ${TEST_WRKSRC} && \
|
||||
${SETENV} ${TEST_ENV} ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test)
|
||||
|
||||
.include <bsd.port.mk>
|
3
editors/py-vim-bridge/distinfo
Normal file
3
editors/py-vim-bridge/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1625548530
|
||||
SHA256 (nvie-vim_bridge-0.6_GH0.tar.gz) = 33a752e28b27ddc8f6e8f343b82194e55ed07fc6dbae7778fc5710f3add93783
|
||||
SIZE (nvie-vim_bridge-0.6_GH0.tar.gz) = 4679
|
11
editors/py-vim-bridge/files/patch-tests_test__vim__bridge.py
Normal file
11
editors/py-vim-bridge/files/patch-tests_test__vim__bridge.py
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- tests/test_vim_bridge.py.orig 2021-07-06 05:27:03 UTC
|
||||
+++ tests/test_vim_bridge.py
|
||||
@@ -80,7 +80,7 @@ class TestBridgedDecorator(unittest.TestCase):
|
||||
self.assertCodeEquals(vim.command.call_args[0][0], \
|
||||
"""
|
||||
fun! Foo(x, y)
|
||||
- python << endp
|
||||
+ python3 << endp
|
||||
__vim_brdg_3_x = vim.eval("a:x")
|
||||
__vim_brdg_3_y = vim.eval("a:y")
|
||||
|
4
editors/py-vim-bridge/pkg-descr
Normal file
4
editors/py-vim-bridge/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
vim_bridge is a Python-to-Vim bridge decorator that allows transparent calls to
|
||||
Python functions in native Vim scripts.
|
||||
|
||||
WWW: https://github.com/nvie/vim_bridge
|
Loading…
Reference in a new issue