- Remove unrecognized CONFIGURE_ARGS
- Cosmetic change - Do not silence installation message - Reformat pkg-descr - Add sourceforge to WWW - Take maintainership
This commit is contained in:
parent
c2c774de77
commit
8e41174ddb
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=374253
5 changed files with 34 additions and 67 deletions
|
@ -6,34 +6,29 @@ PORTVERSION= 1.12.1
|
|||
CATEGORIES+= net textproc
|
||||
MASTER_SITES= SF/dict/${PORTNAME}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
MAINTAINER?= ports@FreeBSD.org
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= Dict protocol (RFC 2229) server
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
LIB_DEPENDS= libmaa.so:${PORTSDIR}/devel/libmaa
|
||||
|
||||
USE_RC_SUBR= ${PORTNAME}
|
||||
USES= bison gmake libtool:build
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc --with-cflags="${CFLAGS}" \
|
||||
--without-local-zlib
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LIBS+= -L${LOCALBASE}/lib
|
||||
|
||||
SUB_FILES+= dictd.conf pkg-message
|
||||
SUB_LIST+= PORTSDIR=${PORTSDIR}
|
||||
|
||||
ALL_TARGET= dictd dictzip
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALL_TARGET= install.dictd install.dictzip
|
||||
LIBS+= -L${LOCALBASE}/lib
|
||||
USES= bison gmake libtool:build
|
||||
|
||||
SUB_FILES= dictd.conf pkg-message
|
||||
SUB_LIST= PORTSDIR=${PORTSDIR}
|
||||
USE_RC_SUBR= ${PORTNAME}
|
||||
|
||||
post-patch:
|
||||
.for i in Makefile.in dict.1.in dictd.8.in
|
||||
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/$i
|
||||
.endfor
|
||||
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/Makefile.in ${WRKSRC}/dict.1.in ${WRKSRC}/dictd.8.in
|
||||
@${REINPLACE_CMD} -e "s|\([\ \t(]\)T_USER|\1T_USERNAME|g" ${WRKSRC}/*.[chly]
|
||||
|
||||
post-install:
|
||||
@${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.conf ${STAGEDIR}${PREFIX}/etc/${PORTNAME}.conf.sample
|
||||
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.conf ${STAGEDIR}${PREFIX}/etc/${PORTNAME}.conf.sample
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,22 +1,22 @@
|
|||
database devils { data "%%PREFIX%%/lib/dict/devils.dict.dz"
|
||||
index "%%PREFIX%%/lib/dict/devils.index" }
|
||||
database easton { data "%%PREFIX%%/lib/dict/easton.dict.dz"
|
||||
index "%%PREFIX%%/lib/dict/easton.index" }
|
||||
database elements { data "%%PREFIX%%/lib/dict/elements.dict.dz"
|
||||
index "%%PREFIX%%/lib/dict/elements.index" }
|
||||
database foldoc { data "%%PREFIX%%/lib/dict/foldoc.dict.dz"
|
||||
index "%%PREFIX%%/lib/dict/foldoc.index" }
|
||||
database gazetteer { data "%%PREFIX%%/lib/dict/gazetteer.dict.dz"
|
||||
index "%%PREFIX%%/lib/dict/gazetteer.index" }
|
||||
database hitchcock { data "%%PREFIX%%/lib/dict/hitchcock.dict.dz"
|
||||
index "%%PREFIX%%/lib/dict/hitchcock.index" }
|
||||
database jargon { data "%%PREFIX%%/lib/dict/jargon.dict.dz"
|
||||
index "%%PREFIX%%/lib/dict/jargon.index" }
|
||||
database vera { data "%%PREFIX%%/lib/dict/vera.dict.dz"
|
||||
index "%%PREFIX%%/lib/dict/vera.index" }
|
||||
database web1913 { data "%%PREFIX%%/lib/dict/web1913.dict.dz"
|
||||
index "%%PREFIX%%/lib/dict/web1913.index" }
|
||||
database wn { data "%%PREFIX%%/lib/dict/wn.dict.dz"
|
||||
index "%%PREFIX%%/lib/dict/wn.index" }
|
||||
database gazetteer { data "%%PREFIX%%/lib/dict/gazetteer.dict.dz"
|
||||
index "%%PREFIX%%/lib/dict/gazetteer.index" }
|
||||
database jargon { data "%%PREFIX%%/lib/dict/jargon.dict.dz"
|
||||
index "%%PREFIX%%/lib/dict/jargon.index" }
|
||||
database foldoc { data "%%PREFIX%%/lib/dict/foldoc.dict.dz"
|
||||
index "%%PREFIX%%/lib/dict/foldoc.index" }
|
||||
database elements { data "%%PREFIX%%/lib/dict/elements.dict.dz"
|
||||
index "%%PREFIX%%/lib/dict/elements.index" }
|
||||
database easton { data "%%PREFIX%%/lib/dict/easton.dict.dz"
|
||||
index "%%PREFIX%%/lib/dict/easton.index" }
|
||||
database hitchcock { data "%%PREFIX%%/lib/dict/hitchcock.dict.dz"
|
||||
index "%%PREFIX%%/lib/dict/hitchcock.index" }
|
||||
database vera { data "%%PREFIX%%/lib/dict/vera.dict.dz"
|
||||
index "%%PREFIX%%/lib/dict/vera.index" }
|
||||
database devils { data "%%PREFIX%%/lib/dict/devils.dict.dz"
|
||||
index "%%PREFIX%%/lib/dict/devils.index" }
|
||||
database world95 { data "%%PREFIX%%/lib/dict/world95.dict.dz"
|
||||
index "%%PREFIX%%/lib/dict/world95.index" }
|
||||
|
|
|
@ -9,7 +9,7 @@
|
|||
# dictd_enable="YES"
|
||||
#
|
||||
|
||||
dictd_enable=${dictd_enable-"NO"}
|
||||
dictd_enable=${dictd_enable:-"NO"}
|
||||
|
||||
. /etc/rc.subr
|
||||
|
||||
|
|
|
@ -1,29 +0,0 @@
|
|||
--- dictd.8.in.orig 2008-12-25 01:16:13.000000000 +0800
|
||||
+++ dictd.8.in 2009-06-17 16:29:39.000000000 +0800
|
||||
@@ -120,7 +120,7 @@
|
||||
.TP
|
||||
.BI \-c " file\fR or " \-\-config " file"
|
||||
Specify configuration file. The default is
|
||||
-.I @SYSCONFDIR@/dictd.conf
|
||||
+.I %%PREFIX%%/etc/dictd.conf
|
||||
, but may be changed in the
|
||||
.I defs.h
|
||||
file at compile time (DICTD_CONFIG_FILE).
|
||||
@@ -283,7 +283,7 @@
|
||||
.TP
|
||||
.B Introduction
|
||||
The configuration file defaults to
|
||||
-.I @SYSCONFDIR@/dictd.conf
|
||||
+.I %%PREFIX%%/etc/dictd.conf
|
||||
but can be specified on the command line with the
|
||||
.B \-c
|
||||
option (see above).
|
||||
@@ -1443,7 +1443,7 @@
|
||||
library you build dictd with.
|
||||
.SH "FILES"
|
||||
.TP
|
||||
-.I @SYSCONFDIR@/dictd.conf
|
||||
+.I %%PREFIX%%/etc/dictd.conf
|
||||
.B dictd
|
||||
configuration file
|
||||
.TP
|
|
@ -1,8 +1,9 @@
|
|||
The DICT Protocol, described in RFC 2229 is a TCP transaction based
|
||||
query/response protocol that allows a client to access dictionary
|
||||
definitions from a set of natural language dictionary databases. While
|
||||
RFC 2229 is a finished document, we plan to clarify and enhance the
|
||||
protocol definition as we gain more experience with large dictionary
|
||||
database servers. By default, the DICT protocol uses TCP port 2628.
|
||||
query/response protocol that allows a client to access dictionary definitions
|
||||
from a set of natural language dictionary databases. While RFC 2229 is a
|
||||
finished document, we plan to clarify and enhance the protocol definition as we
|
||||
gain more experience with large dictionary database servers. By default, the
|
||||
DICT protocol uses TCP port 2628.
|
||||
|
||||
WWW: http://www.dict.org/
|
||||
WWW: http://sourceforge.net/projects/dict/
|
||||
|
|
Loading…
Reference in a new issue