- Fix typo w.r.t. XDG_OPEN option
- Add a a backported patch from cups 1.6 which fixes an issue with regard to a timed out TCP connection. it should be deleted once the port is updated to 1.6. - Pet portlint a bit - remove unused CONFLICTS line PR: 178987 Submitted by: "r4721@tormail.org" <r4721@tormail.org> PR: 179194 Submitted by: Sayetsky Anton <vsjcfm@gmail.com> Approved by: c.petrik.sosa@gmail.com (maintainer)
This commit is contained in:
parent
0964e7868d
commit
8efafbce82
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=319651
2 changed files with 29 additions and 2 deletions
|
@ -69,7 +69,6 @@ OPTIONS_DEFINE= GNUTLS
|
|||
.else
|
||||
PORTREVISION= 1
|
||||
CUPS_SUFFIX= -base
|
||||
CONFLICTS+= cupsddk-*
|
||||
OPTIONS_DEFINE= GNUTLS LIBPAPER PHP PYTHON PAM LDAP DBUS LIBUSB XDG_OPEN GHOSTSCRIPT XPDF AVAHI MDNSRESPONDER
|
||||
OPTIONS_DEFAULT= LIBPAPER GHOSTSCRIPT
|
||||
NO_OPTIONS_SORT= yes
|
||||
|
@ -78,7 +77,7 @@ NO_OPTIONS_SORT= yes
|
|||
LIBUSB_DESC= USB support
|
||||
GHOSTSCRIPT_DESC= Build pdftops with GHOSTSCRIPT
|
||||
XPDF_DESC= Build pdftops with XPDF
|
||||
XDG_OPEN= Build with XDG_OPEN as browser
|
||||
XDG_OPEN_DESC= Build with XDG_OPEN as browser
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
|
|
28
print/cups-base/files/patch-cups-request.c
Normal file
28
print/cups-base/files/patch-cups-request.c
Normal file
|
@ -0,0 +1,28 @@
|
|||
--- cups/request.c
|
||||
+++ cups/request.c
|
||||
@@ -1004,6 +1004,25 @@
|
||||
httpClose(cg->http);
|
||||
cg->http = NULL;
|
||||
}
|
||||
+ else
|
||||
+ {
|
||||
+ /*
|
||||
+ * Same server, see if the connection is still established...
|
||||
+ */
|
||||
+
|
||||
+ char ch; /* Connection check byte */
|
||||
+
|
||||
+ if (recv(cg->http->fd, &ch, 1, MSG_PEEK | MSG_DONTWAIT) < 0 &&
|
||||
+ errno != EWOULDBLOCK)
|
||||
+ {
|
||||
+ /*
|
||||
+ * Nope, close the connection...
|
||||
+ */
|
||||
+
|
||||
+ httpClose(cg->http);
|
||||
+ cg->http = NULL;
|
||||
+ }
|
||||
+ }
|
||||
}
|
||||
|
||||
/*
|
Loading…
Reference in a new issue