- Convert to USES=localbase sqlite
- Add LICENSE_FILE - Register proxy dependencies found by stage-qa - Fix absolute path link - Use options helper for DOCS installation - Regenerate patch with make makepatch
This commit is contained in:
parent
e12d0b5334
commit
8f04487f5a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=420935
2 changed files with 10 additions and 10 deletions
|
@ -10,20 +10,19 @@ MAINTAINER= ports@FreeBSD.org
|
|||
COMMENT= WebTV player based on GTK3+ and LibVLC
|
||||
|
||||
LICENSE= GPLv3
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
LIB_DEPENDS= libvlc.so:multimedia/vlc \
|
||||
libdbus-1.so:devel/dbus \
|
||||
libdbus-glib-1.so:devel/dbus-glib \
|
||||
libsqlite3.so:databases/sqlite3 \
|
||||
libcurl.so:ftp/curl \
|
||||
libnotify.so:devel/libnotify
|
||||
|
||||
USES= gmake iconv libtool pkgconfig
|
||||
USE_GNOME= gtk30 intltool
|
||||
USES= gmake iconv libtool localbase pkgconfig sqlite
|
||||
USE_GNOME= cairo gtk30 intltool
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-gtk=3.0
|
||||
CFLAGS+= -Wno-return-type -w
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LIBS+= -L${LOCALBASE}/lib
|
||||
INSTALLS_ICONS= yes
|
||||
|
||||
PORTDOCS= AUTHORS ChangeLog README
|
||||
|
@ -48,10 +47,11 @@ pre-configure:
|
|||
${WRKSRC}/src/main.c
|
||||
|
||||
post-install:
|
||||
(cd ${STAGEDIR}${PREFIX}/share/pixmaps && \
|
||||
${LN} -sf ../icons/hicolor/48x48/apps/${PORTNAME}.png)
|
||||
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
|
||||
${STAGEDIR}${PREFIX}/share/pixmaps/
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- data/ui/addchannelsgroups.glade.orig 2014-01-18 15:47:31.000000000 +0100
|
||||
+++ data/ui/addchannelsgroups.glade 2015-01-26 21:44:08.000000000 +0100
|
||||
--- data/ui/addchannelsgroups.glade.orig 2014-01-18 14:47:31 UTC
|
||||
+++ data/ui/addchannelsgroups.glade
|
||||
@@ -1,7 +1,22 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
+<!-- Generated with glade 3.18.3 -->
|
||||
|
|
Loading…
Reference in a new issue