The mdtest software is used for testing the metadata
performance of a file system. WWW: http://www.llnl.gov/icc/lc/siop/ PR: ports/112237 Submitted by: Chao Shin <quakelee at cn.freebsd.org>
This commit is contained in:
parent
17b108023a
commit
8f060f3ca4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=191184
5 changed files with 60 additions and 0 deletions
|
@ -24,6 +24,7 @@
|
|||
SUBDIR += iperf
|
||||
SUBDIR += libmicro
|
||||
SUBDIR += lmbench
|
||||
SUBDIR += mdtest
|
||||
SUBDIR += nbench
|
||||
SUBDIR += netio
|
||||
SUBDIR += netperf
|
||||
|
|
42
benchmarks/mdtest/Makefile
Normal file
42
benchmarks/mdtest/Makefile
Normal file
|
@ -0,0 +1,42 @@
|
|||
# New ports collection makefile for: mdtest
|
||||
# Date created: 2007-4-20
|
||||
# Whom: Chao Shin <quakelee@cn.freebsd.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= mdtest
|
||||
PORTVERSION= 1.7.1
|
||||
CATEGORIES= benchmarks
|
||||
MASTER_SITES= http://www.llnl.gov/icc/lc/siop/downloads/
|
||||
|
||||
MAINTAINER= quakelee@cn.FreeBSD.org
|
||||
COMMENT= A filesystem metadata benchmark utility
|
||||
|
||||
PLIST_FILES= bin/mdtest
|
||||
|
||||
OPTIONS= OPENMPI "Use openmpi instead of mpich2" off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_OPENMPI)
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
|
||||
RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/lib/libmpi.so:${PORTSDIR}/net/openmpi
|
||||
MPICC= ${LOCALBASE}/mpi/openmpi/bin/mpicc
|
||||
.else
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpicc:${PORTSDIR}/net/mpich2
|
||||
RUN_DEPENDS+= ${LOCALBASE}/mpich2/lib/libmpich.so:${PORTSDIR}/net/mpich2
|
||||
MPICC= ${LOCALBASE}/mpich2/bin/mpicc
|
||||
.endif
|
||||
|
||||
USE_GMAKE= yes
|
||||
ALL_TARGET= mdtest
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%MPICC%%|${MPICC}|' ${WRKSRC}/${MAKEFILE}
|
||||
|
||||
do-install:
|
||||
${STRIP_CMD} ${WRKSRC}/mdtest
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/mdtest ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.post.mk>
|
3
benchmarks/mdtest/distinfo
Normal file
3
benchmarks/mdtest/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (mdtest-1.7.1.tar.gz) = 4ea34d1f9d0c498e47edf694a3962e9b
|
||||
SHA256 (mdtest-1.7.1.tar.gz) = 1ebe974d1c275c2abb9ab06a09506ab908718f2e6a73780956d0a89db40c3024
|
||||
SIZE (mdtest-1.7.1.tar.gz) = 11344
|
10
benchmarks/mdtest/files/patch-Makefile
Normal file
10
benchmarks/mdtest/files/patch-Makefile
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- Makefile.orig Sun Apr 29 16:35:18 2007
|
||||
+++ Makefile Sun Apr 29 16:42:07 2007
|
||||
@@ -21,6 +21,7 @@
|
||||
|
||||
CC.AIX = mpcc_r -bmaxdata:0x80000000
|
||||
CC.Linux = mpicc -Wall
|
||||
+CC.FreeBSD = %%MPICC%% -Wall
|
||||
|
||||
# Requires GNU Make
|
||||
OS=$(shell uname)
|
4
benchmarks/mdtest/pkg-descr
Normal file
4
benchmarks/mdtest/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
The mdtest software is used for testing the metadata
|
||||
performance of a file system.
|
||||
|
||||
WWW: http://www.llnl.gov/icc/lc/siop/
|
Loading…
Reference in a new issue