Update to version 1.8.1
PR: ports/73731 Submitted by: Ports Fury
This commit is contained in:
parent
5c6918e613
commit
8f138b6174
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=121221
6 changed files with 36 additions and 18 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= kbarcode
|
||||
PORTVERSION= 1.6.2
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.8.1
|
||||
CATEGORIES= graphics kde
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
@ -18,12 +17,15 @@ COMMENT= A barcode and label printing application for KDE
|
|||
RUN_DEPENDS= barcode:${PORTSDIR}/graphics/barcode
|
||||
|
||||
USE_KDELIBS_VER= 3
|
||||
USE_REINPLACE= yes
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_REINPLACE= yes
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
|
||||
${WRKSRC}/${CONFIGURE_SCRIPT}
|
||||
@${REINPLACE_CMD} -e 's,-O2,,g ; \
|
||||
s,-lpthread,${PTHREAD_LIBS},g' ${WRKSRC}/${CONFIGURE_SCRIPT}
|
||||
@${REINPLACE_CMD} -e \
|
||||
's,$$(LIB_KDEUI)$$,$$(LIB_KDEUI) $$(LIBPTHREAD),g' \
|
||||
${WRKSRC}/kbarcode/Makefile.in
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (kbarcode-1.6.2.tar.gz) = 8a45acb02583c50f0ff363c8c4c78688
|
||||
SIZE (kbarcode-1.6.2.tar.gz) = 961761
|
||||
MD5 (kbarcode-1.8.1.tar.gz) = 5868383df659a1cf4ba696916c1f12b8
|
||||
SIZE (kbarcode-1.8.1.tar.gz) = 969743
|
||||
|
|
11
graphics/kbarcode/files/patch-kbarcode::labeleditor.cpp
Normal file
11
graphics/kbarcode/files/patch-kbarcode::labeleditor.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- kbarcode/labeleditor.cpp.orig Tue Jul 20 05:57:28 2004
|
||||
+++ kbarcode/labeleditor.cpp Mon Aug 23 17:25:56 2004
|
||||
@@ -552,7 +552,7 @@
|
||||
exportZPLAct = new KAction( i18n("...as &IPL or ZPL"), 0, 0, this, SLOT(exportZPL() ), actionCollection() );
|
||||
descriptionAct = new KAction( i18n("&Change description..."), 0, 0, this, SLOT(changeDes()), actionCollection() );
|
||||
deleteAct = new KAction( i18n("&Delete Object"), QIconSet( BarIcon("editdelete") ), Key_Delete, cv, SLOT( deleteCurrent() ), actionCollection() );
|
||||
- editPropAct = new KAction( i18n("&Properties..."), 0, 0, this, SLOT(), actionCollection() );
|
||||
+ editPropAct = new KAction( i18n("&Properties..."), 0, 0, this, SLOT( doubleClickedCurrent() ), actionCollection() );
|
||||
printAct = KStdAction::print( this, SLOT( print() ), actionCollection(), "print" );
|
||||
changeSizeAct = new KAction( i18n("&Change Label..."), 0, 0, this, SLOT( changeSize() ), actionCollection() );
|
||||
barcodeAct = new KAction( i18n("Insert &Barcode"), QIconSet( BarIcon("barcode") ), 0, this, SLOT( insertBarcode() ), actionCollection() );
|
11
graphics/kbarcode/files/patch-kbarcode::tokenprovider.h
Normal file
11
graphics/kbarcode/files/patch-kbarcode::tokenprovider.h
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- kbarcode/tokenprovider.h.orig Wed Jun 30 17:18:40 2004
|
||||
+++ kbarcode/tokenprovider.h Mon Aug 23 16:23:32 2004
|
||||
@@ -18,6 +18,8 @@
|
||||
#ifndef TOKENPROVIDER_H
|
||||
#define TOKENPROVIDER_H
|
||||
|
||||
+#include <time.h>
|
||||
+
|
||||
#include <qstring.h>
|
||||
#include <qregexp.h>
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- kbarcode/Makefile.in.orig Fri May 21 23:23:23 2004
|
||||
+++ kbarcode/Makefile.in Fri May 21 23:24:01 2004
|
||||
@@ -259,7 +259,7 @@
|
||||
|
||||
# the application source, library search path, and link libraries
|
||||
kbarcode_LDFLAGS = $(KDE_RPATH) $(all_libraries)
|
||||
-kbarcode_LDADD = $(LIB_KABC) $(LIB_KSPELL) $(LIB_KDEPRINT) $(LIB_KDEUI)
|
||||
+kbarcode_LDADD = $(LIB_KABC) $(LIB_KSPELL) $(LIB_KDEPRINT) $(LIB_KDEUI) $(LIBPTHREAD)
|
||||
noinst_HEADERS = barcodecache.h barcodecombo.h barcodedialog.h barcodedialogs.h commands.h configdialog.h confwizard.h csvimportdlg.h databasebrowser.h definition.h definitiondialog.h dsmainwindow.h dsrichtext.h kbarcode.h label.h labeleditor.h labelprinter.h labelutils.h mimesources.h multilineeditdlg.h mybarcode.h mycanvasitem.h mycanvasview.h mydatatable.h newlabel.h previewdialog.h printersettings.h printlabeldlg.h rectsettingsdlg.h smalldialogs.h sqltables.h tokenprovider.h xmlutils.h zplutils.h
|
||||
kbarcode_SOURCES = barcodecombo.cpp barcodecache.cpp barcodedialog.cpp barcodedialogs.cpp commands.cpp configdialog.cpp confwizard.cpp csvimportdlg.cpp databasebrowser.cpp definition.cpp definitiondialog.cpp dsmainwindow.cpp dsrichtext.cpp kbarcode.cpp label.cpp labeleditor.cpp labelprinter.cpp labelutils.cpp main.cpp mimesources.cpp multilineeditdlg.cpp mybarcode.cpp mycanvasitem.cpp mycanvasview.cpp mydatatable.cpp newlabel.cpp previewdialog.cpp printersettings.cpp printlabeldlg.cpp rectsettingsdlg.cpp smalldialogs.cpp sqltables.cpp tokenprovider.cpp xmlutils.cpp zplutils.cpp
|
||||
|
|
@ -1,4 +1,6 @@
|
|||
bin/kbarcode
|
||||
lib/kde3/kfile_kbarcode.la
|
||||
lib/kde3/kfile_kbarcode.so
|
||||
share/applnk/Applications/KBarcode/kbarcode-batch.desktop
|
||||
share/applnk/Applications/KBarcode/kbarcode-editor.desktop
|
||||
share/applnk/Applications/KBarcode/kbarcode-label.desktop
|
||||
|
@ -25,7 +27,10 @@ share/locale/fi/LC_MESSAGES/kbarcode.mo
|
|||
share/locale/fr/LC_MESSAGES/kbarcode.mo
|
||||
share/locale/hu/LC_MESSAGES/kbarcode.mo
|
||||
share/locale/it/LC_MESSAGES/kbarcode.mo
|
||||
share/locale/nl/LC_MESSAGES/kbarcode.mo
|
||||
share/locale/pl/LC_MESSAGES/kbarcode.mo
|
||||
share/locale/sv/LC_MESSAGES/kbarcode.mo
|
||||
share/services/kfile_kbarcode.desktop
|
||||
@unexec rmdir %D/share/icons/hicolor/64x64/apps 2>/dev/null || true
|
||||
@unexec rmdir %D/share/icons/hicolor/32x32/apps 2>/dev/null || true
|
||||
@unexec rmdir %D/share/icons/hicolor/32x32/actions 2>/dev/null || true
|
||||
|
|
Loading…
Reference in a new issue