New port py-imaging, the Python Image Library.
This commit is contained in:
parent
dc1bbf6ac4
commit
8f20f01502
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=14356
7 changed files with 293 additions and 0 deletions
63
graphics/py-imaging/Makefile
Normal file
63
graphics/py-imaging/Makefile
Normal file
|
@ -0,0 +1,63 @@
|
|||
# New ports collection makefile for: PIL
|
||||
# Version required: 0.3b2
|
||||
# Date created: 02 November 1998
|
||||
# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= Imaging-0.3b2
|
||||
PKGNAME= py-imaging-0.3b2
|
||||
CATEGORIES= graphics python
|
||||
MASTER_SITES= http://www.pythonware.com/downloads/
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} pyth151.tgz
|
||||
|
||||
MAINTAINER= tg@FreeBSD.ORG
|
||||
|
||||
BUILD_DEPENDS= python:${PORTSDIR}/lang/python
|
||||
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
|
||||
RUN_DEPENDS= python:${PORTSDIR}/lang/python
|
||||
|
||||
DIST_SUBDIR= python
|
||||
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/libImaging
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-jpeg=${PREFIX}/lib
|
||||
MAKE_FLAGS= OPT="${CFLAGS}"
|
||||
|
||||
PYTHONSCRIPTDIR= ${PREFIX}/lib/python1.5
|
||||
PILDIR= ${PYTHONSCRIPTDIR}/site-packages/PIL
|
||||
PILDOCDIR= ${PREFIX}/share/doc/PIL
|
||||
PILEXDIR= ${PREFIX}/share/examples/PIL
|
||||
TKINTERORIG= ${PYTHONSCRIPTDIR}/lib-dynload/_tkinter.so
|
||||
|
||||
post-extract:
|
||||
@(cd ${WRKDIR}; ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/pyth151.tgz \
|
||||
Python-1.5.1/Modules/_tkinter.c Python-1.5.1/Modules/tkappinit.c)
|
||||
@${MV} ${WRKDIR}/Python-1.5.1/Modules/* ${WRKSRC}/..
|
||||
@${CP} ${FILESDIR}/Setup ${WRKSRC}/..
|
||||
|
||||
post-configure:
|
||||
@(cd ${WRKSRC}/..; ${SETENV} ${MAKE_ENV} ${MAKE} -f Makefile.pre.in boot)
|
||||
|
||||
post-build:
|
||||
@(cd ${WRKSRC}/..; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} sharedmods)
|
||||
|
||||
do-install:
|
||||
if test -f ${TKINTERORIG}; then \
|
||||
${MV} ${TKINTERORIG} ${TKINTERORIG}.save; \
|
||||
else true; \
|
||||
fi
|
||||
@(cd ${WRKSRC}/..; ${SETENV} ${MAKE_ENV} ${MAKE} install)
|
||||
@${MKDIR} ${PILDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/../PIL/* ${PILDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/../PIL.pth ${PILDIR}/..
|
||||
@${PREFIX}/bin/python ${PYTHONSCRIPTDIR}/compileall.py ${PILDIR}
|
||||
@${PREFIX}/bin/python -O ${PYTHONSCRIPTDIR}/compileall.py ${PILDIR}
|
||||
@${MKDIR} ${PILDOCDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/../README ${PILDOCDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/../FORMATS ${PILDOCDIR}
|
||||
@${MKDIR} ${PILEXDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/../Scripts/* ${PILEXDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
2
graphics/py-imaging/distinfo
Normal file
2
graphics/py-imaging/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (python/Imaging-0.3b2.tar.gz) = 843b3cd31b1a7f7acfc651630c8862bd
|
||||
MD5 (python/pyth151.tgz) = eb8ef6e37e543058a2d47996ecf62427
|
4
graphics/py-imaging/files/Setup
Normal file
4
graphics/py-imaging/files/Setup
Normal file
|
@ -0,0 +1,4 @@
|
|||
*noconfig*
|
||||
|
||||
_imaging _imaging.c decode.c encode.c map.c display.c path.c -IlibImaging libImaging/libImaging.a -I${PREFIX}/include -L${PREFIX}/lib -ljpeg -lz
|
||||
_tkinter _tkinter.c Tk/tkImaging.c tkappinit.c -DWITH_APPINIT -DWITH_PIL -IlibImaging -I${X11BASE}/include -I${PREFIX}/include/tcl8.0 -I${PREFIX}/include/tk8.0 -L${PREFIX}/lib -ltk80 -ltcl80 -L${X11BASE}/lib -lX11 -lc
|
18
graphics/py-imaging/files/patch-aa
Normal file
18
graphics/py-imaging/files/patch-aa
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- Makefile.in.orig Sun Jul 19 16:34:24 1998
|
||||
+++ Makefile.in Wed Nov 4 10:00:01 1998
|
||||
@@ -25,13 +25,13 @@
|
||||
|
||||
DEFS= @DEFS@
|
||||
|
||||
-LIBS= @LIBS@ @LIBM@
|
||||
+LIBS= @LDFLAGS@ @LIBS@ @LIBM@
|
||||
|
||||
# --------------------------------------------------------------------
|
||||
# Other things that are customizable but not by configure
|
||||
|
||||
INCLDIR= $(srcdir)/.
|
||||
-JPEGINCLUDE= /usr/local/include
|
||||
+JPEGINCLUDE= @prefix@/include
|
||||
OPT= @OPT@
|
||||
#OPT= -g
|
||||
CFLAGS= $(OPT) -I$(INCLDIR) -I$(JPEGINCLUDE) $(DEFS)
|
1
graphics/py-imaging/pkg-comment
Normal file
1
graphics/py-imaging/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
The Python Imaging Library
|
13
graphics/py-imaging/pkg-descr
Normal file
13
graphics/py-imaging/pkg-descr
Normal file
|
@ -0,0 +1,13 @@
|
|||
The Python Imaging Library adds image processing capabilities to your
|
||||
Python interpreter. This library provides extensive file format
|
||||
support, an efficient internal representation, and fairly powerful
|
||||
image processing capabilities.
|
||||
|
||||
The main distribution site for this software is:
|
||||
|
||||
http://www.pythonware.com
|
||||
|
||||
The PIL handbook is not included in this distribution; to get the
|
||||
latest version, check:
|
||||
|
||||
http://www.pythonware.com/library.htm
|
192
graphics/py-imaging/pkg-plist
Normal file
192
graphics/py-imaging/pkg-plist
Normal file
|
@ -0,0 +1,192 @@
|
|||
lib/python1.5/site-packages/PIL/ArgImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/ArgImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/ArgImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/BdfFontFile.py
|
||||
lib/python1.5/site-packages/PIL/BdfFontFile.pyc
|
||||
lib/python1.5/site-packages/PIL/BdfFontFile.pyo
|
||||
lib/python1.5/site-packages/PIL/BmpImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/BmpImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/BmpImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/ContainerIO.py
|
||||
lib/python1.5/site-packages/PIL/ContainerIO.pyc
|
||||
lib/python1.5/site-packages/PIL/ContainerIO.pyo
|
||||
lib/python1.5/site-packages/PIL/CurImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/CurImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/CurImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/DcxImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/DcxImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/DcxImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/EpsImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/EpsImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/EpsImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/FliImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/FliImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/FliImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/FontFile.py
|
||||
lib/python1.5/site-packages/PIL/FontFile.pyc
|
||||
lib/python1.5/site-packages/PIL/FontFile.pyo
|
||||
lib/python1.5/site-packages/PIL/FpxImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/FpxImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/FpxImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/GbrImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/GbrImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/GbrImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/GdImageFile.py
|
||||
lib/python1.5/site-packages/PIL/GdImageFile.pyc
|
||||
lib/python1.5/site-packages/PIL/GdImageFile.pyo
|
||||
lib/python1.5/site-packages/PIL/GifImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/GifImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/GifImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/GimpGradientFile.py
|
||||
lib/python1.5/site-packages/PIL/GimpGradientFile.pyc
|
||||
lib/python1.5/site-packages/PIL/GimpGradientFile.pyo
|
||||
lib/python1.5/site-packages/PIL/GimpPaletteFile.py
|
||||
lib/python1.5/site-packages/PIL/GimpPaletteFile.pyc
|
||||
lib/python1.5/site-packages/PIL/GimpPaletteFile.pyo
|
||||
lib/python1.5/site-packages/PIL/IcoImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/IcoImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/IcoImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/ImImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/ImImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/ImImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/Image.py
|
||||
lib/python1.5/site-packages/PIL/Image.pyc
|
||||
lib/python1.5/site-packages/PIL/Image.pyo
|
||||
lib/python1.5/site-packages/PIL/ImageChops.py
|
||||
lib/python1.5/site-packages/PIL/ImageChops.pyc
|
||||
lib/python1.5/site-packages/PIL/ImageChops.pyo
|
||||
lib/python1.5/site-packages/PIL/ImageDraw.py
|
||||
lib/python1.5/site-packages/PIL/ImageDraw.pyc
|
||||
lib/python1.5/site-packages/PIL/ImageDraw.pyo
|
||||
lib/python1.5/site-packages/PIL/ImageEnhance.py
|
||||
lib/python1.5/site-packages/PIL/ImageEnhance.pyc
|
||||
lib/python1.5/site-packages/PIL/ImageEnhance.pyo
|
||||
lib/python1.5/site-packages/PIL/ImageFile.py
|
||||
lib/python1.5/site-packages/PIL/ImageFile.pyc
|
||||
lib/python1.5/site-packages/PIL/ImageFile.pyo
|
||||
lib/python1.5/site-packages/PIL/ImageFilter.py
|
||||
lib/python1.5/site-packages/PIL/ImageFilter.pyc
|
||||
lib/python1.5/site-packages/PIL/ImageFilter.pyo
|
||||
lib/python1.5/site-packages/PIL/ImageFont.py
|
||||
lib/python1.5/site-packages/PIL/ImageFont.pyc
|
||||
lib/python1.5/site-packages/PIL/ImageFont.pyo
|
||||
lib/python1.5/site-packages/PIL/ImagePalette.py
|
||||
lib/python1.5/site-packages/PIL/ImagePalette.pyc
|
||||
lib/python1.5/site-packages/PIL/ImagePalette.pyo
|
||||
lib/python1.5/site-packages/PIL/ImagePath.py
|
||||
lib/python1.5/site-packages/PIL/ImagePath.pyc
|
||||
lib/python1.5/site-packages/PIL/ImagePath.pyo
|
||||
lib/python1.5/site-packages/PIL/ImageSequence.py
|
||||
lib/python1.5/site-packages/PIL/ImageSequence.pyc
|
||||
lib/python1.5/site-packages/PIL/ImageSequence.pyo
|
||||
lib/python1.5/site-packages/PIL/ImageStat.py
|
||||
lib/python1.5/site-packages/PIL/ImageStat.pyc
|
||||
lib/python1.5/site-packages/PIL/ImageStat.pyo
|
||||
lib/python1.5/site-packages/PIL/ImageTk.py
|
||||
lib/python1.5/site-packages/PIL/ImageTk.pyc
|
||||
lib/python1.5/site-packages/PIL/ImageTk.pyo
|
||||
lib/python1.5/site-packages/PIL/ImageWin.py
|
||||
lib/python1.5/site-packages/PIL/ImageWin.pyc
|
||||
lib/python1.5/site-packages/PIL/ImageWin.pyo
|
||||
lib/python1.5/site-packages/PIL/ImtImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/ImtImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/ImtImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/IptcImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/IptcImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/IptcImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/JpegImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/JpegImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/JpegImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/McIdasImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/McIdasImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/McIdasImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/MicImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/MicImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/MicImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/MpegImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/MpegImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/MpegImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/MspImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/MspImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/MspImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/OleFileIO.py
|
||||
lib/python1.5/site-packages/PIL/OleFileIO.pyc
|
||||
lib/python1.5/site-packages/PIL/OleFileIO.pyo
|
||||
lib/python1.5/site-packages/PIL/PSDraw.py
|
||||
lib/python1.5/site-packages/PIL/PSDraw.pyc
|
||||
lib/python1.5/site-packages/PIL/PSDraw.pyo
|
||||
lib/python1.5/site-packages/PIL/PaletteFile.py
|
||||
lib/python1.5/site-packages/PIL/PaletteFile.pyc
|
||||
lib/python1.5/site-packages/PIL/PaletteFile.pyo
|
||||
lib/python1.5/site-packages/PIL/PcdImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/PcdImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/PcdImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/PcfFontFile.py
|
||||
lib/python1.5/site-packages/PIL/PcfFontFile.pyc
|
||||
lib/python1.5/site-packages/PIL/PcfFontFile.pyo
|
||||
lib/python1.5/site-packages/PIL/PcxImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/PcxImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/PcxImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/PdfImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/PdfImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/PdfImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/PixarImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/PixarImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/PixarImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/PngImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/PngImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/PngImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/PpmImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/PpmImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/PpmImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/PsdImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/PsdImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/PsdImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/SgiImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/SgiImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/SgiImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/SunImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/SunImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/SunImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/TarIO.py
|
||||
lib/python1.5/site-packages/PIL/TarIO.pyc
|
||||
lib/python1.5/site-packages/PIL/TarIO.pyo
|
||||
lib/python1.5/site-packages/PIL/TgaImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/TgaImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/TgaImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/TiffImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/TiffImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/TiffImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/WmfImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/WmfImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/WmfImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/XbmImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/XbmImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/XbmImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL/XpmImagePlugin.py
|
||||
lib/python1.5/site-packages/PIL/XpmImagePlugin.pyc
|
||||
lib/python1.5/site-packages/PIL/XpmImagePlugin.pyo
|
||||
lib/python1.5/site-packages/PIL.pth
|
||||
lib/python1.5/site-packages/_imaging.so
|
||||
lib/python1.5/site-packages/_tkinter.so
|
||||
share/doc/PIL/FORMATS
|
||||
share/doc/PIL/README
|
||||
share/examples/PIL/README
|
||||
share/examples/PIL/bdf2pil.py
|
||||
share/examples/PIL/enhancer.py
|
||||
share/examples/PIL/explode.py
|
||||
share/examples/PIL/gifmaker.py
|
||||
share/examples/PIL/image2py.py
|
||||
share/examples/PIL/painter.py
|
||||
share/examples/PIL/pilconvert.py
|
||||
share/examples/PIL/pilfile.py
|
||||
share/examples/PIL/pilfont.py
|
||||
share/examples/PIL/pilprint.py
|
||||
share/examples/PIL/player.py
|
||||
share/examples/PIL/thresholder.py
|
||||
share/examples/PIL/viewer.py
|
||||
@dirrm lib/python1.5/site-packages/PIL
|
||||
@dirrm share/doc/PIL
|
||||
@dirrm share/examples/PIL
|
||||
@exec [ -f %D/lib/python1.5/lib-dynload/_tkinter.so ] && mv %D/lib/python1.5/lib-dynload/_tkinter.so %D/lib/python1.5/lib-dynload/_tkinter.so.save || true
|
||||
@unexec [ -f %D/lib/python1.5/lib-dynload/_tkinter.so.save ] && mv %D/lib/python1.5/lib-dynload/_tkinter.so.save %D/lib/python1.5/lib-dynload/_tkinter.so || true
|
Loading…
Reference in a new issue