- Update to 6.0

- Take maintainership

PR:		ports/110528
Submitted by:	Tomas Verbaitis <tomasv@megalogika.lt>
This commit is contained in:
Pav Lucistnik 2007-03-22 17:09:48 +00:00
parent da167dde05
commit 8f3561d38a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=188045
7 changed files with 29 additions and 185 deletions

View file

@ -8,39 +8,36 @@
#
PORTNAME= cups-samba
PORTVERSION= 5.0.r3
PORTVERSION= 6.0
CATEGORIES= print net
MASTER_SITES= ftp://ftp.easysw.com/pub/cups/windows/ \
ftp://ftp2.easysw.com/pub/cups/windows/ \
ftp://ftp3.easysw.com/pub/cups/windows/
DISTNAME= ${PORTNAME}-5.0rc3
MASTER_SITES= ${MASTER_SITE_EASYSW}
MASTER_SITE_SUBDIR=cups/windows
DISTNAME= cups-windows-${PORTVERSION}-source
MAINTAINER= ports@FreeBSD.org
MAINTAINER= tomasv@megalogika.lt
COMMENT= The Common UNIX Printing System: MS Windows client drivers
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
tardy:${PORTSDIR}/archivers/tardy \
${LOCALBASE}/sbin/cupsd:${PORTSDIR}/print/cups-base \
smbspool:${PORTSDIR}/net/samba3
RUN_DEPENDS= smbspool:${PORTSDIR}/net/samba3 \
${LOCALBASE}/sbin/cupsd:${PORTSDIR}/print/cups-base \
espgs:${PORTSDIR}/print/cups-pstoraster
${LOCALBASE}/sbin/cupsd:${PORTSDIR}/print/cups-base
NO_BUILD= yes
NO_WRKSUBDIR= yes
SH= ${LOCALBASE}/bin/bash
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
-e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
-e 's|%%TARDY%%|${LOCALBASE}/bin/tardy|g' \
${WRKSRC}/cups-samba.install \
${WRKSRC}/cups-samba.remove
DATADIR= ${TARGETDIR}/share/cups
DRIVER_FILES= cups6.inf cups6.ini cupsps6.dll cupsui6.dll
SUB_FILES= pkg-message
pre-install:
${MKDIR} ${DATADIR}/drivers
do-install:
cd ${WRKSRC} && ${SH} ${WRKSRC}/cups-samba.install now
cd ${WRKSRC} && \
for DRVFILE in ${DRIVER_FILES}; do \
${INSTALL_DATA} ${WRKSRC}/cups-windows-${PORTVERSION}/i386/$${DRVFILE} ${DATADIR}/drivers; \
done
post-install:
@${CAT} ${PKGMESSAGE} | ${SED} 's|%%PREFIX%%|${PREFIX}|g'
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
MD5 (cups-samba-5.0rc3.tar.gz) = 2ac3f000a2e3298a2d86360978556c17
SHA256 (cups-samba-5.0rc3.tar.gz) = 20e502ad533837b90721f1993060a14850cfebaa9222a1843945a45d11456f88
SIZE (cups-samba-5.0rc3.tar.gz) = 199167
MD5 (cups-windows-6.0-source.tar.gz) = 0bca9beb6e84439623781168ab0987f3
SHA256 (cups-windows-6.0-source.tar.gz) = 04ad065a7df6ff930f3b6ec6bc6cfeb7a7507ba9bfb97490f5a454b18ebfdf1d
SIZE (cups-windows-6.0-source.tar.gz) = 39879

View file

@ -1,115 +0,0 @@
--- cups-samba.install.orig Sat Jan 3 19:49:11 2004
+++ cups-samba.install Fri Jul 2 22:45:16 2004
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!%%LOCALBASE%%/bin/bash
# Installation script for CUPS - SAMBA Drivers for Windows NT/2k/XP/2k3 version 5.0rc3.
# Produced using ESP Package Manager v3.7.0; report problems to epm@easysw.com.
#%product CUPS - SAMBA Drivers for Windows NT/2k/XP/2k3
@@ -8,8 +8,8 @@
#%rootsize 0
#%usrsize 503
#
-PATH=/usr/xpg4/bin:/bin:/usr/bin:/usr/ucb:${PATH}
-SHELL=/bin/sh
+PATH=/bin:/usr/bin:${PATH}
+SHELL=%%LOCALBASE%%/bin/bash
case "`uname`" in
Darwin*)
case "`id -un`" in
@@ -44,13 +44,7 @@
ac_c='\c'
fi
# Determine correct extract options for the tar command...
-if test `uname` = Darwin; then
- ac_tar="tar -xpPf"
-else if test "`tar --help 2>&1 | grep GNU`" = ""; then
- ac_tar="tar -xpf"
-else
- ac_tar="tar -xpPf"
-fi fi
+ac_tar="tar -xpPf"
if test "$*" = "now"; then
echo Software license silently accepted via command-line option.
else
@@ -91,9 +85,9 @@
esac
done
fi
-if test -x /etc/software/cups-samba.remove; then
+if test -x %%LOCALBASE%%/etc/software/cups-samba.remove; then
echo Removing old versions of cups-samba software...
- /etc/software/cups-samba.remove now
+ %%LOCALBASE%%/etc/software/cups-samba.remove now
fi
case `uname` in
AIX)
@@ -134,7 +128,7 @@
*)
dfroot=`df -k / | tr '\n' ' '`
- dfusr=`df -k /usr | tr '\n' ' '`
+ dfusr=`df -k %%PREFIX%% | tr '\n' ' '`
fsroot=`echo $dfroot | awk '{print $13}'`
sproot=`echo $dfroot | awk '{print $11}'`
fsusr=`echo $dfusr | awk '{print $13}'`
@@ -167,44 +161,45 @@
if test $spss -gt $spusr; then
echo Not enough free disk space for software:
- echo You need $spss kbytes in /usr but only have $spusr kbytes available.
+ echo You need $spss kbytes in %%PREFIX%% but only have $spusr kbytes available.
exit 1
fi
fi
fi
-if test -w /usr ; then
+if test -w %%LOCALBASE%% ; then
echo Backing up old versions of shared files to be installed...
- for file in /usr/share/cups/drivers/cups5.hlp /usr/share/cups/drivers/cupsdrv5.dll /usr/share/cups/drivers/cupsui5.dll; do
+ for file in %%LOCALBASE%%/share/cups/drivers/cups5.hlp %%LOCALBASE%%/share/cups/drivers/cupsdrv5.dll %%LOCALBASE%%/share/cups/drivers/cupsui5.dll; do
if test -d "$file" -o -f "$file" -o -h "$file"; then
mv -f "$file" "$file.O"
fi
done
fi
echo Installing software...
-if echo Write Test >/usr/.writetest 2>/dev/null; then
- $ac_tar cups-samba.ss
+if echo Write Test >%%PREFIX%%/.writetest 2>/dev/null; then
+ %%TARDY%% -Remove_Prefix /usr/share/cups/drivers -Prefix %%PREFIX%%/share/cups/drivers cups-samba.ss cups-samba.tar
+ $ac_tar cups-samba.tar
fi
-if test -d /etc/software; then
- rm -f /etc/software/cups-samba.remove
+if test -d %%LOCALBASE%%/etc/software; then
+ rm -f %%LOCALBASE%%/etc/software/cups-samba.remove
else
- mkdir -p /etc/software
+ mkdir -p %%PREFIX%%/etc/software
fi
-cp cups-samba.remove /etc/software
-chmod 544 /etc/software/cups-samba.remove
+cp cups-samba.remove %%PREFIX%%/etc/software
+chmod 544 %%PREFIX%%/etc/software/cups-samba.remove
echo Updating file permissions...
-if test -f /usr/.writetest; then
- rm -f /usr/.writetest
+if test -f %%PREFIX%%/.writetest; then
+ rm -f %%PREFIX%%/.writetest
fi
echo Running post-install commands...
# Look for smbspool program in the path and various standard directories...
smbpath=`echo $PATH | tr ':' ' '`
-smbpath="$smbpath /bin /usr/bin /usr/samba/bin /usr/local/samba/bin"
+smbpath="$smbpath /bin /usr/bin /usr/samba/bin %%LOCALBASE%%/samba/bin"
smbpath="$smbpath /usr/freeware/samba/bin /opt/samba/bin"
smbpath="$smbpath /h/COTS/CIFS/bin/Samba/bin"
serverbin="$CUPS_SERVERBIN"
-for dir in /usr/libexec/cups /usr/lib/cups /usr/local/libexec/cups /usr/local/lib/cups; do
+for dir in /usr/libexec/cups /usr/lib/cups %%LOCALBASE%%/libexec/cups %%LOCALBASE%%/lib/cups; do
if test -d $dir; then
serverbin="$dir"
fi

View file

@ -1,37 +0,0 @@
--- cups-samba.remove.old Tue Feb 10 17:30:45 2004
+++ cups-samba.remove Tue Feb 10 17:45:55 2004
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!%%LOCALBASE%%/bin/bash
# Removal script for CUPS - SAMBA Drivers for Windows NT/2k/XP/2k3 version 5.0rc3.
# Produced using ESP Package Manager v3.7.0; report problems to epm@easysw.com.
#%product CUPS - SAMBA Drivers for Windows NT/2k/XP/2k3
@@ -8,8 +8,8 @@
#%rootsize 0
#%usrsize 503
#
-PATH=/usr/xpg4/bin:/bin:/usr/bin:/usr/ucb:${PATH}
-SHELL=/bin/sh
+PATH=/bin:/usr/bin:${PATH}
+SHELL=%%LOCALBASE%%/bin/bash
case "`uname`" in
Darwin*)
case "`id -un`" in
@@ -73,8 +73,8 @@
done
fi
echo Removing/restoring installed files...
-if test -w /usr ; then
- for file in /usr/share/cups/drivers/cups5.hlp /usr/share/cups/drivers/cupsdrv5.dll /usr/share/cups/drivers/cupsui5.dll; do
+if test -w %%PREFIX%% ; then
+ for file in %%PREFIX%%/share/cups/drivers/cups5.hlp %%PREFIX%%/share/cups/drivers/cupsdrv5.dll %%PREFIX%%/share/cups/drivers/cupsui5.dll; do
rm -f "$file"
if test -d "$file.O" -o -f "$file.O" -o -h "$file.O"; then
mv -f "$file.O" "$file"
@@ -82,5 +82,5 @@
done
fi
echo Checking configuration files...
-rm -f /etc/software/cups-samba.remove
+rm -f %%PREFIX%%/etc/software/cups-samba.remove
echo Removal is complete.

View file

@ -3,7 +3,8 @@ server to Windows NT/XP/2000/2003 clients with a single Windows
driver that customizes the printer based on the PPD file for the
printer.
WWW: http://www.easysw.com/
You will also need the Microsoft Windows PostScript drivers from
a Windows 2000 or higher system. Consult the cupsaddsmb(8) man page
for details.
--
John Merryweather Cooper <coop9211@uidaho.edu>
WWW: http://www.cups.org/windows/software.php

View file

@ -1,7 +1,5 @@
etc/software/cups-samba.remove
libexec/cups/backend/smb
share/cups/drivers/cups5.hlp
share/cups/drivers/cupsdrv5.dll
share/cups/drivers/cupsui5.dll
share/cups/drivers/cups6.inf
share/cups/drivers/cups6.ini
share/cups/drivers/cupsps6.dll
share/cups/drivers/cupsui6.dll
@dirrm share/cups/drivers
@dirrm etc/software