net/wmnetmon: Expand patches fix malloc.h-less DF

While here, regenerate all the patches to put them in unified format.
Wow, that old diff format is unreadable.
This commit is contained in:
John Marino 2015-11-13 00:04:37 +00:00
parent 070f7a6e7d
commit 8f3687f167
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=401469
8 changed files with 110 additions and 147 deletions

View file

@ -1,14 +1,12 @@
*** Makefile.in.orig Sat Jul 10 22:04:53 1999
--- Makefile.in Sun Apr 1 16:16:21 2001
***************
*** 11,19 ****
wmnetmon: $(OBJS)
$(CC) $(OBJS) -o wmnetmon $(LDFLAGS)
- .o:.c
- $(CC) $(CFLAGS) -c $.c -o $.o
-
install: wmnetmon
$(INSTALL) wmnetmon $(BINDIR) -o root --mode=4755
--- 11,16 ----
--- Makefile.in.orig 1999-07-10 19:04:53 UTC
+++ Makefile.in
@@ -11,9 +11,6 @@ all: wmnetmon
wmnetmon: $(OBJS)
$(CC) $(OBJS) -o wmnetmon $(LDFLAGS)
-.o:.c
- $(CC) $(CFLAGS) -c $.c -o $.o
-
install: wmnetmon
$(INSTALL) wmnetmon $(BINDIR) -o root --mode=4755

View file

@ -1,19 +1,11 @@
*** configure.orig Sun Apr 1 15:17:16 2001
--- configure Sun Apr 1 15:17:24 2001
***************
*** 1605,1611 ****
fi
! for ac_hdr in fcntl.h malloc.h sys/file.h sys/time.h unistd.h sys/types.h ctype.h X11/Xlib.h X11/xpm.h
do
ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
--- 1605,1611 ----
fi
! for ac_hdr in fcntl.h stdlib.h sys/file.h sys/time.h unistd.h sys/types.h ctype.h X11/Xlib.h X11/xpm.h
do
ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
--- configure.orig 1999-07-23 14:07:40 UTC
+++ configure
@@ -1605,7 +1605,7 @@ EOF
fi
-for ac_hdr in fcntl.h malloc.h sys/file.h sys/time.h unistd.h sys/types.h ctype.h X11/Xlib.h X11/xpm.h
+for ac_hdr in fcntl.h stdlib.h sys/file.h sys/time.h unistd.h sys/types.h ctype.h X11/Xlib.h X11/xpm.h
do
ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6

View file

@ -1,19 +1,11 @@
*** configure.in.orig Sun Apr 1 15:17:40 2001
--- configure.in Sun Apr 1 15:17:47 2001
***************
*** 43,49 ****
dnl Checks for header files.
AC_HEADER_STDC
! AC_CHECK_HEADERS(fcntl.h malloc.h sys/file.h sys/time.h unistd.h sys/types.h ctype.h X11/Xlib.h X11/xpm.h,,
AC_MSG_ERROR([Couldn't find some include files... aborting]))
AC_CHECK_HEADERS(netinet/in_systm.h netinet/in.h netinet/ip.h netinet/ip_icmp.h arpa/inet.h netdb.h sys/socket.h,,
AC_MSG_ERROR([Couldn't find network include files]))
--- 43,49 ----
dnl Checks for header files.
AC_HEADER_STDC
! AC_CHECK_HEADERS(fcntl.h stdlib.h sys/file.h sys/time.h unistd.h sys/types.h ctype.h X11/Xlib.h X11/xpm.h,,
AC_MSG_ERROR([Couldn't find some include files... aborting]))
AC_CHECK_HEADERS(netinet/in_systm.h netinet/in.h netinet/ip.h netinet/ip_icmp.h arpa/inet.h netdb.h sys/socket.h,,
AC_MSG_ERROR([Couldn't find network include files]))
--- configure.in.orig 1999-07-23 14:03:17 UTC
+++ configure.in
@@ -43,7 +43,7 @@ fi
dnl Checks for header files.
AC_HEADER_STDC
-AC_CHECK_HEADERS(fcntl.h malloc.h sys/file.h sys/time.h unistd.h sys/types.h ctype.h X11/Xlib.h X11/xpm.h,,
+AC_CHECK_HEADERS(fcntl.h stdlib.h sys/file.h sys/time.h unistd.h sys/types.h ctype.h X11/Xlib.h X11/xpm.h,,
AC_MSG_ERROR([Couldn't find some include files... aborting]))
AC_CHECK_HEADERS(netinet/in_systm.h netinet/in.h netinet/ip.h netinet/ip_icmp.h arpa/inet.h netdb.h sys/socket.h,,
AC_MSG_ERROR([Couldn't find network include files]))

View file

@ -1,12 +1,10 @@
*** leds.c.orig Sun Apr 1 15:18:44 2001
--- leds.c Sun Apr 1 15:19:01 2001
***************
*** 1,5 ****
--- 1,7 ----
#include <stdlib.h>
+ #ifndef __FreeBSD__
#include <malloc.h>
+ #endif
#include <X11/xpm.h>
#include <stdio.h>
#include "list.h"
--- leds.c.orig 1999-07-26 16:23:23 UTC
+++ leds.c
@@ -1,5 +1,7 @@
#include <stdlib.h>
+#if ! (defined __FreeBSD__ || defined __DragonFly__)
#include <malloc.h>
+#endif
#include <X11/xpm.h>
#include <stdio.h>
#include "list.h"

View file

@ -1,13 +1,11 @@
*** list.c.orig Sun Apr 1 15:19:28 2001
--- list.c Sun Apr 1 15:19:39 2001
***************
*** 1,6 ****
--- 1,8 ----
#include "list.h"
#include <stdlib.h>
+ #ifndef __FreeBSD__
#include <malloc.h>
+ #endif
#include <string.h>
--- list.c.orig 1999-07-22 12:43:11 UTC
+++ list.c
@@ -1,6 +1,8 @@
#include "list.h"
#include <stdlib.h>
+#if ! (defined __FreeBSD__ || defined __DragonFly__)
#include <malloc.h>
+#endif
#include <string.h>

View file

@ -1,14 +1,12 @@
*** pinger.c.orig Sun Apr 1 15:21:08 2001
--- pinger.c Sun Apr 1 15:21:22 2001
***************
*** 14,20 ****
--- 14,22 ----
#include <netdb.h>
#include <errno.h>
#include <stdlib.h>
+ #ifndef __FreeBSD__
#include <malloc.h>
+ #endif
#include <unistd.h>
#include "list.h"
#include "config.h"
--- pinger.c.orig 2000-06-17 11:01:23 UTC
+++ pinger.c
@@ -14,7 +14,9 @@
#include <netdb.h>
#include <errno.h>
#include <stdlib.h>
+#if ! (defined __FreeBSD__ || defined __DragonFly__)
#include <malloc.h>
+#endif
#include <unistd.h>
#include "list.h"
#include "config.h"

View file

@ -1,25 +1,22 @@
*** pinger.h.orig Fri Jul 23 17:08:26 1999
--- pinger.h Sun Apr 1 15:30:20 2001
***************
*** 2,7 ****
--- 2,8 ----
#define __PINGER_H__
+ #include <sys/types.h>
#include <netinet/in.h>
#include "list.h"
#include "config.h"
***************
*** 47,54 ****
--- 48,57 ----
#define UDP_DPORT dest
#endif
+ #ifndef __FreeBSD__
#if ! (defined(__GLIBC__) && (__GLIBC__ >= 2))
#define inet_ntoa(x) inet_ntoa(*((struct in_addr *)&(x)))
+ #endif
#endif
#define TIMEOUT_SIZE 55
--- pinger.h.orig 1999-07-23 14:08:26 UTC
+++ pinger.h
@@ -2,6 +2,7 @@
#define __PINGER_H__
+#include <sys/types.h>
#include <netinet/in.h>
#include "list.h"
#include "config.h"
@@ -47,9 +48,11 @@
#define UDP_DPORT dest
#endif
+#if ! (defined __FreeBSD__ || defined __DragonFly__)
#if ! (defined(__GLIBC__) && (__GLIBC__ >= 2))
#define inet_ntoa(x) inet_ntoa(*((struct in_addr *)&(x)))
#endif
+#endif
#define TIMEOUT_SIZE 55

View file

@ -1,31 +1,21 @@
*** tcpmonitor.c.orig Fri Jul 23 16:58:24 1999
--- tcpmonitor.c Sun Apr 1 15:32:49 2001
***************
*** 12,18 ****
--- 12,20 ----
#include <sys/time.h>
#include <arpa/inet.h>
#include <stdlib.h>
+ #ifndef __FreeBSD__
#include <malloc.h>
+ #endif
#include <fcntl.h>
#include <errno.h>
#include "config.h"
***************
*** 51,57 ****
if (debug)
fprintf(stderr,"trying to connect (tcp) to port %d at %s...\n", h->tcpport,
inet_ntoa(h->tcpsock->sin_addr));
! if (connect(h->tcp_socket, (struct sockaddr_in*)h->tcpsock,
sizeof(struct sockaddr_in))<0)
switch(errno) {
case EISCONN: /* Common.. reported by lots of users
--- 53,59 ----
if (debug)
fprintf(stderr,"trying to connect (tcp) to port %d at %s...\n", h->tcpport,
inet_ntoa(h->tcpsock->sin_addr));
! if (connect(h->tcp_socket, (struct sockaddr*)h->tcpsock,
sizeof(struct sockaddr_in))<0)
switch(errno) {
case EISCONN: /* Common.. reported by lots of users
--- tcpmonitor.c.orig 1999-07-23 13:58:24 UTC
+++ tcpmonitor.c
@@ -12,7 +12,9 @@
#include <sys/time.h>
#include <arpa/inet.h>
#include <stdlib.h>
+#if ! (defined __FreeBSD__ || defined __DragonFly__)
#include <malloc.h>
+#endif
#include <fcntl.h>
#include <errno.h>
#include "config.h"
@@ -51,7 +53,7 @@ int tcp_isalive(pinger_host *h)
if (debug)
fprintf(stderr,"trying to connect (tcp) to port %d at %s...\n", h->tcpport,
inet_ntoa(h->tcpsock->sin_addr));
- if (connect(h->tcp_socket, (struct sockaddr_in*)h->tcpsock,
+ if (connect(h->tcp_socket, (struct sockaddr*)h->tcpsock,
sizeof(struct sockaddr_in))<0)
switch(errno) {
case EISCONN: /* Common.. reported by lots of users