- Update to 1.10
- Respect PORTDOCS - Respect PORTEXAMPLES PR: 119234 Submitted by: Gerrit Beine <gerrit.beine@gmx.de> (maintainer)
This commit is contained in:
parent
f88e2d3b68
commit
8f7854ccc1
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=205899
10 changed files with 122 additions and 121 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= vym
|
||||
PORTVERSION= 1.8.1
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.10.0
|
||||
CATEGORIES= deskutils
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
@ -15,38 +14,29 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
|
|||
MAINTAINER= gerrit.beine@gmx.de
|
||||
COMMENT= VYM (View Your Mind) is a tool to generate and manipulate maps
|
||||
|
||||
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
|
||||
|
||||
USE_QT_VER= 3
|
||||
MAKE_ENV= QTDIR="${QT_PREFIX}"
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
# Add this condititonal while people might still have old versions
|
||||
# of qmake, living in X11BASE, installed. This should go away eventually.
|
||||
|
||||
.if exists(${X11BASE}/share/qt/mkspecs/freebsd-g++)
|
||||
QMAKESPEC= ${X11BASE}/share/qt/mkspecs/freebsd-g++
|
||||
.else
|
||||
QMAKESPEC= ${LOCALBASE}/share/qt/mkspecs/freebsd-g++
|
||||
.endif
|
||||
USE_BZIP2= yes
|
||||
USE_QT_VER= 4
|
||||
QT_COMPONENTS= qmake_build uic_build moc_build qt3support network xml
|
||||
|
||||
do-configure:
|
||||
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} qmake \
|
||||
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} \
|
||||
-spec ${QMAKESPEC} vym.pro
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
|
||||
@${MKDIR} ${DATADIR}
|
||||
@${CP} -R ${WRKSRC}/flags ${DATADIR}
|
||||
@${CP} -R ${WRKSRC}/icons ${DATADIR}
|
||||
@${CP} -R ${WRKSRC}/scripts ${DATADIR}
|
||||
@${CP} -R ${WRKSRC}/styles ${DATADIR}
|
||||
.for dir in exports flags icons lang macros scripts styles
|
||||
@cd ${WRKSRC} && \
|
||||
${FIND} ${dir} -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
|
||||
${FIND} ${dir} -type f -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
|
||||
.endfor
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
|
||||
.endif
|
||||
.if !defined(NOPORTEXAMPLES)
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
@${CP} -R ${WRKSRC}/doc/* ${DOCSDIR}
|
||||
@${CP} -R ${WRKSRC}/demos/* ${EXAMPLESDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/demos/* ${EXAMPLESDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (vym-1.8.1.tar.gz) = de461aef063a3a3a528669715611257e
|
||||
SHA256 (vym-1.8.1.tar.gz) = 2a5a2d27a4f9345f4feba4d6a2b3a5a9d27be71969c541e19c20376b79ac0279
|
||||
SIZE (vym-1.8.1.tar.gz) = 1377030
|
||||
MD5 (vym-1.10.0.tar.bz2) = 188f08f2e0af5e122e2613351f3b92d9
|
||||
SHA256 (vym-1.10.0.tar.bz2) = e8fe5ab9b2a7a52cfe69ce53f5fc8b711ee485688f61287e332db925a937e70f
|
||||
SIZE (vym-1.10.0.tar.bz2) = 2801600
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- editxlinkdialog.ui.h.orig Wed May 18 09:39:51 2005
|
||||
+++ editxlinkdialog.ui.h Fri Sep 16 22:24:33 2005
|
||||
@@ -6,6 +6,8 @@
|
||||
** init() function in place of a constructor, and a destroy() function in
|
||||
** place of a destructor.
|
||||
*****************************************************************************/
|
||||
+#include <typeinfo>
|
||||
+
|
||||
void EditXLinkDialog::init()
|
||||
{
|
||||
delink=false;
|
|
@ -1,10 +0,0 @@
|
|||
--- file.cpp.orig Thu Mar 23 13:38:54 2006
|
||||
+++ file.cpp Mon Sep 4 08:23:18 2006
|
||||
@@ -5,6 +5,7 @@
|
||||
#include "file.h"
|
||||
#include "process.h"
|
||||
|
||||
+#include <unistd.h>
|
||||
|
||||
QString maskPath(QString p)
|
||||
{
|
|
@ -1,8 +0,0 @@
|
|||
--- linkablemapobj.cpp.orig Fri Jul 8 09:24:42 2005
|
||||
+++ linkablemapobj.cpp Sat Aug 6 17:22:48 2005
|
||||
@@ -1,3 +1,5 @@
|
||||
+#include <math.h>
|
||||
+
|
||||
#include "linkablemapobj.h"
|
||||
#include "branchobj.h"
|
||||
#include "mapeditor.h"
|
|
@ -1,22 +1,19 @@
|
|||
--- mainwindow.cpp.orig Mon Jul 11 21:55:32 2005
|
||||
+++ mainwindow.cpp Sat Aug 6 17:20:39 2005
|
||||
@@ -57,6 +57,8 @@
|
||||
#include "settings.h"
|
||||
#include "options.h"
|
||||
--- mainwindow.cpp.orig Tue Sep 4 15:53:33 2007
|
||||
+++ mainwindow.cpp Tue Jan 1 20:35:11 2008
|
||||
@@ -140,7 +140,7 @@
|
||||
#if defined(Q_OS_MACX)
|
||||
s=settings.value (p,"/usr/bin/open").toString();
|
||||
#else
|
||||
- s=settings.value (p,"mozilla");
|
||||
+ s=settings.value (p,"mozilla").toString();
|
||||
#endif
|
||||
#endif
|
||||
settings.setValue( p,s);
|
||||
@@ -3637,6 +3637,7 @@
|
||||
searchList << "doc/tex"; // Easy testing working on vym.tex
|
||||
searchList << "/usr/share/doc/vym"; // Debian
|
||||
searchList << "/usr/share/doc/packages";// Knoppix
|
||||
+ searchList << "/usr/local/share/doc/vym"; //FreeBSD
|
||||
|
||||
+#include <unistd.h>
|
||||
+
|
||||
extern TextEditor *textEditor;
|
||||
extern Main *mainWindow;
|
||||
extern int statusbarTime;
|
||||
@@ -2322,7 +2324,9 @@
|
||||
docpath="./vym.app/Contents/vym.pdf";
|
||||
#else
|
||||
// default path in SUSE LINUX
|
||||
- docpath="/usr/share/doc/packages/vym/doc/vym.pdf";
|
||||
+// docpath="/usr/share/doc/packages/vym/doc/vym.pdf";
|
||||
+ // default path in FreeBSD
|
||||
+ docpath="/usr/local/share/doc/vym/vym.pdf";
|
||||
#endif
|
||||
|
||||
if (!QFile (docpath).exists() )
|
||||
bool found=false;
|
||||
QFile docfile;
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- mapeditor.cpp.orig Wed Jul 13 13:36:14 2005
|
||||
+++ mapeditor.cpp Sat Aug 6 17:19:14 2005
|
||||
@@ -58,6 +58,8 @@
|
||||
#include "icons/flag-flash.xpm"
|
||||
#include "icons/flag-lifebelt.xpm"
|
||||
|
||||
+#include <unistd.h>
|
||||
+
|
||||
extern TextEditor *textEditor;
|
||||
extern int statusbarTime;
|
||||
extern Main *mainWindow;
|
|
@ -1,11 +0,0 @@
|
|||
--- misc.cpp.orig Fri Jul 8 09:24:43 2005
|
||||
+++ misc.cpp Sat Aug 6 17:14:20 2005
|
||||
@@ -1,6 +1,8 @@
|
||||
#include <qregexp.h>
|
||||
#include <qpoint.h>
|
||||
|
||||
+#include <math.h>
|
||||
+
|
||||
#include "misc.h"
|
||||
|
||||
|
|
@ -1,10 +0,0 @@
|
|||
--- xml.cpp.orig Fri Jul 8 09:24:43 2005
|
||||
+++ xml.cpp Sat Aug 6 17:19:33 2005
|
||||
@@ -4,6 +4,7 @@
|
||||
#include <qcolor.h>
|
||||
#include <qstylesheet.h>
|
||||
#include <iostream>
|
||||
+#include <typeinfo>
|
||||
|
||||
#include "misc.h"
|
||||
#include "settings.h"
|
|
@ -1,4 +1,45 @@
|
|||
bin/vym
|
||||
%%DATADIR%%/exports/template-orange-blue/META-INF/manifest.xml
|
||||
%%DATADIR%%/exports/template-orange-blue/Pictures/1000000000000040000000400142E835.png
|
||||
%%DATADIR%%/exports/template-orange-blue/Thumbnails/thumbnail.png
|
||||
%%DATADIR%%/exports/template-orange-blue/content-template.xml
|
||||
%%DATADIR%%/exports/template-orange-blue/content.xml
|
||||
%%DATADIR%%/exports/template-orange-blue/meta.xml
|
||||
%%DATADIR%%/exports/template-orange-blue/styles.xml
|
||||
%%DATADIR%%/exports/template-orange-blue/settings.xml
|
||||
%%DATADIR%%/exports/template-orange-blue/page-template.xml
|
||||
%%DATADIR%%/exports/template-orange-blue/mimetype
|
||||
%%DATADIR%%/exports/orange-blue.conf
|
||||
%%DATADIR%%/flags/freemind/attach.png
|
||||
%%DATADIR%%/flags/freemind/back.png
|
||||
%%DATADIR%%/flags/freemind/bell.png
|
||||
%%DATADIR%%/flags/freemind/bookmark.png
|
||||
%%DATADIR%%/flags/freemind/clanbomber.png
|
||||
%%DATADIR%%/flags/freemind/desktopnew.png
|
||||
%%DATADIR%%/flags/freemind/flag.png
|
||||
%%DATADIR%%/flags/freemind/forward.png
|
||||
%%DATADIR%%/flags/freemind/gohome.png
|
||||
%%DATADIR%%/flags/freemind/help.png
|
||||
%%DATADIR%%/flags/freemind/idea.png
|
||||
%%DATADIR%%/flags/freemind/kaddressbook.png
|
||||
%%DATADIR%%/flags/freemind/knotify.png
|
||||
%%DATADIR%%/flags/freemind/korn.png
|
||||
%%DATADIR%%/flags/freemind/mail.png
|
||||
%%DATADIR%%/flags/freemind/licq.png
|
||||
%%DATADIR%%/flags/freemind/password.png
|
||||
%%DATADIR%%/flags/freemind/pencil.png
|
||||
%%DATADIR%%/flags/freemind/penguin.png
|
||||
%%DATADIR%%/flags/freemind/priority-1.png
|
||||
%%DATADIR%%/flags/freemind/priority-2.png
|
||||
%%DATADIR%%/flags/freemind/priority-3.png
|
||||
%%DATADIR%%/flags/freemind/priority-4.png
|
||||
%%DATADIR%%/flags/freemind/priority-5.png
|
||||
%%DATADIR%%/flags/freemind/priority-6.png
|
||||
%%DATADIR%%/flags/freemind/priority-7.png
|
||||
%%DATADIR%%/flags/freemind/stop.png
|
||||
%%DATADIR%%/flags/freemind/warning.png
|
||||
%%DATADIR%%/flags/freemind/wizard.png
|
||||
%%DATADIR%%/flags/freemind/xmag.png
|
||||
%%DATADIR%%/flags/flag-arrow-2down.png
|
||||
%%DATADIR%%/flags/flag-arrow-2up.png
|
||||
%%DATADIR%%/flags/flag-arrow-down.png
|
||||
|
@ -34,8 +75,10 @@ bin/vym
|
|||
%%DATADIR%%/icons/cursor16.xcf
|
||||
%%DATADIR%%/icons/cursorcolorpicker.png
|
||||
%%DATADIR%%/icons/cursorcolorpicker16.png
|
||||
%%DATADIR%%/icons/cursorcopy.png
|
||||
%%DATADIR%%/icons/cursorhandopen.png
|
||||
%%DATADIR%%/icons/cursorhandopen16.png
|
||||
%%DATADIR%%/icons/cursorxlink.png
|
||||
%%DATADIR%%/icons/down.png
|
||||
%%DATADIR%%/icons/editcopy.png
|
||||
%%DATADIR%%/icons/editcut.png
|
||||
|
@ -44,20 +87,20 @@ bin/vym
|
|||
%%DATADIR%%/icons/exit.png
|
||||
%%DATADIR%%/icons/fileclose.png
|
||||
%%DATADIR%%/icons/filenew.png
|
||||
%%DATADIR%%/icons/filenewcopy.png
|
||||
%%DATADIR%%/icons/fileopen.png
|
||||
%%DATADIR%%/icons/fileprint.png
|
||||
%%DATADIR%%/icons/filesave.png
|
||||
%%DATADIR%%/icons/filesaveas.png
|
||||
%%DATADIR%%/icons/find.png
|
||||
%%DATADIR%%/icons/flag-hideexport.png
|
||||
%%DATADIR%%/icons/flag-url-16x16.png
|
||||
%%DATADIR%%/icons/formatcolorbranch.png
|
||||
%%DATADIR%%/icons/formatcoloritem.png
|
||||
%%DATADIR%%/icons/formatcoloritem.xpm
|
||||
%%DATADIR%%/icons/formatcolorpicker.png
|
||||
%%DATADIR%%/icons/formatcolorpicker.xpm
|
||||
%%DATADIR%%/icons/formatcolorsubtree.png
|
||||
%%DATADIR%%/icons/formatfixedfont.png
|
||||
%%DATADIR%%/icons/formatvarfont.png
|
||||
%%DATADIR%%/icons/history.png
|
||||
%%DATADIR%%/icons/icons.xcf
|
||||
%%DATADIR%%/icons/modecolor.png
|
||||
%%DATADIR%%/icons/modecopy.png
|
||||
|
@ -78,17 +121,39 @@ bin/vym
|
|||
%%DATADIR%%/icons/viewmag+.png
|
||||
%%DATADIR%%/icons/viewmag-.png
|
||||
%%DATADIR%%/icons/viewmag-reset.png
|
||||
%%DATADIR%%/icons/viewshowsel.png
|
||||
%%DATADIR%%/icons/vym-128x128.png
|
||||
%%DATADIR%%/icons/vym-16x16.png
|
||||
%%DATADIR%%/icons/vym-editor.png
|
||||
%%DATADIR%%/icons/vym.icns
|
||||
%%DATADIR%%/icons/vym.png
|
||||
%%DATADIR%%/icons/vym.xcf
|
||||
%%DATADIR%%/icons/vym.xpm
|
||||
%%DATADIR%%/lang/vym_es.qm
|
||||
%%DATADIR%%/lang/vym_en.qm
|
||||
%%DATADIR%%/lang/vym_en.ts
|
||||
%%DATADIR%%/lang/vym_it.qm
|
||||
%%DATADIR%%/lang/vym_de.qm
|
||||
%%DATADIR%%/lang/vym_it.ts
|
||||
%%DATADIR%%/lang/vym_de.ts
|
||||
%%DATADIR%%/lang/vym_fr.ts
|
||||
%%DATADIR%%/lang/vym_es.ts
|
||||
%%DATADIR%%/macros/macro-3.vys
|
||||
%%DATADIR%%/macros/macro-1.vys
|
||||
%%DATADIR%%/macros/macro-7.vys
|
||||
%%DATADIR%%/macros/macro-12.vys
|
||||
%%DATADIR%%/macros/macro-9.vys
|
||||
%%DATADIR%%/macros/macro-4.vys
|
||||
%%DATADIR%%/macros/macro-2.vys
|
||||
%%DATADIR%%/macros/macro-6.vys
|
||||
%%DATADIR%%/macros/macro-11.vys
|
||||
%%DATADIR%%/macros/macro-8.vys
|
||||
%%DATADIR%%/macros/macro-5.vys
|
||||
%%DATADIR%%/macros/macro-10.vys
|
||||
%%DATADIR%%/scripts/exportvym
|
||||
%%DATADIR%%/scripts/niceXML
|
||||
%%DATADIR%%/scripts/release-mac
|
||||
%%DATADIR%%/scripts/update-bookmarks
|
||||
%%DATADIR%%/scripts/vym2html.sh
|
||||
%%DATADIR%%/scripts/vym2txt.sh
|
||||
%%DATADIR%%/styles/cm.xsl
|
||||
%%DATADIR%%/styles/kdebookmarks2vym.xsl
|
||||
%%DATADIR%%/styles/mmap2vym.xsl
|
||||
|
@ -99,15 +164,25 @@ bin/vym
|
|||
%%DATADIR%%/styles/vym2taskjuggler.xsl
|
||||
%%DATADIR%%/styles/vym2txt.xsl
|
||||
%%DATADIR%%/styles/vym2xhtml.xsl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vym_es.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vym.pdf
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/liveform.vym
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/math.vym
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/time-management.vym
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/todo.vym
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lifeforms.vym
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/math.vym
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/time-management.vym
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/vym-projectplan.vym
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
|
||||
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
|
||||
@dirrm %%DATADIR%%/exports/template-orange-blue/Configurations2
|
||||
@dirrm %%DATADIR%%/exports/template-orange-blue/Pictures
|
||||
@dirrm %%DATADIR%%/exports/template-orange-blue/META-INF
|
||||
@dirrm %%DATADIR%%/exports/template-orange-blue/Thumbnails
|
||||
@dirrm %%DATADIR%%/exports/template-orange-blue
|
||||
@dirrm %%DATADIR%%/exports
|
||||
@dirrm %%DATADIR%%/flags/freemind
|
||||
@dirrm %%DATADIR%%/flags
|
||||
@dirrm %%DATADIR%%/icons
|
||||
@dirrm %%DATADIR%%/lang
|
||||
@dirrm %%DATADIR%%/macros
|
||||
@dirrm %%DATADIR%%/scripts
|
||||
@dirrm %%DATADIR%%/styles/wiki
|
||||
@dirrm %%DATADIR%%/styles
|
||||
|
|
Loading…
Reference in a new issue