- Fix an issue with PATH environment, without it, consul-alerts will not
watch checks and events. - Update a constant with the proper version of consul-alerts. - Fix pkg-descr replacing URL by WWW keyword. PR: ports/218027 Submitted by: John Hixson <jhixson@gmail.com> (maintainer)
This commit is contained in:
parent
a70a4104e1
commit
8f7c859224
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=436752
4 changed files with 19 additions and 3 deletions
|
@ -3,6 +3,7 @@
|
||||||
PORTNAME= consul-alerts
|
PORTNAME= consul-alerts
|
||||||
PORTVERSION= 0.4.0
|
PORTVERSION= 0.4.0
|
||||||
DISTVERSIONPREFIX= v
|
DISTVERSIONPREFIX= v
|
||||||
|
PORTREVISION= 1
|
||||||
CATEGORIES= sysutils
|
CATEGORIES= sysutils
|
||||||
|
|
||||||
MAINTAINER= jhixson@gmail.com
|
MAINTAINER= jhixson@gmail.com
|
||||||
|
@ -24,7 +25,7 @@ PLIST_FILES= ${PREFIX}/bin/consul-alerts
|
||||||
|
|
||||||
USE_RC_SUBR= consul-alerts
|
USE_RC_SUBR= consul-alerts
|
||||||
|
|
||||||
STRIP=
|
STRIP= #none
|
||||||
|
|
||||||
post-patch:
|
post-patch:
|
||||||
@${MKDIR} ${WRKDIR}/src/github.com/AcalephStorage
|
@${MKDIR} ${WRKDIR}/src/github.com/AcalephStorage
|
||||||
|
@ -40,7 +41,9 @@ do-build:
|
||||||
-ldflags "-X main.GitDescribe=v${PORTVERSION}" -o bin/consul-alerts
|
-ldflags "-X main.GitDescribe=v${PORTVERSION}" -o bin/consul-alerts
|
||||||
|
|
||||||
do-install:
|
do-install:
|
||||||
${INSTALL_PROGRAM} ${WRKDIR}/src/github.com/AcalephStorage/consul-alerts/bin/consul-alerts ${STAGEDIR}${PREFIX}/bin/consul-alerts
|
${INSTALL_PROGRAM} \
|
||||||
|
${WRKDIR}/src/github.com/AcalephStorage/consul-alerts/bin/consul-alerts \
|
||||||
|
${STAGEDIR}${PREFIX}/bin/consul-alerts
|
||||||
|
|
||||||
.include <bsd.port.pre.mk>
|
.include <bsd.port.pre.mk>
|
||||||
|
|
||||||
|
|
|
@ -16,6 +16,8 @@
|
||||||
|
|
||||||
. /etc/rc.subr
|
. /etc/rc.subr
|
||||||
|
|
||||||
|
export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin
|
||||||
|
|
||||||
name=consul_alerts
|
name=consul_alerts
|
||||||
rcvar=consul_alerts_enable
|
rcvar=consul_alerts_enable
|
||||||
|
|
||||||
|
|
11
sysutils/consul-alerts/files/patch-consul-alerts.go
Normal file
11
sysutils/consul-alerts/files/patch-consul-alerts.go
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- consul-alerts.go.orig 2016-11-30 21:41:15.770397000 -0800
|
||||||
|
+++ consul-alerts.go 2016-11-30 21:41:25.037217000 -0800
|
||||||
|
@@ -20,7 +20,7 @@
|
||||||
|
"github.com/AcalephStorage/consul-alerts/Godeps/_workspace/src/github.com/docopt/docopt-go"
|
||||||
|
)
|
||||||
|
|
||||||
|
-const version = "Consul Alerts 0.3.3"
|
||||||
|
+const version = "Consul Alerts 0.4.0"
|
||||||
|
const usage = `Consul Alerts.
|
||||||
|
|
||||||
|
Usage:
|
|
@ -4,4 +4,4 @@ check, or host that enables specific handlers and reminder intervals.
|
||||||
consul-alerts makes use of consul services to provide leader election
|
consul-alerts makes use of consul services to provide leader election
|
||||||
and automatic failover amongst multiple instances.
|
and automatic failover amongst multiple instances.
|
||||||
|
|
||||||
URL: https://github.com/AcalephStorage/consul-alerts
|
WWW: https://github.com/AcalephStorage/consul-alerts
|
||||||
|
|
Loading…
Reference in a new issue