Update port: x11/x3270 to version 3.3.2p1
This port has been stuck on an ancient, non-SSL-capable version for seveal years. Please consider updating to a more recent upstream source. The attached files are offered as a starting point; some "adjustment" is probably needed. Note that what's below completely replaces the previous port; all previous patches are no longer valid. Also, I've added "net" to the CATEGORIES, along with a link to the official web page in the package description. The compilation produces one "warning: assignment from incompatible pointer type"; this deserves further investigation (particularly for 64-bit builds). Since I do not have access to the requisite legacy systems, I am unable to properly test this software (particularly the SSL aspects). PR: ports/70808 Submitted by: Eric P. Scott <eps+psub0408@ana.com> Approved by: maintainer timeout
This commit is contained in:
parent
11fc19071e
commit
8f7fc644d0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=124189
7 changed files with 45 additions and 78 deletions
|
@ -6,23 +6,30 @@
|
|||
#
|
||||
|
||||
PORTNAME= x3270
|
||||
PORTVERSION= 3.1.1.6
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
|
||||
MASTER_SITE_SUBDIR= applications
|
||||
PORTVERSION= 3.3.2p1
|
||||
CATEGORIES= x11 net
|
||||
MASTER_SITES= http://x3270.bgp.nu/download/
|
||||
EXTRACT_SUFX= .tgz
|
||||
DISTFILES= ${PORTNAME}-332p1${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= onatan@gmail.com
|
||||
MAINTAINER= Yonatan@xpert.com
|
||||
COMMENT= 3270 Terminal emulator
|
||||
|
||||
BUILD_DEPENDS= bdftopcf:${X_CLIENTS_PORT}
|
||||
RUN_DEPENDS= mkfontdir:${X_CLIENTS_PORT}
|
||||
|
||||
USE_IMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --without-pr3287 --with-fontdir=local --disable-dbcs
|
||||
.if defined(WITHOUT_OPENSSL)
|
||||
CONFIGURE_ARGS+= --disable-ssl
|
||||
.else
|
||||
USE_OPENSSL= yes
|
||||
.endif
|
||||
|
||||
WRKSRC= ${WRKDIR}/x3270-3.1.1
|
||||
MAN1= x3270.1 x3270if.1 x3270-script.1 ibm_hosts.1
|
||||
WRKSRC= ${WRKDIR}/x3270-3.3
|
||||
MAN1= x3270.1
|
||||
MANCOMPRESSED= yes
|
||||
USE_REINPLACE= yes
|
||||
|
||||
pre-install:
|
||||
.if !exists(${X11BASE}/lib/X11/fonts/local)
|
||||
|
@ -33,14 +40,4 @@ pre-install:
|
|||
@${ECHO} "*********************************************************"
|
||||
.endif
|
||||
|
||||
#
|
||||
# This patch is to make sure that mkversion.sh can be ran on FreeBSD 4-STABLE
|
||||
# which will get $(CLIENTENVSETUP) in its CC macro.
|
||||
#
|
||||
post-configure:
|
||||
${REINPLACE_CMD} \
|
||||
-e 's,sh \./mkversion\.sh $$(CC),$$(CLIENTENVSETUP) sh ./mkversion.sh %%CC%%,' \
|
||||
-e 's,%%CC%%,${CC},' \
|
||||
${WRKSRC}/Makefile
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (x3270-3.1.1.6.tar.gz) = 71678f6bee6fcf5270bfd8f72af5f5c5
|
||||
SIZE (x3270-3.1.1.6.tar.gz) = 428444
|
||||
MD5 (x3270-332p1.tgz) = af53fc2eedad95248b19692771817d59
|
||||
SIZE (x3270-332p1.tgz) = 909703
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
--- Imakefile.orig Thu Feb 13 23:04:51 1997
|
||||
+++ Imakefile Wed Feb 28 00:15:00 2001
|
||||
@@ -24,7 +24,7 @@
|
||||
FontObj(3270gt24) FontObj(3270gt24b) \
|
||||
FontObj(3270gt32) FontObj(3270gt32b)
|
||||
|
||||
- FONTINSTDIR = $(FONTDIR)/misc
|
||||
+ FONTINSTDIR = $(FONTDIR)/local
|
||||
|
||||
LIBX3270DIR = $(LIBDIR)/x3270
|
||||
HOSTSFILE = ibm_hosts
|
||||
@@ -104,7 +104,13 @@
|
||||
install:: $(DESTDIR)$(FONTINSTDIR)/fonts.dir
|
||||
$(DESTDIR)$(FONTINSTDIR)/fonts.dir::
|
||||
-chmod u+w $(DESTDIR)$(FONTINSTDIR) $(DESTDIR)$(FONTINSTDIR)/fonts.dir
|
||||
- $(BINDIR)/$(MKFONTDIR) $(DESTDIR)$(FONTINSTDIR)
|
||||
+ if [ -x $(BINDIR)/$(MKFONTDIR) ]; then \
|
||||
+ $(BINDIR)/$(MKFONTDIR) $(DESTDIR)$(FONTINSTDIR); \
|
||||
+ elif [ -x $(MKFONTDIR) ]; then \
|
||||
+ $(MKFONTDIR) $(DESTDIR)$(FONTINSTDIR); \
|
||||
+ else \
|
||||
+ echo "*** mkfontdir not found -- please run manually ***"; \
|
||||
+ fi
|
||||
chmod u=rwx,go=rx $(DESTDIR)$(FONTINSTDIR)
|
||||
chmod a=r $(DESTDIR)$(FONTINSTDIR)/fonts.dir
|
||||
|
|
@ -1,12 +0,0 @@
|
|||
--- util.c.orig Sun Dec 1 16:07:11 2002
|
||||
+++ util.c Sun Dec 1 16:07:29 2002
|
||||
@@ -585,8 +585,8 @@
|
||||
local_strerror(e)
|
||||
int e;
|
||||
{
|
||||
- extern int sys_nerr;
|
||||
#if !defined(__FreeBSD__)
|
||||
+ extern int sys_nerr;
|
||||
extern char *sys_errlist[];
|
||||
#endif
|
||||
|
|
@ -1,12 +0,0 @@
|
|||
--- popups.c.orig Sun Dec 1 16:07:06 2002
|
||||
+++ popups.c Sun Dec 1 16:07:19 2002
|
||||
@@ -498,8 +498,8 @@
|
||||
{
|
||||
va_list args;
|
||||
char *s;
|
||||
- extern int sys_nerr;
|
||||
#if !defined(__FreeBSD__)
|
||||
+ extern int sys_nerr;
|
||||
extern char *sys_errlist[];
|
||||
#endif
|
||||
|
|
@ -1 +1,3 @@
|
|||
3270 terminal emulator under X. (version 3.1.1.6)
|
||||
3270 terminal emulator under X. (version 3.3.2p1)
|
||||
|
||||
WWW: http://www.geocities.com/SiliconValley/Peaks/7814/
|
||||
|
|
|
@ -1,14 +1,28 @@
|
|||
bin/x3270
|
||||
bin/x3270if
|
||||
lib/X11/fonts/local/3270.pcf.gz
|
||||
lib/X11/fonts/local/3270b.pcf.gz
|
||||
etc/x3270/ibm_hosts
|
||||
lib/X11/fonts/local/3270-12.pcf.gz
|
||||
lib/X11/fonts/local/3270-12b.pcf.gz
|
||||
lib/X11/fonts/local/3270-20.pcf.gz
|
||||
lib/X11/fonts/local/3270-20b.pcf.gz
|
||||
lib/X11/fonts/local/3270d.pcf.gz
|
||||
lib/X11/fonts/local/3270h.pcf.gz
|
||||
lib/X11/fonts/local/3270gt8.pcf.gz
|
||||
lib/X11/fonts/local/3270.pcf.gz
|
||||
lib/X11/fonts/local/3270b.pcf.gz
|
||||
lib/X11/fonts/local/3270e-12.pcf.gz
|
||||
lib/X11/fonts/local/3270e-12b.pcf.gz
|
||||
lib/X11/fonts/local/3270e-20.pcf.gz
|
||||
lib/X11/fonts/local/3270e-20b.pcf.gz
|
||||
lib/X11/fonts/local/3270e.pcf.gz
|
||||
lib/X11/fonts/local/3270eb.pcf.gz
|
||||
lib/X11/fonts/local/3270egt12.pcf.gz
|
||||
lib/X11/fonts/local/3270egt12b.pcf.gz
|
||||
lib/X11/fonts/local/3270egt16.pcf.gz
|
||||
lib/X11/fonts/local/3270egt16b.pcf.gz
|
||||
lib/X11/fonts/local/3270egt24.pcf.gz
|
||||
lib/X11/fonts/local/3270egt24b.pcf.gz
|
||||
lib/X11/fonts/local/3270egt32.pcf.gz
|
||||
lib/X11/fonts/local/3270egt32b.pcf.gz
|
||||
lib/X11/fonts/local/3270egt8.pcf.gz
|
||||
lib/X11/fonts/local/3270gr.pcf.gz
|
||||
lib/X11/fonts/local/3270gt12.pcf.gz
|
||||
lib/X11/fonts/local/3270gt12b.pcf.gz
|
||||
lib/X11/fonts/local/3270gt16.pcf.gz
|
||||
|
@ -17,11 +31,15 @@ lib/X11/fonts/local/3270gt24.pcf.gz
|
|||
lib/X11/fonts/local/3270gt24b.pcf.gz
|
||||
lib/X11/fonts/local/3270gt32.pcf.gz
|
||||
lib/X11/fonts/local/3270gt32b.pcf.gz
|
||||
lib/X11/x3270/ibm_hosts
|
||||
lib/X11/fonts/local/3270gt8.pcf.gz
|
||||
lib/X11/fonts/local/3270h.pcf.gz
|
||||
man/man1/x3270if.1
|
||||
man/man1/x3270-script.1
|
||||
man/man5/ibm_hosts.5
|
||||
@exec /bin/chmod u+w %D/lib/X11/fonts/local %D/lib/X11/fonts/local/fonts.dir
|
||||
@exec %D/bin/mkfontdir %D/lib/X11/fonts/local
|
||||
@exec /bin/chmod u=rwx,go=rx %D/lib/X11/fonts/local
|
||||
@exec /bin/chmod a=r %D/lib/X11/fonts/local/fonts.dir
|
||||
@unexec %D/bin/mkfontdir %D/lib/X11/fonts/local
|
||||
@unexec if [ `wc -c %D/lib/X11/fonts/local/fonts.dir | awk '{print $1}'` = 2 ]; then rm -f %D/lib/X11/fonts/local/fonts.dir; fi
|
||||
@dirrm lib/X11/x3270
|
||||
@dirrm etc/x3270
|
||||
|
|
Loading…
Reference in a new issue