- Add patch to make the port build GCC and CMake 3.1.0.
Tulip overrides CMake's built-in add_library() and add_executable() commands, so obviously things would explode at some point. This is a band-aid solution to get things working; the right solution would be to stop overriding CMake's commands, or even stopping setting RPATH on libraries and executables altogether, but that depends on getting the Tulip developers involved (I'm still figuring out if they respond to pings and patches). - Use quazip from ports instead of building Tulip's bundled copy. Bundled software is evil. - Clean up CMAKE_ARGS. PYTHON_INCLUDEDIR and LOCALBASE were used years ago in patch-CMakeLists.txt, but that has not been the case for several releases at least. - Clean up the port's dependencies: * devel/qt4-assistant, devel/qt4-designer have not been required since Tulip 3.something. * devel/qt4-libqtassistantclient is severely outdated and unsupported, thankfully it has not been used since Tulip 3.4.0. * devel/libqxt is not needed because Tulip always builds its own bundled copy. * Add explicit dependency on print/freetype2 since the port links directly against it. * Stop depending on devel/libexecinfo directly and use USES=execinfo instead.
This commit is contained in:
parent
957561b463
commit
8f80525551
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=376116
3 changed files with 20 additions and 12 deletions
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= tulip
|
||||
PORTVERSION= 4.6.0
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= SF/auber/${PORTNAME}/${PORTNAME}-${PORTVERSION}
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}_src
|
||||
|
@ -11,25 +11,24 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}_src
|
|||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= System dedicated to the visualization of huge graphs
|
||||
|
||||
LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
|
||||
libQxtCore.so:${PORTSDIR}/devel/libqxt \
|
||||
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
|
||||
libOGDF.so:${PORTSDIR}/math/ogdf \
|
||||
libpng.so:${PORTSDIR}/graphics/png \
|
||||
libquazip.so:${PORTSDIR}/archivers/quazip \
|
||||
libjpeg.so:${PORTSDIR}/graphics/jpeg
|
||||
|
||||
USES= cmake:outsource compiler:c++11-lib dos2unix python shebangfix
|
||||
USES= cmake:outsource compiler:c++11-lib dos2unix execinfo python \
|
||||
shebangfix
|
||||
SHEBANG_FILES= tulip-config.in
|
||||
DOS2UNIX_FILES= software/tulip/src/main.cpp
|
||||
USE_CXXSTD= c++11
|
||||
USE_GL= glew glut
|
||||
USE_GNOME= libxml2
|
||||
USE_QT4= corelib moc_build uic_build rcc_build gui opengl xml network qmake_build \
|
||||
designer assistant assistantclient
|
||||
USE_QT4= corelib gui network opengl webkit xml xmlpatterns \
|
||||
qmake_build moc_build rcc_build uic_build
|
||||
CXXFLAGS+= -fPIC -I${LOCALBASE}/include -DNDEBUG -DOGDF_DLL
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
CMAKE_ARGS+= -DPYTHON_INCLUDEDIR:PATH=${PYTHON_INCLUDEDIR} \
|
||||
-DLOCALBASE:PATH=${LOCALBASE} \
|
||||
-DOGDFLibrary=${LOCALBASE}/lib/libOGDF.so \
|
||||
CMAKE_ARGS= -DOGDFLibrary=${LOCALBASE}/lib/libOGDF.so \
|
||||
-DOGDFInclude=${LOCALBASE}/include \
|
||||
-DBUILD_DOC:BOOL=false
|
||||
USE_LDCONFIG= ${PREFIX}/lib/tulip
|
||||
|
|
|
@ -1,5 +1,17 @@
|
|||
--- CMakeLists.txt.orig 2014-09-28 22:18:14.000000000 +0200
|
||||
+++ CMakeLists.txt 2014-09-30 12:39:54.000000000 +0200
|
||||
@@ -108,7 +108,10 @@
|
||||
IF(APPLE)
|
||||
SET_TARGET_PROPERTIES(${name} PROPERTIES INSTALL_NAME_DIR "@executable_path/../lib")
|
||||
ENDIF(APPLE)
|
||||
- SET_TARGET_PROPERTIES(${name} PROPERTIES INSTALL_RPATH "$ORIGIN")
|
||||
+ GET_TARGET_PROPERTY(_target_type ${name} TYPE)
|
||||
+ IF(NOT "${_target_type}" STREQUAL "INTERFACE_LIBRARY")
|
||||
+ SET_TARGET_PROPERTIES(${name} PROPERTIES INSTALL_RPATH "$ORIGIN")
|
||||
+ ENDIF(NOT "${_target_type}" STREQUAL "INTERFACE_LIBRARY")
|
||||
IF(MSVC)
|
||||
SET_TARGET_PROPERTIES(${name} PROPERTIES RUNTIME_OUTPUT_DIRECTORY_DEBUG "${CMAKE_CURRENT_BINARY_DIR}")
|
||||
SET_TARGET_PROPERTIES(${name} PROPERTIES RUNTIME_OUTPUT_DIRECTORY_RELEASE "${CMAKE_CURRENT_BINARY_DIR}")
|
||||
@@ -401,8 +401,8 @@
|
||||
SET(FTGLLibrary ftgl-tulip-${TulipMMVersion})
|
||||
ENDIF(NOT BUILD_CORE_ONLY)
|
||||
|
|
|
@ -303,9 +303,6 @@ lib/libftgl-tulip-%%TULIP_VERS%%.so.2
|
|||
lib/libftgl-tulip-%%TULIP_VERS%%.so.2.1
|
||||
lib/libgzstream-tulip-%%TULIP_VERS%%.so
|
||||
lib/libgzstream-tulip-%%TULIP_VERS%%.so.0
|
||||
lib/libquazip-tulip-%%TULIP_VERS%%.so
|
||||
lib/libquazip-tulip-%%TULIP_VERS%%.so.1
|
||||
lib/libquazip-tulip-%%TULIP_VERS%%.so.1.0.0
|
||||
lib/libqxt-tulip-%%TULIP_VERS%%.so
|
||||
lib/libqxt-tulip-%%TULIP_VERS%%.so.0
|
||||
lib/libtulip-core-%%TULIP_VERS%%.so
|
||||
|
|
Loading…
Reference in a new issue