- Update to 1.10
- Give maintainership to submitter PR: ports/163019 Submitted by: Olivier Cochard-Labbe <olivier@cochard.me> Approved by: maintainer
This commit is contained in:
parent
2bff1d7273
commit
8fbf66d89b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=291269
6 changed files with 41 additions and 23 deletions
|
@ -6,12 +6,11 @@
|
|||
#
|
||||
|
||||
PORTNAME= sslh
|
||||
PORTVERSION= 1.7a
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.10
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.rutschle.net/tech/
|
||||
|
||||
MAINTAINER= jnlin@csie.nctu.edu.tw
|
||||
MAINTAINER= olivier@cochard.me
|
||||
COMMENT= A ssl/ssh multiplexer
|
||||
|
||||
USE_GMAKE= yes
|
||||
|
@ -20,7 +19,9 @@ USE_PERL5_BUILD= yes
|
|||
.if !defined(NO_INSTALL_MANPAGES)
|
||||
MAN8= sslh.8
|
||||
.endif
|
||||
PLIST_FILES= sbin/sslh
|
||||
|
||||
VARDIR= /var
|
||||
PLIST_SUB= VARDIR=${VARDIR}
|
||||
|
||||
USE_RC_SUBR= sslh
|
||||
|
||||
|
@ -28,7 +29,10 @@ post-patch:
|
|||
@${REINPLACE_CMD} -e 's|^PREFIX=/usr/local|PREFIX=${PREFIX}|g' ${WRKSRC}/Makefile
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/sslh ${PREFIX}/sbin
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/sslh-fork ${PREFIX}/sbin
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/sslh-select ${PREFIX}/sbin
|
||||
@${MKDIR} ${VARDIR}/run/${PORTNAME}
|
||||
@${CHOWN} -R nobody:nobody ${VARDIR}/run/${PORTNAME}
|
||||
.if !defined(NO_INSTALL_MANPAGES)
|
||||
@${INSTALL_MAN} ${WRKSRC}/sslh.8 ${MANPREFIX}/man/man8
|
||||
.endif
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (sslh-1.7a.tar.gz) = add698342ea622e5085a26f05e4ec613763f71ff203202cadfa119a45659e13a
|
||||
SIZE (sslh-1.7a.tar.gz) = 9733
|
||||
SHA256 (sslh-1.10.tar.gz) = 5554e42969a00955048b45d3d269785bbd0211d4fb2b4cf5e79503b592695771
|
||||
SIZE (sslh-1.10.tar.gz) = 25293
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
--- Makefile 2010-02-01 19:18:23.000000000 +0800
|
||||
+++ Makefile.new 2010-03-29 00:43:42.198577686 +0800
|
||||
@@ -4,7 +4,7 @@
|
||||
USELIBWRAP=1 # Use libwrap?
|
||||
--- Makefile.old 2011-12-02 10:16:46.000000000 +0000
|
||||
+++ Makefile 2011-12-02 10:18:04.000000000 +0000
|
||||
@@ -5,7 +5,7 @@
|
||||
COV_TEST= # Perform test coverage?
|
||||
PREFIX=/usr/local
|
||||
|
||||
-MAN=sslh.8.gz # man page name
|
||||
|
@ -9,8 +9,8 @@
|
|||
|
||||
# End of configuration -- the rest should take care of
|
||||
# itself
|
||||
@@ -27,7 +27,7 @@
|
||||
strip sslh
|
||||
@@ -46,7 +46,7 @@
|
||||
$(CC) $(CFLAGS) -o echosrv echosrv.o common.o $(LIBS)
|
||||
|
||||
$(MAN): sslh.pod Makefile
|
||||
- pod2man --section=8 --release=$(VERSION) --center=" " sslh.pod | gzip -9 - > $(MAN)
|
||||
|
|
|
@ -14,6 +14,9 @@
|
|||
# sslh_enable="YES"
|
||||
#
|
||||
# You can fine tune others variables too:
|
||||
# sslh_mode="fork | select"
|
||||
# fork: stable but slow performance
|
||||
# select: new but high performance
|
||||
# sslh_fib="NONE"
|
||||
# sslh_pidfile="/var/run/sslh.pid"
|
||||
# sslh_ssltarget="localhost:443"
|
||||
|
@ -40,24 +43,32 @@ sslh_setfib() {
|
|||
name="sslh"
|
||||
rcvar=sslh_enable
|
||||
|
||||
command="%%PREFIX%%/sbin/${name}"
|
||||
start_precmd="sslh_setfib"
|
||||
stop_postcmd="sslh_postcmd"
|
||||
|
||||
load_rc_config $name
|
||||
|
||||
sslh_enable=${sslh_enable:-"NO"}
|
||||
sslh_mode=${sslh_mode:-"fork"}
|
||||
sslh_fib=${sslh_fib:-"NONE"}
|
||||
sslh_listening=${sslh_listening:-"0.0.0.0:443"}
|
||||
sslh_sshtarget=${sslh_sshtarget:-"localhost:22"}
|
||||
sslh_ssltarget=${sslh_ssltarget:-"localhost:8443"}
|
||||
sslh_uid=${sslh_uid:-"nobody"}
|
||||
sslh_sshtimeout=${sslh_sshtimeout:-"2"}
|
||||
sslh_ssltarget=${sslh_ssltarget:-"localhost:8443"}
|
||||
|
||||
pidfile=${sslh_pidfile:-"/var/run/sslh.pid"}
|
||||
sslh_openvpntarget=${sslh_openvpntarget:-"localhost:1193"}
|
||||
sslh_xmpptarget=${sslh_xmpptarget:-"localhost:5222"}
|
||||
sslh_tinctarget=${sslh_tinctarget:-"localhost:655"}
|
||||
|
||||
pidfile=${sslh_pidfile:-"/var/run/sslh/sslh.pid"}
|
||||
command="%%PREFIX%%/sbin/${name}-${sslh_mode}"
|
||||
command_args="-t ${sslh_sshtimeout} -p ${sslh_listening} \
|
||||
-l ${sslh_ssltarget} -s ${sslh_sshtarget} -P ${pidfile} \
|
||||
-u ${sslh_uid}"
|
||||
--ssl ${sslh_ssltarget} --ssh ${sslh_sshtarget} -P ${pidfile} \
|
||||
--user nobody --openvpn ${sslh_openvpntarget} \
|
||||
--xmpp ${sslh_xmpptarget} --tinc ${sslh_tinctarget}"
|
||||
|
||||
sslh_postcmd()
|
||||
{
|
||||
rm -f ${pidfile}
|
||||
}
|
||||
|
||||
run_rc_command "$1"
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
sslh lets one accept both HTTPS and SSH connections on the same port. It makes
|
||||
it possible to connect to an SSH server on port 443 (e.g. from inside a
|
||||
corporate firewall) while still serving HTTPS on that port.
|
||||
sslh accepts HTTPS, SSH, OpenVPN, tinc and XMPP connections on the same port.
|
||||
This makes it possible to connect to any of these servers on port 443 while
|
||||
still serving HTTPS on that port.
|
||||
|
||||
WWW: http://www.rutschle.net/tech/sslh.shtml
|
||||
|
|
3
net/sslh/pkg-plist
Normal file
3
net/sslh/pkg-plist
Normal file
|
@ -0,0 +1,3 @@
|
|||
sbin/sslh-fork
|
||||
sbin/sslh-select
|
||||
@dirrmtry %%VARDIR%%/run/sslh
|
Loading…
Reference in a new issue