get rid of libgnugetopt dependency.
as the distfile includes GNU getopt, we don't need to depend on extra library.
This commit is contained in:
parent
1337d85a81
commit
9005f23c85
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=84832
2 changed files with 31 additions and 6 deletions
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= mpeg4ip
|
||||
PORTVERSION= 0.9.8
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= multimedia audio ipv6 net
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
@ -16,8 +17,7 @@ COMMENT= Standards-based system to encode, stream and play MPEG-4 audio/video
|
|||
|
||||
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm \
|
||||
pkg-config:${PORTSDIR}/devel/pkgconfig
|
||||
LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
|
||||
gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
|
||||
LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
|
||||
|
||||
USE_GNOME= gtk20
|
||||
USE_GMAKE= yes
|
||||
|
@ -111,10 +111,6 @@ post-patch:
|
|||
@${REINPLACE_CMD} -E -e \
|
||||
's!SDL_(AudioDelayMsec|HasAudioDelayMsec).*;$$!0;!' \
|
||||
${WRKSRC}/player/src/audio_sdl.cpp
|
||||
# use libgnugetopt
|
||||
@${REINPLACE_CMD} -E -e \
|
||||
's|(-lm)|\1 -lgnugetopt|' \
|
||||
${WRKSRC}/util/iptv/Makefile.in
|
||||
# do not install manm man pages
|
||||
@${REINPLACE_CMD} -E \
|
||||
-e 's|api.mpt||' \
|
||||
|
|
29
multimedia/mpeg4ip/files/patch-config.h.in
Normal file
29
multimedia/mpeg4ip/files/patch-config.h.in
Normal file
|
@ -0,0 +1,29 @@
|
|||
FreeBSD 5 has getopt.h and getopt_long() but they are not fully compatible
|
||||
with GNU getopt. Specifically, FreeBSD 5 does not have getopt_long_only().
|
||||
So using stock GNU getopt seems simplest way to solve this issue.
|
||||
|
||||
--- config.h.in.orig Fri Mar 7 04:38:55 2003
|
||||
+++ config.h.in Sat Jul 12 08:04:26 2003
|
||||
@@ -12,12 +12,6 @@
|
||||
/* Define to 1 if you have the `getopt' function. */
|
||||
#undef HAVE_GETOPT
|
||||
|
||||
-/* Define to 1 if you have the <getopt.h> header file. */
|
||||
-#undef HAVE_GETOPT_H
|
||||
-
|
||||
-/* Define to 1 if you have the `getopt_long' function. */
|
||||
-#undef HAVE_GETOPT_LONG
|
||||
-
|
||||
/* Define to 1 if you have the `getrusage' function. */
|
||||
#undef HAVE_GETRUSAGE
|
||||
|
||||
@@ -26,9 +20,6 @@
|
||||
|
||||
/* Define to 1 if you have the <inttypes.h> header file. */
|
||||
#undef HAVE_INTTYPES_H
|
||||
-
|
||||
-/* Define to 1 if you have the `gnugetopt' library (-lgnugetopt). */
|
||||
-#undef HAVE_LIBGNUGETOPT
|
||||
|
||||
/* Define to 1 if you have the `sndfile' library (-lsndfile). */
|
||||
#undef HAVE_LIBSNDFILE
|
Loading…
Reference in a new issue