Add a configuration knob to allow the usage of the super key instead of alt
as modifier. Strip binary, fix whitespace. PR: 225227 Submitted by: Mateusz Piotrowski Approved by: maintainer timeout (2 weeks)
This commit is contained in:
parent
15cd370d0a
commit
9037a7079d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=460417
2 changed files with 19 additions and 2 deletions
|
@ -3,10 +3,11 @@
|
|||
|
||||
PORTNAME= dwm
|
||||
PORTVERSION= 6.1
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= x11-wm
|
||||
MASTER_SITES= http://dl.suckless.org/${PORTNAME}/ \
|
||||
http://schot.a-eskwadraat.nl/files/
|
||||
|
||||
PATCH_SITES= http://dwm.suckless.org/patches/
|
||||
|
||||
MAINTAINER= schot@a-eskwadraat.nl
|
||||
|
@ -17,12 +18,16 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
|
|||
|
||||
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig
|
||||
|
||||
OPTIONS_DEFINE= XINERAMA DOCS
|
||||
OPTIONS_DEFINE= XINERAMA DOCS SUPERASMODKEY
|
||||
OPTIONS_DEFAULT=XINERAMA
|
||||
|
||||
SUPERASMODKEY_DESC= Use Super instead of Alt for the dwm mod key
|
||||
|
||||
XINERAMA_USE= XORG=xinerama
|
||||
XINERAMA_MAKE_ARGS_OFF= XINERAMAFLAGS= XINERAMALIBS=
|
||||
|
||||
SUPERASMODKEY_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-config.def.h
|
||||
|
||||
USE_XORG= x11 xft
|
||||
MAKE_ARGS= CC="${CC}" PREFIX="${PREFIX}" MANPREFIX="${MANPREFIX}/man" \
|
||||
X11INC="${LOCALBASE}/include" X11LIB="${LOCALBASE}/lib"
|
||||
|
@ -45,5 +50,6 @@ post-extract:
|
|||
post-install:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/dwm
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
11
x11-wm/dwm/files/extra-patch-config.def.h
Normal file
11
x11-wm/dwm/files/extra-patch-config.def.h
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- config.def.h.orig 2018-01-16 16:05:12 UTC
|
||||
+++ config.def.h
|
||||
@@ -42,7 +42,7 @@ static const Layout layouts[] = {
|
||||
};
|
||||
|
||||
/* key definitions */
|
||||
-#define MODKEY Mod1Mask
|
||||
+#define MODKEY Mod4Mask
|
||||
#define TAGKEYS(KEY,TAG) \
|
||||
{ MODKEY, KEY, view, {.ui = 1 << TAG} }, \
|
||||
{ MODKEY|ControlMask, KEY, toggleview, {.ui = 1 << TAG} }, \
|
Loading…
Reference in a new issue