Update the gimp suite to 2.10.6.

* add libheif support
* use openjpeg for jpeg2000 support instead of jasper.
This commit is contained in:
Koop Mast 2018-10-07 19:10:03 +00:00
parent 007426d8ea
commit 9044b9a535
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=481477
9 changed files with 3017 additions and 842 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME?= gimp-app
PORTVERSION= 2.8.22
PORTREVISION= 1
PORTVERSION= 2.10.6
PORTEPOCH?= 1
CATEGORIES?= graphics gnome
MASTER_SITES= GIMP/gimp/v${PORTVERSION:R}
@ -15,22 +14,34 @@ COMMENT= GNU Image Manipulation Program
LICENSE= GPLv3 LGPL3
LICENSE_COMB= multi
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes \
mypaint-brushes>0:graphics/mypaint-brushes
LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff \
libwebp.so:graphics/webp \
libIex-2_3.so:graphics/ilmbase \
libasound.so:audio/alsa-lib \
liblcms2.so:graphics/lcms2 \
libgegl-0.2.so:graphics/gegl \
libgegl-0.4.so:graphics/gegl \
libbabl-0.1.so:x11/babl \
libharfbuzz.so:print/harfbuzz \
libfontconfig.so:x11-fonts/fontconfig \
libdbus-1.so:devel/dbus \
libgexiv2.so:graphics/gexiv2 \
libjson-c.so:devel/json-c \
libIlmImf.so:graphics/openexr \
libjson-glib-1.0.so:devel/json-glib \
libfribidi.so:converters/fribidi \
libmypaint.so:graphics/libmypaint \
libfreetype.so:print/freetype2
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes \
mypaint-brushes>0:graphics/mypaint-brushes
GNU_CONFIGURE= yes
USES+= cpe gettext gmake jpeg libtool \
USES+= compiler:c++14-lang cpe gettext gmake gnome jpeg libtool \
localbase pathfix pkgconfig shebangfix tar:bzip2
USE_XORG= ice sm xcursor xext xfixes xmu xpm xt x11
USE_GNOME+= cairo gtk20 intlhack
USE_GNOME+= cairo gtk20 intlhack librsvg2
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
@ -43,11 +54,12 @@ CONFIGURE_ARGS?=--with-html-dir=${PREFIX}/share/doc/gimp \
--without-linux-input \
--with-print \
--enable-default-binary \
--with-lcms=lcms2 \
--disable-gimp-console \
--disable-python \
--without-appdata-test \
--with-desktop-dir=${PREFIX}/share \
--docdir=${PREFIX}/share/doc/gimp \
--with-icc-directory=${LOCALBASE}/share/color/icc \
--enable-default-binary
CONFIGURE_ENV= GIMP_THREAD_LIBS=-lpthread
LIBS+= -lexecinfo
@ -56,17 +68,17 @@ CPE_VENDOR= gnu
SHEBANG_FILES= plug-ins/pygimp/plug-ins/*.py
PLIST_SUB+= LIBVER=0.800.${PORTVERSION:E}
PLIST_SUB+= LIBVER=0.1000.${PORTVERSION:E}
.if !defined(GIMP_SLAVE)
USES+= desktop-file-utils
OPTIONS_DEFINE?= AA DBUS LIBEXIF GHOSTSCRIPT GVFS HELPBROWSER JASPER \
LIBMNG LIBRSVG2 POPPLER SIMD WMF
OPTIONS_DEFAULT= AA DBUS LIBEXIF GVFS HELPBROWSER LIBMNG LIBRSVG2 \
POPPLER WMF
OPTIONS_DEFINE?= AA LIBEXIF GHOSTSCRIPT GVFS HELPBROWSER \
LIBHEIF LIBMNG OPENJPEG POPPLER SIMD WMF
OPTIONS_DEFAULT= AA LIBEXIF GVFS LIBMNG OPENJPEG POPPLER WMF
OPTIONS_SUB= yes
AA_DESC= Ascii-art Plug-in
HELPBROWSER_DESC= Internal help browser
@ -87,8 +99,9 @@ DEBUG_CONFIGURE_ON= --enable-debug
AA_LIB_DEPENDS= libaa.so:graphics/aalib
AA_CONFIGURE_OFF= --without-aa
DBUS_LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib
DBUS_CONFIGURE_WITH= dbus
# libheif
LIBHEIF_LIB_DEPENDS= libheif.so:graphics/libheif
LIBHEIF_CONFIGURE_WITH= libheif
GHOSTSCRIPT_USES= ghostscript
GHOSTSCRIPT_CONFIGURE_WITH= gs
@ -101,17 +114,14 @@ HELPBROWSER_LIB_DEPENDS= libwebkitgtk-1.0.so:www/webkit-gtk2 \
libsoup-2.4.so:devel/libsoup
HELPBROWSER_CONFIGURE_WITH= webkit
JASPER_LIB_DEPENDS= libjasper.so:graphics/jasper
JASPER_CONFIGURE_WITH= libjasper
LIBEXIF_LIB_DEPENDS= libexif.so:graphics/libexif
LIBEXIF_CONFIGURE_OFF= --without-libexif
LIBMNG_LIB_DEPENDS= libmng.so:graphics/libmng
LIBMNG_CONFIGURE_OFF= --without-libmng
LIBRSVG2_USE= GNOME=librsvg2
LIBRSVG2_CONFIGURE_WITH=librsvg
OPENJPEG_LIB_DEPENDS= libopenjp2.so:graphics/openjpeg
OPENJPEG_CONFIGURE_WITH=jpeg2000
POPPLER_LIB_DEPENDS= libpoppler-glib.so:graphics/poppler-glib
POPPLER_CONFIGURE_OFF= --without-poppler
@ -130,8 +140,6 @@ post-patch:
s|%%GIMP_THUMB_LIBS%%|${GIMP_THUMB_LIBS}|; \
s|%%GIMP_UI_LIBS%%|${GIMP_UI_LIBS}|' \
${WRKSRC}/plug-ins/pygimp/Makefile.in
@${REINPLACE_CMD} -e 's/-u /-Wl,-u,/' \
${WRKSRC}/app/Makefile.in
@${REINPLACE_CMD} -e 's|"libpng"|"libpng15"|' \
-e 's|x86_64|amd64|g' \
${WRKSRC}/configure

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1494885183
SHA256 (gimp-2.8.22.tar.bz2) = 9187a35cc52b110d78124d7b27b68a68ade14a794c2721314bac6134d2a5638a
SIZE (gimp-2.8.22.tar.bz2) = 20873278
TIMESTAMP = 1537606601
SHA256 (gimp-2.10.6.tar.bz2) = 4ec8071f828e918384cf7bc7d1219210467c84655123f802bc55a8bf2415101f
SIZE (gimp-2.10.6.tar.bz2) = 31447973

View file

@ -1,6 +1,8 @@
--- libgimp/gimp.c.orig Fri Sep 1 06:14:32 2006
+++ libgimp/gimp.c Sun Dec 31 15:56:37 2006
@@ -29,6 +29,7 @@
Why is this patch needed?
--- libgimp/gimp.c.orig 2018-03-25 14:35:18.000000000 +0200
+++ libgimp/gimp.c 2018-04-14 18:55:00.422346000 +0200
@@ -28,6 +28,7 @@
#include <stdlib.h>
#include <string.h>
#include <sys/types.h>
@ -8,10 +10,10 @@
#ifdef HAVE_SYS_TIME_H
#include <sys/time.h>
@@ -291,6 +292,9 @@
@@ -425,6 +426,9 @@ gimp_main (const GimpPlugInInfo *info,
gimp_env_init (TRUE);
progname = argv[0];
progname = argv[ARG_PROGNAME];
+
+ /* Ignore floating point exceptions */
+ fpsetmask(0);

View file

@ -1,6 +1,6 @@
--- plug-ins/pygimp/Makefile.in.orig 2012-05-05 10:19:33.000000000 +0200
+++ plug-ins/pygimp/Makefile.in 2012-05-05 10:22:53.000000000 +0200
@@ -99,7 +99,7 @@
--- plug-ins/pygimp/Makefile.in.orig 2018-07-15 19:04:00.269226000 +0200
+++ plug-ins/pygimp/Makefile.in 2018-07-15 19:07:22.157457000 +0200
@@ -146,7 +146,7 @@ am__installdirs = "$(DESTDIR)$(pygimpdir)" "$(DESTDIR)
"$(DESTDIR)$(pygimpdir)"
LTLIBRARIES = $(pygimp_LTLIBRARIES)
am__DEPENDENCIES_1 =
@ -9,7 +9,7 @@
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_1)
am__gimpenums_la_OBJECTS = gimpenumsmodule.lo
@@ -110,16 +110,15 @@
@@ -158,17 +158,16 @@ am__v_lt_1 =
_gimpenums_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
$(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
$(_gimpenums_la_LDFLAGS) $(LDFLAGS) -o $@
@ -25,11 +25,13 @@
$(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
$(_gimpui_la_LDFLAGS) $(LDFLAGS) -o $@
-gimp_la_DEPENDENCIES = $(libgimp) $(libgimpcolor) $(libgimpbase) \
- $(libgimpui) $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
+gimp_la_DEPENDENCIES = \
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_1)
+ $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
am_gimp_la_OBJECTS = gimpmodule.lo pygimp-item.lo pygimp-display.lo \
@@ -129,14 +128,14 @@
pygimp-drawable.lo pygimp-image.lo pygimp-parasite.lo \
@@ -177,14 +176,14 @@ gimp_la_OBJECTS = $(am_gimp_la_OBJECTS)
gimp_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
$(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
$(gimp_la_LDFLAGS) $(LDFLAGS) -o $@
@ -46,18 +48,19 @@
$(am__DEPENDENCIES_1)
am_gimpthumb_la_OBJECTS = gimpthumbmodule.lo gimpthumb.lo
gimpthumb_la_OBJECTS = $(am_gimpthumb_la_OBJECTS)
@@ -588,9 +587,7 @@
@@ -761,10 +760,7 @@ gimp_la_LDFLAGS = -module -avoid-version $(no_undefine
-export-symbols-regex initgimp
gimp_la_LIBADD = \
- $(libgimp) \
- $(libgimpcolor) \
- $(libgimpbase) \
- $(libgimpui) \
+ %%GIMP_LIBS%% \
$(GLIB_LIBS) \
$(GEGL_LIBS) \
$(PYLINK_LIBS) \
$(RT_LIBS)
@@ -602,9 +599,7 @@
@@ -777,9 +773,7 @@ _gimpenums_la_LDFLAGS = -module -avoid-version $(no_un
-export-symbols-regex init_gimpenums
_gimpenums_la_LIBADD = \
@ -68,7 +71,7 @@
$(GLIB_LIBS) \
$(PYLINK_LIBS) \
$(RT_LIBS)
@@ -619,7 +614,7 @@
@@ -794,7 +788,7 @@ gimpcolor_la_LDFLAGS = -module -avoid-version $(no_und
-export-symbols-regex initgimpcolor
gimpcolor_la_LIBADD = \
@ -77,7 +80,7 @@
$(GLIB_LIBS) \
$(PYLINK_LIBS)
@@ -631,13 +626,7 @@
@@ -806,13 +800,7 @@ _gimpui_la_LDFLAGS = -module -avoid-version $(no_undef
-export-symbols-regex init_gimpui
_gimpui_la_LIBADD = \
@ -92,7 +95,7 @@
$(GTK_LIBS) \
$(PYLINK_LIBS) \
$(RT_LIBS) \
@@ -651,7 +640,7 @@
@@ -826,7 +814,7 @@ gimpthumb_la_LDFLAGS = -module -avoid-version $(no_und
-export-symbols-regex initgimpthumb
gimpthumb_la_LIBADD = \

View file

@ -1,4 +1,4 @@
On FreeBSD 10.3 gimp can cause the following error.
On FreeBSD 10.4 gimp can cause the following error.
(script-fu:3985): LibGimp-ERROR **: shmat() failed: Invalid argument
Could not attach to gimp shared memory segment

File diff suppressed because it is too large Load diff

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gimp
DISTVERSION?= 2.8.22
DISTVERSION?= 2.10.6
PORTREVISION?= 0
PORTEPOCH?= 2
CATEGORIES= graphics gnome
@ -10,7 +10,7 @@ CATEGORIES= graphics gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= The "meta-port" for The Gimp
RUN_DEPENDS= gimp-2.8:graphics/gimp-app
RUN_DEPENDS= gimp-2.10:graphics/gimp-app
USES+= metaport

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gimp
PORTREVISION= 1
PORTREVISION= 0
PORTEPOCH= 0
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
PKGNAMESUFFIX=

View file

@ -1,17 +1,17 @@
libexec/gimp/2.2/environ/pygimp.env
libexec/gimp/2.2/interpreters/pygimp.interp
libexec/gimp/2.2/plug-ins/colorxhtml.py
libexec/gimp/2.2/plug-ins/file-openraster.py
libexec/gimp/2.2/plug-ins/foggify.py
libexec/gimp/2.2/plug-ins/gradients-save-as-css.py
libexec/gimp/2.2/plug-ins/palette-offset.py
libexec/gimp/2.2/plug-ins/palette-sort.py
libexec/gimp/2.2/plug-ins/palette-to-gradient.py
libexec/gimp/2.2/plug-ins/py-slice.py
libexec/gimp/2.2/plug-ins/pyconsole.py
libexec/gimp/2.2/plug-ins/python-console.py
libexec/gimp/2.2/plug-ins/python-eval.py
libexec/gimp/2.2/plug-ins/text-brush.py
libexec/gimp/2.2/plug-ins/colorxhtml/colorxhtml.py
libexec/gimp/2.2/plug-ins/file-openraster/file-openraster.py
libexec/gimp/2.2/plug-ins/foggify/foggify.py
libexec/gimp/2.2/plug-ins/gradients-save-as-css/gradients-save-as-css.py
libexec/gimp/2.2/plug-ins/histogram-export/histogram-export.py
libexec/gimp/2.2/plug-ins/palette-offset/palette-offset.py
libexec/gimp/2.2/plug-ins/palette-sort/palette-sort.py
libexec/gimp/2.2/plug-ins/palette-to-gradient/palette-to-gradient.py
libexec/gimp/2.2/plug-ins/py-slice/py-slice.py
libexec/gimp/2.2/plug-ins/python-console/pyconsole.py
libexec/gimp/2.2/plug-ins/python-console/python-console.py
libexec/gimp/2.2/plug-ins/python-eval/python-eval.py
libexec/gimp/2.2/python/_gimpenums.so
libexec/gimp/2.2/python/_gimpui.so
libexec/gimp/2.2/python/gimp.so