- Stagify

- Update to 2.5.4
- Adopt port
This commit is contained in:
Johan van Selst 2014-08-27 11:13:57 +00:00
parent 5a31f9ef93
commit 905506f792
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=366306
6 changed files with 270 additions and 157 deletions

View file

@ -2,16 +2,14 @@
# $FreeBSD$
PORTNAME?= inn
PORTVERSION?= 2.5.3
PORTREVISION?= 1
PORTVERSION?= 2.5.4
PORTREVISION?= 0
CATEGORIES= news ipv6
# Master distribution broken
MASTER_SITES?= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR?= ${PORTNAME}
#MASTER_SITES= ${MASTER_SITE_LOCAL}
#MASTER_SITE_SUBDIR= fluffy
MAINTAINER= ports@FreeBSD.org
MAINTAINER= johans@FreeBSD.org
COMMENT= InterNetNews -- the Internet meets Netnews
BUILD_DEPENDS= p5-GD>=0:${PORTSDIR}/graphics/p5-GD \
@ -24,15 +22,15 @@ SUB_FILES= pkg-install
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
USES= gmake perl5
USES= gmake perl5 uidfix
CONFLICTS?= inn-stable-[0-9]* inn-current-[0-9]*
OPTIONS_DEFINE= PYTHON KERBEROS SASL KEYWORDS BERKELEYDB OPENSSL \
OPTIONS_DEFINE= KERBEROS SASL KEYWORDS BERKELEYDB OPENSSL \
TAGGED_HASH LARGE_FILES GNUPG
OPTIONS_DEFAULT= KEYWORDS
OPTIONS_SUB= yes
PYTHON_DESC= Embedded Python module support
KERBEROS_DESC= Enable Kerberos v5 (for auth_krb5)
SASL_DESC= Enable SASL (for imapfeed authentication)
TAGGED_HASH_DESC= Use tagged hash table for history
@ -44,7 +42,6 @@ GNUPG_DESC= GnuPG support (for pgpverify control message)
VARBASE?= /var
NO_STAGE= yes
.include "Makefile.layout"
HAS_CONFIGURE= yes
@ -55,7 +52,7 @@ CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man \
--with-spool-dir=${INN_NEWSSPOOL} \
--with-log-dir=${INN_LOGDIR} \
--with-tmp-dir=${INN_TMPDIR} \
--sysconfdir=${INN_ETCDIR} \
--sysconfdir=${INN_CONFDIR} \
--with-run-dir=${INN_RUNDIR} \
--with-db-dir=${INN_DBDIR} \
--datarootdir=${INN_SHAREDIR} \
@ -79,16 +76,8 @@ CONFIGURE_ARGS+= --with-kerberos=/usr
. endif
CONFIGURE_ENV+= ac_cv_search_krb5_parse_name="-lcrypt -lcrypto -lkrb5 -lasn1 -lroken -lhx509"
CONFIGURE_ENV+= ac_cv_func_krb5_init_ets=yes
MAN8+= auth_krb5.8
PLIST_SUB+= KRB5=""
.else
CONFIGURE_ARGS+= --without-kerberos
PLIST_SUB+= KRB5="@comment "
.endif
.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= yes
CONFIGURE_ARGS+= --with-python
.endif
.if ${PORT_OPTIONS:MLARGE_FILES}
@ -117,6 +106,7 @@ DBZ_FILES= dir hash index
PLIST_SUB+= WITH_TAGGED_HASH="@comment "
PLIST_SUB+= WITHOUT_TAGGED_HASH=""
.endif
SUB_LIST+= DBZ_FILES="${DBZ_FILES}"
.if ${PORT_OPTIONS:MOPENSSL}
USE_OPENSSL= yes
@ -133,53 +123,27 @@ RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
PORTDOCS= CONTRIBUTORS HACKING INSTALL LICENSE MANIFEST NEWS README TODO
HEADERS= clibrary.h config.h dbz.h libinn.h storage.h
MAN1= convdate.1 fastrm.1 getlist.1 grephistory.1 inews.1 innconfval.1 \
innmail.1 nntpget.1 pgpverify.1 rnews.1 shlock.1 \
shrinkfile.1 simpleftp.1 sm.1 pullnews.1
MAN3= INN::Config.3pm INN::Utils::Shlock.3pm clientlib.3 dbz.3 inndcomm.3 libauth.3 \
libinn.3 libinnhist.3 libstorage.3 list.3 qio.3 tst.3 uwildmat.3
MAN5= active.5 active.times.5 buffindexed.conf.5 control.ctl.5 \
cycbuff.conf.5 distrib.pats.5 distributions.5 expire.ctl.5 history.5 \
incoming.conf.5 inn.conf.5 innfeed.conf.5 innwatch.ctl.5 \
moderators.5 motd.news.5 newsfeeds.5 newsgroups.5 \
newslog.5 nnrpd.track.5 nntpsend.ctl.5 ovdb.5 \
passwd.nntp.5 radius.conf.5 readers.conf.5 \
storage.conf.5 subscriptions.5
MAN8= actsync.8 archive.8 batcher.8 buffchan.8 \
ckpasswd.8 cnfsheadconf.8 cnfsstat.8 controlchan.8 ctlinnd.8 \
cvtbatch.8 docheckgroups.8 domain.8 expire.8 expireover.8 \
expirerm.8 filechan.8 \
ident.8 inncheck.8 innbind.8 innd.8 inndf.8 innfeed.8 innreport.8 \
innstat.8 innupgrade.8 innwatch.8 innxbatch.8 innxmit.8 mailpost.8 makedbz.8 \
makehistory.8 mod-active.8 news.daily.8 news2mail.8 ninpaths.8 \
nnrpd.8 nntpsend.8 ovdb_init.8 ovdb_monitor.8 ovdb_server.8 \
ovdb_stat.8 overchan.8 perl-nocem.8 procbatch.8 prunehistory.8 \
radius.8 rc.news.8 scanlogs.8 scanspool.8 send-nntp.8 send-uucp.8 \
sendinpaths.8 tally.control.8 tdx-util.8 tinyleaf.8 writelog.8
MLINKS= actsync.8 actsyncd.8 docheckgroups.8 localgroups.5 perl-nocem.8 nocem.ctl.5 \
innfeed.8 imapfeed.8 motd.news.5 motd.innd.5 motd.news.5 motd.nnrpd.5 \
ninpaths.8 inpaths.8
TO_BE_STRIPPED= bin/auth/resolv/domain bin/auth/resolv/ident \
bin/auth/passwd/ckpasswd bin/auth/passwd/radius bin/rnews.libexec/decode \
bin/rnews.libexec/encode bin/tdx-util bin/innd bin/nnrpd \
bin/innfeed bin/imapfeed bin/convdate bin/expire \
bin/innfeed bin/imapfeed bin/buffindexed_d bin/convdate bin/expire \
bin/expireover bin/fastrm bin/grephistory bin/makedbz bin/makehistory \
bin/prunehistory bin/ctlinnd bin/getlist bin/inews bin/innconfval \
bin/ovdb_init bin/ovdb_monitor bin/ovdb_server bin/ovdb_stat bin/rnews \
bin/sm bin/actsync bin/archive bin/batcher bin/buffchan bin/cvtbatch \
bin/filechan bin/inndf bin/innxmit bin/innxbatch bin/ninpaths bin/nntpget \
bin/overchan bin/shlock bin/shrinkfile
bin/overchan bin/shlock bin/shrinkfile bin/tinyleaf
CONFIG_FILES= actsync.cfg actsync.ign buffindexed.conf control.ctl \
control.ctl.local cycbuff.conf \
distrib.pats distributions \
expire.ctl localgroups incoming.conf inn.conf innfeed.conf \
innreport.conf innshellvars.local innshellvars.pl.local innshellvars.tcl.local \
innwatch.ctl moderators motd.innd motd.nnrpd news2mail.cf \
innwatch.ctl moderators news2mail.cf \
newsfeeds nocem.ctl \
nnrpd.track nntpsend.ctl ovdb.conf \
passwd.nntp radius.conf readers.conf send-uucp.cf \
passwd.nntp readers.conf send-uucp.cf \
storage.conf subscriptions
SUB_LIST+= EGDIR="${EXAMPLESDIR:C,^${PREFIX},\\$\\${PREFIX},}"
@ -187,6 +151,10 @@ PLIST_SUB+= ETCFILES="${CONFIG_FILES}"
.include <bsd.port.pre.mk>
.if !defined(GID)
GID!= id -g
.endif
post-patch:
@${REINPLACE_CMD} -E 's!\$$[{(]PATHETC[})]!${EXAMPLESDIR}!g' \
${WRKSRC}/site/Makefile
@ -202,45 +170,36 @@ post-patch:
@cd ${WRKDIR} && ex ${WRKSRC}/site/Makefile < ex.script > /dev/null
pre-install:
@${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
# @${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@${MKDIR} ${STAGEDIR}${INN_DBDIR} \
${STAGEDIR}${EXAMPLESDIR} \
${STAGEDIR}${EXAMPLESDIR}/db
@${REINPLACE_CMD} -e '/^RUNASUSER *=/s/news/${UID}/' \
-e '/^RUNASGROUP *=/s/news/${GID}/' \
-e '/^RNEWSGROUP *=/s/news/${GID}/' \
${WRKSRC}/Makefile.global
post-build:
@${FIND} ${WRKSRC} -name "inn.conf" \
| ${XARGS} ${REINPLACE_CMD} -e 's/^pathhost:.*/pathhost: host.example.com/'
post-install:
.if !defined(WITHOUT_STRIP)
. for FILE in ${TO_BE_STRIPPED}
[ -e ${INN_NEWSBASE}/${FILE} ] && ${STRIP_CMD} ${INN_NEWSBASE}/${FILE}
. endfor
.endif
${CHOWN} ${MANOWN}:${MANGRP} ${PREFIX}/man ${PREFIX}/man/man1 ${PREFIX}/man/man3 \
${PREFIX}/man/man5 ${PREFIX}/man/man8
${MKDIR} ${INN_NEWSSPOOL}
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
. for FILE in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
. endfor
.endif
${MKDIR} ${INN_NEWSBASE}/include
# XXX .for FILE in ${HEADERS}
# XXX ${INSTALL_DATA} ${WRKSRC}/include/${FILE} ${INN_NEWSBASE}/include/
# XXX .endfor
${CHOWN} ${BINOWN}:news ${INN_NEWSBASE}/bin/auth/passwd/ckpasswd
${CHMOD} 4755 ${INN_NEWSBASE}/bin/auth/passwd/ckpasswd
@${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} CHECK-CONF ${INN_ETCDIR}
@(if [ ! -f ${INN_DBDIR}/history ] ; then \
${ECHO} 'Creating empty history database...' ; \
cd ${INN_DBDIR} ; \
${TOUCH} history ; \
${CHMOD} 644 history ; \
${CHOWN} news:news history ; \
su -fm news -c "${INN_NEWSBASE}/bin/makedbz -i" ; \
for s in ${DBZ_FILES} ; do \
${MV} history.n.$${s} history.$${s} ; \
done ; \
fi)
@${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL PORTMODE
.for FILE in ${TO_BE_STRIPPED}
${STRIP_CMD} ${STAGEDIR}${INN_NEWSBASE}/${FILE}
.endfor
${MKDIR} ${STAGEDIR}${INN_NEWSSPOOL}
${MKDIR} ${STAGEDIR}${INN_CONFDIR}
.for FILE in ${CONFIG_FILES}
${CP} -p ${STAGEDIR}${EXAMPLESDIR}/${FILE} ${STAGEDIR}${INN_CONFDIR}/${FILE}.sample
.endfor
${MKDIR} ${STAGEDIR}${INN_DBDIR}
.for FILE in active active.times newsgroups
${MV} ${STAGEDIR}${INN_DBDIR}/${FILE} \
${STAGEDIR}${INN_DBDIR}/${FILE}.sample
.endfor
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for FILE in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${FILE} ${STAGEDIR}${DOCSDIR}
.endfor
.include <bsd.port.post.mk>

View file

@ -8,7 +8,7 @@ INN_LAYOUT?= old
# /var, where it should be.
#-----------------------------------------------------------------------
INN_NEWSBASE= ${PREFIX}/news
INN_ETCDIR= ${INN_NEWSBASE}/etc
INN_CONFDIR= ${INN_NEWSBASE}/etc
INN_SHAREDIR= ${INN_NEWSBASE}/share
INN_RUNDIR= ${VARBASE}/run/news
INN_LOGDIR= ${VARBASE}/log/news
@ -21,7 +21,7 @@ INN_NEWSSPOOL= ${VARBASE}/news
# under /var.
#-----------------------------------------------------------------------
INN_NEWSBASE= ${PREFIX}/news
INN_ETCDIR= ${PREFIX}/etc/news
INN_CONFDIR= ${PREFIX}/etc/news
INN_SHAREDIR= ${PREFIX}/share/inn
INN_RUNDIR= ${VARBASE}/run/news
INN_LOGDIR= ${VARBASE}/log/news
@ -36,9 +36,9 @@ INN_NEWSSPOOL= ${VARBASE}/spool/news
#-----------------------------------------------------------------------
INN_NEWSBASE= ${PREFIX}/news
. if defined(WITH_STANDARD_ETC)
INN_ETCDIR= ${PREFIX}/etc/inn
INN_CONFDIR= ${PREFIX}/etc/inn
. else
INN_ETCDIR?= ${INN_NEWSBASE}/etc
INN_CONFDIR?= ${INN_NEWSBASE}/etc
. endif
INN_RUNDIR= ${INN_NEWSBASE}/run
INN_NEWSLOG?= ${VARBASE}/log/news
@ -55,9 +55,9 @@ INN_NEWSSPOOL?= ${PREFIX}/news/spool
. endif
.endif
.for sub in NEWSBASE ETCDIR RUNDIR LOGDIR DBDIR TMPDIR NEWSSPOOL SHAREDIR
PLIST_SUB+= ${sub}="${INN_${sub}:C,^${PREFIX},%D,}"
SUB_LIST+= ${sub}="${INN_${sub}:C,^${PREFIX},${PREFIX},}"
.for sub in NEWSBASE CONFDIR RUNDIR LOGDIR DBDIR TMPDIR NEWSSPOOL SHAREDIR
PLIST_SUB+= ${sub}="${INN_${sub}}"
SUB_LIST+= ${sub}="${INN_${sub}}"
.endfor
PLIST_SUB+= CWDNEWSBASE="@cwd ${INN_NEWSBASE}"

View file

@ -1,2 +1,2 @@
SHA256 (inn-2.5.3.tar.gz) = 60f0042b144499680cc577a4330aeaac5dac20c5994649c0e945d32b5f8dbcf1
SIZE (inn-2.5.3.tar.gz) = 2412119
SHA256 (inn-2.5.4.tar.gz) = 5b62240c3074f2f38b3bcc656c343c587f2a923ec9d45e19f0d4ce269cb3f3f4
SIZE (inn-2.5.4.tar.gz) = 2408600

View file

@ -1,6 +1,6 @@
--- configure.orig 2012-06-16 05:25:36.000000000 +1100
+++ configure 2013-11-18 02:00:26.831865533 +1100
@@ -14595,7 +14595,7 @@
--- configure.orig 2014-05-17 10:24:49.000000000 +0200
+++ configure 2014-08-21 15:24:09.000000000 +0200
@@ -14631,7 +14631,7 @@ $as_echo "yes" >&6; }
$as_echo_n "checking for Berkeley DB location... " >&6; }
if test x"$DB_DIR" = xyes ; then
for dir in $prefix /usr/local /usr ; do
@ -9,13 +9,14 @@
DB_DIR=$dir
break
fi
@@ -14604,9 +14604,9 @@
if test x"$DB_DIR" = xyes ; then
@@ -14641,10 +14641,10 @@ $as_echo_n "checking for Berkeley DB loc
as_fn_error $? "cannot find Berkeley DB" "$LINENO" 5
else
- DB_CPPFLAGS="-I$DB_DIR/include"
+ DB_CPPFLAGS="-I$DB_DIR/include/${DB_VER}"
DB_LDFLAGS="-L$DB_DIR/lib"
if test x"$DB_DIR" != x/usr ; then
- DB_CPPFLAGS="-I$DB_DIR/include"
+ DB_CPPFLAGS="-I$DB_DIR/include/${DB_VER}"
DB_LDFLAGS="-L$DB_DIR/lib"
fi
- DB_LIBS="-ldb"
+ DB_LIBS="-l${DB_LIB}"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $DB_DIR" >&5

View file

@ -10,6 +10,7 @@ RUNDIR="%%RUNDIR%%"
TMPDIR="%%TMPDIR%%"
NEWSBASE="%%NEWSBASE%%"
NEWSSPOOL="%%NEWSSPOOL%%"
DBZ_FILES="%%DBZ_FILES%%"
EGDIR="%%EGDIR%%"
@ -78,6 +79,17 @@ case $2 in
for f in ${EGDIR}/db/*; do
cp -pR ${f} ${DBDIR}
done
(if [ ! -f ${DBDIR}/history ] ; then
echo 'Creating empty history database...'
cd ${DBDIR}
touch history
chmod 644 history
chown news:news history
su -fm news -c "${NEWSBASE}/bin/makedbz -i"
for s in ${DBZ_FILES} ; do
mv history.n.${s} history.${s}
done
fi)
fi
fi

View file

@ -4,8 +4,12 @@ bin/actmerge
bin/actsync
bin/actsyncd
bin/archive
@group news
@mode 4755
bin/auth/passwd/ckpasswd
%%KRB5%%bin/auth/passwd/auth_krb5
@group
@mode
%%KERBEROS%%bin/auth/passwd/auth_krb5
bin/auth/passwd/radius
bin/auth/resolv/domain
bin/auth/resolv/ident
@ -164,31 +168,124 @@ lib/perl/INN/Config.pm
lib/perl/INN/Utils/Shlock.pm
@comment --------------------------------------------------------------
@cwd
@exec mkdir -p %%DBDIR%%
@exec mkdir -p %%EXAMPLESDIR%%/db
@unexec f=active; if cmp -s %%DBDIR%%/$f %D/%%EXAMPLESDIR%%/db/$f; then rm -f %%DBDIR%%/$f; fi
@unexec f=active.times; if cmp -s %%DBDIR%%/$f %D/%%EXAMPLESDIR%%/db/$f; then rm -f %%DBDIR%%/$f; fi
@unexec f=history; if cmp -s %%DBDIR%%/$f %D/%%EXAMPLESDIR%%/db/$f; then rm -f %%DBDIR%%/$f; fi
@unexec f=history.dir; if cmp -s %%DBDIR%%/$f %D/%%EXAMPLESDIR%%/db/$f; then rm -f %%DBDIR%%/$f; fi
@unexec f=newsgroups; if cmp -s %%DBDIR%%/$f %D/%%EXAMPLESDIR%%/db/$f; then rm -f %%DBDIR%%/$f; fi
%%EXAMPLESDIR%%/db/active
%%EXAMPLESDIR%%/db/active.times
%%EXAMPLESDIR%%/db/history
%%EXAMPLESDIR%%/db/history.dir
%%EXAMPLESDIR%%/db/newsgroups
@unexec rm -f %D/%%EXAMPLESDIR%%/db/active.old 2> /dev/null || true
@unexec rm -f %D/%%EXAMPLESDIR%%/db/history.n.dir 2> /dev/null || true
@unexec rm -f %D/%%EXAMPLESDIR%%/db/history.n.hash 2> /dev/null || true
@unexec rm -f %D/%%EXAMPLESDIR%%/db/history.n.index 2> /dev/null || true
man/man1/convdate.1.gz
man/man1/fastrm.1.gz
man/man1/getlist.1.gz
man/man1/grephistory.1.gz
man/man1/inews.1.gz
man/man1/innconfval.1.gz
man/man1/innmail.1.gz
man/man1/nntpget.1.gz
man/man1/pgpverify.1.gz
man/man1/pullnews.1.gz
man/man1/rnews.1.gz
man/man1/shlock.1.gz
man/man1/shrinkfile.1.gz
man/man1/simpleftp.1.gz
man/man1/sm.1.gz
man/man3/INN::Config.3pm.gz
man/man3/INN::Utils::Shlock.3pm.gz
man/man3/clientlib.3.gz
man/man3/dbz.3.gz
man/man3/inndcomm.3.gz
man/man3/libauth.3.gz
man/man3/libinn.3.gz
man/man3/libinnhist.3.gz
man/man3/libstorage.3.gz
man/man3/list.3.gz
man/man3/qio.3.gz
man/man3/tst.3.gz
man/man3/uwildmat.3.gz
man/man5/active.5.gz
man/man5/active.times.5.gz
man/man5/buffindexed.conf.5.gz
man/man5/control.ctl.5.gz
man/man5/cycbuff.conf.5.gz
man/man5/distrib.pats.5.gz
man/man5/distributions.5.gz
man/man5/expire.ctl.5.gz
man/man5/history.5.gz
man/man5/incoming.conf.5.gz
man/man5/inn-radius.conf.5.gz
man/man5/inn.conf.5.gz
man/man5/innfeed.conf.5.gz
man/man5/innwatch.ctl.5.gz
man/man5/localgroups.5.gz
man/man5/moderators.5.gz
man/man5/motd.innd.5.gz
man/man5/motd.news.5.gz
man/man5/motd.nnrpd.5.gz
man/man5/newsfeeds.5.gz
man/man5/newsgroups.5.gz
man/man5/newslog.5.gz
man/man5/nnrpd.track.5.gz
man/man5/nntpsend.ctl.5.gz
man/man5/nocem.ctl.5.gz
man/man5/ovdb.5.gz
man/man5/passwd.nntp.5.gz
man/man5/readers.conf.5.gz
man/man5/storage.conf.5.gz
man/man5/subscriptions.5.gz
man/man8/actsync.8.gz
man/man8/actsyncd.8.gz
man/man8/archive.8.gz
man/man8/batcher.8.gz
man/man8/buffchan.8.gz
man/man8/ckpasswd.8.gz
man/man8/cnfsheadconf.8.gz
man/man8/cnfsstat.8.gz
man/man8/controlchan.8.gz
man/man8/ctlinnd.8.gz
man/man8/cvtbatch.8.gz
man/man8/docheckgroups.8.gz
man/man8/domain.8.gz
man/man8/expire.8.gz
man/man8/expireover.8.gz
man/man8/expirerm.8.gz
man/man8/filechan.8.gz
man/man8/ident.8.gz
man/man8/imapfeed.8.gz
man/man8/innbind.8.gz
man/man8/inncheck.8.gz
man/man8/innd.8.gz
man/man8/inndf.8.gz
man/man8/innfeed.8.gz
man/man8/innreport.8.gz
man/man8/innstat.8.gz
man/man8/innupgrade.8.gz
man/man8/innwatch.8.gz
man/man8/innxbatch.8.gz
man/man8/innxmit.8.gz
man/man8/inpaths.8.gz
man/man8/mailpost.8.gz
man/man8/makedbz.8.gz
man/man8/makehistory.8.gz
man/man8/mod-active.8.gz
man/man8/news.daily.8.gz
man/man8/news2mail.8.gz
man/man8/ninpaths.8.gz
man/man8/nnrpd.8.gz
man/man8/nntpsend.8.gz
man/man8/ovdb_init.8.gz
man/man8/ovdb_monitor.8.gz
man/man8/ovdb_server.8.gz
man/man8/ovdb_stat.8.gz
man/man8/overchan.8.gz
man/man8/perl-nocem.8.gz
man/man8/procbatch.8.gz
man/man8/prunehistory.8.gz
man/man8/radius.8.gz
man/man8/rc.news.8.gz
man/man8/scanlogs.8.gz
man/man8/scanspool.8.gz
man/man8/send-nntp.8.gz
man/man8/send-uucp.8.gz
man/man8/sendinpaths.8.gz
man/man8/tally.control.8.gz
man/man8/tdx-util.8.gz
man/man8/tinyleaf.8.gz
man/man8/writelog.8.gz
@comment --------------------------------------------------------------
%%WITHOUT_TAGGED_HASH%%@unexec f=history.hash; if cmp -s %%DBDIR%%/$f %D/%%EXAMPLESDIR%%/db/$f; then rm -f %%DBDIR%%/$f; fi
%%WITHOUT_TAGGED_HASH%%@unexec f=history.index; if cmp -s %%DBDIR%%/$f %D/%%EXAMPLESDIR%%/db/$f; then rm -f %%DBDIR%%/$f; fi
%%WITHOUT_TAGGED_HASH%%@unexec rm -f %D/%%EXAMPLESDIR%%/db/history.hash 2> /dev/null || true
%%WITHOUT_TAGGED_HASH%%@unexec rm -f %D/%%EXAMPLESDIR%%/db/history.index 2> /dev/null || true
%%WITH_TAGGED_HASH%%@unexec f=history.pag; if cmp -s %%DBDIR%%/$f %D/%%EXAMPLESDIR%%/db/$f; then rm -f %%DBDIR%%/$f; fi
%%WITH_TAGGED_HASH%%@unexec rm -f %D/%%EXAMPLESDIR%%/db/history.pag 2> /dev/null || true
@comment --------------------------------------------------------------
@unexec for f in %%ETCFILES%%; do if cmp -s %%ETCDIR%%/${f} %D/%%EXAMPLESDIR%%/${f}; then rm -f %%ETCDIR%%/${f}; fi; done
%%EXAMPLESDIR%%/actsync.cfg
%%EXAMPLESDIR%%/actsync.ign
%%EXAMPLESDIR%%/buffindexed.conf
@ -199,6 +296,7 @@ lib/perl/INN/Utils/Shlock.pm
%%EXAMPLESDIR%%/distributions
%%EXAMPLESDIR%%/expire.ctl
%%EXAMPLESDIR%%/incoming.conf
%%EXAMPLESDIR%%/inn-radius.conf
%%EXAMPLESDIR%%/inn.conf
%%EXAMPLESDIR%%/innfeed.conf
%%EXAMPLESDIR%%/innreport.conf
@ -208,8 +306,8 @@ lib/perl/INN/Utils/Shlock.pm
%%EXAMPLESDIR%%/innwatch.ctl
%%EXAMPLESDIR%%/localgroups
%%EXAMPLESDIR%%/moderators
%%EXAMPLESDIR%%/motd.innd
%%EXAMPLESDIR%%/motd.nnrpd
%%EXAMPLESDIR%%/motd.innd.sample
%%EXAMPLESDIR%%/motd.nnrpd.sample
%%EXAMPLESDIR%%/news2mail.cf
%%EXAMPLESDIR%%/newsfeeds
%%EXAMPLESDIR%%/nnrpd.track
@ -217,42 +315,85 @@ lib/perl/INN/Utils/Shlock.pm
%%EXAMPLESDIR%%/nocem.ctl
%%EXAMPLESDIR%%/ovdb.conf
%%EXAMPLESDIR%%/passwd.nntp
%%EXAMPLESDIR%%/radius.conf
%%EXAMPLESDIR%%/readers.conf
%%EXAMPLESDIR%%/send-uucp.cf
%%EXAMPLESDIR%%/storage.conf
%%EXAMPLESDIR%%/subscriptions
@exec mkdir -p %%ETCDIR%%
@exec for f in %%ETCFILES%%; do [ -f %%ETCDIR%%/${f} ] || cp -fp %D/%%EXAMPLESDIR%%/${f} %%ETCDIR%%/${f}; done
@comment --------------------------------------------------------------
@cwd /
@sample %%DBDIR%%/active.sample
@sample %%DBDIR%%/active.times.sample
@sample %%DBDIR%%/newsgroups.sample
@comment --------------------------------------------------------------
%%WITHOUT_TAGGED_HASH%%@unexec f=history.hash; if cmp -s %%DBDIR%%/$f %%EXAMPLESDIR%%/db/$f; then rm -f %%DBDIR%%/$f; fi
%%WITHOUT_TAGGED_HASH%%@unexec f=history.index; if cmp -s %%DBDIR%%/$f %%EXAMPLESDIR%%/db/$f; then rm -f %%DBDIR%%/$f; fi
%%WITHOUT_TAGGED_HASH%%@unexec rm -f %%EXAMPLESDIR%%/db/history.hash 2> /dev/null || true
%%WITHOUT_TAGGED_HASH%%@unexec rm -f %%EXAMPLESDIR%%/db/history.index 2> /dev/null || true
%%WITH_TAGGED_HASH%%@unexec f=history.pag; if cmp -s %%DBDIR%%/$f %%EXAMPLESDIR%%/db/$f; then rm -f %%DBDIR%%/$f; fi
%%WITH_TAGGED_HASH%%@unexec rm -f %%EXAMPLESDIR%%/db/history.pag 2> /dev/null || true
%%CONFDIR%%/actsync.cfg.sample
%%CONFDIR%%/actsync.ign.sample
%%CONFDIR%%/buffindexed.conf.sample
%%CONFDIR%%/control.ctl.local.sample
%%CONFDIR%%/control.ctl.sample
%%CONFDIR%%/cycbuff.conf.sample
%%CONFDIR%%/distrib.pats.sample
%%CONFDIR%%/distributions.sample
%%CONFDIR%%/expire.ctl.sample
%%CONFDIR%%/incoming.conf.sample
%%CONFDIR%%/inn.conf.sample
%%CONFDIR%%/innfeed.conf.sample
%%CONFDIR%%/innreport.conf.sample
%%CONFDIR%%/innshellvars.local.sample
%%CONFDIR%%/innshellvars.pl.local.sample
%%CONFDIR%%/innshellvars.tcl.local.sample
%%CONFDIR%%/innwatch.ctl.sample
%%CONFDIR%%/localgroups.sample
%%CONFDIR%%/moderators.sample
%%CONFDIR%%/news2mail.cf.sample
%%CONFDIR%%/newsfeeds.sample
%%CONFDIR%%/nnrpd.track.sample
%%CONFDIR%%/nntpsend.ctl.sample
%%CONFDIR%%/nocem.ctl.sample
%%CONFDIR%%/ovdb.conf.sample
%%CONFDIR%%/passwd.nntp.sample
%%CONFDIR%%/readers.conf.sample
%%CONFDIR%%/send-uucp.cf.sample
%%CONFDIR%%/storage.conf.sample
%%CONFDIR%%/subscriptions.sample
@comment --------------------------------------------------------------
@cwd
@dirrm %%EXAMPLESDIR%%/db
@dirrm %%EXAMPLESDIR%%
@unexec rmdir %%TMPDIR%% 2>/dev/null || true
@unexec rmdir %%SHAREDIR%% 2>/dev/null || true
@unexec rmdir %%NEWSSPOOL%%/overview 2>/dev/null || true
@unexec rmdir %%NEWSSPOOL%%/outgoing 2>/dev/null || true
@unexec rmdir %%NEWSSPOOL%%/innfeed 2>/dev/null || true
@unexec rmdir %%NEWSSPOOL%%/incoming/bad 2>/dev/null || true
@unexec rmdir %%NEWSSPOOL%%/incoming 2>/dev/null || true
@unexec rmdir %%NEWSSPOOL%%/articles 2>/dev/null || true
@unexec rmdir %%NEWSSPOOL%%/archive 2>/dev/null || true
@unexec rmdir %%NEWSSPOOL%% 2>/dev/null || true
@unexec rmdir %%RUNDIR%% 2>/dev/null || true
@unexec rmdir %%NEWSBASE%%/http
@unexec rmdir %%NEWSBASE%%/lib/perl/INN/Utils
@unexec rmdir %%NEWSBASE%%/lib/perl/INN
@unexec rmdir %%NEWSBASE%%/lib/perl
@unexec rmdir %%NEWSBASE%%/lib
@unexec rmdir %%NEWSBASE%%/include/inn
@unexec rmdir %%NEWSBASE%%/include
@unexec rmdir %%ETCDIR%% 2>/dev/null || true
@unexec rmdir %%NEWSBASE%%/doc
@unexec rmdir %%DBDIR%% 2>/dev/null || true
@unexec rmdir %%NEWSBASE%%/bin/rnews.libexec
@unexec rmdir %%NEWSBASE%%/bin/filter
@unexec rmdir %%NEWSBASE%%/bin/control
@unexec rmdir %%NEWSBASE%%/bin/auth/resolv
@unexec rmdir %%NEWSBASE%%/bin/auth/passwd
@unexec rmdir %%NEWSBASE%%/bin/auth
@unexec rmdir %%NEWSBASE%%/bin
@cwd /
@dirrm %%TMPDIR%%
@dirrm %%SHAREDIR%%
@dirrm %%NEWSSPOOL%%/overview
@dirrm %%NEWSSPOOL%%/outgoing
@dirrm %%NEWSSPOOL%%/innfeed
@dirrm %%NEWSSPOOL%%/incoming/bad
@dirrm %%NEWSSPOOL%%/incoming
@dirrm %%NEWSSPOOL%%/articles
@dirrm %%NEWSSPOOL%%/archive
@dirrm %%NEWSSPOOL%%
@dirrm %%RUNDIR%%
@dirrm %%NEWSBASE%%/http
@dirrm %%NEWSBASE%%/lib/perl/INN/Utils
@dirrm %%NEWSBASE%%/lib/perl/INN
@dirrm %%NEWSBASE%%/lib/perl
@dirrm %%NEWSBASE%%/lib
@dirrm %%NEWSBASE%%/include/inn
@dirrm %%NEWSBASE%%/include
@dirrm %%NEWSBASE%%/doc
@dirrm %%NEWSBASE%%/bin/rnews.libexec
@dirrm %%NEWSBASE%%/bin/filter
@dirrm %%NEWSBASE%%/bin/control
@dirrm %%NEWSBASE%%/bin/auth/resolv
@dirrm %%NEWSBASE%%/bin/auth/passwd
@dirrm %%NEWSBASE%%/bin/auth
@dirrm %%NEWSBASE%%/bin
@dirrm %%CONFDIR%%
@dirrm %%DBDIR%%
@dirrm %%LOGDIR%%/OLD
@dirrm %%LOGDIR%%
@unexec rmdir %%NEWSBASE%% 2>/dev/null ||( echo "===> If you don't plan to use inn later, you can safely remove %%NEWSBASE%%. Deinstall process kept these files intact:" | fmt && for i in $(find %D/news -type f); do echo " - $i"; done)