Add new port misc/auto-multiple-choice
PR: 181451 Submitted by: Hiroto Kagotani Auto Multiple Choice (AMC) is a piece of software that helps you to create and manage multiple choice questionnaires, with automated marking. Tests can be written in plain text or LaTeX. Automated correction and grading is performed from scans of the answer sheets using optical mark recognition.
This commit is contained in:
parent
40f42c44c1
commit
9073a291cd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=368639
9 changed files with 560 additions and 0 deletions
|
@ -13,6 +13,7 @@
|
|||
SUBDIR += asbutton
|
||||
SUBDIR += asr-manpages
|
||||
SUBDIR += astrolog
|
||||
SUBDIR += auto-multiple-choice
|
||||
SUBDIR += bb
|
||||
SUBDIR += bbjd
|
||||
SUBDIR += bdelta
|
||||
|
|
61
misc/auto-multiple-choice/Makefile
Normal file
61
misc/auto-multiple-choice/Makefile
Normal file
|
@ -0,0 +1,61 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= auto-multiple-choice
|
||||
PORTVERSION= 1.2.1
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://download.gna.org/auto-qcm/
|
||||
DISTNAME= auto-multiple-choice_${PORTVERSION}_precomp
|
||||
|
||||
MAINTAINER= hiroto.kagotani@gmail.com
|
||||
COMMENT= Multiple-choice questionnaire management with automated marking
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
LIB_DEPENDS= libnetpbm.so:${PORTSDIR}/graphics/netpbm \
|
||||
libopencv_highgui.so:${PORTSDIR}/graphics/opencv
|
||||
RUN_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
|
||||
p5-Email-MIME>=0:${PORTSDIR}/mail/p5-Email-MIME \
|
||||
p5-Email-Sender>=0:${PORTSDIR}/mail/p5-Email-Sender \
|
||||
p5-Gtk2-Notify>=0:${PORTSDIR}/devel/p5-Gtk2-Notify \
|
||||
p5-Locale-gettext>=0:${PORTSDIR}/devel/p5-Locale-gettext \
|
||||
p5-OpenOffice-OODoc>=0:${PORTSDIR}/textproc/p5-OpenOffice-OODoc \
|
||||
p5-Text-CSV>=0:${PORTSDIR}/textproc/p5-Text-CSV \
|
||||
p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
|
||||
p5-XML-Writer>=0:${PORTSDIR}/textproc/p5-XML-Writer \
|
||||
pdftoppm:${PORTSDIR}/graphics/poppler-utils
|
||||
|
||||
WRKSRC= ${WRKDIR}/auto-multiple-choice-${PORTVERSION}
|
||||
PORTDOCS= html auto-multiple-choice.*
|
||||
MANLANG= "" fr ja
|
||||
|
||||
SHARED_MIMEINFO_DIR= ${PREFIX}/share/mime/packages
|
||||
LANG_GTKSOURCEVIEW_DIR= ${PREFIX}/share/gtksourceview-2.0/language-specs
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
USE_TEX= latex texhash
|
||||
USES+= gettext gmake iconv:build perl5 shared-mime-info
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "\
|
||||
s|%%DATADIR%%|${DATADIR}|g; \
|
||||
s|%%DOCSDIR%%|${DOCSDIR}|g; \
|
||||
s|%%LANG_GTKSOURCEVIEW_DIR%%|${LANG_GTKSOURCEVIEW_DIR}|g; \
|
||||
s|%%LOCALBASE%%|${LOCALBASE}|g; \
|
||||
s|%%MANPREFIX%%|${MANPREFIX}|g; \
|
||||
s|%%PREFIX%%|${PREFIX}|g; \
|
||||
s|%%SHARED_MIMEINFO_DIR%%|${SHARED_MIMEINFO_DIR}|g; \
|
||||
s|%%SITE_PERL_REL%%|${SITE_PERL_REL}|g; \
|
||||
s|%%TEXMFLOCALDIR%%|${TEXMFLOCALDIR}|g; \
|
||||
" ${WRKSRC}/Makefile.conf
|
||||
@${REINPLACE_CMD} -e "s|^#! /usr/bin/perl|#!${LOCALBASE}/bin/perl|" \
|
||||
${WRKSRC}/*.pl ${WRKSRC}/*.pl.in
|
||||
@${REINPLACE_CMD} -e "s|^#! @/PERLPATH/@|#!${LOCALBASE}/bin/perl|" \
|
||||
${WRKSRC}/auto-multiple-choice.in
|
||||
|
||||
pre-install:
|
||||
${MKDIR} ${STAGEDIR}/${SHARED_MIMEINFO_DIR} \
|
||||
${STAGEDIR}/${LANG_GTKSOURCEVIEW_DIR}
|
||||
|
||||
.include <bsd.port.mk>
|
2
misc/auto-multiple-choice/distinfo
Normal file
2
misc/auto-multiple-choice/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (auto-multiple-choice_1.2.1_precomp.tar.gz) = 534b1a9cd855532bd6c065a29e09dec2ba07c8ee155317e416260a9d5942420a
|
||||
SIZE (auto-multiple-choice_1.2.1_precomp.tar.gz) = 6022417
|
137
misc/auto-multiple-choice/files/patch-AMC-traitement-image.c
Normal file
137
misc/auto-multiple-choice/files/patch-AMC-traitement-image.c
Normal file
|
@ -0,0 +1,137 @@
|
|||
--- ./AMC-traitement-image.c.orig 2013-07-28 22:22:29.000000000 +0900
|
||||
+++ ./AMC-traitement-image.c 2014-04-16 17:44:03.000000000 +0900
|
||||
@@ -218,6 +218,22 @@
|
||||
printf("CC %d %d\n",n,imax);
|
||||
}
|
||||
|
||||
+#define deplace(_i,_j) \
|
||||
+ do { \
|
||||
+ int i = _i, j = _j; \
|
||||
+ coins[i].x+=delta*(coins[j].x-coins[i].x); \
|
||||
+ coins[i].y+=delta*(coins[j].y-coins[i].y); \
|
||||
+ } while (0)
|
||||
+
|
||||
+#define restreint(_x,_y) \
|
||||
+ do { \
|
||||
+ int *x = _x, *y = _y; \
|
||||
+ if(*x<0) *x=0; \
|
||||
+ if(*y<0) *y=0; \
|
||||
+ if(*x>=tx) *x=tx-1; \
|
||||
+ if(*y>=ty) *y=ty-1; \
|
||||
+ } while (0)
|
||||
+
|
||||
void mesure_case(pixel **img,int tx,int ty,pixval maxval,
|
||||
double prop,point *coins) {
|
||||
int npix,npixnoir,xmin,xmax,ymin,ymax,x,y;
|
||||
@@ -225,18 +241,6 @@
|
||||
int i,ok;
|
||||
double delta;
|
||||
|
||||
- void deplace(int i,int j) {
|
||||
- coins[i].x+=delta*(coins[j].x-coins[i].x);
|
||||
- coins[i].y+=delta*(coins[j].y-coins[i].y);
|
||||
- }
|
||||
-
|
||||
- void restreint(int *x,int *y) {
|
||||
- if(*x<0) *x=0;
|
||||
- if(*y<0) *y=0;
|
||||
- if(*x>=tx) *x=tx-1;
|
||||
- if(*y>=ty) *y=ty-1;
|
||||
- }
|
||||
-
|
||||
npix=0;
|
||||
npixnoir=0;
|
||||
xmin=tx-1;
|
||||
@@ -292,47 +296,48 @@
|
||||
int xmin,xmax,ymin,ymax;
|
||||
} infocol;
|
||||
|
||||
-void repere_magick(pixel **img,int tx,int ty,pixval maxval) {
|
||||
- infocol *infos;
|
||||
-
|
||||
- int ninfo,ninfo_alloc;
|
||||
- int i,x,y,red;
|
||||
- int en_couleur;
|
||||
+int trouve_id(int magick,int exo,int quest,infocol **infos_p,int *ninfo_p,int *ninfo_alloc_p) {
|
||||
+ int i,ii;
|
||||
+ ii=-1;
|
||||
+ for(i=0;i<*ninfo_p;i++) {
|
||||
+ if((*infos_p)[i].magick==magick
|
||||
+ && (*infos_p)[i].exo==exo && (*infos_p)[i].quest==quest) ii=i;
|
||||
+ }
|
||||
+ if(ii<0) {
|
||||
+ ii=*ninfo_p;
|
||||
|
||||
- int trouve_id(int magick,int exo,int quest) {
|
||||
- int i,ii;
|
||||
- ii=-1;
|
||||
- for(i=0;i<ninfo;i++) {
|
||||
- if(infos[i].magick==magick
|
||||
- && infos[i].exo==exo && infos[i].quest==quest) ii=i;
|
||||
+ if(*ninfo_alloc_p<ii+1) {
|
||||
+ *ninfo_alloc_p+=INFO_BLOC;
|
||||
+ *infos_p=(infocol*)realloc(*infos_p,*ninfo_alloc_p*sizeof(infocol));
|
||||
}
|
||||
- if(ii<0) {
|
||||
- ii=ninfo;
|
||||
|
||||
- if(ninfo_alloc<ii+1) {
|
||||
- ninfo_alloc+=INFO_BLOC;
|
||||
- infos=(infocol*)realloc(infos,ninfo_alloc*sizeof(infocol));
|
||||
- }
|
||||
-
|
||||
- infos[ii].magick=magick;
|
||||
- infos[ii].exo=exo;
|
||||
- infos[ii].quest=quest;
|
||||
- infos[ii].xmin=100000;
|
||||
- infos[ii].ymin=100000;
|
||||
- infos[ii].xmax=-1;
|
||||
- infos[ii].ymax=-1;
|
||||
- ninfo++;
|
||||
- }
|
||||
- return(ii);
|
||||
+ (*infos_p)[ii].magick=magick;
|
||||
+ (*infos_p)[ii].exo=exo;
|
||||
+ (*infos_p)[ii].quest=quest;
|
||||
+ (*infos_p)[ii].xmin=100000;
|
||||
+ (*infos_p)[ii].ymin=100000;
|
||||
+ (*infos_p)[ii].xmax=-1;
|
||||
+ (*infos_p)[ii].ymax=-1;
|
||||
+ (*ninfo_p)++;
|
||||
}
|
||||
+ return(ii);
|
||||
+}
|
||||
|
||||
- void ajoute(int id,int x,int y) {
|
||||
- if(x > infos[id].xmax) infos[id].xmax=x;
|
||||
- if(x < infos[id].xmin) infos[id].xmin=x;
|
||||
- if(y > infos[id].ymax) infos[id].ymax=y;
|
||||
- if(y < infos[id].ymin) infos[id].ymin=y;
|
||||
- }
|
||||
+#define ajoute(_id,_x,_y) \
|
||||
+ do { \
|
||||
+ int id = _id, x = _x, y = _y; \
|
||||
+ if(x > infos[id].xmax) infos[id].xmax=x; \
|
||||
+ if(x < infos[id].xmin) infos[id].xmin=x; \
|
||||
+ if(y > infos[id].ymax) infos[id].ymax=y; \
|
||||
+ if(y < infos[id].ymin) infos[id].ymin=y; \
|
||||
+ } while (0)
|
||||
+
|
||||
+void repere_magick(pixel **img,int tx,int ty,pixval maxval) {
|
||||
+ infocol *infos;
|
||||
|
||||
+ int ninfo,ninfo_alloc;
|
||||
+ int i,x,y,red;
|
||||
+ int en_couleur;
|
||||
|
||||
infos=NULL;
|
||||
ninfo_alloc=0;
|
||||
@@ -347,7 +352,7 @@
|
||||
if(red!=PPM_GETG(img[y][x])) en_couleur=1;
|
||||
if(red!=PPM_GETB(img[y][x])) en_couleur=1;
|
||||
if(en_couleur)
|
||||
- ajoute(trouve_id(red,PPM_GETG(img[y][x]),PPM_GETB(img[y][x])),x,y);
|
||||
+ ajoute(trouve_id(red,PPM_GETG(img[y][x]),PPM_GETB(img[y][x]),&infos,&ninfo,&ninfo_alloc),x,y);
|
||||
}
|
||||
}
|
||||
}
|
59
misc/auto-multiple-choice/files/patch-Makefile
Normal file
59
misc/auto-multiple-choice/files/patch-Makefile
Normal file
|
@ -0,0 +1,59 @@
|
|||
--- ./Makefile.orig 2013-07-28 22:22:29.000000000 +0900
|
||||
+++ ./Makefile 2014-03-05 18:40:32.000000000 +0900
|
||||
@@ -51,7 +51,7 @@
|
||||
# try to find right names for OpenCV libs
|
||||
|
||||
ifeq ($(GCC_OPENCV_LIBS),auto)
|
||||
-ifeq ($(shell echo 'main(){}' | gcc -xc -lopencv_core - -o /dev/null 2>/dev/null && echo "OK"),OK)
|
||||
+ifeq ($(shell echo 'main(){}' | $(CC) -xc $(LDFLAGS) -lopencv_core - -o /dev/null 2>/dev/null && echo "OK"),OK)
|
||||
GCC_OPENCV_LIBS:=-lopencv_core -lopencv_highgui -lopencv_imgproc
|
||||
else
|
||||
GCC_OPENCV_LIBS:=-lcv -lhighgui -lcxcore
|
||||
@@ -199,7 +199,7 @@
|
||||
install -d -m 0755 $(USER_GROUP) $(DESTDIR)/$(MODSDIR)/perl
|
||||
install -d -m 0755 $(USER_GROUP) $(DESTDIR)/$(MODSDIR)/exec
|
||||
install -m 0755 $(USER_GROUP) $(MODS) $(DESTDIR)/$(MODSDIR)/perl
|
||||
- install -m 0755 $(USER_GROUP) $(BINARIES) $(DESTDIR)/$(MODSDIR)/exec
|
||||
+ install -s -m 0755 $(USER_GROUP) $(BINARIES) $(DESTDIR)/$(MODSDIR)/exec
|
||||
install -m 0644 $(USER_GROUP) $(GLADE) $(DESTDIR)/$(MODSDIR)/perl
|
||||
install -d -m 0755 $(USER_GROUP) $(DESTDIR)/$(TEXDIR)
|
||||
install -m 0644 $(USER_GROUP) $(STY) $(DESTDIR)/$(TEXDIR)
|
||||
@@ -209,7 +209,7 @@
|
||||
endif
|
||||
ifneq ($(DESKTOPDIR),)
|
||||
install -d -m 0755 $(USER_GROUP) $(DESTDIR)/$(DESKTOPDIR)
|
||||
- install -m 0644 $(USER_GROUP) -T auto-multiple-choice.desktop $(DESTDIR)/$(DESKTOPDIR)/auto-multiple-choice.desktop
|
||||
+ install -m 0644 $(USER_GROUP) auto-multiple-choice.desktop $(DESTDIR)/$(DESKTOPDIR)/auto-multiple-choice.desktop
|
||||
endif
|
||||
install -d -m 0755 $(USER_GROUP) $(DESTDIR)/$(BINDIR)
|
||||
install -m 0755 $(USER_GROUP) auto-multiple-choice $(DESTDIR)/$(BINDIR)
|
||||
@@ -217,7 +217,7 @@
|
||||
install -m 0644 $(USER_GROUP) icons/*.svg $(DESTDIR)/$(ICONSDIR)
|
||||
ifneq ($(PIXDIR),)
|
||||
install -d -m 0755 $(USER_GROUP) $(DESTDIR)/$(PIXDIR)
|
||||
- install -m 0644 $(USER_GROUP) -T $(MAIN_LOGO).xpm $(DESTDIR)/$(PIXDIR)/auto-multiple-choice.xpm
|
||||
+ install -m 0644 $(USER_GROUP) $(MAIN_LOGO).xpm $(DESTDIR)/$(PIXDIR)/auto-multiple-choice.xpm
|
||||
endif
|
||||
install -d -m 0755 $(USER_GROUP) $(DESTDIR)/$(PERLDIR)/AMC
|
||||
install -d -m 0755 $(USER_GROUP) $(DESTDIR)/$(PERLDIR)/AMC/Export
|
||||
@@ -247,7 +247,19 @@
|
||||
chgrp -hR $(INSTALL_GROUP) $(DESTDIR)/$(DOCDIR)
|
||||
endif
|
||||
install -d -m 0755 $(USER_GROUP) $(DESTDIR)/$(MAN1DIR)
|
||||
- install -m 0644 $(USER_GROUP) doc/*.1 $(DESTDIR)/$(MAN1DIR)
|
||||
+ for f in doc/AMC-*.1; do \
|
||||
+ case $$f in \
|
||||
+ *.??.1) ;; \
|
||||
+ *) install -m 0644 $(USER_GROUP) $$f $(DESTDIR)/$(MAN1DIR) ;; \
|
||||
+ esac; \
|
||||
+ done
|
||||
+ install -m 0644 $(USER_GROUP) doc/auto-multiple-choice.1 $(DESTDIR)/$(MAN1DIR)
|
||||
+ mkdir -p $(DESTDIR)/$(FRMAN1DIR)
|
||||
+ install -m 0644 $(USER_GROUP) doc/auto-multiple-choice.fr.1 $(DESTDIR)/$(FRMAN1DIR)/auto-multiple-choice.1
|
||||
+ mkdir -p $(DESTDIR)/$(JAMAN1DIR)
|
||||
+ for f in doc/*.ja.1; do \
|
||||
+ iconv -f UTF-8 -t EUC-JP < $$f > $(DESTDIR)/$(JAMAN1DIR)/`expr $$f : 'doc/\(.*\).ja.1'`.1; \
|
||||
+ done
|
||||
endif
|
||||
|
||||
# Test
|
92
misc/auto-multiple-choice/files/patch-Makefile.conf
Normal file
92
misc/auto-multiple-choice/files/patch-Makefile.conf
Normal file
|
@ -0,0 +1,92 @@
|
|||
--- ./Makefile.conf.orig 2013-07-28 22:22:29.000000000 +0900
|
||||
+++ ./Makefile.conf 2014-03-05 18:41:03.000000000 +0900
|
||||
@@ -28,54 +28,63 @@
|
||||
|
||||
LATEX_FREE=0
|
||||
|
||||
+GCC=$(CC)
|
||||
+GCC_PP=$(CXX)
|
||||
+
|
||||
+CFLAGS = -O2 -I%%LOCALBASE%%/include -I. -DNEEDS_GETLINE
|
||||
+CXXFLAGS = -O2 -I%%LOCALBASE%%/include -I. -DNEEDS_GETLINE
|
||||
+LDFLAGS += -L%%LOCALBASE%%/lib
|
||||
+
|
||||
# INSTALLATION : where to install parts of the package ?
|
||||
|
||||
# directory for executable
|
||||
-BINDIR=/usr/bin
|
||||
+BINDIR=%%PREFIX%%/bin
|
||||
# directory for perl modules
|
||||
-PERLDIR=/usr/share/perl5
|
||||
+PERLDIR=%%PREFIX%%/%%SITE_PERL_REL%%
|
||||
# directory for some AMC executables, not to be used by end-user
|
||||
-MODSDIR=/usr/lib/AMC
|
||||
+MODSDIR=%%PREFIX%%/lib/AMC
|
||||
# directory for LaTeX style file
|
||||
-TEXDIR=/usr/share/texmf/tex/latex/AMC
|
||||
+TEXDIR=%%PREFIX%%/%%TEXMFLOCALDIR%%/tex/latex/AMC
|
||||
# directory for LaTeX doc
|
||||
-TEXDOCDIR=/usr/share/doc/texmf/AMC/
|
||||
+TEXDOCDIR=%%PREFIX%%/%%TEXMFLOCALDIR%%/doc/latex/AMC/
|
||||
# directory for man (1) files
|
||||
-MAN1DIR=/usr/share/man/man1
|
||||
+MAN1DIR=%%MANPREFIX%%/man/man1
|
||||
+FRMAN1DIR=%%MANPREFIX%%/man/fr/man1
|
||||
+JAMAN1DIR=%%MANPREFIX%%/man/ja/man1
|
||||
# directory for desktop file
|
||||
-DESKTOPDIR=/usr/share/applications
|
||||
+DESKTOPDIR=%%PREFIX%%/share/applications
|
||||
# directory for icons (svg)
|
||||
-ICONSDIR=/usr/share/auto-multiple-choice/icons
|
||||
+ICONSDIR=%%DATADIR%%/icons
|
||||
# directory for icons (xpm)
|
||||
-PIXDIR=/usr/share/pixmaps
|
||||
+PIXDIR=%%PREFIX%%/share/pixmaps
|
||||
# directory for locales (MO files will be put in
|
||||
# $(LOCALEDIR)/fr/LC_MESSAGES for example)
|
||||
-LOCALEDIR=/usr/share/locale
|
||||
+LOCALEDIR=%%PREFIX%%/share/locale
|
||||
# directory for AMC packaged models
|
||||
-MODELSDIR=/usr/share/auto-multiple-choice/models
|
||||
+MODELSDIR=%%DATADIR%%/models
|
||||
# directory for documentation (will use html/auto-multiple-choice.* subdirs for HTML docs)
|
||||
-DOCDIR=/usr/share/doc/auto-multiple-choice-doc
|
||||
+DOCDIR=%%DOCSDIR%%
|
||||
|
||||
# directory for Shared MIME-info Database
|
||||
-SHARED_MIMEINFO_DIR=/usr/share/mime/packages
|
||||
+SHARED_MIMEINFO_DIR=%%SHARED_MIMEINFO_DIR%%
|
||||
# directory for gtksourceview/gedit languages highlighting syntax
|
||||
-LANG_GTKSOURCEVIEW_DIR=/usr/share/gtksourceview-3.0/language-specs
|
||||
+LANG_GTKSOURCEVIEW_DIR=%%LANG_GTKSOURCEVIEW_DIR%%
|
||||
|
||||
# BUILD : where to find some files used for building AMC ?
|
||||
# URLs can be used if XML catalogs are present.
|
||||
|
||||
-#DOCBOOK_MAN_XSL=/usr/share/xml/docbook/stylesheet/nwalsh/manpages/docbook.xsl
|
||||
+#DOCBOOK_MAN_XSL=%%LOCALBASE%%/share/xsl/docbook/manpages/docbook.xsl
|
||||
DOCBOOK_MAN_XSL=http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
|
||||
-#DOCBOOK_XHTML_XSL=/usr/share/xml/docbook/stylesheet/nwalsh/xhtml/chunk.xsl
|
||||
+#DOCBOOK_XHTML_XSL=%%LOCALBASE%%/share/xsl/docbook/xhtml/chunk.xsl
|
||||
DOCBOOK_XHTML_XSL=http://docbook.sourceforge.net/release/xsl/current/xhtml/chunk.xsl
|
||||
-#DOCBOOK_DTD=/usr/share/xml/docbook/schema/dtd/4.5/docbookx.dtd
|
||||
+#DOCBOOK_DTD=%%LOCALBASE%%/share/xml/docbook/4.5/docbookx.dtd
|
||||
DOCBOOK_DTD=http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd
|
||||
|
||||
# BUILD : options to compile with netpbm / opencv libraries
|
||||
|
||||
GCC_NETPBM=-lnetpbm
|
||||
|
||||
-GCC_OPENCV=-I /usr/include/opencv
|
||||
+GCC_OPENCV=-I %%LOCALBASE%%/include/opencv
|
||||
GCC_OPENCV_LIBS=auto
|
||||
|
||||
# INFO IN DESKTOP FILE
|
||||
@@ -86,6 +95,6 @@
|
||||
|
||||
ifneq ($(SYSTEM_TYPE),rpm)
|
||||
INSTALL_USER=root
|
||||
-INSTALL_GROUP=root
|
||||
+INSTALL_GROUP=wheel
|
||||
endif
|
||||
|
6
misc/auto-multiple-choice/pkg-descr
Normal file
6
misc/auto-multiple-choice/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
Auto Multiple Choice (AMC) is a piece of software that helps you to create
|
||||
and manage multiple choice questionnaires, with automated marking. Tests
|
||||
can be written in plain text or LaTeX. Automated correction and grading is
|
||||
performed from scans of the answer sheets using optical mark recognition.
|
||||
|
||||
WWW: http://home.gna.org/auto-qcm/
|
15
misc/auto-multiple-choice/pkg-message
Normal file
15
misc/auto-multiple-choice/pkg-message
Normal file
|
@ -0,0 +1,15 @@
|
|||
======================================================================
|
||||
Auto Multiple Choice uses some optional helper software to view and/or
|
||||
edit various files such as PDF, Image, CSV, TeX, etc.
|
||||
You may want to install software from the following command list or
|
||||
specify your favorite one in the GUI preference menu.
|
||||
PDF viewer: evince, acroread, gpdf, okular, xpdf.
|
||||
Image viewer: eog, ristretto, gpicview, mirage, gwenview.
|
||||
ODS viewer: libreoffice, localc, oocalc.
|
||||
XML viewer: gedit, kedit, kwrite, mousepad, leafpad.
|
||||
TeX editor: texmaker, kile, gummi, emacs, gedit, kedit, kwrite, mousepad,
|
||||
leafpad.
|
||||
Text editor: gedit, kedit, kwrite, mousepad, emacs, leafpad.
|
||||
Web browser: sensible-browser, firefox, galeon, konqueror, dillo, chromium.
|
||||
File manager: nautilus, pcmanfm, Thunar, konqueror, dolphin.
|
||||
======================================================================
|
187
misc/auto-multiple-choice/pkg-plist
Normal file
187
misc/auto-multiple-choice/pkg-plist
Normal file
|
@ -0,0 +1,187 @@
|
|||
bin/auto-multiple-choice
|
||||
lib/AMC/exec/AMC-detect
|
||||
lib/AMC/exec/AMC-traitement-image
|
||||
lib/AMC/perl/AMC-analyse.pl
|
||||
lib/AMC/perl/AMC-annote.pl
|
||||
lib/AMC/perl/AMC-association-auto.pl
|
||||
lib/AMC/perl/AMC-association.pl
|
||||
lib/AMC/perl/AMC-export.pl
|
||||
lib/AMC/perl/AMC-getimages.pl
|
||||
lib/AMC/perl/AMC-gui-apropos.glade
|
||||
lib/AMC/perl/AMC-gui-choix_pages_impression.glade
|
||||
lib/AMC/perl/AMC-gui-choix_postcorrect.glade
|
||||
lib/AMC/perl/AMC-gui-choix_projet.glade
|
||||
lib/AMC/perl/AMC-gui-choose-mode.glade
|
||||
lib/AMC/perl/AMC-gui-choose_columns.glade
|
||||
lib/AMC/perl/AMC-gui-choose_students.glade
|
||||
lib/AMC/perl/AMC-gui-cleanup.glade
|
||||
lib/AMC/perl/AMC-gui-edit_preferences.glade
|
||||
lib/AMC/perl/AMC-gui-filter_details.glade
|
||||
lib/AMC/perl/AMC-gui-liste_dialog.glade
|
||||
lib/AMC/perl/AMC-gui-mailing.glade
|
||||
lib/AMC/perl/AMC-gui-main_window.glade
|
||||
lib/AMC/perl/AMC-gui-make_template.glade
|
||||
lib/AMC/perl/AMC-gui-saisie_auto.glade
|
||||
lib/AMC/perl/AMC-gui-source_latex_choix.glade
|
||||
lib/AMC/perl/AMC-gui-source_latex_choix_zip.glade
|
||||
lib/AMC/perl/AMC-gui-source_latex_dialog.glade
|
||||
lib/AMC/perl/AMC-gui-source_latex_modele.glade
|
||||
lib/AMC/perl/AMC-gui-unrecognized.glade
|
||||
lib/AMC/perl/AMC-gui.pl
|
||||
lib/AMC/perl/AMC-imprime.pl
|
||||
lib/AMC/perl/AMC-latex-link.pl
|
||||
lib/AMC/perl/AMC-mailing.pl
|
||||
lib/AMC/perl/AMC-manuel.pl
|
||||
lib/AMC/perl/AMC-meptex.pl
|
||||
lib/AMC/perl/AMC-note.pl
|
||||
lib/AMC/perl/AMC-prepare.pl
|
||||
lib/AMC/perl/AMC-regroupe.pl
|
||||
%%SITE_PERL%%/AMC/Basic.pm
|
||||
%%SITE_PERL%%/AMC/Boite.pm
|
||||
%%SITE_PERL%%/AMC/Calage.pm
|
||||
%%SITE_PERL%%/AMC/Data.pm
|
||||
%%SITE_PERL%%/AMC/DataModule.pm
|
||||
%%SITE_PERL%%/AMC/DataModule/association.pm
|
||||
%%SITE_PERL%%/AMC/DataModule/capture.pm
|
||||
%%SITE_PERL%%/AMC/DataModule/layout.pm
|
||||
%%SITE_PERL%%/AMC/DataModule/report.pm
|
||||
%%SITE_PERL%%/AMC/DataModule/scoring.pm
|
||||
%%SITE_PERL%%/AMC/Exec.pm
|
||||
%%SITE_PERL%%/AMC/Export.pm
|
||||
%%SITE_PERL%%/AMC/Export/CSV.pm
|
||||
%%SITE_PERL%%/AMC/Export/List.pm
|
||||
%%SITE_PERL%%/AMC/Export/ods.pm
|
||||
%%SITE_PERL%%/AMC/Export/register.pm
|
||||
%%SITE_PERL%%/AMC/Export/register/CSV.pm
|
||||
%%SITE_PERL%%/AMC/Export/register/List.pm
|
||||
%%SITE_PERL%%/AMC/Export/register/ods.pm
|
||||
%%SITE_PERL%%/AMC/FileMonitor.pm
|
||||
%%SITE_PERL%%/AMC/Filter.pm
|
||||
%%SITE_PERL%%/AMC/Filter/latex.pm
|
||||
%%SITE_PERL%%/AMC/Filter/plain.pm
|
||||
%%SITE_PERL%%/AMC/Filter/register.pm
|
||||
%%SITE_PERL%%/AMC/Filter/register/latex.pm
|
||||
%%SITE_PERL%%/AMC/Filter/register/plain.pm
|
||||
%%SITE_PERL%%/AMC/Gui/Association.glade
|
||||
%%SITE_PERL%%/AMC/Gui/Association.pm
|
||||
%%SITE_PERL%%/AMC/Gui/Avancement.pm
|
||||
%%SITE_PERL%%/AMC/Gui/Commande.pm
|
||||
%%SITE_PERL%%/AMC/Gui/Manuel.glade
|
||||
%%SITE_PERL%%/AMC/Gui/Manuel.pm
|
||||
%%SITE_PERL%%/AMC/Gui/Notes.glade
|
||||
%%SITE_PERL%%/AMC/Gui/Notes.pm
|
||||
%%SITE_PERL%%/AMC/Gui/PageArea.pm
|
||||
%%SITE_PERL%%/AMC/Gui/WindowSize.pm
|
||||
%%SITE_PERL%%/AMC/Gui/Zooms.glade
|
||||
%%SITE_PERL%%/AMC/Gui/Zooms.pm
|
||||
%%SITE_PERL%%/AMC/Image.pm
|
||||
%%SITE_PERL%%/AMC/Messages.pm
|
||||
%%SITE_PERL%%/AMC/NamesFile.pm
|
||||
%%SITE_PERL%%/AMC/Queue.pm
|
||||
%%SITE_PERL%%/AMC/Scoring.pm
|
||||
%%SITE_PERL%%/AMC/ScoringEnv.pm
|
||||
%%SITE_PERL%%/AMC/State.pm
|
||||
%%SITE_PERL%%/AMC/Substitute.pm
|
||||
man/fr/man1/auto-multiple-choice.1.gz
|
||||
man/ja/man1/AMC-analyse.1.gz
|
||||
man/ja/man1/AMC-annote.1.gz
|
||||
man/ja/man1/AMC-association-auto.1.gz
|
||||
man/ja/man1/AMC-association.1.gz
|
||||
man/ja/man1/AMC-export.1.gz
|
||||
man/ja/man1/AMC-getimages.1.gz
|
||||
man/ja/man1/AMC-imprime.1.gz
|
||||
man/ja/man1/AMC-mailing.1.gz
|
||||
man/ja/man1/AMC-meptex.1.gz
|
||||
man/ja/man1/AMC-note.1.gz
|
||||
man/ja/man1/AMC-prepare.1.gz
|
||||
man/ja/man1/AMC-regroupe.1.gz
|
||||
man/ja/man1/auto-multiple-choice.1.gz
|
||||
man/man1/AMC-analyse.1.gz
|
||||
man/man1/AMC-annote.1.gz
|
||||
man/man1/AMC-association-auto.1.gz
|
||||
man/man1/AMC-association.1.gz
|
||||
man/man1/AMC-export.1.gz
|
||||
man/man1/AMC-getimages.1.gz
|
||||
man/man1/AMC-imprime.1.gz
|
||||
man/man1/AMC-mailing.1.gz
|
||||
man/man1/AMC-meptex.1.gz
|
||||
man/man1/AMC-note.1.gz
|
||||
man/man1/AMC-prepare.1.gz
|
||||
man/man1/AMC-regroupe.1.gz
|
||||
man/man1/auto-multiple-choice.1.gz
|
||||
share/applications/auto-multiple-choice.desktop
|
||||
%%DATADIR%%/icons/amc-annotate.svg
|
||||
%%DATADIR%%/icons/amc-auto-assoc.svg
|
||||
%%DATADIR%%/icons/amc-auto-capture.svg
|
||||
%%DATADIR%%/icons/amc-group.svg
|
||||
%%DATADIR%%/icons/amc-manual-assoc.svg
|
||||
%%DATADIR%%/icons/amc-manual-capture.svg
|
||||
%%DATADIR%%/icons/amc-mark.svg
|
||||
%%DATADIR%%/icons/amc-send.svg
|
||||
%%DATADIR%%/icons/auto-multiple-choice.svg
|
||||
%%DATADIR%%/models/ar/directory.xml
|
||||
%%DATADIR%%/models/ar/groups.tgz
|
||||
%%DATADIR%%/models/ar/scoring.tgz
|
||||
%%DATADIR%%/models/ar/separate.tgz
|
||||
%%DATADIR%%/models/ar/simple.tgz
|
||||
%%DATADIR%%/models/en/directory.xml
|
||||
%%DATADIR%%/models/en/groups.tgz
|
||||
%%DATADIR%%/models/en/scoring.tgz
|
||||
%%DATADIR%%/models/en/separate.tgz
|
||||
%%DATADIR%%/models/en/simple-txt.tgz
|
||||
%%DATADIR%%/models/en/simple.tgz
|
||||
%%DATADIR%%/models/fr/bareme.tgz
|
||||
%%DATADIR%%/models/fr/directory.xml
|
||||
%%DATADIR%%/models/fr/ensemble.tgz
|
||||
%%DATADIR%%/models/fr/groupes.tgz
|
||||
%%DATADIR%%/models/fr/simple-txt.tgz
|
||||
%%DATADIR%%/models/fr/simple.tgz
|
||||
%%DATADIR%%/models/ja/directory.xml
|
||||
%%DATADIR%%/models/ja/groups.tgz
|
||||
%%DATADIR%%/models/ja/scoring.tgz
|
||||
%%DATADIR%%/models/ja/separate.tgz
|
||||
%%DATADIR%%/models/ja/simple-txt.tgz
|
||||
%%DATADIR%%/models/ja/simple.tgz
|
||||
share/gtksourceview-2.0/language-specs/amc-txt.lang
|
||||
share/locale/ar/LC_MESSAGES/auto-multiple-choice.mo
|
||||
share/locale/es/LC_MESSAGES/auto-multiple-choice.mo
|
||||
share/locale/fr/LC_MESSAGES/auto-multiple-choice.mo
|
||||
share/locale/ja/LC_MESSAGES/auto-multiple-choice.mo
|
||||
share/mime/packages/auto-multiple-choice.xml
|
||||
share/pixmaps/auto-multiple-choice.xpm
|
||||
%%TEXMFLOCALDIR%%/doc/latex/AMC/automultiplechoice.pdf
|
||||
%%TEXMFLOCALDIR%%/doc/latex/AMC/questions.tex
|
||||
%%TEXMFLOCALDIR%%/doc/latex/AMC/sample-amc.pdf
|
||||
%%TEXMFLOCALDIR%%/doc/latex/AMC/sample-amc.tex
|
||||
%%TEXMFLOCALDIR%%/doc/latex/AMC/sample-plain.pdf
|
||||
%%TEXMFLOCALDIR%%/doc/latex/AMC/sample-plain.tex
|
||||
%%TEXMFLOCALDIR%%/doc/latex/AMC/sample-separate.pdf
|
||||
%%TEXMFLOCALDIR%%/doc/latex/AMC/sample-separate.tex
|
||||
%%TEXMFLOCALDIR%%/tex/latex/AMC/automultiplechoice.sty
|
||||
@dirrm lib/AMC/exec
|
||||
@dirrm lib/AMC/perl
|
||||
@dirrm lib/AMC
|
||||
@dirrm %%SITE_PERL%%/AMC/DataModule
|
||||
@dirrm %%SITE_PERL%%/AMC/Export/register
|
||||
@dirrm %%SITE_PERL%%/AMC/Export
|
||||
@dirrm %%SITE_PERL%%/AMC/Filter/register
|
||||
@dirrm %%SITE_PERL%%/AMC/Filter
|
||||
@dirrm %%SITE_PERL%%/AMC/Gui
|
||||
@dirrm %%SITE_PERL%%/AMC
|
||||
@dirrmtry man/fr/man1
|
||||
@dirrmtry man/fr
|
||||
@dirrm %%DATADIR%%/icons
|
||||
@dirrm %%DATADIR%%/models/ar
|
||||
@dirrm %%DATADIR%%/models/en
|
||||
@dirrm %%DATADIR%%/models/fr
|
||||
@dirrm %%DATADIR%%/models/ja
|
||||
@dirrm %%DATADIR%%/models
|
||||
@dirrm %%DATADIR%%
|
||||
@dirrmtry share/gtksourceview-2.0/language-specs
|
||||
@dirrmtry share/gtksourceview-2.0
|
||||
@dirrm %%TEXMFLOCALDIR%%/doc/latex/AMC
|
||||
@dirrmtry %%TEXMFLOCALDIR%%/doc/latex
|
||||
@dirrmtry %%TEXMFLOCALDIR%%/doc
|
||||
@dirrm %%TEXMFLOCALDIR%%/tex/latex/AMC
|
||||
@dirrmtry %%TEXMFLOCALDIR%%/tex/latex
|
||||
@dirrmtry %%TEXMFLOCALDIR%%/tex
|
Loading…
Reference in a new issue