- Update to 1.5.17 (version found in the GNOME2 beta4);

- use USE_LIBTOOL.
This commit is contained in:
Maxim Sobolev 2002-04-26 14:19:46 +00:00
parent 8b6bc46375
commit 90a619df21
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=58175
10 changed files with 38 additions and 100 deletions

View file

@ -6,10 +6,10 @@
#
PORTNAME= gnomedesktop
PORTVERSION= 1.5.14
PORTVERSION= 1.5.17
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta3
MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta4
DISTNAME= gnome-desktop-${PORTVERSION}
DIST_SUBDIR= gnome2
@ -23,7 +23,7 @@ USE_XPM= yes
USE_GMAKE= yes
USE_BISON= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome2 \
--datadir=${PREFIX}/share/gnome2
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@ -37,6 +37,6 @@ pre-patch:
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g ; \
s|\$\(datadir\)/gnome|\$\(datadir\)|g'
s|\$\(datadir\)/gnome/|\$\(datadir\)/|g'
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (gnome2/gnome-desktop-1.5.14.tar.bz2) = 4731bdb0df5178d1a63b8e1c3b65c64c
MD5 (gnome2/gnome-desktop-1.5.17.tar.bz2) = 74cd91b5841c753edf5cbfa6f60b9575

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- configure 2002/04/26 14:02:41 1.1
+++ configure 2002/04/26 14:02:56
@@ -7222,6 +7222,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'

View file

@ -1,45 +0,0 @@
$FreeBSD$
--- ltmain.sh.orig Wed Jan 23 11:38:40 2002
+++ ltmain.sh Sun Feb 3 01:44:17 2002
@@ -1037,8 +1037,16 @@
continue
;;
+ -pthread)
+ compile_command="$compile_command -pthread"
+ finalize_command="$finalize_command -pthread"
+ compiler_flags="$compiler_flags -pthread"
+ continue
+ ;;
+
-module)
module=yes
+ build_old_libs=no
continue
;;
@@ -2412,6 +2420,9 @@
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
# Add libc to deplibs on all other systems if necessary.
if test "$build_libtool_need_lc" = "yes"; then
@@ -4179,10 +4190,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View file

@ -27,6 +27,7 @@ share/gnome2/vfolders/Settings.order
share/gnome2/vfolders/System.directory
share/gnome2/pixmaps/apple-green.png
share/gnome2/pixmaps/apple-red.png
share/gnome2/pixmaps/cdeappmenu.png
share/gnome2/pixmaps/gnome-amusements.png
share/gnome2/pixmaps/gnome-aorta.png
share/gnome2/pixmaps/gnome-applets.png

View file

@ -6,10 +6,10 @@
#
PORTNAME= gnomedesktop
PORTVERSION= 1.5.14
PORTVERSION= 1.5.17
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta3
MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta4
DISTNAME= gnome-desktop-${PORTVERSION}
DIST_SUBDIR= gnome2
@ -23,7 +23,7 @@ USE_XPM= yes
USE_GMAKE= yes
USE_BISON= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome2 \
--datadir=${PREFIX}/share/gnome2
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@ -37,6 +37,6 @@ pre-patch:
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g ; \
s|\$\(datadir\)/gnome|\$\(datadir\)|g'
s|\$\(datadir\)/gnome/|\$\(datadir\)/|g'
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (gnome2/gnome-desktop-1.5.14.tar.bz2) = 4731bdb0df5178d1a63b8e1c3b65c64c
MD5 (gnome2/gnome-desktop-1.5.17.tar.bz2) = 74cd91b5841c753edf5cbfa6f60b9575

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- configure 2002/04/26 14:02:41 1.1
+++ configure 2002/04/26 14:02:56
@@ -7222,6 +7222,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'

View file

@ -1,45 +0,0 @@
$FreeBSD$
--- ltmain.sh.orig Wed Jan 23 11:38:40 2002
+++ ltmain.sh Sun Feb 3 01:44:17 2002
@@ -1037,8 +1037,16 @@
continue
;;
+ -pthread)
+ compile_command="$compile_command -pthread"
+ finalize_command="$finalize_command -pthread"
+ compiler_flags="$compiler_flags -pthread"
+ continue
+ ;;
+
-module)
module=yes
+ build_old_libs=no
continue
;;
@@ -2412,6 +2420,9 @@
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
# Add libc to deplibs on all other systems if necessary.
if test "$build_libtool_need_lc" = "yes"; then
@@ -4179,10 +4190,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View file

@ -27,6 +27,7 @@ share/gnome2/vfolders/Settings.order
share/gnome2/vfolders/System.directory
share/gnome2/pixmaps/apple-green.png
share/gnome2/pixmaps/apple-red.png
share/gnome2/pixmaps/cdeappmenu.png
share/gnome2/pixmaps/gnome-amusements.png
share/gnome2/pixmaps/gnome-aorta.png
share/gnome2/pixmaps/gnome-applets.png