. Update to 3.1.2

PR:		177290
Submitted by:	mm@
This commit is contained in:
Greg Lewis 2013-03-23 17:09:43 +00:00
parent a093b1e494
commit 90b681319e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=315047
3 changed files with 35 additions and 28 deletions

View file

@ -1,23 +1,19 @@
# New ports collection makefile for: libarchive
# Date created: 23 March 2004
# Whom: Greg Lewis <glewis@FreeBSD.org>
#
# $FreeBSD$
PORTNAME= libarchive
PORTVERSION= 3.0.4
PORTREVISION= 1
PORTVERSION= 3.1.2
PORTEPOCH= 1
CATEGORIES= archivers
MASTER_SITES= http://cloud.github.com/downloads/${PORTNAME}/${PORTNAME}/
MASTER_SITES= http://libarchive.org/downloads/
MAINTAINER= glewis@FreeBSD.org
COMMENT= Library to create and read several streaming archive formats
OPTIONS_DEFINE= LIBXML2 NETTLE
OPTIONS_DEFAULT= LIBXML2
OPTIONS_DEFINE= LIBXML2 LZO NETTLE
OPTIONS_DEFAULT=LIBXML2 LZO
LIBXML2_DESC= Support writing xar via libxml2
LZO_DESC= Support lzo compression via liblzo2
NETTLE_DESC= Use Nettle instead of OpenSSL
GNU_CONFIGURE= yes
@ -34,7 +30,7 @@ PLIST_FILES= bin/bsdcpio \
lib/libarchive.a \
lib/libarchive.la \
lib/libarchive.so \
lib/libarchive.so.12 \
lib/libarchive.so.14 \
libdata/pkgconfig/libarchive.pc
MANCOMPRESSED= no
@ -48,13 +44,31 @@ MAN3= archive_entry.3 \
archive_entry_stat.3 \
archive_entry_time.3 \
archive_read.3 \
archive_read_data.3 \
archive_read_disk.3 \
archive_read_extract.3 \
archive_read_filter.3 \
archive_read_format.3 \
archive_read_free.3 \
archive_read_header.3 \
archive_read_new.3 \
archive_read_open.3 \
archive_read_set_options.3 \
archive_util.3 \
archive_write.3 \
archive_write_blocksize.3 \
archive_write_data.3 \
archive_write_disk.3 \
archive_write_filter.3 \
archive_write_finish_entry.3 \
archive_write_format.3 \
archive_write_free.3 \
archive_write_header.3 \
archive_write_new.3 \
archive_write_open.3 \
archive_write_set_options.3 \
libarchive.3 \
libarchive_changes.3 \
libarchive_internals.3
MAN5= cpio.5 \
libarchive-formats.5 \
@ -76,8 +90,15 @@ LDFLAGS+= -lbsdxml
CONFIGURE_ARGS+= --without-xml2
.endif
.if ${PORT_OPTIONS:MLZO}
LIB_DEPENDS= lzo2:${PORTSDIR}/archivers/lzo2
CONFIGURE_ARGS+= --with-lzo2
.else
CONFIGURE_ARGS+= --without-lzo2
.endif
.if ${PORT_OPTIONS:MNETTLE}
LIB_DEPENDS+= nettle.4:${PORTSDIR}/security/nettle
LIB_DEPENDS+= nettle:${PORTSDIR}/security/nettle
CONFIGURE_ARGS+= --without-openssl --with-nettle
.else
USE_OPENSSL= yes
@ -87,7 +108,7 @@ CONFIGURE_ARGS+= --with-openssl --without-nettle
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
LIB_DEPENDS+= lzma.5:${PORTSDIR}/archivers/xz
LIB_DEPENDS+= lzma:${PORTSDIR}/archivers/xz
.endif
check:

View file

@ -1,2 +1,2 @@
SHA256 (libarchive-3.0.4.tar.gz) = 76e8d7c7b100ec4071e48c1b7d3f3ea1d22b39db3e45b7189f75b5ff4df90fac
SIZE (libarchive-3.0.4.tar.gz) = 3632806
SHA256 (libarchive-3.1.2.tar.gz) = eb87eacd8fe49e8d90c8fdc189813023ccc319c5e752b01fb6ad0cc7b2c53d5e
SIZE (libarchive-3.1.2.tar.gz) = 4527540

View file

@ -1,14 +0,0 @@
$FreeBSD$
diff --git a/libarchive/archive_read_disk_entry_from_file.c b/libarchive/archive_read_disk_entry_from_file.c
index 7987fa5..25b1edc 100644
--- a/libarchive/archive_read_disk_entry_from_file.c
+++ b/libarchive/archive_read_disk_entry_from_file.c
@@ -584,6 +584,7 @@ translate_acl(struct archive_read_disk *a,
break;
default:
/* Skip types that libarchive can't support. */
+ s = acl_get_entry(acl, ACL_NEXT_ENTRY, &acl_entry);
continue;
}